Jump to content

10.8.2 Final! (C54)


  • Please log in to reply
127 replies to this topic

#41
beta992

beta992

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts
  • Gender:Male

Confusingly, the version is still 1.6. But the binary inside has changed. I md5-summed the old and new ones to see for myself.

Anyone who needed to rollback ACPIPlatform, are you using the ACPISensors or OemSMBIOS kexts? I'm just wondering what triggers the problem with the updated kext. I use Kozlek's HWSensors branch of FakeSMC but only with the CPU, GPU and MB sensor kexts.

Same here, but I also needed to rollback AppleACPIPlatform.kext to boot.

#42
Biso007

Biso007

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 183 posts
  • Gender:Male
  • Location:Cairo, EG
Updated to 10.8.2 thru SW update but had to rollback AppleACPIPlatform.kext to an older version.

#43
tot318

tot318

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
Update went fine using the 10.8.2 Combo Update, no problem. As usual for any update have to install back sound driver.

#44
mtek

mtek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts
Does anyone know why does 10.8.2

AppleACPIPlatform.kext gives some odd users (like myself) trouble?



#45
JamesLittler

JamesLittler

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,022 posts
  • Gender:Male
  • Location:Portsmouth, England
Updated through app store, no issues what so ever.

#46
Himlaklar

Himlaklar

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
Upon further use i noticed that GTX 670 drivers have only OpenGL 2.1 and lower.

And Starcraft 2 crashes.

#47
pepto

pepto

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
I have updated my Dell Optiplex 780 thru 10.8.2 combo update after that reinstalled chameleon and rebooted with success no KP or what ever :)
I wanna update the OSX wiki page for my system but there is no 10.8.2 page yet.

#48
JBX

JBX

    InsanelyMac Protégé

  • Members
  • PipPip
  • 88 posts
  • Gender:Male
used combo updater, had to re- AppleHDA.kext via kexthelper.

No problems noticed so far.

#49
tdtran1025

tdtran1025

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 352 posts

Confusingly, the version is still 1.6. But the binary inside has changed. I md5-summed the old and new ones to see for myself.

Anyone who needed to rollback ACPIPlatform, are you using the ACPISensors or OemSMBIOS kexts? I'm just wondering what triggers the problem with the updated kext. I use Kozlek's HWSensors branch of FakeSMC but only with the CPU, GPU and MB sensor kexts.


I am using the same HWSensors and I never have any issue with KP. Maybe it's board specific since we all use hack.

#50
RobertX

RobertX

    InSanelyMac Maverick

  • Members
  • PipPipPipPipPipPipPip
  • 532 posts
  • Gender:Not Telling
opencl fix for the fermi 5xxx ...

for the stock 10.8.2 drivers (8.0.61 295.30.20f02 version) this fix still works

"So, open up a hex editor of your liking and do this:
open /System/Library/Extensions/GeForceGLDriver.bundle/Contents/MacOS/libclh.dylib (as root or with sudo)
find: 8B 87 1C 0C 00 00 89 06 8B 87 20 0C 00 00 89 02
replace by: 31 C0 FF C0 FF C0 89 06 31 C0 89 02 90 90 90 90
save
reboot is not required, but recommended" from the first post... :thumbsup_anim:

...works for me..

#51
xela

xela

    InsanelyMac Protégé

  • Donators
  • 26 posts
  • Gender:Male

After I disabled VT-d in BIOS it also works with the original 10.8.2. AppleACPIPlatform.kext.
Using a Gigabyte GA-Z77X-UP5 TH with BIOS F9.


Hi, I have "IOUSBFamily did not receive enough extra current for the SuperSpeed device (4-Port USB 3.0 Hub) at 0x14c00000, asked for 400mA but got 0 mA" error message from console. The USB port not charging iPad.

Have to roll back to 10.8.1 IOUSBFamily.kext to fix the problem .. do u have to do that ?

BTW, nice to see you here.

Upon further use i noticed that GTX 670 drivers have only OpenGL 2.1 and lower.

And Starcraft 2 crashes.


hey i got mine running fine ...

#52
khe91

khe91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:Germany

Hi, I have "IOUSBFamily did not receive enough extra current for the SuperSpeed device (4-Port USB 3.0 Hub) at 0x14c00000, asked for 400mA but got 0 mA" error message from console. The USB port not charging iPad.

Have to roll back to 10.8.1 IOUSBFamily.kext to fix the problem .. do u have to do that ?


I got the same messages, still the USB 3.0 ports are working for external hard disks. Didn't try if they can charge devices.

#53
Cavendish Qi

Cavendish Qi

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
  • Gender:Male

if your computer wont boot or acpi state not working try this kext.



Hi, unixservice,

Thanks for your patched kext at first. Would you like to share more about how to modify it manually? Thanks a lot.

#54
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 741 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

Removed oemsmbios and repaired permissions etc. now got Voodoohda KP so going to delete that and see what happens

voodoohda and applehda cannot stay together
you have to remove one of them.

#55
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,924 posts
  • Gender:Male
  • Location:Moscow

Updated through app store, no issues what so ever.

+1

voodoohda and applehda cannot stay together
you have to remove one of them.

Just use AppleHDADisabler and don't bother about updates.

#56
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 741 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

Just use AppleHDADisabler and don't bother about updates.


Hi, slice.
I once use a application which can disable any kexts.
So voodoohda and applehda can stay together.

by the way, I want to know is clover able to restart after kernel panic ?

#57
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,924 posts
  • Gender:Male
  • Location:Moscow

Hi, slice.
I once use a application which can disable any kexts.
So voodoohda and applehda can stay together.

by the way, I want to know is clover able to restart after kernel panic ?

This is kernel function, not bootloader.
sudo pmset autorestart 0

#58
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 741 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

This is kernel function, not bootloader.
sudo pmset autorestart 0


well, I look into the pmset command in terminal
it says like this.
autorestart - automatic restart on [b]power loss[/b] (value = 0/1)

does power loss equal to kernel panic ?

#59
Peter_sm

Peter_sm

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 265 posts
After upgrade sleep is not working (using lid and from menu)
Battery Icon is gone

Anyone know a solution ?

HP laptop DV8, see my sig

//Peter

#60
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,466 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

After upgrade sleep is not working (using lid and from menu)
Battery Icon is gone

Anyone know a solution ?

HP laptop DV8, see my sig

//Peter


hello

if u use any kext for the battery must install all again, and maybe resolve u sleep problem

because the battery kext use another appleacpiplatform

good hack





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy