Jump to content

Apple unveils "macOS Sierra"


fantomas
  • Apple today unveiled "macOS Sierra" at its Worldwide Developers Conference 2016.

Developers are being given a preview version of macOS Sierra today and a public beta will be available this summer (in July).

The final version will be available to the general public in the fall.


User Feedback

Recommended Comments



This one should load kexts from 10.12 dir.

- flooded with msg "acpi error.. _STA"

- cannot load dummy hda from /L/E -or- /S/L/E

 

Failed on my laptop due to VoodooPS2 KP.

 

On the X79 it's booted up to a stream of /var/empty errors so far. Just waiting to see if it progresses beyond those.

Link to comment
Share on other sites

my old laptop cpu is sandybridge.

slice r33 supported 10.6~10.12 now for me. i love slice's fakesmc because he's driver supports all osx. i confimed it

slice fakesmc loaded

 

 

i upload file above post

sorry my mistake  :wub:  :wub:

 i found culprit was AppleALC by mistake which was added in all test to Sierra result in Fail to Slice FakeSMC ( AppleALC and Slice FakeSMC is in one Folder I'm using from mistakenly both getting copied eveytime) 

 

Slice FakeSMC is working i confirm too  :hysterical:  :hysterical:

Link to comment
Share on other sites

sorry my mistake  :wub:  :wub:

 i found culprit was AppleALC by mistake which was added in all test to Sierra result in Fail to Slice FakeSMC ( AppleALC and Slice FakeSMC is in one Folder I'm using from mistakenly both getting copied eveytime) 

 

Slice FakeSMC is working i confirm too  :hysterical:  :hysterical:

i tried to tell the dev about his kext busting 10.12 he wont listen he has a stick up his bum says there isnt a issue

Link to comment
Share on other sites

Guys, does FakeSMC need updating in order to run Sierra? I tried creating a USB drive with Sierra (the same way I always do) and...it gets stuck when booting from it at "asserting sound..." something. Also, does Clover 3556 work to boot up Sierra or do we need a newer version?

Link to comment
Share on other sites

It's installing now on the X79. Using Slice's FakeSMC and Micky's Clover files. My ethernet kext isn't loading (IntelMausi) but I don't know why yet. I'll check when I get the system installed.

 

AppleALC does seem to be the cause of the long delays stuck on the /var/empty loop. Once I moved it out of Other (so it wouldn't load for 10.12) it booted to the installer in more or less normal time.

 

As for the laptop, is there any alternative for VoodooPS2 for keyboards and Synaptic trackpads?

 

@arsradu, get the Clover files from Micky which I've linked to above and overwrite the 3556 ones with these. They fix kext injection.

Link to comment
Share on other sites

Wifi injection? Or kexttopatch?

 

If you use kexttopatch, you need to find hex for work in sierra

 

나의 LG-F410S 의 Tapatalk에서 보냄

I use dsdt injection and fakeid kext from rehabman. Was working fine in 10.11. And I do see airport4360.kext loaded. But still no wifi hardware detected
Link to comment
Share on other sites

this is my problem now:

 

ok, installed and running. but no sound. applealc doesnt work, voodoohda is ignored and if i try to put a patched hda in sle the cache corrupts or something and i get kp system uptime...

Link to comment
Share on other sites

this is my problem now:

 

ok, installed and running. but no sound. applealc doesnt work, voodoohda is ignored and if i try to put a patched hda in sle the cache corrupts or something and i get kp system uptime...

 

I think it's normal for a Beta OS, no? 

Link to comment
Share on other sites

Have it up and running on the X79 now.

 

Had to remove AppleALC as it was causing the /var/empty boot loop. I only use it on the X79 for the sake of completeness as I use external USB audio.

 

Although it didn't load in the installer, IntelMausi ethernet worked from first boot.

 

Using NullCPUPM so I can get hardware speedstepping until the AICPUPM patch is updated for Sierra.

 

Display goes out and comes back between first and second stage.

 

WiFiVelocity keeps spamming console with failed starts. Even when I turn WiFi off.

Link to comment
Share on other sites


×
×
  • Create New...