Jump to content

TimeMachine fails backup


theotheo
 Share

225 posts in this topic

Recommended Posts

Hey all! Just wanted to leave my 2 cents of my experience with my Time Machine woes in writing, since that's what this community is all about.

 

So Time Machine wasn't working for me, giving me Error 35 and no more info. I did notice about how Time Machine issues are related (somehow) with your Networking configuration, and reading here I saw that you *have* to have your Ethernet card at en0 for TM to work. Thing is, my Ethernet was indeed at en0. But I did notice that I had my Firewire card and a non-existant Built-in Modem on the Network Devices list in my Network Preference Pane. Odd, to be sure, but I never paid attention to it because I didn't think it was related since my NIC was en0. But I removed both entries by pressing the "-" underneath, leaving just my active NIC in it. I restarted my system after that and voila, no more Error 35 and Time Machine is, at least apparently and from what I can tell, working just fine.

 

So to sum up: removed my FireWire and non-existent Built-in Modem from my Network Pref. Pane, made sure my NIC's ID was en0 and rebooted. No extra kexts, no patched kexts, nothing. It just worked.

 

I hope this helps anyone else that is having Time Machine issues. As for my system specs, check my signature. Best of luck :D


Now it is working to!

I used this program to make it run IONetworkingFamily_Fix.pkg.zip

:)

 

Btw anyone know why is it so slow when it backs up ?

:)

 

This one completely damaged my osx installation...im using kalyway 10.5.4...

 

upon boot the screen is what i see:

 

http://www.flickr.com/photos/n1kolajen/2778606066/sizes/o/

 

how the heck do i undo that? 0_0

 

im pritty desperate as well


  • 2 weeks later...
I got time machine working with the binary that was posted above. But as it turns out, I also need a different IONetworkingFamily.kext to get my ethernet working. How can I edit or merge the two?

 

This is what I am afraid of... mixing kexts, or mixing old kexts from a year or so back with a newly updated system. There are so many different fixes for so many problems that involve custom kexts (which is fine), but you can possibly fix something and break something else. Seeing as no one outlines what they do to mod the kext, I think I should be afraid to use it.

 

I have the "System Preferences[343] Failed to get MAC address for machine" issue (even though ethernet = en0!) and am reluctant to insert a custom kext. I also have the UUI 35 issue big time, but again, if I insert that, what else do I break.

 

Anyone care to comment?


I had the same thoughts about the risks. So, I plan to do an identical install of 10.5.4 onto an external usb hdd, and test it on that. Of course there could be a difference between booting from usb vs sata, so we'll see. Just changing my wifi card stopped TM from working, due to the en0 problem.


Not sure of what tip you tried, but I tried the enx to en0 fix. I deleted the plist, and edited the pref file. All en1's were changed to en0. When I rebooted, sys profiler said the network was now en0, and TM started working! Now that I'm using the new wireless card, I've noticed that sometimes file sharing, and itunes sharing won't work, while internet is fine. After some time, the full network starts working, including airtunes, ipod touch remote, etc. I tend to leave the computer on at that point. :D


hi how du i reboot with -f do i have to put the kalayway cd in to do that?

 

pleas help... im a newbie

When ur Mac OS is starting u should see Darwin bootloader menu. So just put any key then write "-f" and press Enter.

That's all. :)


I am running "vanilla" 10.5.4 on a Bad Axe 1 and have tried replacing IONetworkingFamily.kext with several of the files linked to in this thread and elsewhere. I am still seeing this error in the console:

 

_CFGetHostUUIDString: unable to determine UUID for host. Error: 35

 

Is there a ready solution for this or not?


Just tried to update to 5.5.4 from 5.5.3 but had frozen log-on screen on reboot. Before I started I did a backup with time mc and also booted Kalyway DVD and created a disk image of my system disk. I booted the DVD again and tried to restore from Time machine and all went well but just a flashing cursor on restart. I suspect that I need to add the Darwin boot stuff back on the disk. How do I do that?

 

I am just trying to restore the disk image right now and have fingers crossed that I will be able to reboot after that completes or maybe I will have the same issue.

 

Thanks for your help


Well I had the same thing when I restored from the image. BUT when I put in the Kalyway DVD and restarted the PC it booted up fine from the hard disk. I do recall there was a way to fix this but if someone could point me to the right place I would really appreciate.

 

Thanks


I just want to add my own experience with this Error 35. The install I'm referring to is my Gigabyte install: original leo using Boot 123 method w/Chameleon upgraded to 10.5.4 using update; patched AHCI, Sound, AppleSMBIOS-27, CHUD shutdown fix (for Quadcore).

 

I kept getting the "Backup volume could not be found" with Time Machine and an external USB drive, so I tried to backup with Super Duper: it didn't work either and when I checked its log it revealed "Error 35". I found this fix but couldn't figure out how to edit the IONetworkingFamily.kext to insert the IONetworkingFamily file (not permitted). I finally just copied the kext from the extenstions folder into a temp, opened it in Finder, replaced the file, and then replaced the original kext with this copy using OSX86Tools. Touched the extensions folder, repaired permissions and rebooted.

 

On reboot, TM still failed with the same message, but Super Duper worked! I interrupted the backup, restarted the computer, but this time I turned off the external USB drive during the reboot, and only turned it on AFTER leo was up and running. I opened the TM preferences, assigned the right drive, right-clicked the TM icon selecting "Backup now" and it started backing up. It's currently past 15 gigs and still backing up. The UUID thingy probably needed a good reset. I'll update if something fishy happens.

 

I agree that using TM is risky business if it means that an update could wipe out our ability to recover data from it. I'm tempted to forget about it and just use Super Duper, foregoing the hourly automated backups in favor of guaranteed recovery...

 

UPDATE: After updating to 10.5.5 this fix is still working. I used TM to recover an original kext and it worked perfectly. Very cool.


i have a different problem...

 

first of all i use iAKATOSv4i osx 10.5.4

 

the backup start and succeded but if i would like to see backup using time machine it doesn't works.. it look to start but not works.. ideas?

 

thanks


(heavily edited...)

...I finally just copied [iONetworkingFamily.kext] from the extenstions folder into a temp, opened it in Finder, replaced the file, and then replaced the original kext with this copy using OSX86Tools. Touched the extensions folder, repaired permissions and rebooted.

 

Thank you. This worked perfectly for me. I followed these directions explicitly, and upon reboot, TM worked. I'm backing up now - 2.7 of 52GB - so I'm far from finished, but I'm a LOT closer than I've ever been. Plus, my other networking issues are fixed now - my iPod touch Remote app can control my iTunes library, my iPod's 1Password app can sync with my desktop app, etc.

 

So THANK YOU! =)


Hi,

 

after the update to 10.5.5 (from 10.5.4, using Netkas method) I am getting the "The backup disk image could not be mounted" meassage, since the update i never had problems with time machine.

 

I am using Leo4allv3 on

ASUS P5K-E/WIFI-AP

2 Samsung SATA HDs

 

Any ideas, possible solutions or similar experiences are welcome, thx.

 

PS: currently back to 10.5.4


Ok I'm going (slightly) more nuts than usual trying to get TM working. I've tried everything in this discussion..my setup is

 

10.5.5 - running from Kalyway, updated with netkas procedures....everything working great except TM...can not find drive

 

Drive is internal.

 

My network setup is one ethernet, one airport

 

I've loaded the ionetworking kext - didn't work

I tried changing my ethernet to en(0), but it doesn't seem to "stick" or I'm not doing something right as my ethernet shows up still as en(1)

 

The drive I'm trying to backup to is internal, is that part of the problem?

 

Any help is greatly appreciated.

 

t


Sounds like you need the moddified IONetworkingFamily.kext by ToH. Here it is...

 

http://www.megaupload.com/?d=HWVMONUU

 

After placing it it /System/Library/Extensions

 

sudo -s

*password*

 

rm -rf /System/Library/Extensions.mkext

chmod -R 755 /System/Library/Extensions/IONetworkingFamily.kext

chown -R root:wheel /System/Library/Extensions/IONetworkingFamily.kext

 

reboot, and keep your fingers crossed

 

HTH,

 

The Baron

 

Thanks! This kext worked for me when all the others didn't. Well, they did, but they also removed my keyboard functionality at the same time... (I'm runnning 10.5.5 btw)


Quote above works for me too. I'm on a ASUS P5W DH tried to make a sata drive work. The Baron's method worked great! I also cleaned up my network connections in System Prefs too to be on the safe side. The dual gig ethernet bios settings can confuse OS X sometimes on this motherboard...

 

P.S. Also anyone who is reading in the first page about Safari adding "@" or w/e to make the files not run as system files. Then to fix they mention commands & components like "xattr -d com.apple.quarantine", it is not needed. Just go to Safari's Preferences and uncheck "Open "safe" files after download". This make it so Safari doesn't add any attributes to downloaded files. For people making packages to help us. Make a folder with the fix file inside then archive that. I learned this when I re packaged a fix for us hackintosh users needing Microsoft Silverlight during the Olympics...

www.insanelymac.com/lofiversion/index.php/t116455.html

 

Thanks again The Baron & all!


  • 2 weeks later...

I did a restore from TimeMachine, my system is a BadAxe2 started w/Kaly 10.5.1 updated to 10.5.4, Chameleon bootloader and vanilla kernel. First I had an Error 13, reinstalled Chameleon, now I only get a few seconds into the gray screen and the system shuts down. Here is the -v text, right before shutdown:

 

Any help certainly appreciated.


Have you tried in TM options: change disk - NONE and then change disk - YOUR DISK?

 

That did it for me.

 

After installing the fixed kext I was still getting the same errors. I just set it to NONE, turned off the TM, closed the window, and opened it back and assigned the HD and it worked.

 

Thank you so much.

 

EDIT: Btw, this is offtopic, but the fixed kext also helped me to fix an issue with the sleep function. Previously my computer would go on sleep, and when it came back the network wouldn't "wake up", it'd stay in sleep mode and the only way to fix it was rebooting.


I'm running OS X 10.5.5:

 

Initially, I could not setup time machine to run. I'm using an internal 500GB SATA drive as the TM drive. BEFORE using Baron's attached IONetwork..Family.kext install, TM would show the drive in GREEN as a Time Machine backup disk drive. However, manually or letting TM auto backup will cause a red ! failure icon.

 

Solution: Use baron's attached kext. I installed with kext helper. Rebooted machine. My 500GB drive showed up as an orange drive icon. I went into time machine, selected "Change Disk..." to NONE. Then I resetup the same disk drive - it would appear as a "GREEN" TM icon drive. Turned on TM and did a manual backup and it works flawlessly.

 

Hope this helps some of ya who are having troubles. The biggest step for me getting it to function was the removal of the drive in the list (AFTER you installed the KEXT update)...then reset up the drive would work flawlessly.


 Share

×
×
  • Create New...