Jump to content

TimeMachine fails backup


225 posts in this topic

Recommended Posts

For anyone who did not get this to work with the above fixes, also give

 

TimeMachineScheduler

 

a try.

 

This freeware not only mounts/unmounts your time machine on command,

it also lets you specify the backup interval from 1 up to 12 hours.

 

Personally, every 12 hours is enough to backup for me :(

UPDATE!!

 

I finally managed to make it work! I found the solution here: http://forum.osx86scene.com/viewtopic.php?...509&p=20212

 

For some reason TM wants the ethernet interface en0 to be used, and for some reason in my machine my network card was assigned at en2! If you have two Network cards i think en0 just has to be assigned, then you can use wathever you want

 

So try removing /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist (backup first) and reboot (this worked for me)

and editing /Library/Preferences/SystemConfiguration/preferences.plist if needed

 

nb: I also have the modified kext, so i dont know if is necessary or not!

:rolleyes:

 

Confirmed, this worked for me. I was on en1 because when I first setup Leo I was using my onboard lan (nForce 4). I recently switched to a pci nic card. All I did was delete the .plist and well, I think this will finish the sentence nicely ... 2233742505_b8f6158754.jpg

 

I have no modified .kext for this to work.

 

Stats:

Drive is plugged in via USB.

AMD Chipset

TM works perfect, even restore works. Now, i got only 20gb part+20gb for tm.

 

Of course i get the message its full and so, my question is : what excatly will tm delete from the tm partition ? the 1ºBackp too or just the last ones ?

 

tx

 

b

 

€: time machine should have its own drive. Samll partition[40gb usb hd], ends in a error message when full. I can restore, but after that i get error message about full hd etc.. and since than, i cant install on my amd setup. I deleted all, internal,external hd, yet cant bypass boot cd : ___....

 

USe tM and make 2 Backups only, 1 clean after install and a 2nd with all the software installed.

  • 2 weeks later...

Hello Everybody,

 

After having no success with the "replace IONetworkingFamily.kext/remove quarantine/nuke NetworkInterfaces.plist" approach, I stumbled upon the following gem on another website:

-------------

"Browse to the Time Machine drive in Finder, there should be a folder called 'Backups.backupdb' in there there should be one folder with the name of your machine. Check that matches the 'Computer Name' set in 'System Preferences / Sharing'."

-------------

 

I told Time Machine to use "No Drive", which turned off Time Machine. I then opened my backup drive/volume in finder and created the two folders referenced above. I then went back to the Time Machine preferences and re-selected my backup drive (an external 500GB USB drive). I then started a TM backup and noticed TM created another folder on my backup drive with the same name as the manually created folder but with the prefix " 2" (space-two). I suspect perhaps only the first folder (Backups.backupdb) needs to exist for this work-around to succeed, but I haven't tried vreating just the first folder.

 

Looks like it's working so far... :D

 

- ZeeJM

I had the same mysterious problem of TM failing backup after a split second - everything else working (kernel patches not working) on my flat image leopard (10.5.2 with graphics update) built on Gigabyte 965P-DS3.

I tried a few things suggested here and thanks to you guys for suggesting the service order of the network cards.

It works now (I haven't tested restore yet)

I removed every item in the networks list (serial port - modem - I made inactive) - rebooted - I added a network card to the list - put it first in the service order - it is en0 - attached the cable and it connected - In TM I assigned a USB drive partition as target - chose backup now - and it started and is backing up as I type.

I hope this helps someone

Thanks Guys - keep up the good work!

Hi Bobbyd,

 

I did not need to mess around with the plist - All done via the GUI Network System Preferences Applet.

 

What led me to do this (besides the duscussion in this thread) was the appearance of a Firewire entry. My motherboard does not have firewire. So I figured that the listed Network Cards (3) were also suspect. I decided to clean the list out - reboot - and enter the devices I really had on the motherboard.

 

Hope it works for you

Hey all... Thanks for all these tips. I was able to backup with time machine with an alternate IONetworkingFamily.kext file. Though now my problem is when I hit the "Enter time machine button" Nothing Happens. I dont go into space or anything, a Finder window pops up then dissapears and the desktop icons and stuff reloads. I have no idea why this happens. Is there anyway to reinstall Time Machine? If anyone has had this problem plz reply back. Thanks.

I got my time machine working. Here are my specs and what I did.

 

Kalyway 10.5.1 installation followed by 10.5.2 upgrade as instructed elsewhere.

Hackintosh : OSX 10.5.1

Pentium Dual Core E2140 @ 1.6GHZ, Lancaster G8 Mobo (Compaq), PNY GeForce 8400GS 256MB, Belkin DGE 530T Gigabit Ethernet.

 

Steps:

1. Turned on both my onboard and PCI ethernet cards (ethernet is connected to the Belkin Gigabit NIC). Loaded Kexts for the Marvel Yukon for the DGE 530T and for the Onboard Realtek NIC.

2. Updated with the IOnetworkingfamily kext referenced in this post.

3. Cleared the networking adaptors in the networking preference pane, and reenabled them for the two network cards with manual IP addresses enabled. (Note for some reason on my system both cards have to be set up for my ethernet connection to work, even though only one is connected to my router)

4. In time machine preference pane, I selected the No drive choice first, attached my freshly formatted USB 2.0 External Drive, and then back in the time machine preference pane I selected my external drive. And Voila, after 119 seconds the time machine back up initiated, and has been running and stable for 24 hours.

 

One of the key steps that this did not work without is having a NIC identified at the en0 location, even if that is not the NIC you are actively using. After working through these steps some of my AFP network stability issues have settled down, but I am not sure which of these steps worked for that, but in the end my hackintosh is fully functional and stable.

 

Thanks for everyone's help on this thread!!

For all the people who having trouble with time machine, I discovered (by my laptop Sony Vaio FZ19VN) when you don't have an ethernet card configured properly, time machine won't work.

This was what I did:

I have a Marvell Yukon Ethernet card in my Vaio Laptop wich I had not configured yet,

- When I replaced IONetworkingFamily.kext, Time machine did not work. (even not when I turned it off and then back on)

- when I configured my Ethernet Card with the drivers, Time Machine started backing up, with the replaced IONetworkingFamily

 

So I think you need your ethernet card configured properly (it worked for me and back ups my whole system as I type.) :P

 

If this also doesn't work, I'm out of ideas.

×
×
  • Create New...