Jump to content

Inserting second M.2 ssd causes stuck on black screen before BIOS


6 posts in this topic

Recommended Posts

Hi!

A have a stable system with Big Sur Opencore 0.6.3, vanilla install:

 

Gigabyte Z390 AORUS PRO

Intel Core i5-9600K Hexa-Core 3.7GHz

ADATA XPG SX8200 PRO 256GB MacOS

ADATA XPG SX8200 PRO 500GB Windows

G.Skill Aegis 16GB 3000MHz

SAPPHIRE Radeon RX 580

Fenvi Wifi BT

 

I recently moved from Clover and I had a second ssd installed which was running Windows 10. Sometimes I got system starting issues, like stuck on a black screen before reaching BIOS (on memory check LED). A restart resolved this usually. A week later I removed the windows ssd, made a clean install with Opencore on the main ssd. The MacOS was running okay with a single ssd, but when I inserted the windows ssd and started the computer it got stuck on a blank screen, so it's not even getting into BIOS screen since then If I use both ssd. If I remove the windows drive, it boots up normally. If I use the windows drive only (tried it in both m.2 slots) it's getting stuck on the black screen again.

The ssd is not faulty, I just had it tested where I bought it. (in a windows PC I think). What can cause this issue? Did I mess up some boot part in the windows ssd? Should I have erased it also? (I currently can't access to a pc where I could erase it)

  • Like 1

I'm not sure about the specifics of the Z390, but a lot of boards (like my Asus x299) share resources between some devices and certain m2 slots. In my case I can use one device or the other, but not both.

 

I'm thinking you should check the motherboard's manual and look for a hardware conflict, though obviously pull the m2 for now to get it booting.

 

If that doesn't work, try a full power off and CMOS reset. I have had some issues with Big Sur and Open Core doing something to my bios that has prevented the machine from posting in the past. I've read some other reports of that as well, though apparently no one has found the cause yet. That's one of the reasons why on my x299 I'm still using Clover and Mojave.

Hi - I have the same board as the OP but the WI/FI version and I also have BS on a M.2 drive in the top slot and Windows 10 on another M.2 drive in the bottom slot (see attached). I don't have any problems what so ever that is reported, the conflict could be BIOS settings or the need for an update and this one is a long shot, it could be that those two drives although the same make do not play nicely with each other in the same system. As suggested check the manual for your options.

Spoiler

1762865312_ScreenShot2020-12-11at01_22_17.thumb.png.2c0a684102b5902de9a33e5076b870b5.png

 

check your efi partitions. make sure windows as its own efi partition. you will only need open core on the Mac drive . make Mac drive the first boot drive. you should then see both drives and be able to pick which drive you can boot from

 

  • Like 1

If you are not getting past the POST --power-on-self-test without issues that would indicate a BIOS issue recognizing that particular hardware.  Checking for a BIOS update would be the first order of business.  Secondarily, if there is a device conflict that may be able to be overcome with a BIOS configuration change.

 

You could purchase a USB enclosure for your m.2 drive that would allow you test it as a USB device.  If windows is installed on that drive make sure that it was installed in EFI mode or converted to boot in EFI mode.

 

Here is an excerpt from one of my previous posts: 

 

Make sure that both secure boot and TPM are disabled in the bios and that windows was installed in EFI mode or has been configured after the install to boot in EFI mode.  Move the BCD files to the main Windows partition as they are not there by default.  Verify that your machine is booting in EFI mode and not CSM.  Verify that your boot EFI boot partition has boot and ESP flags set.  Make sure you shut down windows while holding down the shift key until completely shut down.

 

You could use GRUB2 as your main boot loader and chainload windows bootloader and chainload clover or open core to boot macOS.  Change hd0,gpt1 in the windows boot entry example to match your configuration if different.


Your GRUB2 grub.cfg boot entries should look similar to these where xxxx-xxxx is the UUID of the boot partition:

menuentry 'Windows Boot Manager (on /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-efi-xxxx-xxxx' {
    insmod part_gpt
    insmod fat
    set root='hd0,gpt1'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1 xxxx-xxxx
    else
      search --no-floppy --fs-uuid --set=root xxxx-
    fi
    chainloader /efi/Microsoft/Boot/bootmgfw.efi
}



menuentry "Clover"{
   insmod part_gpt
   search --no-floppy --set=root --fs-uuid xxxx-xxxx
   chainloader /EFI/CLOVER/CLOVERX64.efi    # or whatever path you use
}



menuentry "Open Core"{
    insmod part_gpt

    search --no-floppy --set=root --fs-uuid xxxx-xxxx
    chainloader /EFI/OC/OpenCore.efi   # or whatever path you use
}

###########################

 

 

 

 

  • 1 month later...

Thanks for the help! I tried a bunch of things that you said. Neither of them worked really. So a couple of days ago I bought a different SSD and now it works without any problem. It seems the problem was that the two ssd was exactly the same model. (or maybe motherboard's nvme restriction or something)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...