Jump to content

[AMD] OS X El Capitan (10.11) Kernel Testing & Release (for help use the Help Topic)


1,255 posts in this topic

Recommended Posts

Anyone else having trouble with some pkg installers failing and simple apps not opening. Getting this error alot in crash logs,

Crashed Thread:        5  Dispatch queue: com.apple.root.user-interactive-qos

 

Yes. Adobe Flash Player installer for instance crashes everytime I try to launch it :

 

 

 

Process:               Install Adobe Flash Player [764]
Path:                  /Volumes/VOLUME/Install Adobe Flash Player.app/Contents/MacOS/Install Adobe Flash Player
Identifier:            com.adobe.InstallAdobeFlashPlayer
Version:               2.0.0.65s (2.0.0.65s)
Code Type:             X86 (Native)
Parent Process:        ??? [1]
Responsible:           Install Adobe Flash Player [764]
User ID:               501
Date/Time:             2015-12-10 23:20:44.558 +0100
OS Version:            Mac OS X 10.11.2 (15C50)
Report Version:        11
Anonymous UUID:        768029B8-C2C7-3E60-AE31-7D51EA7F503C

Time Awake Since Boot: 6300 seconds
System Integrity Protection: enabled
Crashed Thread:        2  Dispatch queue: com.apple.root.user-interactive-qos

 

 

 

[EDIT] Same with TextWrangler :(.

 

 

 

Process:               TextWrangler [806]
Path:                  /Applications/TextWrangler.app/Contents/MacOS/TextWrangler
Identifier:            com.barebones.textwrangler
Version:               5.0.2 (3786)
App Item ID:           404010395
App External ID:       814415319
Code Type:             X86 (Native)
Parent Process:        ??? [1]
Responsible:           TextWrangler [806]
User ID:               501

Date/Time:             2015-12-10 23:28:32.032 +0100
OS Version:            Mac OS X 10.11.2 (15C50)
Report Version:        11
Anonymous UUID:        768029B8-C2C7-3E60-AE31-7D51EA7F503C


Time Awake Since Boot: 6800 seconds

System Integrity Protection: enabled

Crashed Thread:        5  Dispatch queue: com.apple.root.user-interactive-qos

 

 

  • Like 1

 

And you are correct !

 

rootless=whatever you want is useless since El Capitan DP3 (or was it DP4 ? Hum… can't remember).

 

CsrActiveConfig=103 (Chameleon) or CsrActiveConfig=0x3 (Clover in RtVariables) is good and also mandatory for everyone now.

Oh, and I forgot to say that you need kernel.plist file in Extra folder for Enoch (Chameleon is still not compatible with El Capitan) with this setting (minimum) :

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>KernelBooter_kexts</key>
<string>Yes</string>
</dict>
</plist>

Guys, if you play with kernel source.... why not modify the relative function in place?? ..you can restore the load of the mkext too: 

 

KLDBootstrap::readPrelinkedExtensions

KLDBootstrap::readBooterExtensions

KLDBootstrap::readStartupExtensions

 

http://www.opensource.apple.com/source/xnu/xnu-3247.1.106/libsa/bootstrap.cpp

..and boot fast  ;)

 

 

I made an install drive with Createinstallmedia and I have the amd kernel in /Extra/Kernels/kernel and I boot with the neccasary bootflags for my machine + /Extra/Kernels/kernel but it doesn't seem to boot the amd kernel and reboots I'm using the latest enoch with csractive.

Yep, "createinstallmedia" load the kernelcache anyway ..no way to boot Vanilla

Edited by Micky1979
  • Like 2

hi, I'm new to hackintosh. is there any guide to build el capitan usb installer for AMD and using kernel from this topic?

 

found it, will try.

The problem is really in the usb, try booting with this stick in the other amd pc - with legasy bios problem was similar until disabled usb2,3. This problem is gone, but the installer will not start for 30 minutes hanging on the <Warning> Endpointed through legasy launch (3) APIs. Please switch to XPC or bootstrap_check_in (): com.apple.bsd.dtrhelper

 
p.s. how to make a picture? jpeg does not accept = (

 

The problem is really in the usb, try booting with this stick in the other amd pc - with legasy bios problem was similar until disabled usb2,3. This problem is gone, but the installer will not start for 30 minutes hanging on the <Warning> Endpointed through legasy launch (3) APIs. Please switch to XPC or bootstrap_check_in (): com.apple.bsd.dtrhelper

 
p.s. how to make a picture? jpeg does not accept = (

 

It refear to some Apple Helper Tool (com.apple.bsd.dtrhelper), and is a log that say to swicth to an XPC Server instead to use deprecated SMJobBless APIs.

No AMD related, and not a problem.

Hello everyone! Well, I was able to boot installer!))) I have used clover 3326. I didn't used VoodooTSCSyncAMD.kext, only FakeSMC.kext and NullCPUPowerManagement.kext. Flags I've used: -v -f npci=0x3000 kext-dev-mode=1 rootless=0 (I know, someone said, that it is useless but still I have used that flag). Also when I've prepared usb installer with Clover Special Edition - there were already made some settings for El Cap, for example: BooterConfig=0x28 and CsrActiveConfig=0x67. And some kext patch for those USB problems I suppose... Anyway it works and perhaps I will install it today on my test partition. I've used 10110R2 kernel by y2k4u, thank you very much! Very good job!

p.s Now I've red about those BooterConfig and CsrActiveConfig, so it's the default settings to disable whole protection of making some changes to system folders and injecting unsigned kexts, am I correct? And I suppose that today kext-dev-mode and rootless flags are no longer needed?

 

upd. forgot to say, it's 10.11.2 installer...)

post-1484325-0-61690300-1449930869_thumb.jpg

Edited by ImmortalSoulL
  • Like 5

B)

 

Phenom /HD 6670 / motherboard no UEFI (GA78lmtusb3) works good but problem USBMassstorage and problem AppleRTC , the video is fluid  :rolleyes:

 

commmand terminal repair HDD if you please  :blush: , KP aléatoire  :worried_anim:

 

iCloud works ootb :)

 

flag :

 

<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>AtiConfig</key>
<string>Lotus</string>
<key>AtiPorts</key>
<string>3</string>
<key>KernelBooter_kexts</key>
<string>Yes</string>
<key>KernelPm</key>
<string>Yes</string>
<key>KernelLapicError</key>
<string>Yes</string>
<key>KernelLapicVersion</key>
<string>No</string>
<key>KernelHasswell</key>
<string>No</string>
<key>KernelcpuFamily</key>
<string>No</string>
<key>KernelSSE3</key>
<string>No</string>
<key>Kernel Flags</key>

 

<string>npci=0x2000 GraphicsEnabler=Yes USBLegacyOff=Yes</string>
 
thantks polyzargone and Ermac , use Enoch 2795 :)
 
edit : repair but the kernel ? 
 
 
iMac-de-gils:~ gils$ sudo /usr/libexec/repair_packages --repair --standard-pkgs --volume /

WARNING: Improper use of the sudo command could lead to data loss
or the deletion of important system files. Please double-check your
typing when using sudo. Type "man sudo" for more information.

To proceed, enter your password, or type Ctrl-C to abort.

Password:
	Permissions differ on "Library/Java", should be drwxr-xr-x , they are drwxrwxr-x .
	Repaired "Library/Java".
	User differs on "System/Library/Kernels/kernel", should be 0, user is 501.
	Unable to set owner & group on "System/Library/Kernels/kernel". Error 1: Operation not permitted
	Unable to set permissions on "System/Library/Kernels/kernel". Error 1: Operation not permitted
	User differs on "private/var/db/displaypolicyd", should be 0, user is 244.
	Group differs on "private/var/db/displaypolicyd", should be 0, group is 244.
	Repaired "private/var/db/displaypolicyd".

post-1093405-0-36727400-1449934819_thumb.png

post-1093405-0-05818100-1449934874_thumb.png

post-1093405-0-05252600-1449935184_thumb.png

post-1093405-0-88044200-1449938837_thumb.png

  • Like 3

Guys, unfortunately after the reboot I couldn't boot into the installer. Getting this USB problem every time I try to boot:

4ASli88.jpg?2


 
I have red that and that and no result.(( It's because with AMD motherboard is all different:

O42kxxK.png


 
I've tried to remove ports restriction, also I've tried to figure out how to add ports to DSDT, I even tried to use injector kexts, where I've deleted ports restriction and still no result. I've spent whole day to find the solution. Perhaps I'm doing something wrong, I don't know. Oh and by the way if you want to use clover, then you should install it on EFI partition, otherwise it will not boot! At least I couldn't boot, when I've installed clover in the same partition where installer was. I think I'll get same issue even with chameleon, maybe I'll try it later... If someone know how to solve this, please help.)
p.s. It's really strange, I was able to boot once, but then again this thing...

  • Like 1

El Capitan is fake !!!  :mad:

 

no repair Extension  , no repair kernel , update iTunes crash , mediaflashplayer crash , many Appli crash , usbmassstorage crash , etc.......... , chiot !!  :thumbsdown_anim:

 

return Yosemite 

  • Like 3

repair kernel? :)

 

Yes repair with Extension , look 

 

Password:

    Permissions differ on "Library/Java", should be drwxr-xr-x , they are drwxrwxr-x .

    Repaired "Library/Java".

    User differs on "System/Library/Kernels/kernel", should be 0, user is 501.

    Unable to set owner & group on "System/Library/Kernels/kernel". Error 1: Operation not permitted

    Unable to set permissions on "System/Library/Kernels/kernel". Error 1: Operation not permitted

    User differs on "private/var/db/displaypolicyd", should be 0, user is 244.

    Group differs on "private/var/db/displaypolicyd", should be 0, group is 244.

    Repaired "private/var/db/displaypolicyd".

El Capitan is fake !!!  :mad:

 

no repair Extension  , no repair kernel , update iTunes crash , mediaflashplayer crash , many Appli crash , usbmassstorage crash , etc.......... , chiot !!  :thumbsdown_anim:

 

return Yosemite

 

Ahahahah true...))
  • Like 1

@Gills there is no need to repair the kernel permission because is loaded by the bootloader when root is not existing yet...so no matter :)

 

euh ?? 

 

repair permission of El Capitan , the kernel works but très mal ,  AppleRTC patched no works (clearcmos atfer reboot) , voodooPState no works  (kp)   :( + UEFI motherboard AMD no works  :hysterical:

Calling FX testers,

 

Attached is the AMD 10.11.0 kernel for FX CPUs.  I don't know if the FX kernel works since I don't have access to FX CPU, thus, making the FX kernel work is like shooting in the dark.

 

10110FxR1.zip

  • Like 2
×
×
  • Create New...