Jump to content

[AMD] Yosemite Kernel Testing (for help use the Help Topic)


1,948 posts in this topic

Recommended Posts

  • 2 weeks later...

 

Hi ! 
Sorry ! With this kernel not works vmware and etc ... I fixed this, and fixed for cpu kabini and etc , then now works vmware ... )))
This kernel works for all cpus ...

attachicon.gifkernel_10.10.5_rc4_fix.zip

 

 

 

rc4 was working smooth for me, I did upgrade and my system dont start :(

I did upgrade kernel because photoshop was getting crashed

  • Like 1

The problem with Adobe think it's a problem of FX8320 CPU ,

RC3 Bronya kernel is fine for my FX8350

 

Illustrator

Schermata 2016-07-10 alle 11.00.58.png

Photoshop

Schermata 2016-07-10 alle 11.01.48.png
A colleague of mine here has the same problem with Illustrator and Photoshop Go in crash

http://www.insanelymac.com/forum/topic/309625-macos-x-maverick-su-amd-fx-8320/page-8?do=findComment&comment=2250457

he has a FX8350 , we made many tests but nothing , it works for me and not him

 

@saumil 

You have FX8320

 

@Bronya , Because it can happen?

We tested it with clover in legacy and UEFI mode and Enoch, changing GPU nvidia 210 and AMD r9 380x
 but nothing he does have the problem, you may depend on the frequency of the CPU ?

  • Like 3

The problem with Adobe think it's a problem of FX8320 CPU ,

RC3 Bronya kernel is fine for my FX8350

 

Illustrator

attachicon.gifSchermata 2016-07-10 alle 11.00.58.png

Photoshop

attachicon.gifSchermata 2016-07-10 alle 11.01.48.png

A colleague of mine here has the same problem with Illustrator and Photoshop Go in crash

http://www.insanelymac.com/forum/topic/309625-macos-x-maverick-su-amd-fx-8320/page-8?do=findComment&comment=2250457

he has a FX8350 , we made many tests but nothing , it works for me and not him

 

@saumil 

You have FX8320

 

@Bronya , Because it can happen?

We tested it with clover in legacy and UEFI mode and Enoch, changing GPU nvidia 210 and AMD r9 380x

 but nothing he does have the problem, you may depend on the frequency of the CPU ?

 

Yes i have FX8320.

 

I downloaded 3 Photoshop versions

the latest CC2015.5 = Crash on font change [tried all regular fixes but still]

CC2015.1 = same problems [peoples reported this on amd using bronya's kernel on fx]

CC2015 = working smooth as far as I have tested

 

CC2015 is this one

 

PhotoshopCC2015.jpeg

Yes i have FX8320.

 

I downloaded 3 Photoshop versions

the latest CC2015.5 = Crash on font change [tried all regular fixes but still]

CC2015.1 = same problems [peoples reported this on amd using bronya's kernel on fx]

CC2015 = working smooth as far as I have tested

 

CC2015 is this one

 

 

I have the same problem with Illustrator CC.

Your cpu frequency is setting on stock (3,5ghz) ?

Have you never tried to change the cpu frequency with a low overclock?

I have the same problem with Illustrator CC.

Your cpu frequency is setting on stock (3,5ghz) ?

Have you never tried to change the cpu frequency with a low overclock?

 

was running at 3.2Ghz. now stock. no changes

The problem with Adobe think it's a problem of FX8320 CPU ,

RC3 Bronya kernel is fine for my FX8350

...

@Bronya , Because it can happen?

We tested it with clover in legacy and UEFI mode and Enoch, changing GPU nvidia 210 and AMD r9 380x

 but nothing he does have the problem, you may depend on the frequency of the CPU ?

Hi ! 

In CPU FX8320 have problem no stable work crystal. Then problem Mhz ...  . Is best suited cpu processor and stable work FX 8350 .  

You try change multiplier in bios from auto to manual multiplier . 

  • Like 2

 

Hi ! 

In CPU FX8320 have problem no stable work crystal. Then problem Mhz ...  . Is best suited cpu processor and stable work FX 8350 .  

You try change multiplier in bios from auto to manual multiplier . 

 

Hi Bronya, i think there aren't so much difference from FX8320 and FX8350, just the frequency and consumption.. 

I've tried to set in the 8320 the same frequency of the 8350 but nothing changed.. 

Can a specific kernel for this processor, fix this issue? I can't sell my 8320 to buy the 8350 because i am attached  :(  .. no i'm just kidding, i dont have to much money to buy it.

  • Like 1

Hi Bronya, i think there aren't so much difference from FX8320 and FX8350, just the frequency and consumption.. 

I've tried to set in the 8320 the same frequency of the 8350 but nothing changed.. 

Can a specific kernel for this processor, fix this issue? I can't sell my 8320 to buy the 8350 because i am attached  :(  .. no i'm just kidding, i dont have to much money to buy it.

 

try installing older versions, it solves problem for me :)

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

 

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)

Exception Codes:       KERN_INVALID_ADDRESS at 0x00000000000007c0

 

this is the error I am getting btw

  • 2 months later...

Try kernel.10.10.5_rc3 ! Enabled ring0 in kernel. 

If problem reboot , problem boot , need new version boot =)). 

attachicon.gifkernel_10.10.5_rc3.zip

Hello dear Bronya, I have a surprise to communicate you, your Yosemite Kernel AMD of November 4th, 2015 is only Kernel capable of running Yosemite (up to date 14F2003) on the motherboard ASSUS P8H61-I LX R2.0 (chipset intel H61) with I5 2400 and NVDIA (MSI 210) or an ATI (ASSUS HD5450). Otherwise impossible to run it with Kernels Intel (that I boot with Chameleon or Clover). With this motherboard same scenario for Mac Os Lion (11G63) , the only one possible kernel it's your that of January 2013 Kernel AMD.

 

  • Haha 1

Cool , thank ! )) 

ok dear Bronya, but As you can think of it, I do not understand why Kernels AMD runs this motherboard. And that doubtless other motherboards can also work with Kernels AMD rather As you can think of it, I do not understand why Kernels AMD runs this motherboard. And that doubtless other motherboards can also work with Kernels AMD rather.

Thanks for all.

Intel platforms can all run AMD kernels; these kernels not reserved/limited to AMD/non-Intel platforms if that's your query. What you would need to suss out is why your Intel platform cannot run the vanilla kernel but that's something to discuss in its own separate thread.

  • Like 1
  • 4 weeks later...

I have a strange problem with GTX 950 + web drivers + 10.10.5. When I use web drivers random freezes occur. With nv_disable=1 I have no freezes, but there's no QE/CI.

 

Dont know where to post it, I just hope that anybody knows smthing about this issue and can help me.

 

Gigabyte GA-970A-UD3P (rev 2.0)

I have a strange problem with GTX 950 + web drivers + 10.10.5. When I use web drivers random freezes occur. With nv_disable=1 I have no freezes, but there's no QE/CI.

 

Dont know where to post it, I just hope that anybody knows smthing about this issue and can help me.

 

Gigabyte GA-970A-UD3P (rev 2.0)

Please write more details, or upload the Extra folder or Clover folder ... It should work fine, possibly a minor mistake

  • 2 months later...

 

Hi ! 
Sorry ! With this kernel not works vmware and etc ... I fixed this, and fixed for cpu kabini and etc , then now works vmware ... )))
This kernel works for all cpus ...

attachicon.gifkernel_10.10.5_rc4_fix.zip

 

Hi!

 

Does this kernel need boot-arguments for non-SSSE3 processors (like it was in your kernel for Lion)?

 

UPD: Trying to install Yosemite 10.10.5 on desktop (AMD Athlon II X2 270), but have KP on corecrypto.kext, but before there is a line about invalidkernel opcode (64-Bit): 74 a2 a3 80 7f ff ff ff 00 00 00 00 00 00 00 00.

I've installed your kernel and replaced System.kext, and Frameworks. Also tried to replace AppleACPIPlatform, IOPCIFamily and pthread from Help Topic, but have no changes.

(Bootloader: Enoch r.2839). Clover rebooted trying to boot kernel. Any ideas?

 

Thanks in advance!

I have a strange problem with GTX 950 + web drivers + 10.10.5. When I use web drivers random freezes occur. With nv_disable=1 I have no freezes, but there's no QE/CI.

 

Dont know where to post it, I just hope that anybody knows smthing about this issue and can help me.

 

Gigabyte GA-970A-UD3P (rev 2.0)

 

When you get to the main screen do you receive a "there is a problem with the graphics" related message?

 

I have a gtx 750 ti EVGA running on Yosemite 10.10.1, I had the freezes too, after months of having this problem I solved it using this bootflag:

 

msibase=0x90

 

Since then I've been having my GPU fully working, hope it helps you

  • Like 1
  • 2 years later...
On 1/8/2017 at 5:50 PM, Neo.aka.Darkman said:

Hi!

 

Does this kernel need boot-arguments for non-SSSE3 processors (like it was in your kernel for Lion)?

 

UPD: Trying to install Yosemite 10.10.5 on desktop (AMD Athlon II X2 270), but have KP on corecrypto.kext, but before there is a line about invalidkernel opcode (64-Bit): 74 a2 a3 80 7f ff ff ff 00 00 00 00 00 00 00 00.

I've installed your kernel and replaced System.kext, and Frameworks. Also tried to replace AppleACPIPlatform, IOPCIFamily and pthread from Help Topic, but have no changes.

(Bootloader: Enoch r.2839). Clover rebooted trying to boot kernel. Any ideas?

 

Thanks in advance!

 

I also can not put this Kernel https://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_rel_module=post&attach_id=187542 get the same error. Maybe this is due to the fact that our processor is not FX?

  • 5 months later...
On 2014/11/8 at PM10点58分, gils83 said:

:)

 

速龙53 50 

 

嗯?bof .......... idem内核Bronya 14A389,我的kabini低值  :( 频率差1600 Mhz:(

 

标志:busratio = 20 fsb = 100 Mhz / HD 4670工作/ GT 440工作但滞后......滞后............滞后............. .. :(  和HD 6850无工作屏白:(

1093405-0-97621700-1415458763_thumb.png

Can you share your AMD kernel? Thank you very much!:)

×
×
  • Create New...