Jump to content

How to Install MacOSX 10.9 Mavericks on a MSI GS70 Laptop


47 posts in this topic

Recommended Posts

How to Install MacOSX 10.9 Mavericks on a MSI GS70 Laptop

This guide will show you how to get a basic functioning install of 10.9 Mavericks on a GS70 - a thin, fast, gaming laptop by MSI (details here, hw specs below).  Not all hardware is functioning, please check list below, and share if you find ways to get things working. Please keep posts focused on problems, helpful hints, and solutions.

FYI, my machine is triple booting Linux Mint, Windows 8, and MacOSX 10.9. I mostly use MacOS to fix my friends' computers and for iOS development, not everyday use.  I haven't taken the time to get sleep, mic input, etc. working properly.  Hopefully some folks can use this as a base to get more things functional.

Big thank you to RehabMan, rockinron_1, EMlyDinEsH, and the makers of Clover, Kext Wizard, DSDT Editor, and all the other great, necessary tools.



  • Basic Install
  • Trackpad (multi-touch)
  • Keyboard (including some function keys and glowy keyboard)
  • Sound (output speakers/headphones)
  • USB
  • Bluetooth
  • Shutdown
  • Integrated Intel Graphics


Not Working Yet

  • Internal wireless
  • Ethernet
  • Sound input
  • Sleep
  • NVidia accelerated graphics with optimus


Needed Tools:


Step 1: Create the USB Installer
(taken mostly from Vanilla Install guide)

  • In a previous MacOSX install, use DiskUtility to Partition a USB disk with 1 HFS+ Partition, make sure GUID partion map is selected in the options.
  • Mount your Mavericks dmg image
  • Go to the mounted image, right click on "Mavericks.app" and choose "Show Contents"
  • Go to "Contents/Shared Support" and mount InstallESD.dmg
  • Mount BaseSystem.dmg by typing the following in terminal:  open /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg
  • In DiskUtility, go to the "OS X Base System", Restore it to your USB disk.
  • Navigate to /System/Installation on your USB drive. Delete the “Packages” link, then copy the Packages folder from “OS X Install ESD” to this location.
  • Copy the following kext's to /System/Library/Extensions on your USB stick.
    • FakeSMC.kext and NullCPUPowerManagement.kext files from the Vanilla Guide
    • The patched AppleCPUPowerManagement.kext from Mieze
    • (optional, untested) You can try copying the Elan Touchpad drivers as well, read Step 5 "Touchpad and Keyboard" section below and delete approriate kexts, this could save you from needing a USB keyboard/mouse during installation
  • Install Clover to the usb drive, customize the install with the following options:
    • Bootloader->Install boot0af in MBR
    • CloverEFI->64-bits SATA
    • Themes->Choose one (Black_Green_Moody is nice)
    • Drivers64->XhciDxe-64
    • Drivers64UEFI->OsxAptioFixDrv-64
  • Copy the mach_kernel file from RehabMan to the root of the USB drive


Step 2: Installing OS X

  • Boot into the installer, I use reFind bootloader and the USB disk just shows up when it's plugged in, you should be able to select the boot order in your bios to boot from the USB key if you don't have another bootloader installed
  • Select "Options". Do the following:
    • under the DSDTfixmask menu, disable "fix display"
    • under the Graphics menu, select "Inject EDID" (inject Intel should already be selected)
  • Now boot into the installer (return to the menu with all the OS icons and select the USB key. It'll read "Boot Mac OSX HFS+" or something)
  • If you did not install the Elan kexts, you will have to use a USB keyboard and mouse for the install.
  • Install OS X (use a HFS+ partition on a drive partitioned with a GUID partition map, MacOSX is a good name for the partition)
  • Boot back into the installer like you just did early (yes select all those options)
  • Select "Utilities" from the top and then Terminal
  • You need to copy all those kext's you installed on the USB drive to your new installation partition. Type in the following lines, replacing MacOSX with the actual name of the partition you installed to (hint: after entering the first one, press the up arrow to save yourself some typing):
    • cp –R /System/Library/Extensions/NullCPUPowerManagement.kext /Volumes/MacOSX/System/Library/Extensions/
    • cp –R /System/Library/Extensions/AppleCPUPowerManagement.kext /Volumes/MacOSX/System/Library/Extensions/
    • cp –R /System/Library/Extensions/FakeSMC.kext /Volumes/MacOSX/System/Library/Extensions/
    • cp –R /System/Library/Extensions/ApplePS2ElanTouchpad.kext /Volumes/MacOSX/System/Library/Extensions/
    • cp –R /System/Library/Extensions/ApplePS2Controller.kext /Volumes/MacOSX/System/Library/Extensions/
  • Likewise, copy the patched mach_kernel from your USB drive to the install, replacing the original
    • - cp –R /mach_kernel /Volumes/MacOSX/
  • Now type "reboot" and hit enter


Step 3: Intial Reboot

  • Reboot again into the installer, choosing the same options as before BUT boot from the hard-drive, not the USB drive
  • As MacOSX 10.9 pops up, do a little dance of joy.
  • Install Clover onto your hard-drive, choosing the same options as before.
  • Install Clover Configurator and run it.  Do the following:
    • Go to File->Open on the top bar and choose /EFI/Clover/config.plist (this is your current Clover configuration)
    • In the ACPI tab, deselect FixDisplay. Make sure the DSDT name is DSDT.aml
    • Under Graphics, select Inject EDID
    • Choose File->Save (now you no longer have to select those options at boot time)


Step 4: Touchpad and Keyboard

  • Download EMlyDinEsH's Elan drivers (latest is 2.8.3 at time of writing): http://forum.osxlatitude.com/index.php?/topic/1948-elan-touchpad-driver-mac-os-x/
  • In finder, go to /System/Library/Extensions and delete the following if you can find them: ApplePS2Controller, VoodooPS2Controller, AppleACPIPS2Nub, ApplePS2Keyboard and anything that says Elan Touchpad.
  • Using Kext Wizard, install ApplePS2Controller and ApplePS2ElanTouchpad kexts
  • Reboot and enjoy.  My keyboard glows,using my windows settings. Also, note: the touchpad is a little jerky... I think this is because of the graphics driver, but it's functional.


Step 5: Ext4 (for linux peeps)

  • Buy or try the trial of Paragon Extfs... I couldn't get anything else to read my partitions.  They overcharge, buy hey, it works...


Step 6: Audio (output)

  • A bit complicated.  You need to patch your DSDT, install an updated HDA driver, and maybe install VoodooHDA.  I had VoodooHDA installed before I did the rest and I just left it installed... I am not sure if it is required or makes things worse (maybe input works without it?)  I dunno.  I would try without it first and then install it after if you need it.
  • Download a Java runtime for 10.9 (google JavaForOSX2013-05.dmg)
  • Download DSDT Editor (http://www.insanelymac.com/forum/topic/223205-dsdt-editor-and-patcher/ )
  • Download RehabMan's audio 12 layout patch: https://github.com/RehabMan/Laptop-DSDT-Patch/blob/master/audio_HDEF-layout12.txt
  • Edit the patch and remove all the instances of "\n"
  • Run DSDT editor and Choose File->Extract DSDT from the top bar, this will get your DSDT from your BIOS
  • Choose Patch->Open from the top bar, and select the audio 12 patch
  • Select Patch
  • Now choose File->Save DSL from the top bar and save this to your Desktop as DSDT.aml
  • Now copy this to /EFI/CLOVER/ACPI/origin
  • Now download and use Kext Wizard to install the AppleHDA.kext from RehabMan found here: (reference: here)
  • Restart and cheer!
  • If it doesn't work, or you want more controls, install VoodooHDA.  Make sure PCM is turned up in the VoodooHDA control panel thing.
  • If you need mic input, etc. working, the DSDT patch is probably where you need to be digging.  Post results please.


Step 7: USB Wireless


You will need to either install a wireless card that works with MacOS (advanced, warranty-voiding, numerous guides found elsewhere on this forum) or else buy yourself a compatible usb wireless adapter (easy, cheap).  I bought this one for 8$ and it works perfectly with the drivers on the CD it came with: GMYLE Wireless 11n USB Adapter



Step 8: Final notes

  • If the computer goes to sleep it will plant, so go into the power settings and tell it not to go to sleep!  (if you fix this, please post here)
  • No networking... buy yourself a Mavericks compatible usb network adapter (will let you know when I get one working)
  • Give credit and donations to the fine people that made these tools and patches, I just assembled them to make it work on this dreamy computer.
  • I will try to post a zip file with some of these kexts, etc. later.
  • If you are having trouble, in the clover boot options, add "-v" (without quotes) to the boot options. This will give a more verbose output and may indicate the issue
  • If you are not using Clover, the busratio for this computer is 24.  Adding "busratio=24" to the boot-up options (without quotes) might help for other loaders (Clover autodetects this)
  • If you get some extra hardware working, please let us know!


MSI GS70 Hardware Specifications:

  • CPU: i7-4700HQ (2.4GHz, Haswell)
  • Memory: 16GB DDR3 1600MHz
  • Accelerated Graphics: NVidia GTX 765M
  • Integrated Graphics: Intel HD Graphics 4600 (8086:0416)
  • Audio: Creative X-Fi. (8086:8C20)
  • Wireless: Atheros AR9462 (168C:0034)
  • Ethernet: Atheros Killer E2200 (1969:E091)
  • Hard-disk (custom: 128gb SSD, 512gb SSD, 1TB 7200rpm HDD)






Edited by fantomas1
tonymax86 site links edited!
  • Like 5
Link to comment
Share on other sites


  • Wireless: Atheros AR9462 (168C:0034),
  • ok?!

Hmm, I have no idea what you asking, if you are indeed asking something.  Maybe try to be a little more verbose next time?  I don't think anyone has gotten Atheros AR9462 cards to work on MacOS.  Therefore, as clearly stated in my post, the built in wireless for this computer is not working, you will need to buy a wireless card that is or use a usb dongle.

Link to comment
Share on other sites

  • 2 weeks later...

Hi there,


Thanks for taking the time to post a full guide here. Highley appreciated by me (I specially created an account here to thank you).


By the way: I have the same laptop and specs. Did you already managed to get the wifi working? Or the Nvidia card?

If so, can you tell me the kext files?



Link to comment
Share on other sites

Thank you very much! It is really cool because I am about purchasing this laptop. Actually a cheaper version, with only one 128gb SSD. That leads me to one question. It is possible to create a dual/triple boot on the same SSD? Do I have to erase the SSD in NFTS+extended macOS? Should I let win8 on the HDD, then install mac OS, then reinstall win8 on the SDD? Sorry for newbie questions!!!

Link to comment
Share on other sites

hey linixgirl,


can you upload your dsdt.aml without audio and with audio...


Now i have installed Mavericks on my XMG C703, but I can't boot with the Cloverbootloader on my Systempartion. (boot0af: error)  :(

But I can boot with the usb-stick into the Systempartion...

I am happy that it works a little bit...

but we have the problem with the mouse, or the animation with the intel 4600, we need to get solved this...  :yes:


I'm going to installed a compatible wlan & bluetooth module in my hackbook...and test an extern lan-module on the usb 3.0...




Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...

please help me.

I've finally got it to get through the first stage of the install. (installing Clover to USB as UEFI and setting bios to UEFI) the non-UEFI/Legacy mode instructions in this guide doesnt boot me into clovers gui, i can only get some grey bootloader config screen that has no use. 


With injectATI selected (and inject EDID+disable display fix) I boot to a black screen, without ATI-inject I can get to the installer and install, but upon rebooting (after copying over the files to my install volume) My MACHD drive hangs after bluetooth before loading the video if I leave inject-ATI off (this only works getting into phase1 of the install) and when I turn it on I can only get the black screen again) I've attempted alternate boot configs w Clover, and tried using Chimera as well with a series of various blootflags like IGPEnabler=Yes/No etc.. still just hangs or black screen. Almost ready for a mall shooting. (not)


Desperation mode has been enabled here, any suggestions would be much appreciated! :) 

Link to comment
Share on other sites

Hey aeondubs,

I have some similar Problems.

I have fixed it by loading all kexts in L/E and S/L/E.

And then I deleted some Bluetooth kexts...but I don't know if this fixed it....

I have a XMG C703, I think it has the same Hardware...


Did the beachball show on the black screen?



Link to comment
Share on other sites

hi linuxgirl, how did you solve the shutdown issue?


I have a Haswell laptop (specs: i5-4200U + Intel 8 Series Chipset Family), which can almostly perfectly run Mavericks now. and only a shutdown problem remains:
After that i click shutdown, the sreen will be turned off, but the power can't be shut off, and same with the keybord light. How shoulld i probably fix it in my DSDT?
in addition: i'm using Clover with the argument <KernelPM>, so that i thought that XCPM is in charge of the power management.
and smbios: MacbookAir 6.2. With a SSDT, which was generated by using PRGen, the SpeedStepping works also totally fine. 
and my laptop can't sleep deeply, just turn off the screen while sleeping. i don't know if it's also related to the shutdown issue.
here is my dsdt.dsl zip.gif  DSDT.dsl.zip
Thanks in advance!
Link to comment
Share on other sites


I have found that the graphics of the intel 4600 supports QE/CI with the default clover intel injection.

In this point we have a very glitchy mouse(courser), but in the systeminformation I can see that I have 1024mb VRAM.


Now when I change the AAPL, ig-platform-id to 0x0c260000 the mouse(courser) doesn't have this glitch but I don't know which of these numbers is for the intel 4600 mobile.

On the number 0x0c260000 I get 7mb.

On the number 0x80860416 I get 64mb.


But I want 1024mb VRAM, when I set in the Clover Configurator the VRAM, it has no effect on the systeminformation, it doesn't show 1024mb RAM.


Numbers from here


and here...


I think this is for the Desktop intel HD4600.


One way is, you can type in the number in the clover configuator.

And another way is to type the number in when you boot into the clover and then type it into the intelinjection menu.



I have no shutdown issue, do you have the same mach_kernel as used of this guide?

And can you see, in the verbose mode when you shutdown your system, some more information?




Link to comment
Share on other sites

  • 2 weeks later...

I'm also facing the same problem as aeondubs.

Created the USB installer successfully as per the procedure, booted into the installer (with FixDisplay unchecked and inject EDID checked in clover boot options).  Was able to install onto my internal SSD (only one partition, formatted as HFS+).  When I try to boot from my SSD (with Fix Display unchecked and inject EDID checked), in verbose mode, it stops right after loading the bluetooth module and does not proceed further.  I don't see any obvious errors in the verbose log.  Has anyone faced this issue and worked around it?  Any help will be much appreciated.  Thanks.

Link to comment
Share on other sites

  • 2 months later...
:thumbsup_anim: Hi all,


I finally managed to install Mavericks on my GS70 .


Thank to linux girl for her first post and Mo.1 for the graphics card solution.


My config:



Windows 8.1 pre- installed on SSD Raid 0


CPU: i7- 4700HQ ( 2.4GHz , Haswell )               OK

Memory : 8GB DDR3 1600MHz                         OK

Accelerated Graphics : NVidia GTX 765m         KO

Integrated Graphics : Intel HD Graphics 4600   OK (no glicht , thank you to Mo.1 )

Audio: Creative X -Fi .                                         OK

Wireless: Atheros AR9462                                  KO

Ethernet : Atheros Killer E2200                          OK

Hard -disk (2 KINGSTON : 64gb SSD Raid 0 , 1TB 7200rpm HDD ) OK


I can boot from CLOVER, in RAID mode, it was very dificult to write to the EFI patition (always read-only) .

I board made ​​four days to solve the addition of EFI boot of clover on the EFI partion .


If you have a system pre- installed with Windows 8 , you must disable the RAID in the bios, switch it to AHCI or install the AHCI drivers before install, after you can see your disks.

Use UEFI and not legacy .


I'll make a tutorial to explain everything.


Excuse me for my poor english, I'm french.

  • Like 1
Link to comment
Share on other sites

Hello IanMoone,


I post you my mach_kernel, patch base on this post, you can download it here,


Ras rita



@rasrita could you please tell me which osx image  you used. I get the bluetooth HCI error and cannot seem to proceed after that...  Please post a detailed tutorial including the places from where you got the sources.

Can you post more about this error ???

when have this error, first install boot ??



Link to comment
Share on other sites

Hey, I have remake a new version of this guide...with some more details and more fixes...


I hope you like :)



  • Like 1
Link to comment
Share on other sites

Finally got everything to work....only 1 problem...how do I add clover bootloader so that when I boot up, I get the clover.menu... I am able to boot only into windows without the clover USB.

I guess I would have to install clover to the efi partition on the ssd but I don't see a EDI partition from Mac...I am able tonsee it only in windows..

And also please tell me if anyone knows to how to remove the unnecessary boot drives from.clover.l boot menu. Right now it shows many options like my partitions along with mavericks and windowas.I want it to show only windows or mavericks when booting up. In short how do I edit the boot options or settings of the clover bootoader.

And also please tell me if anyone knows to how to remove the unnecessary boot drives from.clover.l boot menu. Right now it shows many options like my partitions along with mavericks and windowas.I want it to show only windows or mavericks when booting up. In short how do I edit the boot options or settings of the clover bootoader.

Link to comment
Share on other sites


  • Create New...