Jump to content

Lenovo ThinkPad T420 with UEFI Only


K0gen
5,253 posts in this topic

Recommended Posts

What is the problem?

 

My advice is update to latest zip before dong the upgrade to 10.12.4

 

So update ESP and kexts

Remove IntelBacklight.kext

Reboot

Then apply the upgrade from app store

  • Like 1
Link to comment
Share on other sites

The problem is the backlight's gone off after the apple logo, i can only boot to safe mode right now to have a backlight and it's flickering like crazy on chrome. I applied the update after upgrading to 10.12.4 T_T

Is there anyway to save my system without reinstall? Tried re-doing the post install steps exactly, but there's no luck. IntelBaclight.kext is in the S/L/E right? I have deleted it and re-run kext utility and restart, it does not produce any effect

Link to comment
Share on other sites

@abbiss

-  should be no need to reinstall OS. i didn't.

- so to be clear you - you cannot make the screen brighter by using ScrLck?

 

Note:

the IntelBacklight.kext is in /Library/Extensions where all the custom kexts are installed. 

did you install the AppleBacklightInjector kext? 

Link to comment
Share on other sites

that solve it! yeah turns out i just deleted the one's in System/Library/Extensions and not Library/Extensions, and yeah I cannot use any key turn up my brightness. Thanks! my issue is solved, it's perfect :).

Also, i've experienced a maximum volume loss when i'm installing osx on my T420. Windows and Linux is louder. Anybody knows how to turn up the maximum volume? Also, is it safe when i deleted the ones in S/L/E ? Not having any issue though, just curious why it have the file as well.


For anyone that have issue with camera not detected, this solve it for me :)

http://osxdaily.com/2013/12/27/fix-there-is-no-connected-camera-error-mac/


anyone knows how to do dual/triple booting with this setup?

  • Like 1
Link to comment
Share on other sites

@Abbiss

 

all of the custom scripts in the Zip i posted, put custom kexts in /Library/Extensions - if you used other installation apps, they could have put stuff in /S/L/E.

as of 10.12.4, IntelBackLight.kext doesn't work. 

 

I am planning on updating the Zip soon ... but there isn't any new really, except an updated install script/tool to check for "obsolete" kexts.

  • Like 3
Link to comment
Share on other sites

Hi! Have an issue after installing new wi-fi card  AW-CB160H BCM94360HMB... Everything works perfectly except turning laptop off. It boots up again after a second.

I use custom 1.48 bios and 10.12.4 sierra. Shutting down worked all right before installing wifi card. Any thoughts? Thx

Link to comment
Share on other sites

hello i tried to install sierra on my x220 and i did all the steps from the guide, i created the usb installer which installed the macos on the hd alright but at the first boot after installation it said that the install failed and i can try to install sierra again. Now everytime i to boot with clover to the macos partition it gets me to the installer like i boot from the usb and not into the macos desktop.

i look at the macos partition and it has these files : macOS Install Data (directory) and .journal_info_block,.journal,.OSinstallerMessages,

 

my ssd is GPT and using the latest clover from guide archive. It has a 200MB EFI partition with clover + win efi partition + win 7 partition + macos (install partition)

 

Anyone else has encounter this behavior? thank you

Link to comment
Share on other sites

@sot_22

 

i have not tried to install from USB lately. so not sure. you can remove these installation files to start over.

i just updated the zip with a newer clover that may have better support for 10.12.4 installation files etc.

i will make a 10.12.4 install USB and test later today.

  • Like 1
Link to comment
Share on other sites

thank you tluck, i'll try with the new clover but maybe its time to do a complete repartition of the drive and start over but i'll try to avoid it :) 

Link to comment
Share on other sites

@trifero yes i use the dsdt from that site cause i dont want to make all the changes again to my old dsdt...(not any more, i use my own  old dsdt now modified for sierra based on tluck fixes) the brightness control doesnt work with the mcdonnelltech guide, for me anyway, the guides are similar but tluck is active here (has the best guide for thinkpads) and you can get answers on a forum :) .

 

i used a script by Rehabman (PatchAppleBacklight_v2.zip) to make AppleBacklightInjector.kext that works with my x220 monitor.

 

the only downside is that it seems i cant get the same max brightness as in windows, the brightness levels works alright with the last level turning the screen black (this is how real macs works from what i read).

 

another issue (if its a issue i dont know) is that i have that wifivelocityd spam in console which i get rid of with this method (so its solved): http://www.insanelymac.com/forum/topic/317694-wifi-wifivelocityd-spamming-system-log/

 

and the last issue is that i get messages in the console about com.apple.Webkit.Networking TIC Read Error and SafariNotificationAgent errors when i go to a site like macrumors.

 

is this normal? can we stop console from flooding with these errors?

 

ps. from what i see the hd 3000 is a little slow if you use transparencies and such.

Link to comment
Share on other sites

on Brightness:

 

IntelBacklight.kext as is, doesn't work with 10.12.4 - it is not a DSDT issue.

 

So I included a customized version of RehabMan's AppleBacklightInjector script in the Utilities Folder. This script will allow you match the Brightness Profile (levels) for your panel and to max levels set in the Framebuffer  - which is 0x1312 = 4882. Th x220 is HD 3000 Gfx same as T420, so use T420 as the input argument. this should provide full brightness range.

  • Like 1
Link to comment
Share on other sites

@tluck just tried now and it works alright but just the last 2 level values dont change the brightness but if i sleep and wake they work as it should .

Link to comment
Share on other sites

i guess i should rename the kext patch for the framebuffer - it does more than add VGA as 4th port.

 

find

01020400 10070000 10070000 05030000 02000000 30000000 02050000 00040000 07000000 03040000 00040000 09000000 04060000 00040000 09000000

replace

01020400 12130000 12130000 05030000 02000000 30000000 02050000 00040000 07000000 03040000 00040000 09000000 06020000 10000000 09000000

 

max levels ---------------^

 

changes from x0701 to 0x1312

Link to comment
Share on other sites

thx tluck , i just patched my old dsdt to know what i'm doing (it had only sleep issues now its ok, the gfx seems faster too and more responsive).

 

Now 5 brightness levels does not do anything before sleep but after sleep all work,

 

added the vga kext patch on clover and nothing changed but i did not change the patch like you said above , i convert these numbers to base64 and replace the ones in config ?

 

seems i must patch the kext directly but its better with clover on the fly

Link to comment
Share on other sites

×
×
  • Create New...