Jump to content

pitx0n

Members
  • Content Count

    15
  • Joined

  • Last visited

About pitx0n

  • Rank
    InsanelyMac Protégé

Recent Profile Visitors

915 profile views
  1. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    My family (inc. my so worst feeded greyhound) wish you al a very perfect 2018 Command line types. My worst feeded greyhound in the world has plenty useful Nails, sometimes cleverer than mines ;P Let's see what kind of life Will 2018 bring us so. Happy new day!
  2. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    Yes, it's working.
  3. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    No luck at first try. I changed BIOS display settings to integrated and no OS detection. Install Sierra, create user, etc. Replace /System/Library/CoreServices/PlatformSupport.plist with the attached one to bypass MacPro 3,1 check. Replace config.plist on USB EFI partition with the one attached in #3346 Reboot. Set BIOS to discrete with no OS detection. Kernel Panic loading nvidia official. I will try to load latest Sierra Nvidia WebDriver, then set to discrete... Thank you, that's great. You can attach files by clicking "More Reply Options" button. PlatformSupport.plist.zip
  4. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    Is your Laptop a T420? This guide/files are not for other brand nor model. To reinstall securely, just to discard a wrong installation file, you must download again macOS installer from the apple store and redo the USB stick.
  5. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    Can you upload paste the terminal command lines running it?
  6. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    Have you run the kext install command?
  7. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    As I wrote, I need to use a MacPro 3,1 SMBIOS. I was unable to install macOS Sierra because MacPro 3,1 is not a supported platform. I don't know if this can be bypass or not. EDIT: http://www.insanelymac.com/forum/topic/312659-guide-unsupported-real-macpro-works-with-sierra-example-of-real-macpro31/ Will this work?. I'll try it.
  8. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    It affects USB 2.0 and USB 3.0 devices. But I don't know if it affects them in the same way. Reading the Thread about Making NEC USB 3.0 Card Fully Comportable with Original MAC Drivers, I think it's a USB controller Vendor/Device ID issue. W520 has 2 USB 3.0 ports, and I alternate plug/unplug with them. You can try it and get back with results for your T420s with only one USB 3.0 port.
  9. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    I had no problems with the USB 3.0 once it begins to work. Both ports work at full speed with no losing connections until I reboot or shut down the machine.
  10. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    Thank you. They talk about add-on cards. Is it safe flashing the internal NEC/renesas chip?.
  11. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    I was able to get my T420 with the Nvidia NVS 4200m fully working on El Capitan 10.11.6, using Mac Pro 3,1 SMBIOS and injecting NVIDIA with clover. But I can not install Sierra. MacPro3,1 platform not supported (is there any way to bypass this?). MacBookPro 8,2 or 10,1 do not work... If you want to install El Capitan, just use attached config.plist matching your resolution and replace tlucks files with them. Bios display settings must be set to discrete and disable OS detection. Brightness control is not working (no DSDT patch). Just use Shady: http://instinctivecode.com/shady/ EDIT : Tried Nvidia CUDA and WebDriver. Webdriver causes a KP, CUDA driver working. EDIT-2 : Tried to remove nvda_drv=1 from nvram boot flags, removing official kexts, renaming web driver kext to match official names, removing nvidia stuff from /L/PreferencePanes, installing only WebDriver... I assume Webdriver is a no go with this config. With official kexts and Nvidia CUDA driver everything seems to work fine. So, don't install WebDriver unless you can try something else to get a solution. CUDA driver http://www.nvidia.com/object/macosx-cuda-8.0.46-driver.html WebDriver Nvidia Web Driver - 346.03.15f01 @POWerSUrgeSW3 @tluck I have W520 working USB3 ports installing RehabMan's GenericUSBXHCI (attached) with kext wizard. I only need to reinsert USB device twice or three times (alternating ports with 2 sec. delay) to get it always working until reboot. Maybe this solution works with T420s too. T420NVidia.tiff T420-NVidia-config.plist.zip GenericUSBXHCI.kext.zip
  12. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    Thank you. I'll try it with sierra.
  13. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    I was able to get a working 10.11.6 T520 with these files including DSDT. I just rename matched resolution config.plist to install it. Have you tried to install to a standard SATA drive? Can you upload that DSDT to try it?
  14. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    I tried it on a T420 with a corrupted 1.49 original BIOS and it shows hidden menu and the short beeps from the security chip once flashed. So, yes. I assume it works.
  15. pitx0n

    Lenovo ThinkPad T420 with UEFI Only

    1.49 bios mod. Whitelist and hidden menu. Try at your own risk Lenovo T420 v1.49 mod.7z
×