Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

89 posts in this topic

Recommended Posts

Ok I've been trying this for a few days. tried a few different distro's. hazard went the farthest, with booting -x -v I can get most of the hfs+ files to load through chameleon but it errors on the tmsafetynet.kext, pauses 5 seconds, displays:

ACPI table not found. Dsdt.aml

No DsDt found, using 0 as uid value

Using PCI-root-uid value:0

No SMbios replacement

Patched DMI table

found SMbios system information Table 1

customizing systemID with 002-003-004-005-006007008009

efi_inject_get_devprp_string NULL trying stringdata





Then it has another ACPI and reboots.


System is Fx-4100 cpu, ta990fxe mb, radeon hd 6770 gpu, 8 gig corsair 1600 dual channel ram, seagate 250 gig sata 6.0gbs hdd.


Please help a brother out

Share this post

Link to post
Share on other sites

Here are shots from cpu-z......could it possibly have anything to do with the bulldozer architecture supporting sse3 as intel chips do. The hazard distro i'm using only seems to have Mach_kernel.




Share this post

Link to post
Share on other sites

Ok well after a lot more looking and playing with downloads. I got osx 10.5 to run through vmware. I hooked up my physical disk and formatted it into the mac os Journled format. Now I'm gonna try to get the retail version to restore to the drive and then patch the amd kernel over since I can now do the patching through leopard.


If anyone has some advice on what steps I should take I would greatly appreciate it.

Share this post

Link to post
Share on other sites

Ok so after all the different distros I have tried, the only thing I can get to run is 10.5.5 leopard in vmware workstation. I have been able to use the virtual machine to partition my drive to an hfsj and been able to load the iosx86 10.5.6 onto the partition through my virtual machine but I don't seem to be able to boot it anyway.


Anytime I try to boot my comp with one of the distro cd's i get a kernel panic.


Can anyone out there give me a point in the right direction?

Share this post

Link to post
Share on other sites

Try using a 10.6.3 Snow Leopard retail disk with Nawcom's ModCD.

This will give you a 'vanilla' (un-bastardised) install. This will be much easier to support as we know what goes on during the install.

By using a distro like Hazard you are at the whim of the authors as to which kexts are patched/installed and to where.


A distro may look like the easy option but I promise you it is not.

There is a very steep learing curve with OS X 86 and this is where most seem to be put off. But if you stick with it, read as much as you can and don't be affraid to experiment, you should get there eventually.

Share this post

Link to post
Share on other sites

thank you, I kinda got dismayed with the lack of help in the osx86 community. I am not new to computers at all but mac I am, so trying to piece together how to write everything I need gets discouraging.


I now have the SL retail install on a Usb and I'm going to go from there, looks like next step is to setup a linux live enviro so I can work my dsdt.aml file there. Any pointers are greatly appreciated as always.

Share this post

Link to post
Share on other sites

If you want to move the modbin kernel over to your installation, boot with the ModCD into SL, locate the ModCD and open the image Preboot.dmg. Inside Preboot, there is an Extra folder; that folder contains the modbin kernel. Simply drag the kernel onto the root of your hard drive. :) Now, to make Chameleon boot the modbin kernel automatically, open Terminal (/Applications/Utilites) and type:


sudo nano /Extra/com.apple.boot.plist


Locate the following:


and change it to:


And now you can boot from your HDD. :)

Share this post

Link to post
Share on other sites

I already tried taking the modbin_kernel.test7 and sticking it in the root directory of my mac drive, since I cannot get osx to boot after a successful install, I can't edit anything this way. I was able however to edit the com.apple.boot.plist in win7 and edit that string so it would load the modbin kernel. Now whether I use the osx86 mod cd, or I boot directly from the mac (it brings up chameleon when I pick mac on my boot list) it runs through the text and hangs at.


AppleServerworksATA: IXP700 (cmd 0x1f0, ctr 0x3f4, IRQ 14, BM 0xf000)

USBF 7.688 AppleUSBOHCI [0x421b800] Check sleep capability controller will be unloaded across sleep.


When I throw in the -x command it runs through the kexts and then runs the white lines again, this time it will pass this one line but the next line it gets stuck on is the


ERROR: Firewire unable to determine security-mide: defaulting to full-secure



And it just sits, and sits, and sits,.....then it sits some more.....thinks about doing something else.....doesn't....it just sits there........


the only way I have access to anything for mac is when I boot the Install USB, I then can use terminal but it doesn't seem to work like it should........maybe I'm doing something wrong........

Share this post

Link to post
Share on other sites




Ok I got vmware workstation 8 and found a working image of 10.5.5 from Xelabos. But I can access my mac drive and run certain things. Now I know that I can't pull files through the virtual machine, but since I can pull them in linux for example and I can edit them in the virtual machine, what do I do now?

Share this post

Link to post
Share on other sites

I need to know if I understand you correctly.


You now have 10.5.5 on the workstation? If so, do you also have an install on a separate drive; USB shell, or a key drive?


If you have enough space on your host drive, then, you are good to go for a fresh install from either SL or Lion at this point. Do you have cloning tools?


You can do everything you need such as patches and file moves straight from your VM. No need for linux or windows at this point. It will be a bit sluggish but the job will get done just the same.

Share this post

Link to post
Share on other sites

Keep in mind that if you move a kernel extension to (or make modifications to anything in) /System/Library/Extensions it will not load, because it will not have the proper permissions and ownership.


If you do that you'll have to set permissions and ownership correctly first before trying to boot, you can do that via Terminal.app from your virtual machine or your USB installer.


Note that Chameleon doesn't care about permissions or ownership, so any kernel extensions you place in /Extra/Extensions will work without having to do anything else. Some kernel extensions (mainly those with lots of dependencies) will not work from /E/E at all though.




The screenshot in your first post shows normal verbose output from Chameleon, this is from before the kernel loads and OS X starts to boot. There's nothing out of the ordinary there. Apparently you have no DSDT.aml and no smbios.plist but that's not necessarily a problem. DSDT override is mostly used on Intel platforms that are closer to Apple hardware and can run the vanilla kernel, smbios.plist is where you set which mac model you want your hack to appear to the OS as, but smbios.plist is not necessary in order to boot, Chameleon has some smbios defaults built-in which will be used when there's no smbios.plist in /extra. Google/Forum search smbios.plist for more information.


Neither "USB bla bla unloaded across sleep" nor "Firewire bla bla full security mode" mean anything in relation to the boot process, it is not stopping because of any of those messages. As an experiment you can try disabling Firewire in the BIOS, I can guarantee that it will halt at the same place.

Share this post

Link to post
Share on other sites

Gringo: I did try to disable firewire and same thing, On one boot it actually said waiting for root device. but the rest it just freezes. I just tried copying the ata kexts from the install dvd to the hard drive through terminal and that didn't seem to help either.


Zoot: Yes I have 10.5.5 installed through vmware 8.0.1. I cant seem to get the permission to access a physical drive though. I keep getting an error and I have been trying to work around that so no dice on editing any files through the virtual machine.


As for the installs I have 3 HDDs. My main is a 1.5tb WD I have that in 3 partations, 1 for win 7, 1 for data files, 1 for ubuntu. the second drive is a seagate 250gb that has win 8 on it, and the 3rd is a samsung 200gb that I have 1 partition for mac osx.


My SL install is on a 8gb usb.


Did I answer all your questions?


Edit: Whatever device it is sticking on, the numbers may flucuate but the IRQ address is alway 14. How do I find out what this is?


This is where it sticks, this is even after copying the ata kexts. and I must us the command rd(0,0)/extra/modbin_kernel or anything else reboots




FYI to copy the kexts I loaded the boot usb and used terminal and used :

cp -pr /Volumes/Snow/System/Library/Extensions/*ATA* /Volumes/Mac/System/Library/Extensions/
chown -R root:wheel /Volumes/Mac/System/Library/Extensions/*ATA*
chmod -R 775 /Volumes/Mac/System/Library/Extensions/*ATA*
rm -rf /Volumes/Mac/System/Library/Extensions.*

then rebooted with -f

Share this post

Link to post
Share on other sites

ok after doing some digging I see what is causing my issue, just not sure how to fix yet. The appleserverworksATA is trying to access my IDE ATA/ATAPI controllers. That has the IRQ of 14 and that seems to be responsible for the hang up. Seems to have to do with the SB controller. Since, in the pic u can see that it is ixp700, giving this issue, it has something to do with the sb700 support on my MB. now my board will go up to 950SB so any ideas on how to correct this so I get rid of my hang?

Share this post

Link to post
Share on other sites

After playing around with the bios settings and my sata control I notice I have 4 options to choose from, native ide, raid, ahci, legacy ide. Now on ahci it sticks on the appleseverworksata, under legacy ide it makes it past the appleserverworksata but the next line in ATI ATA and it sticks there, same on native ide, and didn't even bother with raid mode, also it will allow me to enable or disable combined ide, with legacy ide and combined ide disabled, my cdrom does not load.


Also a side note, now when I was just playing somehow instead of my boot menu from BCD that gives me win 7, win 8, ubuntu, and osx option has now been replaced with the chameleon bootloader and I have to select my win 7 drive to get back to my main bootloader. What would cause that? I was just playing with the sata controls in bios?

Share this post

Link to post
Share on other sites

Success!!!!! IT BOOTED!!!!!!!!!!!!



Ok so what I had to do.......The good, the bad, and the dirty.


Reloaded the install usb, deselected every option on the customize screen except under chipset. I did not pick the atiata that it auto selected, it was the one down on the list for ati. After successful install, did not restart, opened terminal, copied all the kexts from the install usb, gave permission, rebooted modcd, typed rd(0,0)/extra/modbin -v -f. SUCCESS!!!!!!!!!!!!




now I just gotta get everything else working.....but I got it to boot :)

Share this post

Link to post
Share on other sites

Well, great job!! :D


Something to note: if you are planning on updating to 10.6.5 or later, you will have to update your kernel.

Share this post

Link to post
Share on other sites

yes I noticed, em messed up the working copy...


So what I did for experimenting is I reformatted my hd for mac with 2 parts. One for the reg install of SL, the one I'm typing on again, and one so I can install SL onto that and try to update it.


So this way hopefully I won't have to keep reloading on trial and error.


Also I can't seem to locate my cdrom now on the mac, I of course have to use it to boot with the modcd but it doesn't show in SL.

and when I try to boot my mac osx partition from my regular bootloader it gives me a chain boot error.

Share this post

Link to post
Share on other sites

well I had the iso for the modcd so I pulled the modbin kernel out of there, put it in the root, sudo nano'ed to death and then when I try to boot without the cd it gives me a cpu halt.....hmm

Share this post

Link to post
Share on other sites

sudo nano'ed? You edited some kexts? :P


CPU halt...hm? Boot with the ModCD, download the latest Chameleon package via Chameleon Wizard (click the Buildbot tab, then click the little package beside the Chameleon build) and run the pkg. See if that helps.

Share this post

Link to post
Share on other sites

Have you tried Virtual Box? Try that out as it seems you have plenty of drive space. It is more supportive of USB peripherals than VMWare. Mounting an external drive is no problem under the VB environment. VB is also a tad faster.

Share this post

Link to post
Share on other sites

Pookymacman: well it definetely gave me a new symptom, now it freezes on powermanagement :(


Zoot: I gave up on VM since I just got it working on the HDD, just gotta boot with modcd everytime.

Share this post

Link to post
Share on other sites

Well, your situation is different, but, I was able to take my external drive to my PPC (Leopard Universal 10.5.8). I mounted OSX86ModCD on the desk top, mounted my SL 10.6.8 drive, then, I opened Tinker Tool to show all files. I installed ChameleonRC3PCEFI10.5. to my SL drive using Pacifist. I went to the ModCD and took the entire Extra folder and dragged it to SL /. with Administrative Privilege, then, I opened the usr folder from ModCD and replaced the i386 in the usr on the SL drive.


After all that I plugged into my notebook and booted without the ModCD; that would be because I esentialy have the CD on my SL root now. I can boot on any machine in my house with this method. Once on the desk-top I repair permissions with Kext Utility.


I have different images of pre boot configured for each machine to make swapping easy.


Change this: <string>-v maxmem=2048 cpus=1 arch=i386</string>

to: <string> maxmem=(whatever you have and what is supported) cpus=1 arch=i386</string> from pre-boot com.appleBoot.plist

Then you'll get the Apple Spinner before you reach the desk-top.


It is all a grand experiment so results may vary.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gengik84
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                             http://www.hwsensors.com/releases 
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.

      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni

      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"

        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script

      Nel caso che la usb fosse ok, avrete allo stesso modo conferma dal terminale, quindi non dovrete far altro che selezionare la relativa opzione a seconda dell’installer che vorrete creare

      L'installer una volta completato è nominato "Install Mac_OS_X"

      Potete adesso passare ad installare il bootloader Clover bella vostra usb 
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra usate --> C_I_M
      Alternativa: potete usare anche lo script che ho fatto --> C_I_M.zip
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.13.... 

      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      METODO "MANUALE"....  (lascio per futura memoria)
      Copiate OS X  sulla scrivania
      Aprite ShowAllfiles per visualizzare i file nascosti. 
      Doppio click su SHOW
      Senza questa operazione non vedrete i file nascosti.

      OS X  tasto destro - Mostra contenuto pacchetto - Contenuti - Shared Support - InstallESD.dmg
      Doppio click su InstallESD.dmg
      Tasto destro del mouse sopra BaseSystem.dmg, apri.

      Tramite Utily Disco, da sinistra selezionate BaseSystem.dmg e cliccate su ripristina: 
      su Sorgente mettete "OS X BaseSystem" e su Destinazione la penna usb.
      Cliccate su Ripristina.

      Stessa procedura Fatta da EL Capitan
      Selezionate OS X Base System, poi in alto su File, modifica e poi su ripristina.
      Selezionate successivamente come destinazione USB

      Finito il processo la vostra usb sarà nominata OS X BaseSystem , per praticità rinominatela USB o comunque un nome diverso  a vostro piacimento.
      Recatevi in InstallESD.dmg” (all’ interno della app) selezionate e copiate la cartella Packages in System/Installation della USB, eliminando il collegamento esistente.
      Copiate BaseSystem.dmg e BaseSystem.chunklist, che trovate in InstallESD.dmg,  nella root  (radice)della USB. 

      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.

      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  selezionate OsxAptioFixDrv-64
                             *  :Se nel vostro sistema è presente una scheda grafica (discreta) della serie 9xx nVidia selezionate OsxAptioFix2Drv-64 al posto di  OsxAptioFixDrv-64 *
      ** OsxAptioFix2Drv :E' necessario per poter impostare CsrActiveConfig= 0x3 **
      ***OsxAptioFix3Drv oppure AptioMemory devono essere usati su hardware Skylake o successivi perché permettono alla nvram di lavorare correttamente
           (mi raccomando o uno o l'altro)
      Proseguite con l’installazione.


      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      Per installazione Legacy
      Mettete i vari Flag come da foto.

      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”

      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2

      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      *Nota: potete inserire anche il flag verbose che servirà per vedere possibili blocchi in fase di boot.
      Risulta utile quando si chiede aiuto sul forum postando la foto di tale schermata.
      Avremo la stessa funzione premendo la barra spaziatrice al boot di Clover, selezionando avvio in verbose mode.
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67

      7) Sezione System Parameters: Su inject kext mettete YES
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      L’aggiunta di  righe sopra citate comporta la totale disattivazione di questa sicurezza.
      Questo ci permette di installare, far caricare kext di terze parti e riparare permessi.
      Se volete sapere di più a riguardo vi rimetto a questo topic: http://www.insanelymac.com/forum/topic/307398-info-considerazioni-sulla-sicurezza-di-1011/
      Una volta installato e configurato il nostro osx, giusta operazione da fare sarà quella di riabilitare tale protezione.
      Impostando il valore CsrActiveConfig su 0x1 si avrà questo risultato
      Questo valore così messo, ha la stessa funzione di kext-dev-mode=1 nei precedenti osx, ma ormai obsoleto in questa versione.
      SIP parzialmente abilitata: Impostando il valore CsrActiveConfig su 0x3 si  avrà questo risultato
             Apple Internal: disabled
             Kext Signing: disabled
             Filesystem Protections: disabled
             Debugging Restrictions: enabled
             DTrace Restrictions: enabled
             NVRAM Protections: enabled
             BaseSystem Verification: enabled
      SIP parzialmente abilitata
      Apple Internal: disabled
             Kext Signing: disabled
             Filesystem Protections: disabled
             Debugging Restrictions: enabled
             DTrace Restrictions: enabled
             NVRAM Protections: enabled
             BaseSystem Verification: enabled
      SIP Disabilitata Impostando il valore CsrActiveConfig su 0x67

      Apple Internal: disabled
             Kext Signing: disabled
             Filesystem Protections: disabled
             Debugging Restrictions: disable
             DTrace Restrictions: disable
             NVRAM Protections: disable
             BaseSystem Verification: disable
      Impostando il valore CsrActiveConfig su 0x0 avremo questo risultato e SIP totalmente abilitata
      Per controllare ad installazione fatta lo stato di SIP, recarsi sul terminale e digitare questo comando: csrutil status
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Per High Sierra:
      scaricare il driver apfs.efi a fine guida,collocarlo:
      EFI/clover/Driver64UEFI se stiamo usando UEFI
      EFI/Clover/Driver64 se stiamo usando Legacy
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto-Fake+Sensors 6.26.1440.zip
    • By Mr.Darkwraith
      Is it possible to install/run Android TV/x86 on the 1st generation Apple TV?
    • By haegar33
      I have browsed thru all forums and all threads for this card but apparently my system is still something special. With some cumbersome effort (none of the simple one-click ##### and other USB-Installers methods ever worked for me) I managed to install Sierra 10.12.5. However when booting is nearly finsihed I get the famous black screen which can be recovered by quickly unplug/plug the DP monitor cable leading finally to a proper initialisation of my 290X. 

      1.) RadeoDeInit is on, without this patch the screens stays dark forever
      2.) Booting with iGFX never works for me, I always get memory allocation errors during boot until I disable the Intel graphics completely.
      3.) I am on Clover 4318, newer version do not make any differences.
      4.) I am using a System Configuration for an Imac 14,2. Most other configs do not make difference either.

      I have not started again the nightmare of Framebuffer patching (as I remember from Yosemite) and I think it will not help as the card is recognised by Sierra but just not initialised.
    • By TheBloke
      Hi all
      I currently use an NVidia 760 with four displays: 1 x 4K; 2 x 1920x1200; 1 x 1920x1080.   This mostly works, but I am considering replacing it with an AMD GPU - likely a Radeon 7970 - for two reasons:
      I would like to add a fifth monitor, maybe even a sixth; I get small stutters and slowdowns with my NVidia, using both Native and NVidiaWeb drivers.  It is a lot better than it was with my NVidia 980Ti, but it's still not perfectly smooth as it should be, especially when I have a full screen video playing while also doing UI movements like Swipe Left A Space or Mission Control.  
      I have just been told that it should be possible to access all display outputs on an AMD 79XX GPU, possibly requiring a custom SSDT and/or radeonDeInit?  I've only ever had one AMD GPU and that was 8 years ago so I am not experienced with them.  My NVidia 980Ti has five outputs, but can only use four at once.  But I believe AMD's EyeFinity does allow it to use them all as separate displays.
      Before I buy the GPU, I'd be most grateful if anyone could confirm that it should be possible to run five or six simultaneous displays on a card such as the ASUS HD 7970 DirectCU II (6 x DP outputs) or XFX AMD Radeon HD 7970 (2 x mini-DP; 1 x HDMI; 2 x DVI).  With one display being 4K @ 60fps and the rest 1920x1200 or 1080P.
      I have Googled on this a while but haven't yet found anyone discussing connecting more than four monitors to an AMD Hack  I did see that the late-2013 Mac Pro (which uses 2 x AMD FirePro GPUs) states it can support "up to 6 Thunderbolt displays".  So I know the OS can do it, it's just a question of whether a particular GPU can, and in a Hack setup.
      Thanks very much
    • By Angelo_
      Hi guys, i'm trying to help a friend of mine trying to install osx(possibly high sierra) on his pc with the following specs: 
      Amd fx8350 
      Asrock 990fx extreme 3
      8gb of fury Kingston ddr3 ram(2x4)
      Radeon hd 7950
      128gb ssd( crucial m550)
      A couple of hdds I don't remember the brand(maybe a seagate barracuda and a dumb old disk for data)
      We tried to install it using the regular clover+high showers installer but we couldn't get it to reach the installer, then we tried osx-amd(don't know if i can talk about it there, sorry if i can't) and we still couldn't get to the installer.
      Is there a guide i can use to install osx in that machin, i tried to search in the forum but i couldn't find it.