Jump to content
89 posts in this topic

Recommended Posts

Ok I've been trying this for a few days. tried a few different distro's. hazard went the farthest, with booting -x -v I can get most of the hfs+ files to load through chameleon but it errors on the tmsafetynet.kext, pauses 5 seconds, displays:

ACPI table not found. Dsdt.aml

No DsDt found, using 0 as uid value

Using PCI-root-uid value:0

No SMbios replacement

Patched DMI table

found SMbios system information Table 1

customizing systemID with 002-003-004-005-006007008009

efi_inject_get_devprp_string NULL trying stringdata





Then it has another ACPI and reboots.


System is Fx-4100 cpu, ta990fxe mb, radeon hd 6770 gpu, 8 gig corsair 1600 dual channel ram, seagate 250 gig sata 6.0gbs hdd.


Please help a brother out

Here are shots from cpu-z......could it possibly have anything to do with the bulldozer architecture supporting sse3 as intel chips do. The hazard distro i'm using only seems to have Mach_kernel.




Ok well after a lot more looking and playing with downloads. I got osx 10.5 to run through vmware. I hooked up my physical disk and formatted it into the mac os Journled format. Now I'm gonna try to get the retail version to restore to the drive and then patch the amd kernel over since I can now do the patching through leopard.


If anyone has some advice on what steps I should take I would greatly appreciate it.

Ok so after all the different distros I have tried, the only thing I can get to run is 10.5.5 leopard in vmware workstation. I have been able to use the virtual machine to partition my drive to an hfsj and been able to load the iosx86 10.5.6 onto the partition through my virtual machine but I don't seem to be able to boot it anyway.


Anytime I try to boot my comp with one of the distro cd's i get a kernel panic.


Can anyone out there give me a point in the right direction?

Try using a 10.6.3 Snow Leopard retail disk with Nawcom's ModCD.

This will give you a 'vanilla' (un-bastardised) install. This will be much easier to support as we know what goes on during the install.

By using a distro like Hazard you are at the whim of the authors as to which kexts are patched/installed and to where.


A distro may look like the easy option but I promise you it is not.

There is a very steep learing curve with OS X 86 and this is where most seem to be put off. But if you stick with it, read as much as you can and don't be affraid to experiment, you should get there eventually.

  • 2 weeks later...

thank you, I kinda got dismayed with the lack of help in the osx86 community. I am not new to computers at all but mac I am, so trying to piece together how to write everything I need gets discouraging.


I now have the SL retail install on a Usb and I'm going to go from there, looks like next step is to setup a linux live enviro so I can work my dsdt.aml file there. Any pointers are greatly appreciated as always.

If you want to move the modbin kernel over to your installation, boot with the ModCD into SL, locate the ModCD and open the image Preboot.dmg. Inside Preboot, there is an Extra folder; that folder contains the modbin kernel. Simply drag the kernel onto the root of your hard drive. :) Now, to make Chameleon boot the modbin kernel automatically, open Terminal (/Applications/Utilites) and type:


sudo nano /Extra/com.apple.boot.plist


Locate the following:


and change it to:


And now you can boot from your HDD. :)

I already tried taking the modbin_kernel.test7 and sticking it in the root directory of my mac drive, since I cannot get osx to boot after a successful install, I can't edit anything this way. I was able however to edit the com.apple.boot.plist in win7 and edit that string so it would load the modbin kernel. Now whether I use the osx86 mod cd, or I boot directly from the mac (it brings up chameleon when I pick mac on my boot list) it runs through the text and hangs at.


AppleServerworksATA: IXP700 (cmd 0x1f0, ctr 0x3f4, IRQ 14, BM 0xf000)

USBF 7.688 AppleUSBOHCI [0x421b800] Check sleep capability controller will be unloaded across sleep.


When I throw in the -x command it runs through the kexts and then runs the white lines again, this time it will pass this one line but the next line it gets stuck on is the


ERROR: Firewire unable to determine security-mide: defaulting to full-secure



And it just sits, and sits, and sits,.....then it sits some more.....thinks about doing something else.....doesn't....it just sits there........


the only way I have access to anything for mac is when I boot the Install USB, I then can use terminal but it doesn't seem to work like it should........maybe I'm doing something wrong........




Ok I got vmware workstation 8 and found a working image of 10.5.5 from Xelabos. But I can access my mac drive and run certain things. Now I know that I can't pull files through the virtual machine, but since I can pull them in linux for example and I can edit them in the virtual machine, what do I do now?

I need to know if I understand you correctly.


You now have 10.5.5 on the workstation? If so, do you also have an install on a separate drive; USB shell, or a key drive?


If you have enough space on your host drive, then, you are good to go for a fresh install from either SL or Lion at this point. Do you have cloning tools?


You can do everything you need such as patches and file moves straight from your VM. No need for linux or windows at this point. It will be a bit sluggish but the job will get done just the same.

Keep in mind that if you move a kernel extension to (or make modifications to anything in) /System/Library/Extensions it will not load, because it will not have the proper permissions and ownership.


If you do that you'll have to set permissions and ownership correctly first before trying to boot, you can do that via Terminal.app from your virtual machine or your USB installer.


Note that Chameleon doesn't care about permissions or ownership, so any kernel extensions you place in /Extra/Extensions will work without having to do anything else. Some kernel extensions (mainly those with lots of dependencies) will not work from /E/E at all though.




The screenshot in your first post shows normal verbose output from Chameleon, this is from before the kernel loads and OS X starts to boot. There's nothing out of the ordinary there. Apparently you have no DSDT.aml and no smbios.plist but that's not necessarily a problem. DSDT override is mostly used on Intel platforms that are closer to Apple hardware and can run the vanilla kernel, smbios.plist is where you set which mac model you want your hack to appear to the OS as, but smbios.plist is not necessary in order to boot, Chameleon has some smbios defaults built-in which will be used when there's no smbios.plist in /extra. Google/Forum search smbios.plist for more information.


Neither "USB bla bla unloaded across sleep" nor "Firewire bla bla full security mode" mean anything in relation to the boot process, it is not stopping because of any of those messages. As an experiment you can try disabling Firewire in the BIOS, I can guarantee that it will halt at the same place.

Gringo: I did try to disable firewire and same thing, On one boot it actually said waiting for root device. but the rest it just freezes. I just tried copying the ata kexts from the install dvd to the hard drive through terminal and that didn't seem to help either.


Zoot: Yes I have 10.5.5 installed through vmware 8.0.1. I cant seem to get the permission to access a physical drive though. I keep getting an error and I have been trying to work around that so no dice on editing any files through the virtual machine.


As for the installs I have 3 HDDs. My main is a 1.5tb WD I have that in 3 partations, 1 for win 7, 1 for data files, 1 for ubuntu. the second drive is a seagate 250gb that has win 8 on it, and the 3rd is a samsung 200gb that I have 1 partition for mac osx.


My SL install is on a 8gb usb.


Did I answer all your questions?


Edit: Whatever device it is sticking on, the numbers may flucuate but the IRQ address is alway 14. How do I find out what this is?


This is where it sticks, this is even after copying the ata kexts. and I must us the command rd(0,0)/extra/modbin_kernel or anything else reboots




FYI to copy the kexts I loaded the boot usb and used terminal and used :

cp -pr /Volumes/Snow/System/Library/Extensions/*ATA* /Volumes/Mac/System/Library/Extensions/
chown -R root:wheel /Volumes/Mac/System/Library/Extensions/*ATA*
chmod -R 775 /Volumes/Mac/System/Library/Extensions/*ATA*
rm -rf /Volumes/Mac/System/Library/Extensions.*

then rebooted with -f

ok after doing some digging I see what is causing my issue, just not sure how to fix yet. The appleserverworksATA is trying to access my IDE ATA/ATAPI controllers. That has the IRQ of 14 and that seems to be responsible for the hang up. Seems to have to do with the SB controller. Since, in the pic u can see that it is ixp700, giving this issue, it has something to do with the sb700 support on my MB. now my board will go up to 950SB so any ideas on how to correct this so I get rid of my hang?

After playing around with the bios settings and my sata control I notice I have 4 options to choose from, native ide, raid, ahci, legacy ide. Now on ahci it sticks on the appleseverworksata, under legacy ide it makes it past the appleserverworksata but the next line in ATI ATA and it sticks there, same on native ide, and didn't even bother with raid mode, also it will allow me to enable or disable combined ide, with legacy ide and combined ide disabled, my cdrom does not load.


Also a side note, now when I was just playing somehow instead of my boot menu from BCD that gives me win 7, win 8, ubuntu, and osx option has now been replaced with the chameleon bootloader and I have to select my win 7 drive to get back to my main bootloader. What would cause that? I was just playing with the sata controls in bios?

Success!!!!! IT BOOTED!!!!!!!!!!!!



Ok so what I had to do.......The good, the bad, and the dirty.


Reloaded the install usb, deselected every option on the customize screen except under chipset. I did not pick the atiata that it auto selected, it was the one down on the list for ati. After successful install, did not restart, opened terminal, copied all the kexts from the install usb, gave permission, rebooted modcd, typed rd(0,0)/extra/modbin -v -f. SUCCESS!!!!!!!!!!!!




now I just gotta get everything else working.....but I got it to boot :)

Well, great job!! :D


Something to note: if you are planning on updating to 10.6.5 or later, you will have to update your kernel.

yes I noticed, em messed up the working copy...


So what I did for experimenting is I reformatted my hd for mac with 2 parts. One for the reg install of SL, the one I'm typing on again, and one so I can install SL onto that and try to update it.


So this way hopefully I won't have to keep reloading on trial and error.


Also I can't seem to locate my cdrom now on the mac, I of course have to use it to boot with the modcd but it doesn't show in SL.

and when I try to boot my mac osx partition from my regular bootloader it gives me a chain boot error.

well I had the iso for the modcd so I pulled the modbin kernel out of there, put it in the root, sudo nano'ed to death and then when I try to boot without the cd it gives me a cpu halt.....hmm

sudo nano'ed? You edited some kexts? :P


CPU halt...hm? Boot with the ModCD, download the latest Chameleon package via Chameleon Wizard (click the Buildbot tab, then click the little package beside the Chameleon build) and run the pkg. See if that helps.

Have you tried Virtual Box? Try that out as it seems you have plenty of drive space. It is more supportive of USB peripherals than VMWare. Mounting an external drive is no problem under the VB environment. VB is also a tad faster.

Pookymacman: well it definetely gave me a new symptom, now it freezes on powermanagement :(


Zoot: I gave up on VM since I just got it working on the HDD, just gotta boot with modcd everytime.

Well, your situation is different, but, I was able to take my external drive to my PPC (Leopard Universal 10.5.8). I mounted OSX86ModCD on the desk top, mounted my SL 10.6.8 drive, then, I opened Tinker Tool to show all files. I installed ChameleonRC3PCEFI10.5. to my SL drive using Pacifist. I went to the ModCD and took the entire Extra folder and dragged it to SL /. with Administrative Privilege, then, I opened the usr folder from ModCD and replaced the i386 in the usr on the SL drive.


After all that I plugged into my notebook and booted without the ModCD; that would be because I esentialy have the CD on my SL root now. I can boot on any machine in my house with this method. Once on the desk-top I repair permissions with Kext Utility.


I have different images of pre boot configured for each machine to make swapping easy.


Change this: <string>-v maxmem=2048 cpus=1 arch=i386</string>

to: <string> maxmem=(whatever you have and what is supported) cpus=1 arch=i386</string> from pre-boot com.appleBoot.plist

Then you'll get the Apple Spinner before you reach the desk-top.


It is all a grand experiment so results may vary.

  • Create New...