Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Hexidecimal

VoodooHDA in Lion

22 posts in this topic

Recommended Posts

Has anyone tried the SL builds of VoodooHDA in Lion yet? I'm going to give it a shot shortly to get my X-Fi Titanium Fatal1ty running but was wondering if anyone else had attempted it yet.

Share this post


Link to post
Share on other sites

at least tow different voodohda's and prefpane combos for my alc272 work in Lion as they did in SL. Nothing to fear.

 

remove applehda to be on the safe side and avoid any interfering.

Share this post


Link to post
Share on other sites

I do have VoodooHDA from somewhere, everything is working, volume up/down, control via touch-buttons (I'll attach that kext when I'll be on Lion (30mins~)

Share this post


Link to post
Share on other sites

VoodooHDA 2.7.2 works for me both internal speakers and line out, had to chance the kext to make it recognize the volume controls, but everything else works, no KP's. Didn't test the microphone, I don't care.

Share this post


Link to post
Share on other sites
Sorry for delay, had to painfully reinstall Lion.

 

This next works with any OS, you don't need to delete anything, install and you're ready to go.

 

Is it OK to have this in E/E :blink:

//Peter

Share this post


Link to post
Share on other sites
Is it OK to have this in E/E ;)

//Peter

 

voodoohda is for /S/L/E

Share this post


Link to post
Share on other sites

Why strictly VodooHDA? I used HDAEnabler and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and everything is working fine...

Share this post


Link to post
Share on other sites
at least tow different voodohda's and prefpane combos for my alc272 work in Lion as they did in SL. Nothing to fear.

 

remove applehda to be on the safe side and avoid any interfering.

 

 

Hi smartie,

 

I too have a alc272 that was working good with voodoohda 0.2.1 in SL because anything newer was creating a loopback between the mic and the speakers.

 

After updating to Lion I can not use this anymore because it's 32bit, and with voodohda2.7.2 I'm getting the same loopback problem

 

Can you please post your solution to see if I can receive some light about it?

 

Thanks!

Share this post


Link to post
Share on other sites
Hi smartie,

 

I too have a alc272 that was working good with voodoohda 0.2.1 in SL because anything newer was creating a loopback between the mic and the speakers.

 

After updating to Lion I can not use this anymore because it's 32bit, and with voodohda2.7.2 I'm getting the same loopback problem

 

Can you please post your solution to see if I can receive some light about it?

 

Thanks!

 

Hi,

 

you can try this kext. It's voodooHDA 0.2.1 compiled for 64bit.

 

VoodooHDA.kext.zip

 

It works great for me in Lion for my XFi in 64bit. However sometimes it gives me a KP on startup. Does anyone know how to prevent these occasional KPs or alternative drivers for XFi Titanium without crackling noises?

 

 

Thanks

Share this post


Link to post
Share on other sites

I use it, only thing I can't get working is the mic. I'm going to mess around with the next and see if I can get it working.

Share this post


Link to post
Share on other sites

I use voodoo as [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] doesnt work for me i ve tried it no dice ALC888 ICH7

Share this post


Link to post
Share on other sites
Hi,

you can try this kext. It's voodooHDA 0.2.1 compiled for 64bit.

VoodooHDA.kext.zip

It works great for me in Lion for my XFi in 64bit. However sometimes it gives me a KP on startup. Does anyone know how to prevent these occasional KPs or alternative drivers for XFi Titanium without crackling noises?

Thanks

 

Hi, what is the motherboard and sound chip on it, please ??

I have Acer Aspire 7720 with 82801JI (ICH10 Family) HD Audio Controller, it worket well with VoodooHDA 0.2.1 under SL, but with Lion doesn't work ...

Share this post


Link to post
Share on other sites

Hi guys, I've a Creative X-FI Titanium PCI-E. Deleted AppleHDA.kext and added VoodooHDA.kext 2.7.2 in /E/E. After kextcache and reboot I can now see a volume controller on the menu and I can as well see only the green output bar in the settings as well. but for some reason there's no sound output through my speaker. I switched to windows 7 and made sure all the connectivity is okay. Any help please? I've also disabled the on-board audio.

 

Thanks.

Share this post


Link to post
Share on other sites

While we're talking about VoodooHDA, I tired it on my ASUS P5N-D with ALC883 and line-out works fine under Lion.

 

But as soon as I try to go to Audio-MIDI-Setup and set up my SPDIF optical output, I get a kernel panic!

 

Any help?

Share this post


Link to post
Share on other sites
Hi,

 

you can try this kext. It's voodooHDA 0.2.1 compiled for 64bit.

 

VoodooHDA.kext.zip

 

It works great for me in Lion for my XFi in 64bit. However sometimes it gives me a KP on startup. Does anyone know how to prevent these occasional KPs or alternative drivers for XFi Titanium without crackling noises?

 

 

Thanks

 

 

thanks

lion x-fi titanium is work ;)

Share this post


Link to post
Share on other sites

Anyone knows how to make ALC665 to work in Lion without any issues? My Alienware M11x works really good apart from the sound. I have managed to install some old kext to have sound working, but now everytime I boot it says something about a delay of kernel cache by number of seconds, which also casues it wont boot evertime.

 

Edit. I've managed to get rid of that message by adding ForceWake=Y to apple.boot.plist, then I got another one "header read size 200 incorrect image signature" and managed get rid of that also, by executing in terminal: sudo pmset -a hibernatemode 0

 

then deleted the sleepimage with:

sudo rm /var/vm/sleepimage

 

So far no issues during boot and working sound.

Share this post


Link to post
Share on other sites

Guys,

 

I cannot get my X-Fi Fatality with front ports working on Lion 10.7.2?

 

As soon as I install VoodooHDA 2.7.2 and install the AppleHDA disabler kext I found I the PC won't boot to Mac (Freezes on the Apple logo screen and I'm unable to start). I therefore have to re-install Lion.

 

Sick of re-installing due to VoodooHDA so I've cloned my Mac drive to another partition now so at least hopefully I can have a play around.

 

Any suggestions? Sorry this is my first time having a go at running Hackintosh. Should I try Prabas or Helmi123's Kexts? Should I run AppleHDA disabler?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×