Jump to content

[Tutorial] AMD 10.6.8 Retail Snow Leopard Guide!


298 posts in this topic

Recommended Posts

update...

 

It worked. Well not really...

 

I followed your insctructions. I reinstalled charmelion (using my back up 10.5.7) onto my snow leopard partition then re-copied all the files in the extra folder + the kernal (not what you suggested... but I wanted to make sure all the extra files were there as they should be).

It seems that it was restarting because somehow it was using the vanilla kernel (which I was sure I had deleted long ago) which was of course incompatible with my machine so was making it restart. I managed to bypass the hibernate warning thing with -x then it went into mac (took ages to load though). I had put both the audio and video drivers (NVEnabler 64 bit for my graphics card...) into the extra folder too and it either did not read them or they did not work as I still had no sound and my resolution was still stuck at 1024x768. Same as last time... my network drivers and stuff seemed fine. (ie. the ones that were there because you had put them there in the "My_EFI_Partition_update" zip folder)

 

In an attempt to fix it I went into disk utility and clicked 'repair permissions' and after letting that run I told it to restart. This is when it all started to go wrong...

 

Just like the last time I got snow working it seemed to freese on shut down (stuck on something.. the progress thingie stopped spinning) and after a few minutes I pushed the shut down button to shut it down. So I turned it on again and now after getting past the warning about the hibernate image it tells me 'waiting for root device' (as per the two pics of the diffrent things it says) each time it says "waiting for rood device" it does this just after complaining about my firewire. (Not sure if that has anything to do with it.)(as per the pics included)

 

What could be causing it to be "waiting for rood device"?

was it me repairing permissions? (it did 'repair' my kernal but I re-copied it all and it still does this after re-copying my kernal and Extra folder (and re-installing my bootloader) but, still nothing...)

 

This might be linked to its falure to shut down properly (however, I would have no idea how to fix that...)

 

so I need somthing that would fix the "waiting for rood device" (I tried it with the dsdt in the extra folder but that still failed [would it read the dsdt if there is that other kext there too?]) So I'm not sure what has gone wrong. It has done this twice now and I still have no idea what could be causing it.

 

Please note the pics were taken from my macbook pro's camera so are a little sideways and do not show the whole screen. (might help if you use ctrl + mouse wheel up in mac os to zoom in a bit on the pics. Just in case you don't know... ctrl + mouse wheel down zooms back out. Its a full screen zoom... kinda useful. Just in case you did not know how to do that already...)

 

 

 

Side question.... I would like to try and get my normal leopard in better working condition (as Snow leopard is STILL not working)... would you be able to send me your network and sound drivers for leopard (or tell me where I might find them...) I also need a graphics driver that would actualy work for my 8800 gts (the NVEnabler does not seem to do anything, despite it listed as working for this card. Any ideas???)

post-653182-1283157423_thumb.jpg

post-653182-1283157460_thumb.jpg

take out your jmicron kext you dont need it, i dont may be the cause of your waiting for root deivce

 

make sure you got AHCI in bios

 

you should really put your system specs in your sig

make sure you got AHCI in bios - Always have it on. I have IDE drives for things like my normal leopard that don't like AHCI.

 

 

you should really put your system specs in your sig. -done. Any help??

 

I noticed you say your CPU is running at 3.5GHz. What setting do you use to get it there (I have overclocked before... just not with anything new... like this) and does this generate heaps of heat? Just wondering...

 

ok i attached the pics in a zip, i added a red dot on the left side (where the check mark would normaly be) of the kext, kernel, bootloader etc that i would recommend to use

 

 

 

 

Hej!

 

 

did you use a dvd to install ideneb v1.6? on which sata ports are your hdd and your dvd drive ? on sata 2?

 

Did you change something inside your bios except ahci? I cannot get inside the installer of ideneb. it writes a few lines and reboots.

 

To see if it would change something, I updated my bios from F4 to F7c. I saw which one I had in windows 7 with the tool @Bios. I have the rev1 of the ga-890gpa-ud3h.

 

 

 

 

I attached pictures of my bios settings.

 

 

post-600751-1283206206_thumb.jpg

 

 

post-600751-1283206405_thumb.jpg

 

post-600751-1283206517_thumb.jpg

 

post-600751-1283206554_thumb.jpg

 

post-600751-1283206591_thumb.jpg

 

 

 

 here are the two last bios screenshots

 

post-600751-1283206732_thumb.jpg

 

 

post-600751-1283206772_thumb.jpg

 

if you have any ideas what I could change to be able to enter the installer of ideneb...

these are 100% stable P-Steps for my proc and most likely for yours too:

MULTI  FSB	   Ghz		V-Core
14  x  250	  3.5		 1.3375 
or
13  x  250	  3.2		 1.2375 
11  x  250	  2.75	   1.1500
7.5 x  250	  1.875	 1.0000
4.0 x  250	  1		   .90000

 

notice the or between 14x250 and 13x250? when my cpu is at 100% at 3.5ghz its temps max out at 67C(about 25C idle, ick). so i left at 14x250(3.5Ghz) in the bios but used phenomstweaker in windows to change my speeds and vcore to more appropriate levels because i have no use for 3.5Ghz on a six core all the time, as i may use the 3.5 speed when encoding. am i correct that encoding doesnt use 100% cpu all the time,right? During 3.2ghz temps max at 52C(100% load, 20C idle). at stock the CPU has plenty of voltage so thats why the vcore is so much lower than stock

 

i have a enzotech extreme cpu air cooler, thinking about making a DIY water cooling setup, as i already have a air blower, car heater core, and could easily make a DIY cpu block

 

ive noticed that my temps are probably more like 75C instead of the 67C when at 3.5ghz. it reports the CPU at 18C idle when the room is 80F, i think my temps are wrong, so that isnt good. when i found that the max temp was 62C, i thought OOPS(it still works :D), so

 

 

Phen123:

go to bios and set to optimized defaults, set ALL satas to AHCI and i put HD on the Sata port lowest on the board, first layer of ports closest(touching) the board. and my bluray sata port is right above HD sata connector on the mobo and my DVD-RW sata port is right above the Bluray drive sata port.

 

then i just popped in the dvd to my Bluray or DVD drive and away i went to the install i didnt have any issues, just make sure your booting form the ideneb DVD and for good measure type -f -v -x at boot

 

on the 4th pic down(the sata screenie) you dont have everything as sata, the IDE port needs to be as Sata so then snow will see any IDE drives as sata's. doubt this matters but it wont hurt

 

i need to update my bios i see some new things to play whit :D

Hmmm. You do use a better cooler than the deafault fan (as I am currently stuck with) My machine does however run exposed to the cold air. I am using an old G4 case with this powerful beast inside. As these old macs had a nifty way of opening up to reveal the motherboard and stuff I keep it open when using it for long periods of time (as the cpu is then out of the way of other hot components in the cold air). I'm not sure this would be enough cooling to keep it at the temps you run it at though (as my idiling temp is 37-42 C. Quite a lot higher than yours... So I might only overclock it a bit... not quite to 3.5 sigh...)

 

 

onto business:

I think I have isolated the main problem as follows:

(as this is after my snow leopard "fixing" its permissions I think it had initially shifted all my kexts to the system/libary/Extentions as I mysteriously found them there when deleting the kext you told me to.)

Before I removed all the extra kexts (the 6 from you + the nvenabler 64bit) from the system/libary/Extentions folder (where normal mac ones go) it boots with this as the aparent error (as far I can tell):

"

From path: “uuid”

Waiting for boot volume with UUID 95D35B04-C130-3768871B-1EBB25ABC2D6

Waiting on IOProiderClass IOResoruces IOResourceMatch ???

"

and after trying to load my firewire...

"

ERROR: Firewire unable to detimrine security mode; defaulting to full-secure.

Still waiting for root device

"

(This is it shortened to what I think is the main points. I might have missed an important point.)

 

When I remove them it does not get past loading all the files in the system/libary/extentions folder. It either complains about my dsdt or (when I add my dsdt back into the Extras folder) this:

"

using PCI-Root-UID value: 0

"

then stops (its obviously near the end of loading these kexts).

 

I seem to be stuck. So tonight I will re-copy mac os snow leo. and try again with a 'fresh' install of everything on this partition (as I seem to be getting nowhere fast). Then tell you what happens, as I am likely to still encounter problems ;)

 

 

 

oh and about those kexts for leopard (any idea on where to get them?)

xKrNMBoYx:

im pretty sure all the hardware you have listed is compatible, hope you have better luck than Setura :) lol

 

Setura:

are you using chameleon RC5 when you try to boot Snow ? and when you get the root-uid error try booting with PCIRootUID=1

 

but dont try ANYTHING till you do a fresh install, oh the wonders it can do :)

Oh the wonders it has done...

 

Now I only get the waiting for root device (no problems with hibernate image or anything else) just that. So I shall try your suggestion with other command and yes I am using charmelion rc5 on my snow leopard volume (char 1 is on my normal leopard drive as that is what seems to work for it. The two are completly seperated...)

Oh the wonders it has done...

;)

 

 

first try rd=disk3s2 at boot, then i would try puting a jmicron kext in /E/E, if that doesnt work then try some other ahci snow leopard kexts from kexts.com, im not sure why its almost the same mobo as me.

well my current motherboard is like a gigabyte GA-MA770-UD3 and some 250gb 7200 rpm seagate harddrive

 

i'll probably take $300 out of $1000 for my laptop, and buy the components you have minus the 5850

 

.:edit:.

 

well im downloading ideneb 10.5.8 lite..never tried this before..but i may try it on my current set up

well my current motherboard is like a gigabyte GA-MA770-UD3 and some 250gb 7200 rpm seagate harddrive

 

i'll probably take $300 out of $1000 for my laptop, and buy the components you have minus the 5850

sounds great, idk why you'd need the new mobo they're pretty much the same besides sata 3 and usb 3 and the audio / ethernet built is prob different but they still work with osx so why bother with a new mobo and waste money?

 

well im downloading ideneb 10.5.8 lite

it should work, if doesn't, i posted a zip of screenies of which options to choose during iDeneb 10.5.8 setup

well i'm trying to burn it..but its not working..do i have to burn it from a mac?

 

i tried burning it with imgburn...but not working..is there a specific program?

 

im sure the dvd burner are no problem..cause i can read dvds and stuff

 

but i think it may be the type of dvd rom..which kind of rom should i use

 

never mind..it was the burner..it was to old..only a dvd rom..not a burner

 

.:edit:.

 

im trying on a old dell dimension 2350..and its at the screen where theres an apple logo in the middle with the rotating ring under it that means its loading or something. But near the top of the apple there is a "do not" sign...you know the red circle with the line through it..except its not red

first try rd=disk3s2 at boot - didn't work. I looked on kexts.com and could not find a jmicrom for snow leopard (only an old one for 10.5) I had a good look around there and could not find a ahci kext (what category would they be in?)

i had a hunch a few days ago!! and i just tried it, i updated my bios to latest F7 for my mobo and i get the same error with my retail osx that im sure it worked before the bios update. so for now id just downgrade your bios till you get one that boots osx

 

 

EDIT\\ try changing the defualt boot drive in bios and use the boot drive selection screen during boot up(like f12 at bios splash screen), it could fix it.

×
×
  • Create New...