Jump to content

[Tutorial] AMD 10.6.8 Retail Snow Leopard Guide!


298 posts in this topic

Recommended Posts

ummm are you sure thats your DSDT? it says:

 *	 OEM ID		   "APPLE "
*	 OEM Table ID	 "MacBook"

 

when in your syspref pics above, it clearly says macpro... download DSDTSE and run it on your mac, get the DSDT that way...

I remove the DSDT. It seems to be working fine. I don't know how to build one from the ground up to just target the sata controller though as there seems to be no option to build a new dsdt using that utility.

 

I'll find out how stable it is without any dsdt when I test it soon.

Sata connection still comes up as unknown.

Ok. Baby steps :)

 

I seem to be having trouble with quicktime too.

I tried patching it like in your guide but the last two things to copy and paste into terminal didn't work for some reason. I need a working quicktime to run Final Cut pro...

but finder likes to crash oftern wich is even more annoying.

 

Here it is. I only know what a tiny ammount of it means...

 

Can eSata work too?

-copy "amd_insn_patcher" file to /usr/bin

then:

cd /usr/bin/

amd_insn_patcher /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents.patched

mv /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents.patched /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents

 

Then restart + boot up in 64bit mode: arch=x86_64 (in chameleon)

and run:

cd /usr/bin/

amd_insn_patcher /usr/lib/libSystem.B.dylib /usr/lib/libSystem.B.dylib.patched

mv /usr/lib/libSystem.B.dylib.patched /usr/lib/libSystem.B.dylib

amd_insn_patcher /usr/lib/dyld /usr/lib/dyld.patched

mv /usr/lib/dyld.patched /usr/lib/dyld

 

 

only do the 64Bit stuff if you are currently in 64bit.

First off thanks for all your help so far. Without you I would not have a partly working hack.

 

All that is missing (as far as I am concerned...) is a dsdt. I still cant seem to get it right.

Did you get the one I sent you?

What needs to be changed?

  • 1 month later...

Did some major clean up/updating on post. Added USB OSX isntall guide. very nice now with new forum theme and editing features. :)

 

Enjoy!

 

AWW dude... Setura, sorry, forgot about your dsdt.... really... now i feel bad

Its ok. My rig spazed out not too long after my last post and Snow Leopard has been failing to boot since, giving me "root device error". (or restarting after loading for 2-3 secs)

 

So Ive been stuck using my two macbook pro's. It would be good to get that dsdt. It might help my situation. I'm using the same kexts I was when I last posted (minus the one for my graphics). All thats changed is that I have managed to get a 8800gt from a mac pro to use in my hackintosh. When I first put it in there it worked like a charm. Then I reinstalled the system so that I could try again with the terminal commands to get quicktime working. With that reinstall I could no longer get a working mac os. Tried reinstalling twice since then with the same reaults.

 

Looking at the lines of text as it starts in verbose mode I see that it seems to have a problem with several IO kexts and also one called appleUSBOHCI which I cant seem to find.

 

 

 

- Edit.

 

Just got it working by adding an intel 6 series chipset driver. (and a few other intel drivers I found for a gigabyte sandy bridge chipset) Not sure how that works though... Its definantly not stable at the moment. It seems to hang a lot. A correct dsdt might help :) I still cant yet figure out how to get mine filled in.

"stuck" with you MBP hahaha

 

the root device wouldn't have anything to do with the OHCI next as that is USB not sata(youre booting off of internal HDD?)

could you give me a really quick refresher on how you installed and at what point you getting these errors so that i can help ?

Sure... :)

(2 macbook pros... my new 17" macbook pro's nice to use but has limited space when it comes to editing HD video, so my goal is to get Final cut pro working on the hackintosh, I did it with my old one, before its motherboard died...)

 

 

So this is how I installed Snow Kittey:

I installed Snow Leopard by using Carbon Copy Cloner to clone my old macbook pro's hard drive accross to what I intend on using as my hacks interanl drive for Snow.

It has 10.6.7 When I tried .8 on the hack it failed big time. With .7 it works most of the time...

 

After cloning I instal the latest version of Chameleon then I copy all the kexts from your guide into thier correct places. After that I install my lan driver which gets rid of the one that comes with your guide.

 

Since I usualy get the root device error I tried all kinds of sata kexts. At best this has got my system to partly work some of the time. I have no idea what I did the first time I got this new rig working :(

My back up of the working kexts from my first working install on this machine gives the same result for some reason... I have no idea what I have missed that is causing this to happen because I know that Snow leopard can work on this machine with minimal extra kexts.

Ah yes... I updated my bios about a month ago due to boot errors which have now gone. Snow Kittey might not like the new bios much. I can try going back to an older one... Not sure which one shipped with my machine though...

 

When I try sata ports other than 1 something about the cpu flashes up then it suddenly shuts down. No Idea why it does that but I assume it only likes port one.

 

Found I was missing the bit from kernal flags that has "arch=x86_64"

Tested it and it produces KPs. Not sure why. Is it an important flag to have?

 

Having C1 enabled is what gave me that one sucessful boot into mac os. I don't think its a worthwhile setting though because of how badly mac os lagged the whole time. When its enabled even the startup slows down.

changing the sata port might be changing the root device address and so it may not find the kernel and thus, not boot.

 

arch=x86_64 is for enabling 64bit, and will most likely cause issues. better to wait till regular 32bit boots first before trying (arch=i386)

 

not sure exactly about C1...

 

different sata ports might give the HDD a different root device, so it might not find the kernel(depending where you put it in the first place)

 

arch=x86_64 is for enabling 64bit mode, but it is better to wait till 32bit works first, as 64bit tends to cause some issues.

 

not sure about AMD C1...

Checked...

 

In other sata ports it does find the kernal. It just then has its little something with the cpu flash up in the middle of osx loading then it shuts down.

 

 

Might the update to the bios be screwing with my install, giving me the root device error?

Since I am using the same kexts and stuff I think that might be whats doing it.

 

 

Thanks for the info about what the arch=x86_64. Ive reverted to my arch=i386 and am getting my usual root device errors.

 

I'll see if I can clearly read what flashes up when its about to shut down when I'm using another sata port and get back to you on what it says.

Just Got Snow Leopard working. Funny enough its after trying to get leopard working that I found sucess.

 

Steps I took:

Found that there was an issue between Leopard and 8 gig of ram. So I took it down to 4 and it booted. Tried it with Snow Leopard and with a dsdt helping my hack and it works almost perfect. Just those two steps, and as a side note my hack is running the latest bios.

Now I just need to get quicktime patched and I'll be up and running. Ill try arch=x86_64 once Ive got a few more sucessful boots and fell confident that it won't screw up like its done so many times. (but I need 64 bit to get the latest Final Cut Pro to work so I need to go there soon.)

 

Thanks for your help. I couldn't have done it without you. :)

Ok it doesn't like 64 bit :( the arch=x86_64 still gives kps. It also didn't like:

"Note: Some say to do these patches below in 64bit, but i have done in 32bit with no issues.

cd /usr/bin/

amd_insn_patcher /usr/lib/libSystem.B.dylib /usr/lib/libSystem.B.dylib.patched

mv /usr/lib/libSystem.B.dylib.patched /usr/lib/libSystem.B.dylib

amd_insn_patcher /usr/lib/dyld /usr/lib/dyld.patched

mv /usr/lib/dyld.patched /usr/lib/dyld

 

and finally;

update_dyld_shared_cache"

being done as it kp'd and I had to restore from the usr directory from my old mac. It didn't seem to update the dyld_shared cache as it kept denying acess. So I'm currently running without this implemened. What is it suposed to do anyway?

 

Finaly... with my apple 8800gt I get random graphcs freezes where everything else is sill running (I know cause my itunes keeps playing) but the screen flickers once then freezes. Pulling it out then plugging it back in doesn't help. This happens at 10-15 minute intervals. So annoying restarting each time to fix. Any ideas on why this is hapening?

amd insn patcher patches dylibs, like quick time, for use with amd kernel

 

"

8800gt"

 

can you play the chess app?

 

 

"

update_dyld_shared_cache"

 

you need to run it as root, so:

sudo update_dyld_shared_cache

 

can you take a pic of this kp?

Im using this kernal (http://blog.nawcom.com/?p=640) for my 10.6.7 install. Reading up it almost seems that I don't need to patch the libSystem.B.dylib as the legacy kernal installer might be doing it.

 

 

I'll check the chess app as soon as I get it restored from my old mac again. (as trying to patch the dylib with your patcher produces kp's that go on about cpu 0)

 

 

I'll take a pic of the kp if I see it again.

 

- edit -

 

I can play older mac games on it (tested battlefield 1942 and Neverwinter Nights) with no problems. Havent tried chess as I deleted it from my old mac :) a long time ago. It shows that its not all there when I try and convert video footage too as the app trying to transcode crashes.

I found that I did not even need to patch quicktime to get it to work for me now. (with my latest install attempt...) It seems that the installer patches everything for me. I have even managed to get 64 bit working smoothly. I have found I am now using a slightly diffrent set of boot flags than your guide recomends to get my 9xx motherboard working.

The random screen freezes are a pain though. Here a pic to demonstrate. It doesn't kp at the moment. When the freezing happens I find that the keyboard is locked too...)

Oh and something I find strange is that I need to have the "graphicsenabler=yes" in order to get my mac graphics card detected in mac os. Is that part of the problem? I thought that it should work out of the box just fine with snow leoprad since its an apple card taken from a mac pro.

 

-Further update. I have finaly managed to get the .8 update to work. I still have the annoying graphics freezes.

 

 

- update Feb 27. Ditching Graphics card. Hackintosh will have no mac os Till I find a good new one.

post-653182-0-02102800-1327471415_thumb.jpg

  • 2 months later...
×
×
  • Create New...