Jump to content
InsanelyMac Forum
blackosx

[Guide] Vanilla Retail 10.6.x with Chameleon v2 for Gigabyte GA-EP45-DS3L

Recommended Posts

Vanilla retail 10.6.x install with Chameleon on a separate partition for the Gigabyte GA-EP45-DS3L

 

 

News

 

24th July 2011

Time to wind down this topic

10.7 is now out and in full swing and I have also changed my hardware.

 

After two years of covering Snow Leopard installations on the GA-EP45-DS3L here the time has come to draw a line and cease coverage. The PDF guides and Support files are up to date with regards to installing 10.6.0 -> 10.6.8 so I feel happy to leave this alone now and concentrate on other things. Please see here for more info.

 

18th July 2011

Chameleon boot0hfs file now superceded by boot0md

Thanks to dmazar, extra functionality has been added to boothfs to allow it to scan multi disks. More info

EDIT: PDF parts 2&3, along with the Support Files have been updated to reflect this.

 

15th July 2011

Updates to guide PDF's part 1,2,3 & 4, the Support Files and the BootCD

After about a year, I've finally got round to doing some updates here after a few nudges by the kind users here :P

 

The main update has been to 'Part 4 - Configure for GA-EP45-DS3L' PDF to bring it up to date for 10.6.8 while tweaks have been made to some of the other PDF's. The method for enabling audio has been revised to make the most of the latest methods (thanks tmongkol, Mald0n, toleda and others) and the PDF guides refer to using org.chameleon.Boot.plist.. The Support Files now include the latest DSDT I use for our mobo (the same one works for 10.7 too) and the most recent Chameleon RC5 build. The BootCD also uses the latest Chameleon and includes Support Files v1.4.5.

 

When I get more time, I'll look to see if the remaining PDF's need tweaking.

 

5th July 2011

Important: Notification of changes to Chameleon

I've just learned that as of commit 1105, /Extra/com.apple.Boot.plist will now be known as /Extra/org.chameleon.Boot.plist.

So anybody who uses Chameleon v2 RC5 rev1105 -> will need to make this change. There are more changes to come too so anybody testing the latest builds of Chameleon will need to read the CHANGES file in the source.

 

23rd June 2011

10.6.8 is released

I've just learned about it so will download the combo update from Apple. Link. For more info for now, keep your eye on this topic.

 

9th June 2011

About the forthcoming 10.7 on our EP45-DS3L

Since the developer previews of 10.7 have been around I've been concentrating my time on running that on my EP45-DS3L based system. I can happily report that so far, up to the 4th preview version, Lion runs nicely on our older hardware. I've pieced together a couple of posts here in this topic from various other posts at InsanelyMac as notes for future reference for installation, audio, network and the CMOS reset issue, though when 10.7 is finally released I am sure I'll revise the installation post to be a final comprehensive list of steps.

 

 

Introduction

 

When Mac OS X 10.6, Snow Leopard, came out there wasn't much info on InsanelyMac about how to install it, so I created this guide at the end of August 2009 from tips I had learned from Lazlo at projectsnow.net. The guide was then tweaked and revised a few times to iron out bugs and make it fairly comprehensive. The guide had racked up over 20,000 downloads since it's inception which is incredible and the Support Files had also been updated continuously to try and keep up to date with all the changes in the world of OSX86. But by the start of 2010 the guide was showing it's age and couldn't easily be amended to keep it up to date with all the latest developments, so I decided to re-create it and in the mean time take the opportunity to split it in to sections to hopefully make it easier to maintain in the future.

 

Please note that this is not a bible to the only way of doing things and there are now Snow Leopard install guides everywhere so choose which ever one seems to suit your system best. The original purpose of this guide was to show users currently running 10.5.8 on their EP45-DS3L's how to put a vanilla Snow Leopard install on to a spare HDD.

 

I am currently running a Mac OS X 10.6.7 system with the kernel happily booting in either 32-bit & 64-bit mode (more info) with sleep, automatic sleep, shutdown, restart, speedstep, time machine, bonjour networking, video and audio. Native 5.1 surround from digital coaxial posted as working with DSDT (See this post by philippebezoteaux). It's slick, rock solid and operates perfectly for my needs.

 

 

Notes

 

This guide was made for my system using the following hardware. GA-EP45-DS3L Rev 1 BIOS F10. Intel Core2Duo 7300 2.66Ghz, 4GB DDR 800Mhz, nVidia 8800GT 512MB, 2 x 500GB SATA II Hard Drive, SATA II DVD-RW, USB Keyboard & Mouse. If you have different hardware then you will probably experience some differences and if you want to use additional devices, for example Wi-Fi or Firewire PCI cards, then that will be for you to work out how to get them functioning. But I recommend doing that after this install is complete.

 

If you are coming from using a 10.5 system without ever using a DSDT then get used to hearing about it. But all you need to know for now is you need a patched DSDT to stop Snow Leopard resetting your CMOS when you reboot. I have supplied a generic DSDT for the GA-EP45-DS3L (based on mm67's work) in the Support Files for you to use. If you are using a different motherboard then you will have to build your own DSDT for which you can find plenty of guides here at InsanelyMac.

 

Although I have tried to make this guide as simple as possible, it still requires some knowledge of OSX86 and the willingness to research, read and learn. Before posting problems on this thread, please ensure you have read and completed the install guide PDF and have searched this thread for possible solutions.

 

 

Requirements (Please don't ignore this!)

 

• GA-EP45-DS3L

• CPU that supports SSE3 (Core2Duo/Quad/Extreme).

• SATA HDD & SATA DVD drives.

• A purchased Retail Mac OS X install DVD (not a restore DVD).

• A USB keyboard & Mouse (not PS/2).

• Video card - preferably nVidia (8 series or newer) for this guide (See note below for video cards).

• My Support Files (Download link below).

• GA-EP45-DS3L BootCD (Download link below).

• An existing 10.5 installation and USB memory stick (any size) (if the BootCD option doesn’t work for you).

• Access to a Mac and an 8GB (minimum) USB memory stick (if the BootCD option doesn’t work for you).

• A spare HDD.

• Some patience.

 

Video Cards:

The hackintosh world always requires research and the more OS X friendly your hardware, the easier your journey will be. Therefore, you will need to read around and check what works and what doesn’t. Generally, nVidia cards have been easier to get up and running, and my old 8800GT has been great, though more and more ATi cards are now said to be fully working but I have no experience with using one on a hack. I've included some links in 'Part 1 - Preparation' PDF to help give a starting point for research.

 

 

Install Guide PDF's

 

I've adopted a colour scheme to identify the current state of the PDF's

= Out of Date = Still Current = Recently Updated

 

Introduction v1.2 Last updated 4th April 2010

Part 1 - Preparation v1.2.1 Last updated 14th July 2011

Part 2 - Install Snow Leopard v1.4.5 Last updated 19th July 2011

Part 3 - Install Chameleon Bootloader v1.2.6 Last updated 19th July 2011

Part 4 - Configure for GA-EP45-DS3L v1.5.3 Last updated 19th July 2011

Part 5 - Booting with Chameleon v1.2 Last updated 8th April 2010

Part 6 - TroubleShooting v1.2 Last updated 15th April 2010

Part 7 - What's New v1.4.1 Last updated 1st October 2010

Part 8 - Apple Updates v1.3.1 Last updated 30th September 2010

Part 9 - Dual Boot Windows7 v1.1 Last updated 22nd February 2010

 

Previous Install Guide PDF for reference v2.4 (7.13MB) Last updated 12th September 2009

 

 

Supplementary Files

 

Support Files v1.4.7 Last updated 19th July 2011

GA-EP45-DS3L BootCD v1.14 Last updated 19th July 2011

Previous BootCD's were forged by Trauma's BootCDMaker and edited by hand to suit my needs, though this one was made by hand. It uses three kexts which were originally supplied in Superhai's Dell BootCD which I originally posted about here.

 

 

Useful links in this thread

This is a new section here that I will slowly populate with links to posts in this thread

 

What to know about updates: 10.6.2, 10.6.3, 10.6.4, 10.6.5, 10.6.6, 10.6.7

Can I add a firewire card to my system? Link, Link

Dual monitor problems with 10.6.2

 

Install Variations:

Using a single HD and a distro (iPC).

Using a Single HD, 2 x partitions, Boot from USB to launch a restored 10.6 DVD image on HD..

Using a single HD with 10.5 already installed and a USB.

 

Making a bootable USB memory stick.

Adding a Windows7 dual boot option

 

Here's a link to the front page of this thread from 17th December 2009 before I cleaned it up, just incase there is any information I have forgotten to include in the revised PDF guides.

 

 

Credits

 

Running OS X on non-Apple hardware had been a target of a few for a long time and after years of hard work and research by many talented individuals, the dream was realised. And from all the reading I have done, it is apparent that creating a system using the latest version of OS X on hardware such as the GA-EP45-DS3L is whole lot easier than it was five years ago. So my experience with OSX86 which resulted to the information in this guide is all thanks to various contributions by many, many people across many different places. and some of the info came from way before I came along..... For example, the work outlined in this post was majorly important.

 

But if I started to list names it would become long and I would only miss somebody out so can I just give out a big thank you to the community as a whole and the individuals from this thread who have contributed in many ways to fine tune, bug test and further develop this guide. Thank you all ;)

 

 

And finally...

 

I only know what I have learnt so far, and if you have any tips, suggestions, better ways of doing things then please share it. If anybody follows this guide then please report your successes, failures etc.

 

Don't forget to have fun and enjoy this hobby, even if it gets frustrating to start with, you will find a way. Take your time to learn to understand how it all works, learn about your hardware and get used to searching and reading as there is a lot of information already in this thread and on this forum.

 

Many Thanks :)

 

This post was last edited by blackosx on 24th July 2011

Share this post


Link to post
Share on other sites
Advertisement

Worked great for me thank you! I have been reading through several guides including lazlo's and booting with Chameleon always resulted in a KP.

 

EP45-DS3L

4GB DDR2

Nvidia 9600GSO 384MB as 8800GS

Followed your DSDT guide

Share this post


Link to post
Share on other sites

blackosx, I congratulate and thank you for your guide. It is a model of clarity and orderly presentation. Absolutely top notch.

 

Using GA-EP45-DS3L

4x2GB RAM

Working system with Leo 10.5.8 vanilla (separate disk)

Add-on Realtek PCI Ethernet (to work around bonjour problem on integrated realtek)

GeForce 7950GT 512MB, BIOS flashed for OSX

 

I followed the steps and am getting to the desktop, but within a few seconds to a minute I get a KP. The panic is on various processes and the process listed in the panic appears slightly random, everything from mds to ical helper is reported as the faulting module.

 

If I boot with -x flag I do not get a KP.

 

I have a DSDT.aml that worked with 10a380, and I have tried that and made a new one using your procedure with a windows virtual machine and the bios file from gigabyte. I have added the modification of for the bios reset fix.

 

I am paring down the extra folder to eliminate anything not needed to get to a basic desktop. At present I have dsdt.aml, com.apple.boot.plist, fakesmc, ioahciblockstorageinjector, nullcpupowermanagement. I tried removing appleintelcpupowermanagement and appleintelcpupowermanagementclient from s/l/e but seemed to make no difference.

 

The weird thing is that I get snow's desktop, mouse, 1024x768 video without artifacts for a short period before the KP. My experience with OSX is if you get that far on a boot everything is normally good, but not this time.

 

I think I am going to pull the add-on realtek network card so I can check the model number to post here and also try some other variations when I have time this evening, but any troubleshooting advice would be welcome.

 

Am I correct in thinking dsdt.aml and smbios.plist are not required for basic booting?

 

And should HPET be set to anything in particular in BIOS? I am considering replacing fakesmc.kext with dsmos.kext and smbiosenabler.kext to see what happens.

 

EDIT: Thanks for the suggestions. I thought the network card was the most likely problem, and per blackosx's suggestion looked at it first. I am getting no KPs now and did not alter anything/repair permissions in any way. What I did was boot with a USB NIC _while_ the PCI card was still installed. After one boot, I was able to remove the USB interface and just use the PCI card. This seems implausible to me, but I cannnot explain it otherwise! The PCI card is a Netgear GA311 Rev.A1 PCI and the USB NIC is a Trendnet TU2-ET1000. Both of these cards are supported out of the box with 10.5.x, so no kexts to mess with, and are supported OOB with 10.6 apparently.

 

I am adding back items I removed with no issues. I do still get my BIOS reset despite the DSDT.aml modification, so need to investigate that further and perhaps look at Stellarola's original fix which I have not read yet.

 

Time permitting, I plan to start anew with a fresh 10.6 install and see if I can replicate this.

 

All of this is with the 32 bit kernel, btw.

Share this post


Link to post
Share on other sites
And should HPET be set to anything in particular in BIOS? I am considering replacing fakesmc.kext with dsmos.kext and smbiosenabler.kext to see what happens.

 

I set it to 64bit, I got that from reading other guides.

Share this post


Link to post
Share on other sites

Hi HMiller

 

Thanks for trying the guide. It's only others testing it that we can try and iron out any issues.

 

I had a few random KP's when I was doing various install testing. The system would boot and be usable but then, like you, the system would just KP. But I got it working in the end and now both 32 & 64-bit for me are stable.

 

Try without the network card for now and then try removing the Cache folder from /Volumes/SnowLeopard/System/Library/

 

Yes, DSDT.aml and SMBIOS.plist are not necessary for basic booting, as too some of the extensions which you have already removed. Yes try dsmos.kext instead of fakesmc.kext.

 

I have HPET set to 64-bit

 

EDIT: After trashing your Cache folder and rebooting if it still KP's, try this.

Boot in to your 10.5.8 system, Load up Terminal and type

sudo chown -R 0:0 /Volumes/SnowLeopard/System/Library/Extensions

sudo kextcache -v -l -t -m

/Volumes/SnowLeopard/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /Volumes/SnowLeopard/System/Library/Extensions/

The command in purple starting sudo kextcache should be entered all in one line. Where the lines have ended there is a space.

 

Then reboot and see how that goes ;)

 

EDIT: - I have just seen you have added your response to your previous post.. Sorry, I was waiting for a new post :D

Okay, so removing the extra hardware has solved the KP without having to do any terminal work. Great!.. Well done.

 

The best method is to get 10.6 up an running without any additional hardware then try adding things after.

I am working on Bonjour so you won't have to use your add on network cards.

Share this post


Link to post
Share on other sites

Thank you ! i own a GA-p35-DS3L (10.5.8) boot 132 method, i'll read everything and maybe switch to 10.6, maybe that works ? :(

 

EDIT :

otherwise everytime you restart the BIOS will

present you with an error, offering you load from default settings or from the previously last used

settings

oh my god i've noticed that, i thought my motherboard was going crazy, what is a DSDT.aml ? i've tryied many time to CMOS clear my motherboard but after it reboots and ask me to choose default settings, can i solve that ? i still haven't install 10.6 i thing this happenned since the 10.5.8 update. thanks !

Share this post


Link to post
Share on other sites

I take it you have got it installed then? :(

Maybe I should emphasise that bit to make it stand out.

I did write it in the guide too...

 

EDIT: It's happened since the 10.5.8 update?.. And you haven't even started this install yet?

I don't know what you have done but if you can't fix it, I suggest you power off, clear CMOS manually by following your motherboard instructions, then try and boot your system to sort it somehow.

Worst case scenario is to back up what you can and do a fresh install..

Share this post


Link to post
Share on other sites

GREAT Blackosx!!!

On Monday i try SL with your recipe on a separate HD

 

a Perfecto job, like others :)

Share this post


Link to post
Share on other sites

Just a little tip for people attempting SL.

Download kextutility for snow leopard I do not have a link.

Run this utility after you make any changes before doing a reboot.

My system would hang if I deleted or added and new files without running this.

 

BTW

I am running SL vanilla on a Rampage II Extreme and core i7 920 and only need 4 kext changes!!!!

Share this post


Link to post
Share on other sites

I've tried this guide using an EP35-DS3L, but ran into some problems. If I boot in 64-bit mode, as soon as it starts to load the GUI (goes to the gray screen just before loginwindow, not the gray screen during startup) I get a kernel panic. Using -x32 flag, I was able to boot up, log in, and use for about 5 minutes and got a kernel panic. I followed blackosx's guide on DSDT patching including sound (I did not do the network part since network was already working out of the box) but I did not have sound (ALC888a). Should I not patch the audio portion of the DSDT and just do the CMOS patch? I read from another post that the ALC888 was close enough to the ALC889 that the pinout should work, but no audio. I'd like to figure out what's making it KP though before I work on the sound.

 

Any ideas as to what could be causing the KP? I'm using netkas' EFI bootloader version 10.1, vanilla kernel, Chemeleon 2.0 r431, and the latest FakeSMC.

 

The last entry in my system.log before the KP was:

/usr/libexec/kextd[10]: FIXME: IOUnserialize has detected a string that is not valid UTF-8, "������??".

 

The last entry in the kernel.log was:

ug 22 17:52:40 iMac kernel[0]: DSMOS has arrived

Aug 22 17:52:45iMac kernel[0]: ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out

 

Any ideas?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

Guess I spoke to soon. KP in 64bit about as soon as the desktop loads, and 32bit is random but within several minutes. I killed the cache directory, and tried re-building Extensions.mkext like suggested above but still have the same issues.

Share this post


Link to post
Share on other sites

I have been messing around with Snow Kitty the whole weekend...

I managed to get up and running without Kernel Panics in Snow...

How???

 

JUST DONT INSTALL THE LATEST CHAMELEON! This is the cause of all random Kernel panics....

Instead use the classic Chameleon v1.0 (bootloader.dmg) and replace the boot file....as many guides mention...

And something else!

Never boot with -f flag....

Hope that helps someone...

I was in front of my computer 2 days in order to solve the random kernel panics problems....he he :)

Share this post


Link to post
Share on other sites
EDIT: It's happened since the 10.5.8 update?.. And you haven't even started this install yet?[...]

Worst case scenario is to back up what you can and do a fresh install..

No i'm still using Leopard, I think my motherboard is broken. Even when i clear CMOS I can't change/save BIOS settings. I'll try to change the battery or ask Gigabyte a new one :)

Share this post


Link to post
Share on other sites

I'm following your guide. I can't get SL to install. After apox 8-9 min of install message says install will continue after restart. machine then restarts and of course doesn't continue because it's booted into OS 10.5.8. I then see a folder called Mac OS install data and it's full of the install pkg etc. Any idea to get past this?

Share this post


Link to post
Share on other sites
JUST DONT INSTALL THE LATEST CHAMELEON! This is the cause of all random Kernel panics....

Instead use the classic Chameleon v1.0 (bootloader.dmg) and replace the boot file....as many guides mention...

And something else!

Never boot with -f flag....

Hope that helps someone...

I was in front of my computer 2 days in order to solve the random kernel panics problems....he he.

 

I am going into day two of random KPs myself, heh.

 

Zef does not even have this on his site any more as far as I can see. Would something like Chameleon 1.0.12 w/ PCI EFI v9 package work do you suppose? Assuming I replace boot after installing it Chameleon? I have my chameleon partition stable and hours of dealing with Snow weirdness has made me superstitious that if I touch it I will die suddenly, so am hesitant to wipe the drive and do Chameleon 1 until someone can confirm.

 

Here's a totally separate idea. I have installed snow about 6 times today trying for something totally stable, or at least something with predictable errors. I noticed verify permissions would not run at one point and found this http://www.infinitemac.com/f57/no-installe...3623/page3.html where the suggestion is to install SL from another working SL install. I have had problems with OSInstall.mpkg randomly crashing part way through some of the time (under 10.5.8) and have had no crashes during 3 installs from SL. My earlier problem of having to remove my PCI ethernet card for first boot also went away with this technique.

 

I hate to draw conclusions here, though, because SL can appear to work great for a while then crash for no reason...but by Jove I hope it is Chameleon 2 doing 'cause that's easier than the alternatives.

 

For what it is worth, I found I can boot to the "DVD" by restoring the image to a hard disk partition then picking this partition from Chameleon's menu during boot. This is with the Cham partition fully configured, which allows the DVD installer partition to load the same as any other SL install. This is only useful if you are installing SL more than once for some reason :)

Share this post


Link to post
Share on other sites

Good Morning everyone… :)

Wow, I see a few more people have expressed interest in my guide.

 

@Z4g0r - Yes, this guide is here (But being put through it's paces to catch any issues)

 

@jimmydigital00 - Yes, Kext Utility v2.3.2 by cVaD is great. I have it on my system and I used it for testing so maybe it could be something for people to try.

 

To use it, either double click it to let it run and clean your caches and rebuild permissions etc, or drag a SL kext on the apps' icon to install a kext in the retail system.

 

The reason I didn't include it in my guide was because this install leaves the system untouched and works by only adding extra items to Chameleon's /Extra folder. So in theory, no reason so touch the /S/L/E folder.

 

@Cheezmen - You'll have to do some searching.

 

@h4ck1nt05h - The EP35-DS3L has it's differences from the EP45-DS3L that this guide is written for. Hopefully it can give you some pointers but yours uses ICH9 not ICH10 so you might need an extra kext for that (maybe IOAHCIFamily.kext I can't remember exactly). The audio for the EP45-DS3L is a pig, and the instructions in my DSDT guide are very specific for it. You might need to visit tmongkol's thread for more info on yours.

 

The FIXME: IOUnserialize has detected a string that is not valid UTF-8, "������??".

error you see in system.log, I have seen in my logs before when I was testing. But I have just checked my log now and it's not there any longer. So maybe that's something? I will have to look in to that one.

 

And as for the boot process stalling at waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out, again I had that during testing. Double check your kexts, But I remember once leaving it for quite a while and the boot process continued after stalling but I can'r remember if it was from that error?

 

@brushedtooth - Keep trying with it, as I had these issues to. Maybe try running the kept utility I mentioned earlier? and rebooting in verbose mode a few times. I think the system just needs to settle down.

 

@zikman - When I started installing SL with Laszlo's guide, he insisted on installing PC EFI v9 first, then booting SL to get it running. Then after this proceed and install Chameleon. So that could be something too. But I am using Chameleon V2 RC1 r431 (not RC2 v640) and it works perfectly.

 

@Schwinn555 - I haven't seen that before. Sorry, I have no idea for you there. I have installed SL 9 or 10 times and it has completed the install 100% everytime.

 

@HMiller - I have read the OSInstall.mpkg method might not be the best way and to maybe try installing the SL disc image from a USB drive. But I don't have one of these to be able to test.

 

When you say at the end of your post that you can boot the 'DVD' by restoring the image to a HD partition… Does it boot for you and not KP then?

 

Sorry all you guys are having these problems, but stick with it, as I did, and your system will work. :)

Share this post


Link to post
Share on other sites

I got it to install! I restored the DVD to a partition. Then made files visible and used OSInstall.mpkg to do the install. DVD install failed every time.I wonder if I got a bad download? I get a kernel panic in verbose mode shows using 64 bit kernel surprised it installed that one for my machine. It's late and will have to wait until tomorrow for more work. thanks for sharing your work.

Share this post


Link to post
Share on other sites

Well done Schwinn555. Hopefully you'll have more time tomorrow to do some testing with it :)

 

 

Just and update on the error mentioned by h4ck1nt05h

/usr/libexec/kextd[10]: FIXME: IOUnserialize has detected a string that is not valid UTF-8, "????????".

I have just booted in to my backup partition where yesterday I added another install of SL. This uses the same Chameleon boot files from the Cham partition that I boot my main system with.

 

When I installed it yesterday, it KP'd after a short while, similar to many reports here. But after running the terminal kextcache command I posted earlier (but replacing the SnowLeopard references with Backup) and rebooting, it has since been stable.

 

Now if I go to terminal and type grep UTF-8 /var/log/system.log to view any UTF-8 errors I get a long list up until yesterday at 18:06.. Then they stop. This was around the time I was entered the kextcache command for testing when I was answering HMillers questions. So I am thinking the kextcache command fixes the FIXME error?

 

I will wipe my backup partition and do a re-install of SL again (from 10.5.8) to test this theory.

 

EDIT: Okay so this is what I have done (using 32-bit kernel)

 

• Boot in to my 10.5.8 system.

• Open DiskUtility and erase by Backup partition with a new name BackupSL.

• Check permissions box in get info window for BackupSL partition.

• Mount 10A432 disc image.

• From Terminal, do the open osinstall command and start installer and install to BackupSL partition.

• When completed, reboot, using F12 to select correct HD. From Chameleon, select BackupSL partition and boot.

• Watch introduction video, enter questions etc...

• Start to use system and KP!

• So hit reset switch on case, reboot back in to Chameleon and select BackupSL partition but this time with Verbose option.

• Once booted, open Terminal and type grep UTF-8 /var/log/system.log to see 15 FIXME errors with the wrong time (from first boot) and 16 errors now with the correct time from this boot.

• Next type in Terminal

 

sudo chown -R 0:0 /Volumes/BackupSL/System/Library/Extensions

sudo kextcache -v -l -t -m /Volumes/BackupSL/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /Volumes/BackupSL/System/Library/Extensions/

Note: The purple statement should all be in on line with a space when the line breaks occur here

 

• Then reboot

• Once booted, open Terminal and type grep UTF-8 /var/log/system.log again to see no new errors and system seems stable. I am typing this from it.

 

Hope this helps anyone :)

Share this post


Link to post
Share on other sites

@Schwinn555 64 bit is the default as blackosx mentions in his guide, use -x32 kernel flag to boot 32 bit.

 

@blackosx Yes, I can install from the DVD image restored to a HDD partition when I boot from the DVD image partition. I would say it does seem to work better. Having said that, there is way too much unpredictability for me from any of these install types. Like for example, this new install with run great for an hour, survive a couple reboots with no KPs, then all of a sudden it will KP after bringing up the desktop on the next boot. If SL survives a few minutes past boot with no KP, then it will not KP at all during that boot. I am going to walk through your suggestions for checking the log and fixing caches net KP I get.

 

@zikman's method is very interesting because Chameleon 2 overlays the functionality of some kexts within the loader itself. Possibly there could be a more fundamental conflict related to the run time kext patching done inside Chameleon 2?

Share this post


Link to post
Share on other sites
• Once booted, open Terminal and type grep UTF-8 /var/log/system.log to see 15 FIXME errors with the wrong time (from first boot) and 16 errors now with the correct time from this boot.

• Next type in Terminal

 

sudo chown -R 0:0 /Volumes/BackupSL/System/Library/Extensions

sudo kextcache -v -l -t -m /Volumes/BackupSL/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /Volumes/BackupSL/System/Library/Extensions/

Note: The purple statement should all be in on line with a space when the line breaks occur here

 

• Then reboot

• Once booted, open Terminal and type grep UTF-8 /var/log/system.log again to see no new errors and system seems stable. I am typing this from it.

 

Hope this helps anyone :D

 

A variation on this I booted into my SL install as a single user and executed the chown and kextcache and so far no KP in 32 bit mode.

Share this post


Link to post
Share on other sites

I was about to post the same thing as brushedtooth. Ran the commands in single user mode and 32-bit is running flawlessly. I tried booting in 64-bit and got a KP after about 2 minutes. Just as blackosx said, I no longer get the FIXME error in my system log.

 

Now I'm just working on sound. Thanks for the help!

Share this post


Link to post
Share on other sites

What MD5 sum do you all get for the 10A432 images you are using?

 

Googling indicates MD5 = 1d1fb7eca55470143c153f7f902b4ada _might_ be the correct sum, but I am having trouble confirming this.

 

(if you have not used md5 before, just open terminal and run md5 "dmg image name" )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×