Jump to content

SSE2 and SSE3 information PLEASE READ


154 posts in this topic

Recommended Posts

found this on amd site

 

http://www.amd.com/us-en/Processors/Produc...9_11604,00.html

 

which states sempron is sse2 but I am sure I too have seen that sempron 754 is sse3 not sure where, I also can find no referene to 64 bit.

 

 

There are several revisions.

 

130nm semprons have SSE2d, if its socket 754 (ill leave socket a out, as its just a rebranded athlon xp anyways)

first revision 90nm (winchester like) have SSE2 only aswell.

Second revision (venice like) have SSE3. (90nm)

 

They are just variations in cores.

I Have Centrino 1.5Ghz .... SSE2 how do I have to patch the ISO image for running Rosetta?

 

What do I have to use for it?

 

I have already the Maklar-Tiger.iso image and I'll patch it now with the Maklar-tiger-patch-release1.ppf (using ppf-o-matic3).

 

What else do I have to do?... I have too the SSEPatcher.exe ....do this program patch the SSE2 processor automactly? or must the image be patched too?

 

thanks.

arg my overclocked barton 2500 with 1gb of corsair and raid array has more than enough power if only apple wasnt so f***ing retarded in encoding something explicitley for sse2 it's an extension no program let alone operating system should DEPEND on it's presence. but then again apple never intended it to run on anything but new intel hardware which is sad and a leaves out amd. AMD has some great technology but it doesnt have the resources intel does to push out the new designs and research smaller manufacturing processes, I read intel has perfected it's .45 process if only amd had the funds to pursue that then they could really give intel a run for its' money. Not that apple is a big fish anymore it's not a lot of bussiness really for intel but anyways the point of the whole rant is this blows I love my barton and apple should have kept their options open by compiling this so that sse2 and 3 COULD be used if they were there but so that it would not DEPEND on them. What if they do decide to liscense this out to pc's they'll loose bussiness.

 

Hold on there, sport.

 

1.) Apple has no interest in licensing this for PC's.

2.) How would it be losing business if they did and your PC couldn't run it? They wouldn't lose customers they never had in the first place.

3.) Apple's hardware is what it's designed to run on. Therefore if you want it to run, get hardware that closely matches Apple's hardware.

4.) Unless you're a dev trying to get this software off your dev box and onto your personal box, or unless you've donated (not that I have, mind you, though I really should because the info is so excellent) to great sites like this, you haven't paid $.01 for the development. There are awesome people in this community who have gotten as much running on as much hardware as possible. I, for one, am thankful.

my cpu is a semp. 2600, i have it running at 2.25ghz (this cpu is able to take a major overclock) OSX is running wonderful. boots in about 18 sec. It is stable, and fast, and just for the hell of it, i "compared" to a duel 2ghz G5 that i use at work...

 

10x10, 300 DPI photoshop file, created a gradient fill, gave it a radial blur set at 70... results... G5 18 sec... Semp. 21 sec... the sempron of course is running photoshop in rosetta...

 

I have to say... i am not disappointed with the speed of the overclocked sempron cpu... One more thing... i'm not sure it is normal with the SSE2 patch applied... (during install i assumed my CPU didn't have SSE3) but the system profiler says SSE3 is a supported tech.

 

(this is of course a sempron 754-64bit)

my question is how come no one has made a site iwth the following kernels. or all the possible combinations of the following

 

RTC / NO RTC

CPUID / NO CPUID

NX(DX) / NO NX(DX)

SSE2 / SSE3

 

I'm trying to find a way to get my mach_kernel.orig to be RTC and SSE3 ONLY.

 

because i know my computer supports NX and SSE3, and i dont know what the CPUID does but im guessing it has to do with the naming of the processor. If i can get it to say AMD Opteron 165 Dual Core then i'd appreciate it if someone just gave me some instructions because running the kernel without patches through darwin ends up giving me a double panic, so it's either the CPUID or the RTC.

 

and all the other posts i made got NO replies for something that's been talked about but never tutorialed.

 

and for some stupid reason the patches that are released all have CPUID undo, and RTC Undo, NX/DX undo..... but no SSE3 undo.

 

And i followed the instructions on how to run the kernels and whatever with no SSE3.... but it JUST PANICS!

 

so i want to atleast know how i can do this in either a windows or a osx environment without having to download an entire new DVD or something like that. all i'm asking for is somenoe to provide different mach_kernel flavours for 10.4.3 so that i may test which one works best.

 

that cant be so hard, can it? its not like im asking someone to write nVidia drivers.

i just this really weird stuttering problem after a while of use, and i'm thinking it has something to do with NX or SSE3... both of which i support, but are patched out in my current kernel. and if CPUID will not do any harm, but just change the name of my processor, that'd be damn sweet too.

  • 3 weeks later...

After reading many posts i finally figured out that my computer is too old :(

 

 

my g5 sits next to it, so its not that bad....

 

 

for all the people that dont know that much about hardware... (ie myself)

 

when you boot from the cd and it says press F8 for more options, boot with the -v option

 

 

there will then be a line cpu features: this is were you find out you have a crappy cpu with SSE only :(

  • 2 weeks later...
  • 1 month later...

I also have some cpu problems... I've got an Athlon 64 3700 with San Diego core which should support SSE3, CpuZ on Windows x64 shows it. But the system profiler doesn't show it. I'm worried about that. My internet browsing is very slow (Safari, Camino, Firefox, Netscape 7.2) although i have full internet speed (220 kbit/s+). Could this depend on the missing ppc emulator? I can't find rosetta in the system. I read sometimes, that the DVDplayer will have problems in this cases, but it works and also iTunes, but I can't configure iTunes, only have an empty windows which I can't close. I had this problem on other programs, like Power20 or Power64. My system profiler also says that I have no ram modules installed but 16 GB RAM... shiish.

 

Has anyone an idea about that?

i had the problem "no sse3 on sse3 cpu"

 

original $199 hackintosh (celeron d, asrock p4dual) with cpuid limit off in bios. 10.4.5 myzar (?) dvd install.

 

so far no sse3

 

solution: original kernel from Maxxuss_Patch_Solution_v1.0a_1045 with applied patches base, nonx and amd_enabler.

 

this finally did it. there is visible improvement on expose, and xbench of course.

 

phew! :(

i had the problem "no sse3 on sse3 cpu"

 

original $199 hackintosh (celeron d, asrock p4dual) with cpuid limit off in bios. 10.4.5 myzar (?) dvd install.

 

so far no sse3

 

solution: original kernel from Maxxuss_Patch_Solution_v1.0a_1045 with applied patches base, nonx and amd_enabler.

 

this finally did it. there is visible improvement on expose, and xbench of course.

 

phew! :D

 

I'm having the exact same issue, SSE3 is not showing up in my system profiler event though it is an SSE3 cpu.

 

Spacest, can you please post a detail instruction on how you got it to work? Your post was a little vauge regarding the steps you took.

 

Thanks.

I have the same issuse on my Pentium D 805. I know it supports SSE3 (cpuz in windows) but only SSE2 in OS X. I have Mac OS X 10.4.5 (8G1454).

 

... and amd_enabler

 

Are you saying to install this even if we have Intel CPUs?

@Acido: No. Your CPU only supports SSE. CPU-Z showns no SSE2, no SSE3. Therefore, due to lack of SSE2, you're not able to install Mac OS X on your AMD. Sorry to spoil your hope!

 

 

@all: If you have an Mac OS running and want to see if your CPU, means SSE3, is really supported, just use Maxxuss' emulator-tool. It should come with the patch and is called "maxxuss_sse". Open a terminal and run "maxxuss_sse -i" (without quotes, of course). It should display some stats. If every value is "0", the emulator has nothing to do and your CPU's SSE3 is supported by Mac OS X. If are the values greater than 0, the emulator has detected SSE3-commands that can't be handled by the CPU. Also, in this tool, you'll find a little benchmark to compute the overhead for SSE3-emulating on your machine, just look in the usage by entering "maxxuss_sse" only.

 

Don't be afraid of an patched kernel (like the JaS-Patch floating around) even on a SSE3 CPU! Even a patched kernel will work properly with an SSE3 equipped CPU! The emulator just has nothing to do and wont be activated.

 

 

 

dripple

I think there is a another problem. Try booting in verbose mode (press andn hold F8 while power up and then enter into the commandline -v) and have a look at the output. There must be a warning or error apearing on the screen.

 

dripple

  • 2 weeks later...

I Have PC: Sempron 64 2800+ (SSE2,SSE3 if believe in CPU-Z)

ASUS K8N4-E(NForce4-4x,PCI-E, etc.)

512Mb DDR-400 Ram, 160GB Seagate 7200.9 SATAII, 80GB Seagate 7200.7 IDE, 128Mb ATI Radeon x550 (128bit) and Keyboard and mouse USB and PS/2 too

I Have OS: MacOS X 10.4.4 to 10.4.5 by Myz Bootable DVD

 

Can you say me, What is trouble: I can't install it NATIVE mode.... HELP ME ~___~

@iTux: Sempron Socket 754 or 939?

 

There maybe some other posts for installation but I know that it can be frustrating to do this research. Here are my experiences which I made to get it run.

 

OS: Check the Image. I used the 10.4.5 prepatched version. It's not too easy to find, but I still have a t*rrent for it. I read somewhere that it must be burned to a DVD-R, a RW media won't work. It worked fine on my MSI Neo4 Platinum with nVidia 4 chipset and Radeon X1600 card.

HD: OSX could only be installed on the IDE ports of the NVidia 4 chipset, it won't recognize the SATA controller.

DVD: Must be set to master, if it's set to slave the installation will hang.

 

Installation process:

 

Make sure that you've got an empty IDE HD for testing. Maybe not too big, I had a 20 Gb HD for testing. It is possible to use mixed Windoze/Mac partitions, but try that later. Set it to primary master.

If the DVD works it should show a message of some kind of HD unit, ignore it. After this you should get the grey MacOS screen with the rotating busy logo. If the DVD-ROM stops working after some time, it could be a problem with the graphics interface "couldn't match family graphics" always appeared during system boot. After this you should select the language. If the installation starts, select the 'Disk Utility', select your hard drive (if it's present) and erase it. Then select it for installation. Tip: Use custom install and deselect all languages you don't need. It saves a LOT of disk space. The installation took about an hour on my machine with an Athlon 64 3700.

After the installation MacOS wants to reboot. The system may hang. On some machines a reboot won't work, but shutdown will. Others have the same problem. You probably won't get the grey MacOS boot screen, only a wild amount of text scrolling around. Another problem which other users also have. The machine will probably hang some time while it's trying to initialize the graphics display. After this you'll get the installation intro and you have to set some things like network address and so on. Skip the .mac network. After the reboot the default language is set back to English. If you're using another language, you have change it in the system preferences. Don't install System Updates, they cold kill the OS.

 

Yo, that was it. You have to use the Marvell LAN port, the NVidia Chipset LAN won't work. Look in the wiki to get it run. Internet and Windows Network should run immediately. Bluetooth runs fine via USB stick. If you have a mobile phone with Bluetooth, try to find it, using 'search for all devices'. It worked superb with my Motorola V620.

 

Wish you luck for installation and have fun with MacOS!

 

GreetinX from the Other Side!

×
×
  • Create New...