Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


GMA X4500

1,615 posts in this topic

Recommended Posts

hi guys!...


i got a pavilion dv5 1000us

running kalywar 10.5.1


it is a GMA X4500


screen resolution set to 1024 x 768


this is the output from the system profiler




Type: Display

Bus: Built-In

VRAM (Total): 64 MB of shared system memory

Vendor: Intel (0x8086)

Device ID: 0x2a42

Revision ID: 0x0007

Kernel Extension Info: No Kext Loaded



Resolution: 1024 x 768

Depth: 32-bit Color

Core Image: Software

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported





any help??? thank you!!!!

Share this post

Link to post
Share on other sites

There is no solution. Just cross your fingers that Apple's next lineup includes GMA X4500 video...then MAYBE we get driver support.

Share this post

Link to post
Share on other sites

Thanks man for the answer!


i guess that i'll have to live with it till they come out with it :)


it is not too bad... could be worse :rolleyes:



thank you!! Al

Share this post

Link to post
Share on other sites

I would like to suggest trying command line options:



"Graphics Mode"="1920x1080x32" (or similar)



"Graphics Mode"= Tells the system what resolution width, height, color depth & refresh rate to boot the OS with.


Ex: "Graphics Mode"="1024x768x32" WIDTHxHEIGHTxDEPTH


If that doesn't work then you might want to try and modify the kext. These solutions worked for me on another system and card a while back


I really would like to now if this works since a motherboard I am looking at has this onboard.

Share this post

Link to post
Share on other sites

Installed 10.5.5 on a LENOVO IdeaPad Y530 - 405


all XP, VISTA drivers here: http://consumersupport.lenovo.com/lenovo/D...?CategoryID=673

no Linux no Mac (lol)


Installed perfectly dual boot OSx & XP using Fool-Proof guide.

Worked with XxX Leopard 10.5.5 Beta 1 w/PPF1 - Hackintosh OSX86 build.


Realtek High Definition Audio: not working

Vendor ID: 10ec Dev. 0888


Intel High Definition Audio HDMI: not working

Vendor ID: 8086 Dev. 2802


Intel GMA45 x4500: not working (a really drawback)

Mobile Intel® 4 series Express Chipset Family Vendor ID: 8086 Dev. 2A42


Intel Wireless Wi-Fi Link 5100: not working

Vendor ID: 8086 Dev. 4237


Ricoh Memory Stick Controller: not Working

Optiarc DVD RW AD7560S: works


Firewire 400: works


SATA controller: works

intel® ICH9M - E/M SATA AHCI


Lenovo EasyCamera: works


Processor Centrino T5800 2ghz with 4GB RAM: works


Disk Drive: Hitachi HTS543232L9A300: works

Share this post

Link to post
Share on other sites

I have the intel gma 4500mhd too. I understand that there is no working drivers for it but is there any way to force it into 1280x800, i tried the command lines and i dont have a boot.plist file. Any thing at all that can up the resolution, kext, anything? If not i think i will have to render my laptop un-macable because i cant stand to use its great display in 1024x768. Has anyones tired any external apps. Also has anyone got the eithernet working on an hp g-50 112nr.


Thanks a lot and good luck to other 4500 users

Share this post

Link to post
Share on other sites

Guys, we're all in this together.. As everyone knows, we were all hoping that we would be getting GMA 4500 support in the new Macbooks, but Apple decided to scrap that idea and just go with NVidia. It was good news to NVidia users, but not to us.


There are three things we could do: first is get another video card or replace our laptops--which is the last thing in my mind right now.


The second is we could wait for the Macworld Expo this January and hope that we get support for GMA 4500 through the new Mac Pros (and perhaps the new Mac Minis, if Apple does release them). That's the best case scenario because we're going to get native drivers. So we'll have to cross our fingers for that.


And finally, if all else fails, I guess we'll just have to write drivers ourselves. As was written in this thread, Intel recently released the documentation that we need to write drivers, including those for GMA 4500. It's the best thing I've actually read all week, and it gives us hope that we will be able to make our graphics work. The only problem with that is that this will take a lot of effort and a lot of skill.


So we shouldn't give up. It'll work out, I think.. :D

Share this post

Link to post
Share on other sites

My native resolution is 1600 x 900 (16:9) aspect ratio; so i see all stretched on 1024x768 :lol::P:angry:


I only obtained QuartzGL compatible, whith OSx86Tools




Tipo: Pantalla

Bus: Integrado

VRAM (total): 64 MB de memoria de sistema compartida

Fabricante: Intel (0x8086)

ID del dispositivo: 0x2a42

ID de la revisión: 0x0007

Información de la extensión del kernel: Ninguna extensión de kernel (kext) cargada



Resolución: 1024 x 768

Profundidad: Color de 32 bits

Core Image: Software

Pantalla principal: Sí

Duplicado: Desactivado

En línea: Sí

Quartz Extreme: Incompatible

QuartzGL: Compatible

Share this post

Link to post
Share on other sites

+1 on wait for GMA4500m. stuck on 1024x768. chose GMA950 on customize option but still no way to change resolution. is there a way to have options to change resoution. i have a Lenovo 3000 g530l 4151 and i also can't get photo booth to work because of the video card issue so i don't know any other way to test my camera. i saw it worked on the startup/setup screen when it asked for a picture or snapshot for the user but thats as far as i've got with the camera...so any suggestions????

Share this post

Link to post
Share on other sites

4500m here too. Stuck at 1024x768. I have an Acer Aspire AS4730 that I recently installed ideneb on and I'm also having trouble with my sound drivers. I can't believe there are so many of us looking for a solution. :wacko:

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.