Jump to content

[How To] ATI Radeon Mobility x600 QE/CI Enabled with Full Resolution


123 posts in this topic

Recommended Posts

  • 2 weeks later...
  • 2 weeks later...

Hey!

 

Thanks for the kexts! I managed to get qe/ci working on my ATI X700 (5e4d).

 

My DVD player now starts up where it previously didn't. The following is not working:

 

1. iTunes cover flow

2. VLC Media Player show no video

3. iPhoto don't go full screen

4. Can't change resolution

 

It almost seems as if qe/ci only cheating and not really working...

Hey I'm new here, I've tried all the above on a Compaq nx9600 and to my surprise, it works! No translucent menu bar or no tearing of the mouse. This is incredible! How do I know if the Quartz display works or not? Also does internet pages maximize to the full window?

  • 5 weeks later...
Picture1.jpg

 

Hey guys, after a long hard read and alot of head scratching, i finally got QE/CI enabled on my ATI Mobility Radeon x600 with Mac OS X Leopard! Whether this is a good thing or not is a question ive yet to answer. A few cosmetic things are annoying now, such as the completely transparent menubar which has lost the apple logo. But, i have faith that now, if this method of enabling QE/CI on pre x1000 cards can be proven for more models, then maybe the brains here at InsanelyMac will be able to help me in ironing out the issues and making the full OS X experience available to people with older hardware such as myself!

 

The Situation So Far...

Ok so whats new with QE/CI enabled?

1. Completely Transparent Menu Bar with loss of Apple menu Icon.

2. Cant view pictures with Preview. Though they work fine in iPhoto.

3. DVD Player DOES play dvd's! it just doenst show the video. Audio works though haha! Shows thumbnails for each chapter though, which makes me think theres hope for video yet!

4. Mouse tearing is still there.

 

My Goal...

My goal is to irradicate these issues and come up with a solution for osx86 users like myself with older hardware. Any help is welcomed!

 

How Did i Do It?

Ok, this is how i got QE/CI working on my x600!

(I dont think i can post the kexts, though i can email them to anyone that wants them as i have the complete collection needed for this guide!)

 

1.Download Kext Helper b7!! this makes implementing the new kexts alot quicker/easier!

http://www.cheetha.net/Kext_Helper/Softwar...Helper%20b7.zip

 

2.Step two was to install the appropriate Callisto kexts in order to enable full resolution changing on my graphics card. Basically chuck the files into Kext Helper, Type your password, Install and Reboot! The ones for the x600 will be posted at the end of this guide. If other can please email me their working Callisto kext for other cards along with the device ID's i can add them at the bottom of the post!!

 

THE FOLLOWING STEPS WILL REQUIRE MY KEXT PACKAGE, PLEASE PM ME FOR THE LINK.

 

3. Ok, so upon downloading my kext package, you should have natit.kext, Leo Kexts and Tiger Kexts, this is all you need to get it working.

 

4. Navigate to Tiger Kexts and drop and drag all the kexts inside the folder into Kext Helper. Now go into Leo Kexts, and drag the kext thats in there into Kext Helper also. Type in your password and install. Do not reboot. If you reboot now i believe that only QE will be enabled, not CI.

 

5. The next step is to navigate to /System/Library/Extensions/ . Inside there, right click on the kext: ATIRadeonX1000GLDriver.Bundle and click Show Package Contents. Go into the contents folder then the MacOS folder and there will be a file called ATIRadeonX1000GLDriver. Copy this to your desktop. Once on your desktop, Rename the file to this EXACTLY. ATIRadeon9700GLDriver. Then copy the file and navigate back to /System/Library/Extensions/. This time right click on ATIRadeon9700GLDriver.Bundle and go Show package contents. Move through the contents folder to the MacOS folder and paste the file there. It will ask for a password and make sure you replace the file!!!!

 

6. Next go back into my kext package and now drag natit.kext into a fresh Kext helper. install the kext but dont reboot.

 

7. Open the Terminal from utilities.It is essential that you type the following commands correctly:

 

sudo rm -f /System/Library/Extensions/ATINDVR.kext

 

It will ask you for your password, enter it and all should go smoothly.

 

8. Next repair permissions:

 

diskutil repairPermissions /

 

9.When thats done, all thats left to do is remove the extensions.mkext!

 

sudo rm -f /System/Library/Extensions.mkext

 

10. Now that thats done, you can reboot the system! Upon rebooting you should have QE/CI Enabled! check it in the system profiler if you are not sure!

 

Please post your results and perhaps a screenshot of it working! The sooner we get started on fixing the issues the quicker we can have full support on our gfx cards!!

 

 

(NOTE: This method was not created by me, all credit goes to the members that posted in this thread: http://forum.insanelymac.com/index.php?showtopic=70808 All i did was compile the tutorial and gather the appropriate kexts!)

 

-flashGX

 

Can you please send your kexts @ qtip2629@gmail.com plz thank you

  • 1 month later...
  • 3 weeks later...
  • 4 weeks later...
  • 3 months later...

Hey i need those kexts really badly i have an emachines that runs osx perfectly except the ati video card doesn't have QE. Could you pm me those kexts or send them to voxibanez@gmail.com

That would be great

  • 3 weeks later...
  • 4 weeks later...
  • 3 weeks later...
  • 2 weeks later...
  • 2 months later...
  • 2 weeks later...
  • 2 weeks later...
Picture1.jpg

 

Hey guys, after a long hard read and alot of head scratching, i finally got QE/CI enabled on my ATI Mobility Radeon x600 with Mac OS X Leopard! Whether this is a good thing or not is a question ive yet to answer. A few cosmetic things are annoying now, such as the completely transparent menubar which has lost the apple logo. But, i have faith that now, if this method of enabling QE/CI on pre x1000 cards can be proven for more models, then maybe the brains here at InsanelyMac will be able to help me in ironing out the issues and making the full OS X experience available to people with older hardware such as myself!

 

The Situation So Far...

Ok so whats new with QE/CI enabled?

1. Completely Transparent Menu Bar with loss of Apple menu Icon.

2. Cant view pictures with Preview. Though they work fine in iPhoto.

3. DVD Player DOES play dvd's! it just doenst show the video. Audio works though haha! Shows thumbnails for each chapter though, which makes me think theres hope for video yet!

4. Mouse tearing is still there.

 

My Goal...

My goal is to irradicate these issues and come up with a solution for osx86 users like myself with older hardware. Any help is welcomed!

 

How Did i Do It?

Ok, this is how i got QE/CI working on my x600!

(I dont think i can post the kexts, though i can email them to anyone that wants them as i have the complete collection needed for this guide!)

 

1.Download Kext Helper b7!! this makes implementing the new kexts alot quicker/easier!

http://www.cheetha.net/Kext_Helper/Softwar...Helper%20b7.zip

 

2.Step two was to install the appropriate Callisto kexts in order to enable full resolution changing on my graphics card. Basically chuck the files into Kext Helper, Type your password, Install and Reboot! The ones for the x600 will be posted at the end of this guide. If other can please email me their working Callisto kext for other cards along with the device ID's i can add them at the bottom of the post!!

 

THE FOLLOWING STEPS WILL REQUIRE MY KEXT PACKAGE, PLEASE PM ME FOR THE LINK.

 

3. Ok, so upon downloading my kext package, you should have natit.kext, Leo Kexts and Tiger Kexts, this is all you need to get it working.

 

4. Navigate to Tiger Kexts and drop and drag all the kexts inside the folder into Kext Helper. Now go into Leo Kexts, and drag the kext thats in there into Kext Helper also. Type in your password and install. Do not reboot. If you reboot now i believe that only QE will be enabled, not CI.

 

5. The next step is to navigate to /System/Library/Extensions/ . Inside there, right click on the kext: ATIRadeonX1000GLDriver.Bundle and click Show Package Contents. Go into the contents folder then the MacOS folder and there will be a file called ATIRadeonX1000GLDriver. Copy this to your desktop. Once on your desktop, Rename the file to this EXACTLY. ATIRadeon9700GLDriver. Then copy the file and navigate back to /System/Library/Extensions/. This time right click on ATIRadeon9700GLDriver.Bundle and go Show package contents. Move through the contents folder to the MacOS folder and paste the file there. It will ask for a password and make sure you replace the file!!!!

 

6. Next go back into my kext package and now drag natit.kext into a fresh Kext helper. install the kext but dont reboot.

 

7. Open the Terminal from utilities.It is essential that you type the following commands correctly:

 

sudo rm -f /System/Library/Extensions/ATINDVR.kext

 

It will ask you for your password, enter it and all should go smoothly.

 

8. Next repair permissions:

 

diskutil repairPermissions /

 

9.When thats done, all thats left to do is remove the extensions.mkext!

 

sudo rm -f /System/Library/Extensions.mkext

 

10. Now that thats done, you can reboot the system! Upon rebooting you should have QE/CI Enabled! check it in the system profiler if you are not sure!

 

Please post your results and perhaps a screenshot of it working! The sooner we get started on fixing the issues the quicker we can have full support on our gfx cards!!

 

 

(NOTE: This method was not created by me, all credit goes to the members that posted in this thread: http://forum.insanelymac.com/index.php?showtopic=70808 All i did was compile the tutorial and gather the appropriate kexts!)

 

-flashGX

 

 

hello can you please sent me your kext files about my ati x600? id 0x3150

kostas.seres@gmail.com

thank you

  • 1 month later...
Picture1.jpg

 

Hey guys, after a long hard read and alot of head scratching, i finally got QE/CI enabled on my ATI Mobility Radeon x600 with Mac OS X Leopard! Whether this is a good thing or not is a question ive yet to answer. A few cosmetic things are annoying now, such as the completely transparent menubar which has lost the apple logo. But, i have faith that now, if this method of enabling QE/CI on pre x1000 cards can be proven for more models, then maybe the brains here at InsanelyMac will be able to help me in ironing out the issues and making the full OS X experience available to people with older hardware such as myself!

 

The Situation So Far...

Ok so whats new with QE/CI enabled?

1. Completely Transparent Menu Bar with loss of Apple menu Icon.

2. Cant view pictures with Preview. Though they work fine in iPhoto.

3. DVD Player DOES play dvd's! it just doenst show the video. Audio works though haha! Shows thumbnails for each chapter though, which makes me think theres hope for video yet!

4. Mouse tearing is still there.

 

My Goal...

My goal is to irradicate these issues and come up with a solution for osx86 users like myself with older hardware. Any help is welcomed!

 

How Did i Do It?

Ok, this is how i got QE/CI working on my x600!

(I dont think i can post the kexts, though i can email them to anyone that wants them as i have the complete collection needed for this guide!)

 

1.Download Kext Helper b7!! this makes implementing the new kexts alot quicker/easier!

http://www.cheetha.net/Kext_Helper/Softwar...Helper%20b7.zip

 

2.Step two was to install the appropriate Callisto kexts in order to enable full resolution changing on my graphics card. Basically chuck the files into Kext Helper, Type your password, Install and Reboot! The ones for the x600 will be posted at the end of this guide. If other can please email me their working Callisto kext for other cards along with the device ID's i can add them at the bottom of the post!!

 

THE FOLLOWING STEPS WILL REQUIRE MY KEXT PACKAGE, PLEASE PM ME FOR THE LINK.

 

3. Ok, so upon downloading my kext package, you should have natit.kext, Leo Kexts and Tiger Kexts, this is all you need to get it working.

 

4. Navigate to Tiger Kexts and drop and drag all the kexts inside the folder into Kext Helper. Now go into Leo Kexts, and drag the kext thats in there into Kext Helper also. Type in your password and install. Do not reboot. If you reboot now i believe that only QE will be enabled, not CI.

 

5. The next step is to navigate to /System/Library/Extensions/ . Inside there, right click on the kext: ATIRadeonX1000GLDriver.Bundle and click Show Package Contents. Go into the contents folder then the MacOS folder and there will be a file called ATIRadeonX1000GLDriver. Copy this to your desktop. Once on your desktop, Rename the file to this EXACTLY. ATIRadeon9700GLDriver. Then copy the file and navigate back to /System/Library/Extensions/. This time right click on ATIRadeon9700GLDriver.Bundle and go Show package contents. Move through the contents folder to the MacOS folder and paste the file there. It will ask for a password and make sure you replace the file!!!!

 

6. Next go back into my kext package and now drag natit.kext into a fresh Kext helper. install the kext but dont reboot.

 

7. Open the Terminal from utilities.It is essential that you type the following commands correctly:

 

sudo rm -f /System/Library/Extensions/ATINDVR.kext

 

It will ask you for your password, enter it and all should go smoothly.

 

8. Next repair permissions:

 

diskutil repairPermissions /

 

9.When thats done, all thats left to do is remove the extensions.mkext!

 

sudo rm -f /System/Library/Extensions.mkext

 

10. Now that thats done, you can reboot the system! Upon rebooting you should have QE/CI Enabled! check it in the system profiler if you are not sure!

 

Please post your results and perhaps a screenshot of it working! The sooner we get started on fixing the issues the quicker we can have full support on our gfx cards!!

 

 

(NOTE: This method was not created by me, all credit goes to the members that posted in this thread: http://forum.insanelymac.com/index.php?showtopic=70808 All i did was compile the tutorial and gather the appropriate kexts!)

 

-flashGX

 

 

May you send the kext files for the ATI Radeon X600 to my email: ioustuf@gmail.co(m) ? Thanks! :)

  • 7 months later...
  • 5 months later...
  • 5 years later...
×
×
  • Create New...