Jump to content

dovahkiin

Members
  • Content Count

    39
  • Joined

  • Last visited

Everything posted by dovahkiin

  1. ho scaricato un immagine bootable per i pc intel, che non è altro che yosemite insieme a Clover configurato. ho aggiunto a clover i file ssdt, dsdt patchati per il nostro portatile e ha funzionato tutto liscio come l'olio. una volta installato bisogna installare i kext giusti per far funzionare: audio, touchpad, tasti funzione, riconoscimento livello batteria; niente di che non è stato già risolto. per il wifi dipende dalla scheda di rete che hai (funzionano solo le atheros). ah, dimenticavo, alla fine bisogna installare clover oppure per far partire OSX dovrai usare sempre la chiavetta.
  2. Realtek ALC663 Ho provato con VoodooHDA, l'audio funziona ma il microfono è costantemente attivo. Esiste un AppleHDA patchato ma ho bisogno del SSDT (caricato da iSnob nell'update 2) modificato anche, proverò a modificarlo manualmente dato che ho trovato un utente che dice come fare. Edit: trovato, ho fatto una ricerca sul nuovo sito (ex osx86) e ho trovato il link: http://www.hackintoshosx.com/files/download/3690-asus-n56-n76-mavericks-kextsdsdtapplehda/ Provo se funziona. EDIT: Funziona
  3. Ciao Ragazzi, ho installato Yosemite (da l'immagine `originale` di apple, non tramite update). Praticamente funziona gli stessi DSDT e SSDT patchati di mavericks (10.9). Ho qualche difficoltà a far funzionare l'audio e sto cercando il file AppleHDA.kext e il SSDT che @iSnob ha allegato nel primo post (nella sezione Update 2). Solo che il link non mi rimanda al download. Qualcuno si ritrova i files? Qualche mirror dell'update 2 completo? Grazie in anticipo.
  4. Io non credo che arriverà mai un porting del genere. Hai provato queste opzioni?
  5. l'utente che mi ha sbloccato la scheda chipset, purtroppo non mi ha più risposto. se vuoi contattarlo, dovrai registrati al forum dove è attivo e mandargli un pm: http://www.win-raid.com/u369_lordkag.html oppure se vuoi chiedere puoi aprire una nuova discussione o continuare sulla mia: http://www.win-raid.com/t418f16-BIOS-Mod-Asus-N-VZ.html in ogni caso, sarebbe più utile se ci dicesse appunto gli step piuttosto che modificare il bios (dell'n56vz) a chiunque lo richiede. più tardi provo a chiedere in pm, chissà se mi risponde questa volta
  6. Ciao a tutti. Ho seguito le istruzioni di @magnus71 per modificare il bios. Tutto ok, ho sbloccato le opzioni nascoste in advanced sul mio bios v217. Ho letto che per disabilitare la intel hd4000, c'è bisogno di modificare queste impostazioni: La prima si può fare, le altre no poiché avete già verificato che la 'scheda' chipset non viene visualizzata, nonostante le modifiche con AMIBCP. Le altre opzioni sono visibili in AMIBCP. Hanno Handle pari a 04B7 e 03BB per il mio bios. Farò delle ricerche, speriamo... Update: ho trovato un forum dove c'è un tizio che è riuscito a sbloccare la scheda Chipset sul suo Asus K55A. Ho provato le sua patch su MMTool ma poi quando carico l'immagine con AMIBCP il programma va in crash. Quindi ho paura a flashare. Lo sto contattando, nella speranza che possa aiutare anche noi Se vi interessa la discussione è questa: http://www.win-raid.com/t330f16-BIOS-Mod-Asus-K-A-Laptop-Possible.html Nel frattempo ne ho aperta un'altra sullo stesso forum. Vi tengo aggiornati. Scusate ancora l'offtopic, forse è meglio discutere del bios su un'altra discussione? update 2: sono riuscito a far visualizzare la scheda 'Chipset'. Solo che poi appena salvo i cambiamenti (di qualsiasi scheda), il pc si riavvia va in bootloop (ho temuto il peggio). Ho rimosso l'alimentazione per 20 secondi e poi si è avviato per fortuna. Però i cambiamenti non vengono salvati. Ho ripristinato il bios di backup. Se qualcuno volesse provare, mi faccia sapere. update 3: ho contattato l'autore delle varie patch, ha detto che ho rischiato davvero il brick usando i suoi files sul mio bios. per fortuna è tutto ok. mi ha dato una patch apposita per il mio bios che ha abilitato la scheda 'Chipset' non appena mi risponde, e quando il sito funziona (perché ora è inaccessibile), vi spiego come si fa a patchare il bios con MMTool e un HexEditor (così mi ha detto). Domani pomeriggio, provo ad applicare le opzioni che dicevo sopra (sperando che non succeda nulla di irreparabile). update 4: l'utente che mi ha praticamente sbloccato il bios mi ha detto di non provarci nemmeno a modificare quelle opzioni. Se lo facessi, nel peggiore dei casi dovrei rimuovere la batteria del CMOS. Nel migliore dei casi potrei entrare nel BIOS e reimpostare i valori di default. Se qualcuno è disposto a provarci ben venga, io ci metto una pietra sopra
  7. Non ho mai provato a ridimensionare la partizione, però ho avuto la necessità di 'spostarla'. Per farlo con gparted ho dovuto prima disabilitare il journaling sulla partizione di mac, cosa che credo sia necessaria anche per estendere (o ridurre) la partizione. Puoi farlo dal terminale lanciando il comando: diskutil disableJournal /Volumes/Asus_N , dove Asus_N è la partizione sulla quale è installato osx. Fatto questo, fai le modifiche di cui hai bisogno e infine lo riabiliti con enableJournal al posto di disableJournal P.S. Windows può essere installato su GPT
  8. non abbiamo 2 slot mini PCIe, se vuoi il bluetooth devi trovare una scheda combo (bluetooth + wifi) supportata da osx. per il GPT, ti serve clover e la modifica al tipo della partizione (ne ho parlato qualche post fa, se ti interessa dacci un'occhiata ). per lo scroll, dopo aver installato i kext elan touchpad, ti basta modificare la velocità dello scroll dalle impostazioni per 'abilitarlo' (una volta per tutte). purtroppo è una questione legata al bios e all'architettura interna della scheda madre (se esiste un multiplexer per switchare da una gpu all'altra). data la natura di queste gpu discrete, è molto probabile che da sole non funzioneranno mai poiché fungono da supporto per la hd4000. d'altro canto, su un altro forum qualcuno parlava di aver 'sbloccato' il bios e di aver disabilitato la scheda interna... speriamo che venga a galla qualcosa di interessante!
  9. Si è incluso nella partizione, altrimenti non ci sarebbe verso di far avviare il sistema senza un bootloader adatto Devi trovare un modo per modificare il file /Extra/org.chameleon.Boot.plist nella partizione; forse se avii con il flag -s, monti la partizione (mount -uw /) poi puoi modificare il file con il comando nano.
  10. @M31R90 Se lo schermo non è full hd, bisogna disattivare il dual link da chameleon. Come primo tentativo, prova a modificare il file org.chameleon.Boot.plist (in /Extra) Trova: <key>IntelCapriFB</key> <string>4</string> Al posto di 4, mettici il 3.
  11. cosa intendi per copia della mia usb? Clover? L'avevo già postato qui: http://www.insanelymac.com/forum/topic/294045-asus-n56vz-guida-installazione-mavericks-su-asus-versione-aio-da-windows/?p=1973143 Comunque, la prima volta dopo il ripristino con r-drive (e dopo aver fatto la procedura per cambiare il tipo della partizione) è "normale" che al primo boot non carichi. Al secondo boot sicuramente funzionerà.
  12. ti ricordo che se ripristini la partizione, devi rifare il procedimento per cambiare il tipo e nome della partizione. Se l'hai già fatto, non so cosa possa essere. okok
  13. ma che kexts hai installato? Per 'ripristinato due volte' cosa intendi? Hai usato r-drive? @iSnob, a te il touchpad funziona bene? cioè non mi lamento perché non ne sono un utilizzatore assiduo, preferisco il mouse. Però c'è da dire che nelle operazioni di trascinamento, spostamento e scrolling si impunta un po'. Il nostro touchpad (stando a quanto dicono gli stessi driver) è la versione 4, e lo sviluppatore sta cercando dei beta-tester per questa versione. Non metto il link perché è un forum esterno a questo. Comunque dovrebbe rilasciare a breve un aggiornamento.
  14. Where is my mind?

  15. si, la prima anche a me caricava all'infinito. ti basta spegnere e riavvare, funzionerà (insomma, tieni premuto il tasto di accensione finché non si spegne)
  16. Quel divieto è l'errore "still waiting for root device". Sta a significare che il s.o. non riesce a trovare la partizione per avviarsi completamente. È dovuto proprio al fatto che, dopo il ripristino, la partizione non è di tipo Apple (af00), quindi devi fare la modifica che ti ho descritto sopra. Comunque io sono convinto che tu abbia secureboot attivo. Nel BIOS controlla nella schermata "Security". Alcune distro (ubuntu 64bit) funzionano anche col secureboot attivo, altre invece no. Ovviamente ciò che dico è valido solo per chi usa un partizionamento GPT e UEFI (giusto per precisare).
  17. A me Clover visualizza(va) la partizione anche se il tipo non era quello giusto per il boot. Te lo dirò, non mi costa niente. Allora, apri il terminale e digita: gdisk /dev/sda (/dev/sda è il primo hard disk ad essere riconosciuto dal kernel, quindi teoricamente quello interno del notebook; assicurati che sia davvero giusto) A questo punto gdisk aspetterà un tuo comando, digita p e premi invio. Visualizzerai l'elenco delle partizioni, identifica quella di Mac Os e ricordati il numero della partizione. Ora cambia il nome della partizione: digita c, premi invio; ti chiederà il numero della partizione, inserisci quello che hai trovato prima e premi invio. Ora scrivi Asus_N e premi invio. Cambiamo il tipo: digita t, ti chiederà il numero della partizione... inseriscilo e dai invio. Ora scrivi af00 e dai invio. Scriviamo le modifiche sul disco: digita w e dai invio. Ti chiederà una conferma, rispondi di si. Puoi uscire, digita q e invio. Fatto.
  18. Sinceramente, è davvero strano. Che versione del bios hai? È per caso attivo secureboot? Quando avvii dalla chiavetta, come fai? Premi ESC al riavvio? Quando selezioni la chiavetta tra le boot entry, c'è l'etichetta UEFI prima del nome?
  19. ancora non è chiaro, io non installo niente copio semplicemente quei file nella pennetta usb e faccio il boot. uefi funziona così, basta avere un dispositivo formattato in fat32 e la directory /EFI/BOOT con i relativi file. -- comunque sconsiglio di applicare gli aggiornamenti dall'appstore. ora ho dei kernel panic casuali con relativi riavvi spontanei del sistema operativo.
  20. Non capisco perché non ti funzioni con il mio archivio, io ho provato più volte e clover mi parte correttamente (anche su altri notebook). Basta semplicemente copiare la cartella EFI (la cartella, non solo i file all'interno). Comunque, le impostazioni di default di clover non vanno bene. Devi copiarti il file config.plist e le cartelle ACPI ed inserire i driver che ho elencato sopra in drivers64uefi. La partizione di OSX deve esserci per forza, scorri verso destra (con il tasto direzionale).
  21. cerca di far avviare Clover, devi avviare la pennetta in modalità uefi. sulla questione delle partizioni, poi ti dico (niente di complicato, sono 2-3 comandi). oggi, ho provato ad usare la batteria durante la mia giornata universitaria (browser, xcode). come dici tu, non fa più di due ore. sono convinto che la gt650m sia disattivata già. per quanto riguarda la scheda wifi integrata, io l'ho sostituita con una compatibile con osx e la durata è la stessa, forse c'è un consumo ma è poco significativo. chissà qual è il problema, forse i driver della hd4000 sono settati per andare sempre al massimo (prestazioni elevate), boh. avevo trovato alcuni kext (voodoo battery) sul sito russo, li proverò ma non ci spero molto.
  22. come non capisci se si avvia? se avvii da usb si aprirà clover, vedrai una serie di dischi da cui avviare con un interfaccia grafica.
  23. @teodortenzio, spiegami alcune cose: il tuo disco è GPT? Clover si avvia dalla penna usb? Io appena ora sono riuscito a bootare dal mio disco GPT, dopo aver ripristinato il file arc su uno spazio non partizionato. Comunque, se vuoi fare la stessa cosa che ho fatto io, c'è bisogno di cambiare il tipo della partizione, con una qualsiasi distro linux (anche gparted) con il comando gdisk bisogna cambiare il tipo della partizione (codice AF00) e cambiare il nome della partizione in Asus_N, altrimenti ricevi l'errore "Still waiting for root device"
  24. Allora, prima di tutto ho dovuto capire dove inserire i file patchati (dsdt.aml, ssdt.aml). Se si vuole fare una chiavetta usb, il file dsdt.aml deve andare in /EFI/CLOVER/ACPI/patched ; il file SSDT.aml va, invece, in /EFI/ACPI/patched . Non mi spiego il perché, però così funziona su usb. Io l'ho installato nella partizione EFI del mio hdd (aggiungendolo alle boot entry con efibootmgr da linux) e mi è bastato inserire i due file in ACPI/patched nella stessa cartella di clover. Poi, ho dovuto configurare il file config.plist . Ho aggiunto la chiave DropOem, impostata a true (nel nodo SSDT); ho aggiunto GraphisInjector (= yes) e ig-platform-id (= 0x01660004) nel nodo Graphics. Per ultima cosa, ho inserito i driver efi nella cartella Drivers64uefi: FSInject-64.efi HFSPlus-64.efi OsxAptioFixDrv-64.efi OsxFatBinaryDrv-64.efi VBoxHfs-64.efi (forse qualcuno è inutile, controllerò quali sono essenziali al boot e al funzionamento del s.o.) L'unica cosa che non riesco a configurare è la risoluzione del bootloader, che poi influisce sull'animazione di avvio (la mela e il cerchietto che gira). (se disattivate il CSM, la risoluzione verrà identificata automaticamente da Clover) Per il resto credo sia tutto ok. Se volete risparmarvi questi passaggi, potete utilizzare Clover già configurato da me Lo allego, è un file zip. Dovrete solamente estrarlo sulla vostra chiavetta USB (formattata in FAT32), così da avere la cartella EFI nella root della chiavetta stessa. A questo punto, riavviate e fate bootare il pc dalla dispositivo usb. Saluti. N56VZ_Clover.zip
  25. Finalmente ce l'ho fatta. Grazie alle guide presenti su questo forum e un po' in giro sul web, sono riuscito a far funzionare il bootloader Clover. Ora faccio qualche altro test, e se qualcuno è interessato posso dirvi come ho fatto (potrei persino allegare un file zip che vi basterà estrarre sulla vostra pennetta fat32). Ora devo solo capire se ripristinare il file arc sul mio disco gpt fa danni oppure semplicemente ripristina la partizione, ignorando la scrittura dell'mbr (a quanto ho capito GPT ha una sorta di MBR finto, detto protective).
×