Jump to content
trus0und

[How To] ATI Radeon Mobility x600 QE/CI Enabled with Full Resolution

123 posts in this topic

Recommended Posts

Picture1.jpg

 

Hey guys, after a long hard read and alot of head scratching, i finally got QE/CI enabled on my ATI Mobility Radeon x600 with Mac OS X Leopard! Whether this is a good thing or not is a question ive yet to answer. A few cosmetic things are annoying now, such as the completely transparent menubar which has lost the apple logo. But, i have faith that now, if this method of enabling QE/CI on pre x1000 cards can be proven for more models, then maybe the brains here at InsanelyMac will be able to help me in ironing out the issues and making the full OS X experience available to people with older hardware such as myself!

 

The Situation So Far...

Ok so whats new with QE/CI enabled?

1. Completely Transparent Menu Bar with loss of Apple menu Icon.

2. Cant view pictures with Preview. Though they work fine in iPhoto.

3. DVD Player DOES play dvd's! it just doenst show the video. Audio works though haha! Shows thumbnails for each chapter though, which makes me think theres hope for video yet!

4. Mouse tearing is still there.

 

My Goal...

My goal is to irradicate these issues and come up with a solution for osx86 users like myself with older hardware. Any help is welcomed!

 

How Did i Do It?

Ok, this is how i got QE/CI working on my x600!

(I dont think i can post the kexts, though i can email them to anyone that wants them as i have the complete collection needed for this guide!)

 

1.Download Kext Helper b7!! this makes implementing the new kexts alot quicker/easier!

http://www.cheetha.net/Kext_Helper/Softwar...Helper%20b7.zip

 

2.Step two was to install the appropriate Callisto kexts in order to enable full resolution changing on my graphics card. Basically chuck the files into Kext Helper, Type your password, Install and Reboot! The ones for the x600 will be posted at the end of this guide. If other can please email me their working Callisto kext for other cards along with the device ID's i can add them at the bottom of the post!!

 

THE FOLLOWING STEPS WILL REQUIRE MY KEXT PACKAGE, PLEASE PM ME FOR THE LINK.

 

3. Ok, so upon downloading my kext package, you should have natit.kext, Leo Kexts and Tiger Kexts, this is all you need to get it working.

 

4. Navigate to Tiger Kexts and drop and drag all the kexts inside the folder into Kext Helper. Now go into Leo Kexts, and drag the kext thats in there into Kext Helper also. Type in your password and install. Do not reboot. If you reboot now i believe that only QE will be enabled, not CI.

 

5. The next step is to navigate to /System/Library/Extensions/ . Inside there, right click on the kext: ATIRadeonX1000GLDriver.Bundle and click Show Package Contents. Go into the contents folder then the MacOS folder and there will be a file called ATIRadeonX1000GLDriver. Copy this to your desktop. Once on your desktop, Rename the file to this EXACTLY. ATIRadeon9700GLDriver. Then copy the file and navigate back to /System/Library/Extensions/. This time right click on ATIRadeon9700GLDriver.Bundle and go Show package contents. Move through the contents folder to the MacOS folder and paste the file there. It will ask for a password and make sure you replace the file!!!!

 

6. Next go back into my kext package and now drag natit.kext into a fresh Kext helper. install the kext but dont reboot.

 

7. Open the Terminal from utilities.It is essential that you type the following commands correctly:

 

sudo rm -f /System/Library/Extensions/ATINDVR.kext

 

It will ask you for your password, enter it and all should go smoothly.

 

8. Next repair permissions:

 

diskutil repairPermissions /

 

9.When thats done, all thats left to do is remove the extensions.mkext!

 

sudo rm -f /System/Library/Extensions.mkext

 

10. Now that thats done, you can reboot the system! Upon rebooting you should have QE/CI Enabled! check it in the system profiler if you are not sure!

 

Please post your results and perhaps a screenshot of it working! The sooner we get started on fixing the issues the quicker we can have full support on our gfx cards!!

 

 

(NOTE: This method was not created by me, all credit goes to the members that posted in this thread: http://forum.insanelymac.com/index.php?showtopic=70808 All i did was compile the tutorial and gather the appropriate kexts!)

 

-flashGX

 

Callisto__ATI_x600_.zip

Share this post


Link to post
Share on other sites
Advertisement

after seeing this thread I decided to give my HP NC8230 laptop another go, install iDeneb 10.5.5 v1.3, allworks but video and ethernet, wireless works so not a total loss. I install the Callisto_ATI_X600 kext and now I have resolution change, not bad.

 

From you write up even with QE and QI enable you are still not able to watch a DVD or use other aspects of the OS so just having it say its enabled but not functioning makes it just as useless.

 

I will start more work on this, thanks for the post, once we have DVD playback I will consider this close to usable.

Share this post


Link to post
Share on other sites

Yeah basically the idea is i need help fixing these issues because the more people the more solutions can be tested. first thing we need to do is to find out the reason why things arent working!

 

-flash

Share this post


Link to post
Share on other sites

Hi Flash!

 

I've tried your KEXT package with callisto 003 fix and 008 on my Radeon X700 Pro.

I added my PCI ID into the plist if necessery.

The only thing that happened was that Leo refused to boot...

Well , I'm now playin' around with Kexts and if I find a solution,I'll post it here.

 

Adam

Share this post


Link to post
Share on other sites

hey dude! yeah im not sure how many cards this will work with but its worth testing. It took me a few goes to get it going. thanks for the feedback!

Share this post


Link to post
Share on other sites

Hi,

I tried with your kexts. It did not work on the 200M.

Is there any specific modification required for radeon xpress 200M.

I am open to suggestions and experiments.... :D ...working on spare test install.

Share this post


Link to post
Share on other sites
Hi,

I tried with your kexts. It did not work on the 200M.

Is there any specific modification required for radeon xpress 200M.

I am open to suggestions and experiments.... :D ...working on spare test install.

 

That sucks, was hoping to try it out on my 200G (speaking of which I wonder what the difference is between the two? I do know mine has 128MB -dedicated- memory, with the ability to use shared memory on top of that (up to 128mb)) Is yours shared memory only?

 

At any rate, I'd like to give this a go. Gonna shoot the OP a PM and hopefully get the info :D

Share this post


Link to post
Share on other sites
That sucks, was hoping to try it out on my 200G (speaking of which I wonder what the difference is between the two? I do know mine has 128MB -dedicated- memory, with the ability to use shared memory on top of that (up to 128mb)) Is yours shared memory only?

 

At any rate, I'd like to give this a go. Gonna shoot the OP a PM and hopefully get the info :blink:

 

Yes..i have 256MB shared memory....I was trying something else after putting in the patches....ruined my install but no worries...it was a test install... :P .....will try experiment again.

Share this post


Link to post
Share on other sites

hello, can you post the original version of ATIRadeon9700.kext wich is into "Tiger kexts" ?

thanks!I need it!

Share this post


Link to post
Share on other sites

Well, still working on it... This is what I get now:

 

Radeon XPRESS 200M (PCIE):

 

Chipset Model: Radeon XPRESS 200M (PCIE)

Type: Display

Bus: PCI

VRAM (Total): 256 MB

Vendor: ATI (0x1002)

Device ID: 0x5955

Revision ID: 0x0000

Displays:

Display:

Resolution: 1024 x 768

Depth: 32-bit Color

Core Image: Software

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported

QuartzGL: Supported

Display Connector:

Display Connector:

 

 

Before it had unknow, then when I was fooling with it before I happened onto this thread it would list it as an ATI XPress Video Card... I guess I am getting somewhere, slowly...

 

dmesg output after adding device ID to CallistoHAL (I now have translucent menus, still no QE/CI) however it now says I only have 16MB of video memory (I have 128 on the graphics card):

 

Also, finally able to change resolution finally... Before I was stuck @ 1024x768, now I'm @ 1280x800 (much better for this monitor). Still working on it, maybe this info will help?

 

VGA: family specific matching fails

VGA: family specific matching fails

Natit: Starting.

device-id: 0x5955

Natit: Found device

Natit: Found device name

Natit: Setting @0,device_type=display

Natit: Setting @0,compatible=ATY,Alopias

Natit: Setting @1,display-connect-flags=0x00000400

Natit: Setting @1,name=ATY,Alopias

Natit: Setting @0,display-connect-flags=0x00000400

Natit: Setting device_type=ATY,AlopiasParent

Natit: Setting @0,name=ATY,Alopias

Natit: Setting @1,compatible=ATY,Alopias

Natit: Setting @1,device_type=display

Natit: Setting model=ATI Radeon Xpress Series

CallistoHAL Initialized!

Callisto: omni's ATI Driver&FrameBuffer, build 003 (fixed), 27-May-2006

Callisto: Model Radeon XPRESS 200M (PCIE) (rv410)

Callisto: MMIO range@0x18 (b0100000) mapped to kernel virtual address 0x2059f000

Callisto: 16 MB DDR SGRAM found on 64 bit wide bus

Callisto: VRAM range@0x10 (c0000000:01000000)

Callisto: Found ROM @0xc0000

Callisto: Legacy ATI BIOS detected

Callisto: Retreived PLL infos from BIOS

Callisto: Reference=14.32 MHz (RefDiv=6) Memory=300.00 Mhz, System=250.00 MHz

Callisto: PLL min 20000 max 40000

dsmos: Initializing...

dsmos: Hook and decryption contexts set!

dsmos: Starting...

Callisto: Non-DDC laptop panel detected

Callisto: Found Monitor: LCD

Callisto: panel ID string: LPL

Callisto: detected LVDS panel size from BIOS: 1280x800

Callisto: BIOS provided dividers will be used

Callisto: Default panel mode: 1280x800, pixel clock: 71250 KHz

Callisto: done with Radeon XPRESS 200M (PCIE)

Share this post


Link to post
Share on other sites

Well bumped video memory up by going into the BIOS and adding 128MB of shared memory to bring it up to 256MB...

 

However OS X only sees 48MB :rolleyes:

 

Anyone else messing with this?

Share this post


Link to post
Share on other sites

Unfortunately nothing to do no qe/ci active on the board. Ce possible that something that still escapes?

Share this post


Link to post
Share on other sites
Unfortunately nothing to do no qe/ci active on the board. Ce possible that something that still escapes?

 

Dunno, hoping to at least get QE/CI working... Dunno if it's possible, but with the tweaking of model types I have been able to get it to see all of my video memory now (128MB). Turned off shared mem in BIOS...

 

It's so close it sucks :thumbsup_anim:

Share this post


Link to post
Share on other sites

FlashGX,

please can you send me the link of kext you used,

I think it could work on my ATI X600 mobility ID 5462 .

I tried very hard to activate QE but no succes until today.

many thanks

lunux

 

 

my e-mail : lunux@libero.it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×