Jump to content

[How To] ATI Radeon Mobility x600 QE/CI Enabled with Full Resolution


123 posts in this topic

Recommended Posts

hi ;) )please, send it to me too =))) sorry for bad english ;)

hello from russia =))

nomby@bk.ru

Привет!

 

Read carefully the whole thread. I think there is no final solution. Only some good results. Not so bad!

I propose for many testing and reports with different configurations and versions.

All observations will be useful.

Ok I followed you guide to the letter (thanks again)

 

I aint sure howto do screenshots on a mac so I'll paste my graphic section from system profiler instead

 

Chipset Model: Radeon Mobility X600 (M24) (PCIE)

Type: Display

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 128 MB

Vendor: ATI (0x1002)

Device ID: 0x3150

Revision ID: 0x0000

Displays:

Color LCD:

Resolution: 1440 x 900 @ 60 Hz

Depth: 32-bit Color

Core Image: Software

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported

 

 

Thats the result I have after trying out your method. I dunno if QE is genuinely unsupported or it aint worked. I did get a message about x600 on loading.

 

Heres my end of my dmesg

 

Natit: Setting model=ATI Mobility Radeon X600

CallistoHAL Initialized!

Callisto: omni's ATI Driver&FrameBuffer, build 003 (fixed), 27-May-2006

Callisto: Model Radeon Mobility X600 (M24) (PCIEP1 (rv410)

Callisto: MMIO range@0x18 (c8100000) mapped to kernel virtual address 0x33e26000

Callisto: 128 MB DDR SGRAM found on 128 bit wide bus

Callisto: VRAM range@0x10 (d0000000:08000000)

Callisto: Found ROM @0xc0000

Callisto: Legacy ATI BIOS detected

Callisto: Retreived PLL infos from BIOS

Callisto: Reference=27.00 MHz (RefDiv=6) Memory=400.00 Mhz, System=230.00 MHz

Callisto: PLL min 20000 max 40000

dsmos: Initializing...

dsmos: Hook and decryption contexts set!

dsmos: Starting...

AirPort_Brcm43xx: Ethernet address 00:90:4b:b5:8d:be

Callisto: Non-DDC laptop panel detected

Callisto: Found Monitor: LCD

Callisto: panel ID string: AUO

Callisto: detected LVDS panel size from BIOS: 1440x900

Callisto: BIOS provided dividers will be used

Callisto: Default panel mode: 1440x900, pixel clock: 96300 KHz

Callisto: done with Radeon Mobility X600 (M24) (PCIEP1

RTL8139::fixEnetFlowControl - Flow Control is disabled

com_apple_driver_RTL8139: Ethernet address 00:00:00:6f:00:00

AirPort: Link Up on en1

 

 

Thanks

 

Edit: Just a lil update. I tried running a program that used OpenGL and got a "couldn't create OpenGL content" error I think. Sorry me memorys like a sive. Didn't work anyhoo, lol

 

Any ideas?

okay, here are my testing results:

 

I've tried your guide on an iDeneb 1.3 (10.5.5) with an ATI X700 (5652).

 

First it took me a while to get a working Callisto for full resolution. (006 with ovof's patch) - then I've followed your instructions.

 

The Result is, my osx freezes after loading the ATIRadeon9700.kext - without ATIRadeon9700.kext -> No QE/CI

 

Greetings from Germany,

Tom

  • 2 weeks later...

Thanks for your solution.

Could you mail me the 3 Kexts (natit.kext, Leo Kexts and Tiger Kexts) ?? Please~~~

Because I have any way to find out them by google!!

If you could, Please send them for me!!

My Mail : pochang.peng@gmail.com

 

My notebook is Asus W3V, 1G RAM, 120G HD, VGA- ATI X600!!

Thank you very much!!

Well I've crashed my Leo4x200 install (10.5.2) but today I've reinstalled it and upgraded via AMD Patcher 0.31 (thanks zephyroth!) to 10.5.5 with Voodoo RC1 kernel.

Let's see if it will work with this setup...

 

Adam

  • 2 weeks later...
×
×
  • Create New...