Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×

Leaderboard


Popular Content

Showing content with the highest reputation on 03/22/2019 in all areas

  1. 2 points
    Shaneee

    AMD Vanilla Kernel

    AMD OS X is proud to announce that native macOS is available on Ryzen CPUs thanks to AlGrey. No need to use a patched kernel/prelinkedkernel. This is currently being classed as beta support and other CPUs are being worked on. https://github.com/AMD-OSX/AMD_Vanilla
  2. 2 points
    here friend https://www9.zippyshare.com/v/MFUSPWDb/file.html
  3. 1 point
    ---USB--- https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/ ---CLOVER FOLDER--- https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/ --MOBO GigaByte Z390 M Gaming --PROCESSOR Intel Core i9-9900K --COOLER CoolerMaster MasterLiquid ML120R RGB --MEMORY Corsair Dominator Platinum 16GB (2 x 8GB) --GPU Sapphiretech Radeon RX 590 8 GB GDDR5 --SSD Samsung 970 EVO NVMe M2 Flash Drive --POWER SUPPLY EVGA 750 N1, 750W --WIRELESS TP-Link Archer T9E --BLUETOOTH Orico BTA-403 --CASE Thermaltake View 21 Tempered Glass Edition --DSDT Patches-- -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES --SCREENSHOTS-- --BruceX-- --USB-C-- test with SanDisk Ultra USB-STICK 128gb -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders! Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others! We're all here to have fun and learn from each other!
  4. 1 point
    TLDR, a lot of Corsair HID peripherals are now supported. I know there were other solutions like CKB-Next that got some things working but now we have a more streamlined experience. I hope this was the proper place to post this. Link below and the post it refers to. http://forum.corsair.com/v3/showthread.php?p=982647#post982647 Hi everyone, It has been a long time coming but I am happy to finally announce the beginning of our OPEN BETA for iCUE on MacOS! Link: http://downloads.corsair.com/Files/CUE/iCUE-3.10.125-release.dmg Some of you may remember that I was beta testing a macOS version of CUE2 about a year ago. Since we were planning to launch iCUE in early 2018, I made the hard decision to stop development on macOS for CUE2 because I did not want two different experiences on both platforms. We used this time to accomplish a few tasks: 1.) Ensure that almost all of our CUE2 products will be supported on the macOS platform. 2.) Complete iCUE for Windows and then port it over to macOS. 3.) Validate it for MacOS on desktop and laptop models to ensure a clean transition. The difficulty of implementing iCUE on macOS wasn’t so much the software but the firmware. Due to architectural changes, existing firmware on our devices would not properly be detected in macOS iCUE. Those who tested CUE2 would be familiar with this issue. To resolve this problem, we had to implement a new protocol for firmware. This means that most users will have to update the devices on their Windows machine first, if you have a legacy product, while users with our newest keyboard (K68 RGB and newer) can actually use their devices out of the box without any update. For reference, here are all of the devices that will support iCUE without requiring a firmware update: K68 RGB K70 RGB MK.2 SE K70 RGB MK.2/RAPIDFIRE K70 RGB MK.2 LP Strafe RGB MK.2 M65 RGB Elite M65 PRO RGB K70 RGB LUX K70 RGB RAPIDFIRE SCIMITAR PRO STRAFE RGB HARPOON RGB All VOID headsets (except Stereo) All HS headsets (except Stereo) ST100 MM800 (All versions) To prevent any potential issues with deploying firmware updates, we decided to stagger out firmware releases this time in batches for macOS compatibility. Therefore, the first batch of legacy products that will support macOS will be the following and are live already: K95 RGB PLATINUM K55 RGB K63 WIRELESS/SE DARK CORE RGB/SE Users should use iCUE (Windows) to update their hardware. You will know you’re on the proper firmware if you are on version 3.XX for the legacy devices (STRAFE MK.2 and K68 RGB will show 1.XX but already use the new protocol). For users who don’t have an access to a Windows machine, we are in the process of documenting how to do a manual firmware update with a Mac so you can do the update without iCUE. However, I advise using iCUE is the best method when possible. I hope you all enjoy iCUE on a new platform as we’ve been working on this for more than a year and a half. We will start to deploy more and more firmware updates so if your product isn’t support yet, it will be by sometime in December. If any of you have any questions, feel free to PM me anytime. And as always, thank you for your support with our CORSAIR products! Regards, James FAQ: 1.) What products are supported in iCUE for macOS? iCUE for macOS will only support HID products (keyboards, mice, headset, headset stand, and mousepads). 2.) Why does iCUE for macOS not support DIY products? We use Windows Service to control DIY products and we also use CPUID SDK to do so. Unfortunately, neither of these are compatible with macOS at this time. We are looking at alternative methods but as most people are using macbooks and mac desktops, we don’t think there is a strong enough demand yet to support DIY with users who have Hackintosh’s. However, we are carefully monitoring feedback as well as investigating how to improve the overall experience when it comes to device support. 3.) Is it possible to update firmware on iCUE macOS in the future? Yes but we have not uploaded any firmware for this platform yet. We will do so soon so we can continually monitor people’s experiences during the open beta. 4.) Is there anything missing from iCUE macOS from Windows besides device support? We currently support all the features (Actions, Lighting Effects, Surface Calibration, Performance, Hardware Playback, Surround Sound, etc.) but one known issue is OSD. We are still working on that for macOS but do not have an ETA for now. However, all the main features of iCUE supported with your peripheral are available now. 5.) Will we be able to update iCUE versions on macOS? Yes, when we deploy a new version on the mac, you’ll be prompted to update it through the software just like we do on Windows. 6.) Is there anything special I need to do in macOS? If you want key repeat enabled in macOS, you will need to enable this through the terminal. This is the command to enable press and hold: Enable: defaults write -g ApplePressAndHoldEnabled -bool true <return> Disable: defaults write -g ApplePressAndHoldEnabled -bool false <return> (Thanks Manofclay) After you enable this, you will need to restart your system. 7.) Is this an official release for macOS? No, this is just an Open Beta so we can gather bugs and feedback. However, this can be shared with anyone you desire. 8.) What version of macOS does this support? We are supporting High Sierra and newer but we recommend using the latest if possible.
  5. 1 point
    C.Frio

    [pre-release] macOS Mojave 10.14.4

    hi.. @mnfesq...playing with icons fixed the issue.. thanks c.frio
  6. 1 point
    apianti

    AptioMemoryFix

    It allows you to use your native nvram. However, as the way the nvram implementation in firmware behaves changes over time, there develop different issues. Apparently some newer firmwares now present some other issue that forces using emulated nvram again. You have to reconcile the native nvram with the emulated nvram if you switch back as they will have different variables and values.
  7. 1 point
    KemalALKIN

    AMD Vanilla Kernel

    Thanks for all I created and used this image: (kealOS --> KEmalALkın macOS) https://www.macosforeveryone.com/kealos-catalina-10-15-amd-intel/ Tested on: Success [Ryzentosh] AMD Ryzen 5 3600 | Asus TUF B450 Gaming Plus | MSI Armor AMD RX 570 | macOS Catalina 10.15
  8. 1 point
    Thank you! Fantastic guide, by far the easiest hack I have done. This guide made nearly as simple as a real Mac. Start to finish it took 20ish minutes. Thank you
  9. 1 point
    kultrun

    Hackintool v3.x.x

    Hi Headkaze and friends... I post here what I discovered thanks to Maldon and his team in Olarila. I have a Hack with Mobo GA Z370 HD3, processor Intel CoffeLake i5 8400, graphics UHD 630... I use lastest hackintool to apply the video patch on the UHD 630. I leave this information in case it is useful for other users So, what I did: - follow this guide: https://olarila.com/forum/viewtopic.php?f=62&amp;t=9275 - Set Platform ID to 0x3E9B0007 - on the first try, change smbios to MacMini 8.1 and in connectors I changed the active connector (in red) by type hdmi, which is the correct one of the mother. Result: the hack boots but the screen looks all in shades of pink. - So I changed three things: the smbios to imac 18,3 and changed this parameters in hackintool patch: ID: 3E9B0007, STOLEN: 57 MB, FBMEM: 0 bytes, VRAM: 1536 MB, Flags: 0x00801302 TOTAL STOLEN: 58 MB, TOTAL CURSOR: 1 MB (1572864 bytes), MAX STOLEN: 172 MB, MAX OVERALL: 173 MB (181940224 bytes) GPU Name: Intel UHD Graphics 630 Model Name(s): Camelia: Disabled Mobile: 0, PipeCount: 3, PortCount: 3, FBMemoryCount: 3 [1] busId: 0x05, pipe: 9, type: 0x00000400, flags: 0x000003C7 - DP [2] busId: 0x04, pipe: 10, type: 0x00000400, flags: 0x000003C7 - DP [3] busId: 0x06, pipe: 8, type: 0x00000400, flags: 0x000003C7 - DP 01050900 00040000 C7030000 02040A00 00040000 C7030000 03060800 00040000 C7030000 - As you can see, I went back to all the connectors as DP - But in the hackintool patch, I turned on the option DP → HDMI (patch /advanced) - Result: no more pink screen but video glitches issues - So, I changed the smbios definition again to MacMini 8,1 - Result: everything seems to be ok now!! - Now, all connectors appears as HDMI But, as I only have a monitor, with an HDMI port ... and my mobo has only two outputs: hdmi and dvi ... well, II do not worry too much (or should it be something to worry about it being that way?) I send you some screenshots to confirm that everything seems fine (for now, ja!) The only thing that seems strange to me is that (supposedly) the values of "stolen, fbmem" etc ss you can see in the previous parameters, but they do not seem to reflect or are different (as can be seen in hackintool screenshot) EDITED: apparently this is solved by generating the patch again and NOT selecting the option "DVMT pre-alloc 32 MB". Also, I did not select the option "VRAM 2048 MB" For now, I tried the screen off and the sleep mode, and apparently it goes back well without black screen Well, if everything seems perfect, I continue with this configuration ... but in any case I am attentive to advice and suggestions! Many thanks for all that help, friends! Something to advise: I do not know if it is related to having generated the patch for the video or with the current (newer) version of hackintool, but I had to generate the USB patch again because all the ports appeared as "internal" I attach the config.plist if anybody needs it... config.plist.zip
  10. 1 point
    C.Frio

    macOS 10.14 Mojave Betas (DP's)

    ola... feito. o update da beta 4 para beta 6..aparentemente correu tudo bem, mas,alguns icones nao foram carregados... sera porque nao passei pela beta5? usei este script curl -O https://raw.githubusercontent.com/Gengik84/MacOS_Updater/master/MacOS_Updater && chmod +x ./MacOS_Updater && sh ./MacOS_Updater c.frio EDIT: foi resolvido jogando com os ícones
  11. 1 point
    I'd bought a gigabyte aorus z390 pro wifi two month ago and from all this time I've been without shutdown and sleep properlly but with this guide my Hackintosh is now working correctly. Very very thanks!!!.
  12. 1 point
    Emanuele-1998

    VirtualSMC — SMC Emulator

    Why can’t unload virtualSM super I/O ? @vit9696 @chris1111 @Dr. Hurt
  13. 1 point
    Badruzeus

    Site Issues

    "InsanelyMac teaches us to be patient, but.. ah, nevermind. Get well soon."
  • Newsletter

    Want to keep up to date with all our latest news and information?

    Sign Up
×