Jump to content

Modified BIOS to get all cores working


  • This topic is locked This topic is locked
1884 replies to this topic

#461
kaiser

kaiser

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I use MSI PR320 notebook.

I want your modified BIOS.

I'm Korean, so I'm not good at Engilsh.

Please undersatand me, ;);;

http://download1.msi...xe/1334_113.zip

It is link of bios.

Thank you.

#462
xuhx

xuhx

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Kabyl,

It would be great to get a modded BIOS for AsusP5nd2-sli if possible.
Here is the link http://dlsvr03.asus....LI/P5ND0701.zip

cpu: Intel PentiumD 9.15

Thanks a lot in advance.

#463
bato888

bato888

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Hi Kabyl

can you please modify this bios

Asus A8E
CPU T7300 2.0GHZ
14"WGA
Intel 965
X3100
Link for BIOS Version 302

Thanks in advance

#464
kellylu

kellylu

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi, please check my pic to see if my hackintosh is running 2 cores.

There are 2 CPU in Activity monitor but only 1 core in sys info. Kinda strange...

Attached Files



#465
AEZ2007

AEZ2007

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
question for DTSu/Kabyl/someone more masterful at these low level issues than I am:

I am still struggling with being able to boot the ASUS M50SA I have with or without CPUS=1.

I have now been able to extract/replace Single Architecture Link Bios successfully for this board. I insert the DSDT compiled without the "CPU Alias" lines, flash successfully...and nothing.

It's very strange. The Leo4Allv3 disc I use can run OK, GUI works well enough, but only with CPUS=1. Once installed, nothing seems to work.

This trick isn't it for this board or isn't the only needed step maybe.

Weird, no?

Especially since this M50SA is (I believe) the same mainboard as the NVIDIA-video card version, the M50SV, which is fixed by this.

Any guesses what other things could cause the issue for an ASUS? I am stumped, just trying things like the new Chameleon bootloader, different kernels, but it feels like I'm getting colder, not warmer.

Cannot even boot WITH the CPUS=1 limiter.

Any tips would be appreciated.

Thanks

aez2007

#466
demonfox13x

demonfox13x

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 122 posts

Can someone please help and do the Lenovo Y510 IdeaPad. Attached is the bios.



thanks


GMA X3100
Intel 965 Chipset
Intel Core 2 Duo T5450 1.66 Ghz

Currently will only boot into osx using ACPI kexts from Tiger and CPUS=1.

I am leaving the country soon so if anyone would be gracious enough to modify this for me quickly as soon as possible.. i would be eternally grateful. Thanks again. Will also paypal 5 $ =D :)
BIOS

#467
ashiya

ashiya

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Could you post one for the Asus F8Sn? I get stuck in a reboot loop without using the cpus=1 flag or the -x -f -s flag. Since a modified BIOS worked for the F3 series, I'm hoping that it'll work for my F8Sn.

Intel Core 2 Duo T5450 1.66Ghz (Santa Rosa)
Intel PM965 Crestline Chipset
NVidia Geforce 9500 GS 512MB

Link to BIOS: F8Sn BIOS

#468
zakfontaine

zakfontaine

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
  • Gender:Male
  • Location:West Portsmouth, Ohio
Intel Core 2 Duo (T7300) @ 2.00Ghz

Lenovo Thinkpad T61

http://www-307.ibm.c...MIGR-67988.html
Bios Version = 1.22 (7LET52WW)

Intel GMA X3100 (working fine)

Kalyway 10.5.3

Only showing up as one core. (unknown 2ghz)

Thanks in advance. Will donate if possible.

#469
demonfox13x

demonfox13x

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 122 posts
Kabyl is the man! Lenovo Y510 working BOTH cores will post screenshot soon!

Posted Image

#470
zakfontaine

zakfontaine

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
  • Gender:Male
  • Location:West Portsmouth, Ohio
Hey Kabyl,
I don't need the modded bios after all. Antaholics helped me with my issue. It was in the /Library/Preferences/SystemConfiguration/com.apple.boot.plist I had to remove the cpus = 1 flag. All is well! Now both cores are functional.

#471
budibudifr

budibudifr

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Can you make a modified BIOS for a Toshiba M60 to get internal disk detected by macosx installation ?
the bios is there
http://support1.tosh...70807140716.zip
It is a Phoenix Bios 1.6 version
There is no ACPI option and it seems to block Kalyway installation : ACPI panic unrecognized device

Thanks a lot for your help

regards

#472
unknow

unknow

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Satellite A200 (PSAEC)

BIOS:-
XP: http://support.toshi...la.asp?ID=59999
Vista: http://support.toshi...la.asp?ID=59994

Intel Core2 CPU T7200 @ 2.00GHz, Intel i945PM rev. 03, GeForce 7300 Go 256 MB (01d7).

I can boot only with 1 core if i'm using Vanilla kernel. If I boot it with 2 cores the system automtic reboot it self.

#473
Lord_Twilight

Lord_Twilight

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Can anyone who has done this on MSI P35 Neo F or a similar board post how they flashed the bios? I can't seem to find any information to flash a custom bios.

#474
pmcnano

pmcnano

    Preguntaaame caom!

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,114 posts
  • Gender:Male
  • Location:Merida, Mexico
Since in-topic search doesnt work, i would like to ask, Any news about Dell laptops?

#475
budibudifr

budibudifr

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Can you find a moment to make a modified BIOS for Toshiba M30 to get Kalliway Mac Osx 10.5.2 working?
without mod bios, darwin kernel stop with fatal error

The latest phoenix 1.6 bios can be downloaded here
http://support1.tosh...70807140716.zip


Thanks lot for your help & time

Regards

#476
VooD

VooD

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 781 posts
  • Gender:Male
  • Location:Spain

I will post an instructions doing this mod for AMI bios in a few days. I think teaching someone to fish is better then feeding them for life. I will find some time and write up the way I have extract the DSDT, decompile and inserted the DSDT back. Hopefully if Kabyl is not busy, he can give us some hints if I did something wrong.

About the Dell laptops. I am sitting on a laptop that I absolutely can not get osx to run without cpus=1 also. So far I have extracted the ROM but can not find any editor or find any DSDT strings inside the ROM. If someone can find a software to edit || decompress || decrypt the ROM, I can start working on it. But for now I think some how having the kernel read from an external DSDT file when it load (like linux) would be the best choice.

-DTsu


I'm really happy to ear that, there are far too much notebooks and motherboards for Kabyl to fix for ever. He's been really kind all this time, but no human can make all that work for ever.

Anyway I heard he (Kabyl) was working on a .kext that would fix DSDT problems in the same way Linux does. Any news about that?

Thanks in advance for your future guide, and thanks again to kabyl for his work and his solidarity.

#477
mentorek

mentorek

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 153 posts
  • Location:/dev/urandom

Satellite A200 (PSAEC)

BIOS:-
XP: http://support.toshi...la.asp?ID=59999
Vista: http://support.toshi...la.asp?ID=59994

Intel Core2 CPU T7200 @ 2.00GHz, Intel i945PM rev. 03, GeForce 7300 Go 256 MB (01d7).

I can boot only with 1 core if i'm using Vanilla kernel. If I boot it with 2 cores the system automtic reboot it self.


Try to enable NX in BIOS. It worked for me.

#478
unknow

unknow

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Try to enable NX in BIOS. It worked for me.


Thanks man, Works like a charm :dev:

#479
dengesis

dengesis

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
hi Kabyl,
My notebook Asus M51SN.

T9300 2.5 Ghz

nvidia geforce 9500 gs 512 MB

2 GB Ram

http://dlsvr04.asus..../M51Sn305AS.zip

My computer is not work M51Sn304AS bios.Try M51Sn305AS bios.

please help.

My english is bad excuse me :D

#480
Jerryf

Jerryf

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hello and thank you so much for your extra work to help so many of us.

I am trying to use an ASUS P5K motherboard with Intel E6750 Core Duo processor. Everything has been patched to work except in Apple Profiler it tells me:

Hardware Overview:

Model Name: Mac
Model Identifier: P5K
Processor Name: Intel Core 2 Duo
Processor Speed: 2.67 GHz
Number Of Processors: 0
Total Number Of Cores: 1
L2 Cache: 4 MB
Memory: 6 GB
Bus Speed: 1.33 GHz
Boot ROM Version: BOOT.EFI.V80
Serial Number: CK157KMHK5B


I believe it should state 1 processor and 2 cores.

I have attached the 1006 bios link which also adds the E6750 processor.

http://support.asus....SLanguage=en-us

Thanks so much.

Jerryfmd





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy