Jump to content

 Leopard (Retail) DVD Perfect Guide 10.5.6 Chameleon 2.0 RC1 April 7,2009


  • Please log in to reply
1355 replies to this topic

#121
patrykens

patrykens

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
I can see it, but our specs differ vastly, do I need to do exactly what your sig says ?

I guess "XFX_7600_GS.zip" would work for my graphics ?


Oh ... and one last thing. I've imported my setings and apps, and couldn't see any difference beside not working TM and "Mac pro" in system info :) Is iLife included in retail Leo ?

#122
LS8

LS8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 573 posts
  • Gender:Male
  • Location:Reality Distortion Field
You need to follow those steps for P35-DS4 MoBo. If you have different HW, I cannot verify if those steps work too. iLife is sold separately.

#123
patrykens

patrykens

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
When I patched the way you did, it didn't want to boot, instead it told me to "restart by holding down power button for a few seconds or pressing restart button"

Can you tell me which of these are essential and needed no matter what hardware you have ?

#124
rhalls

rhalls

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 230 posts
Hi!

I followed the instructions, all seemed very well. THANS for that, i will try that with Leo Server, too.
BUT:
Hi!

I just installed Leo from a retail dvd, by following parts of this http://forum.insanel...o...c=76404&hl= and that http://forum.insanel...ho...5863&hl=....

worked very well, gfx string is great, after all 10.5.0 installations i repaired permissions and all went well.
Then i did the 10.5.1 upgrade and the other available upgrades (including the last security upgrade).
And then i tried to repair permissions again. And BOOM:

Warning: The SUID-File usr/libexec/load_hdi has been changed and was not repaired
Warning: The SUID-File System/Library/PrivateFrameworks/DiskManagement.framework/Versions/A/Resources/DiskManagementTool has been changed and was not repaired
Warning: The SUID-File System/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A/Resources/Locum has been changed and was not repaired
Warning: The SUID-File System/Library/PrivateFrameworks/Install.framework/Versions/A/Resources/runner has been changed and was not repaired
Warning: The SUID-File System/Library/PrivateFrameworks/Admin.framework/Versions/A/Resources/readconfig has been changed and was not repaired
Warning: The SUID-File System/Library/PrivateFrameworks/Admin.framework/Versions/A/Resources/writeconfig has been changed and was not repaired
Warning: The SUID-File usr/libexec/authopen has been changed and was not repaired
Warning: The SUID-File System/Library/CoreServices/Finder.app/Contents/Resources/OwnerGroupTool has been changed and was not repaired
Warning: The SUID-File System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent has been changed and was not repaired
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Flags is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Flowers is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Fruit is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Fung Shui is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Funk Animals is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Gems is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Hollowbody Guitars is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Planets is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Tribal Masks is missing.

Dont know the Translation for "Zugriffssteuerungsliste"; kind of permission list.

What is that????

How can i fix that ?

It doesnt look well!!!

#125
karaakeha1

karaakeha1

    Mac Pro Case

  • Donators
  • 561 posts
  • Location:
I Installed Server 10.5. Just like leopard retail.
just be patient when first time configuring Server it takes really long time to configure the last Step

#126
rhalls

rhalls

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 230 posts
Thanks for your answer, will try when i have time...

Did you discover those "SUID-File" warnings on your installation, too?
BTW, with the way i installed, i do not only have the power-off problem, restart also doesnt work. Sleep works well so far. Maybe something with some of the kexts i added.
I installed from within a brazilmac installation (which had well working restarts) worked VERY well. You topic is GREAT, i feel better with a nearly native install. Thanks for that !

#127
karaakeha1

karaakeha1

    Mac Pro Case

  • Donators
  • 561 posts
  • Location:

Did you discover those "SUID-File" warnings on your installation, too?

I didnt get this error, which kext you Added or replaced .

#128
rhalls

rhalls

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 230 posts
I did the following:
Booted from another LEO disk in the machine, installed EFI on this disk after Partitioning with one partition as GUID. EFI install ran smooth.

Then:
- Insert Leo Retail DVD
- cd /Volumes/Mac\ OS\ X\ Install\ DVD/System/Installation/Packages
- open osinstall.mpkg
- Ignore the error message
- Install Leopard, takes about 20 Minutes from DVD
- When ready, go to the extensions folder in system folder
- delete AppleEFIRuntime.kext
- Add AppleHDA.kext, dsmos.kext, AppleAHCIPort.kext, AppleSMBIOS.kext, ALCinject.kext, IOAHCIFamily.kext, IOATAFamily.kext
- set permissions:

sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/ALCinject.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/AppleHDA.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/dsmos.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/AppleAHCIPort.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/AppleSMBIOS.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/IOAHCIFamily.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/IOATAFamily.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/ALCinject.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/AppleHDA.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/AppleAHCIPort.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/dsmos.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/AppleSMBIOS.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/IOAHCIFamily.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/IOATAFamily.kext

- copy com.apple.Boot.plist for your videocard (here a 7300gt 256 or 7600gs 256) to library/preferences/SystemConfiguration
- Repair permission with Disk Utility
- Try to boot!
- Booted fine here!
- Repaired permissions
- All repaired fine
- Updated to 10.5.1 and all the other Updates available, including Security Update
- Repair permissions gave me some errors/warnings ???

Problems: - Warnings with Diskutil/Repair
- No Restart
- No PowerOff (Fan Spinns)

I will try the "big" 110 MB Updater from Apple, instead of the "small" Updater Software-Update gave me.

#129
karaakeha1

karaakeha1

    Mac Pro Case

  • Donators
  • 561 posts
  • Location:

I did the following:
Booted from another LEO disk in the machine, installed EFI on this disk after Partitioning with one partition as GUID. EFI install ran smooth.

Then:
- Insert Leo Retail DVD
- cd /Volumes/Mac\ OS\ X\ Install\ DVD/System/Installation/Packages
- open osinstall.mpkg
- Ignore the error message
- Install Leopard, takes about 20 Minutes from DVD
- When ready, go to the extensions folder in system folder
- delete AppleEFIRuntime.kext
- Add AppleHDA.kext, dsmos.kext, AppleAHCIPort.kext, AppleSMBIOS.kext, ALCinject.kext, IOAHCIFamily.kext, IOATAFamily.kext
- set permissions:

sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/ALCinject.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/AppleHDA.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/dsmos.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/AppleAHCIPort.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/AppleSMBIOS.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/IOAHCIFamily.kext
sudo chown -R root:wheel /Volumes/leuneu/System/Library/Extensions/IOATAFamily.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/ALCinject.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/AppleHDA.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/AppleAHCIPort.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/dsmos.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/AppleSMBIOS.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/IOAHCIFamily.kext
sudo chmod -R 755 /Volumes/leuneu/System/Library/Extensions/IOATAFamily.kext

- copy com.apple.Boot.plist for your videocard (here a 7300gt 256 or 7600gs 256) to library/preferences/SystemConfiguration
- Repair permission with Disk Utility
- Try to boot!
- Booted fine here!
- Repaired permissions
- All repaired fine
- Updated to 10.5.1 and all the other Updates available, including Security Update
- Repair permissions gave me some errors/warnings ???

Problems: - Warnings with Diskutil/Repair
- No Restart
- No PowerOff (Fan Spinns)

I will try the "big" 110 MB Updater from Apple, instead of the "small" Updater Software-Update gave me.

NO Poweroff is know issue with Vanilla , so dont worry
Diskutility does give some error
as long as you leopard running fine Should be ok

#130
rhalls

rhalls

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 230 posts
I tried the 100 MB Update from Apple, and that fixed a bit.

So theres only Warning: The SUID-File „System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent“ has been changed and was not repaired

The "Zugriffssteuerungsliste" for„System/Library/User Template/English.lproj/Pictures/iChat Icons/Flags“ is missing.T
he "Zugriffssteuerungsliste" for„System/Library/User Template/English.lproj/Pictures/iChat Icons/Flowers“ is missing.
The "Zugriffssteuerungsliste" for„System/Library/User Template/English.lproj/Pictures/iChat Icons/Fruit“ is missing.
The "Zugriffssteuerungsliste" for„System/Library/User Template/English.lproj/Pictures/iChat Icons/Fung Shui“ is missing.
The "Zugriffssteuerungsliste" for„System/Library/User Template/English.lproj/Pictures/iChat Icons/Funk Animals“ is missing.
The "Zugriffssteuerungsliste" for„System/Library/User Template/English.lproj/Pictures/iChat Icons/Gems“ is missing.
The "Zugriffssteuerungsliste" for„System/Library/User Template/English.lproj/Pictures/iChat Icons/Hollowbody Guitars“ is missing.
The "Zugriffssteuerungsliste" for„System/Library/User Template/English.lproj/Pictures/iChat Icons/Planets“ is missing.
The "Zugriffssteuerungsliste" for„System/Library/User Template/English.lproj/Pictures/iChat Icons/Tribal Masks“ is missing.left.

I will check whats different between the BrazilMac Installed additional kexts and the ones i installed now, maye then ill get restart back.Then i will try to fix the iChat Icon warnings. THis may be fixable.
And then i will see whats up with the SUID-File of the Remote Desktop ARDAgent.app. BTW, what the heck is a SUID File????
But hey, your advice for using a Retail DVD is (i know i said that before...) GREAT! i just feels a bit ... legal :-)

EDIT: o.k., so i googled for the SUID thing. Found something on Apple Support."SolutionYou can safely ignore these messages. They are accurate but not a cause for concern."http://docs.info.app...l?artnum=306925
So this is solved with out the need to solve it.

#131
karaakeha1

karaakeha1

    Mac Pro Case

  • Donators
  • 561 posts
  • Location:

So theres only Warning: The SUID-File System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent has been changed and was not repaired

The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Flags is missing.T
he "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Flowers is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Fruit is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Fung Shui is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Funk Animals is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Gems is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Hollowbody Guitars is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Planets is missing.
The "Zugriffssteuerungsliste" forSystem/Library/User Template/English.lproj/Pictures/iChat Icons/Tribal Masks is missing.left.

I
EDIT: o.k., so i googled for the SUID thing. Found something on Apple Support."SolutionYou can safely ignore these messages. They are accurate but not a cause for concern."http://docs.info.app...l?artnum=306925
So this is solved with out the need to solve it.


Exactly thats What I mean ,Glad you found peace of mind.
And after moving the Folder iCHAT Icons to desktop all error with it disappeared

I get the same errors ;) before and less after
Look my Pic

Here is link of better explanation
http://discussions.a...ssageID=6036925

Attached Files



#132
samerali2

samerali2

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
any1 hav a driver for a XFX GeForce 7800 GT ?!
would a 7600 work for me!?

#133
karaakeha1

karaakeha1

    Mac Pro Case

  • Donators
  • 561 posts
  • Location:

any1 hav a driver for a XFX GeForce 7800 GT ?!
would a 7600 work for me!?

There one 7XXXgo.hst
Try this I am attaching file
follow the directions Post 1

Attached Files



#134
samerali2

samerali2

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

There one 7XXXgo.hst
Try this I am attaching file
follow the directions Post 1

thanks a lot. much appreciated :help:
have a great day. I will give it a try :)

#135
samerali2

samerali2

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

thanks a lot. much appreciated :P
have a great day. I will give it a try :)

I just want to say that I got the "driver" working.
it is just normal and smooth, no laggy stuff.

But still my display is set to 1042x768 !!! :tomato:
btw, thanks a lot for your help. Much appreciated :D

#136
scfp

scfp

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
karaakeha1 and ls8 you guys rock!!! :D
With this tread and your linked files I've finally got X38 DQ6 working 10.5.1 vanilla
still got the pesky shutdown, reboot problem but from what i can tell it's a quad core issue

Thanks for tacking the time to post the info

#137
macmaniac

macmaniac

    hackaholic

  • Donators
  • 322 posts
  • Gender:Male
  • Location:Ripbum.BC.Canada

The only issue I have is with my Plextor PX-755SA drive which appears once the system boots and it is shown as burning device for a certain period of time but later it just disappears and the systemprofile shows the following message: "No burning device was found. If you are using an external device please make sure that it is connected and powered properly."

Any ideas what I could do about it? It's connected to an orange port on my GA-965P-DS4 motherboard.

Thanks for your responses. :D


Get a different DVD drive. I had that drive and that problem. I replaced with a Samsung SH-S203B. Problem went away.
Another drive that has this problem is Pioneer (can't remember model # tho). Search the forums, you will find that other people have had this problem, the fix is a new DVD drive.

#138
ekahsm

ekahsm

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
I may be a little blur here but I could have sworn this thread contained the guide itself? step by step and not just the 'updates' as per the edited Opening Post???????
I read it a couple of days ago and planning to have a go this afternoon but there's no guide on the 1st post?????

I read things like, 'i used i_am_me's method, EFI pack link, etc etc' where are they?????

edit: nvm,,, my eyes were confused with all the colours hehehe...found the stuffs i need :)

#139
NeoZG

NeoZG

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Get a different DVD drive. I had that drive and that problem. I replaced with a Samsung SH-S203B. Problem went away.
Another drive that has this problem is Pioneer (can't remember model # tho). Search the forums, you will find that other people have had this problem, the fix is a new DVD drive.


Thanks, the problem goes away when booting with AHCI off.
I am not happy with this drive though and yes I will replace the damn thing.

#140
rhalls

rhalls

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 230 posts
Problem is, if on e gives a detailed explanation, it rains questions like " my board is this and that, and what you wrote didnt work", "i have this videocard, will it work" and so on. Im not very professional with all this osx86 things, but i am thankful for everything i read. im learning parts what to do here and there and the i just TRY. Why asking "will this work on my special hardware?" Why not just figure it out?
I know this special thread is a bit colourful and ... confused. But is was one of the most helpful threads for me. I now can install Leo AND Leo Server on my special hardware without a hassle. It works fast and easy. I went out, bought Leopard and felt a bit more legal then just waiting for people like Kalyway doing some installers. Thats great and i am very thankful for that!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy