Jump to content

[GUIDE] Install Mavericks/Yosemite on Sony VAIO S (2012) -and other UEFI capable VAIOs-

* * * * * 8 votes VAIO

  • Please log in to reply
475 replies to this topic

#21
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth

Hi, Midi,  I cannot download the Clover.zip. The dropbox file is not available. Can you post a new link? Also it would be nice to fix the broken picture links as well. Thanks

hmmm, I don't see anything broken, Clover.zip is downloaded and the link is working, check your ISP/Internet Router or whatever if they are blocking dropbox.com, I will try to make a PDF (working on it) for offline guide, but I don't think any picture is broken, it's your internet connection that maybe blocks dropbox links, or try another browser, or connect to a proxy or VPN (look for free VPN or OPENVPN servers :)

Thanks for the feedback :D



#22
pp611

pp611

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

hmmm, I don't see anything broken, Clover.zip is downloaded and the link is working, check your ISP/Internet Router or whatever if they are blocking dropbox.com, I will try to make a PDF (working on it) for offline guide, but I don't think any picture is broken, it's your internet connection that maybe blocks dropbox links, or try another browser, or connect to a proxy or VPN (look for free VPN or OPENVPN servers :)

Thanks for the feedback :D

 

Thanks much for the response. I tried to the LinuxMint partition on the same machine with the same network and it displayed all the contents fine. I went back to OSX and but just could not make it work ( cleaned the browsing history and accepted certificate exception, with Safari, Chrome and Firefox). The browser complained that the "connection is not private" and it could not prove the certificate of dl.dropboxusercontent.com from *.flipboard.com. I chose to proceed unsafe and it returned either I did not have permission to access the file or the file was not found.

 

I was able to get the Clover.zip from the LinuxMint session and proceed to boot with the prepared USB. But it got stopped with "Still waiting for the root device". Any hint how to get around?



#23
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth

Hmmm, weird, are you booting from USB3.0 ? (use 2.0)


I'm available in chat section if you need help for now



#24
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

Nice guide, did you do some research after I patched your DSDT :D



#25
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth

Nice guide, did you do some research after I patched your DSDT :D

Yeah, I made "Try by elimination" I used patches and skipped others, and only the mix of all the selected patch works! <_< I donno why, but now I'm looking for Hibernation :) REALLY THANK YOU! 

Now the big  issue is SSDT, I can't get proper PM (used SSDTPRGen :P ) and either I get x8 or  x(12 29 31 ... 36) and 30+ is Turbo mode :( and now I'm on -xcpm which is a bit good, like I gat 4 steps : x(12 20 24 29) and then those turbo modes

but my laptop is still hot: 50C and nothing less!



#26
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

That's fine, mine's at 50C most of the time



#27
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth

it gets to 90 (but less than 100) and most of the time on 50~60 :( well... a good PM will get it lower than 40 (like on Linux and windows) :(



#28
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth

*THREAD UPDATED* 

19 October 2015 @ 3:58 PM :)



#29
pp611

pp611

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

Hmmm, weird, are you booting from USB3.0 ? (use 2.0)


I'm available in chat section if you need help for now

 

It was boot from an USB 2 port.

 

Actually I did not some tweaks in following the procedure. I first followed the steps in making the USB sticks as a 2 partition MBR but it won't boot. It seems that that the ASSIST key on my Sony  VPCSE does not work. I flashed the BIOS to get advanced menu. It does not have Boot Mode option, instead, it has a "UEFI Boot" option, which I enabled. But still could not make the USB stick to boot. I am not sure wether enabling UEFI BOOT means that the machine will be booted into UEFI mode. It seems not.

 

I googled and found another way to prepare the Clover USB (http://www.tonymacx8...ing-clover.html). This way I could only have the Legacy option to be bootable. I then copied all the Kexts in your Clover.zip to the /EFI/Clover/Kexts/Other, but then run into the "Still Waiting for Root Device" there

 

It seems the major problem is that I cannot boot the USB prepared following your instruction. Probably it is because Vaio VPCSE is not booted in UEFI mode. 



#30
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth
Well that's something different, dude, i got a non UEFI PC guide, not easy tho, but works, I would like to post it here, but Im not sure if it will work, but if you want I'll make in these comming days.
AND, looks like you went to tonymacx86 site and used their guides, and Im sorry to inform you that the rules here forbid the usage of any tool from there (and any guide that includes it) so please, if you think that they will help you more ask there, but we wont help you, OR ask here, and dont use their tools, and we will help you with anything you need, hope I was clear and good luck :D
And btw, if you comapre the folder arrangement I have in clover.zip, it's really different than their's, cuz I made mine and I kept onlt the important files and folders.

#31
alekim89

alekim89

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Midi Thanks for all the work, almost everything works perfect (dual OS X and Windows). The only thing I couldn't do is run the screen brightness, because does not change: /. But it's one thing I do not care much. haha.
 

 

Again , thank you.


#32
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth


Midi Thanks for all the work, almost everything works perfect (dual OS X and Windows). The only thing I couldn't do is run the screen brightness, because does not change: /. But it's one thing I do not care much. haha.


Again , thank you.


No problem :D for the brightness just apply Brighness HD4000 on DSDT and install ACPIBacklight, i don't know your specific key combinaison for that, but you can change the brightness in Preferences > Display ;)

#33
JStark

JStark

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male

MIDI!!! Awesome Job :frantics: 



#34
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth

Thanks Stark :frantics:



#35
luxinhaus

luxinhaus

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 136 posts
  • Gender:Male
@midi

Why do you have to rename bootmgfw.efi to bootmgfwA.efi

#36
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth

@midi

Why do you have to rename bootmgfw.efi to bootmgfwA.efi


Sony's UEFI firmware have locked boot order:
1) bootmgfw.efi
2) bootx64.efi
3) grubx64.efi or whatever is put third with efibootmgr (a binary in linux that controls boot orders)
So, I renamed it to bootmgfwA.efi (you can rename it whatever you want, just remember to remember what you renamed it) and added it to Clover's config, same thing applies to grubx64.efi, sometimes the firmware skips the bootx64.efi (because it's the third option now because linux install changed the order) and boots grubx64.efi, so renaming it and doing the same steps as bootmgfw.efi will force the firmware to boot clover.
But! If you Upgrade Windows to another version OR used the Repair Boot Utility, you'll need to rename the file again, and dont just remove bootmgfw.efi you'll find (cuz you'll find bootmgfwA.efi there, windows wont remove it) remove the bootmgfwA.efi then rename the other, same appies to grub2, if you update grup, this may happen also.

#37
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth

October 24th 2014: GUIDE UPDATED

UPDATE: New Place for the VAIO guide ;) http://pjalm.com/for...php?topic=391.0

Thanks PJ <_< 


Windows UEFI on Legacy http://pjalm.com/for...php?topic=392.0



#38
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 11,611 posts
  • Gender:Male

Your guide is very fun, and is very well explained.  :D

 

Congrats!  ;)



#39
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 884 posts
  • Gender:Male
  • Location:Earth

Thanks dude :D really appreciate it :)



#40
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

Did you try using EasyUEFI to add boot option ? I tried in on some laptops with isolated BIOS. It works as expected. Not sure if the same thing applies to VAIO







Also tagged with one or more of these keywords: VAIO

  Topic Stats Last Post Info

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy