Jump to content

Radeon HD 6770 FULL QE/CI ML/Mavericks/Yosemite

HD 6770 QE/CI OS X ML Mavericks Yosemite

  • Please log in to reply
59 replies to this topic

#21
Maverick

Maverick

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
  • Gender:Male
  • Location:india
  • Interests:Caffeine,Hackintosh,
    AMD hackintosh,
    Technology,

Hi !

i just saw that : http://www.osx86.net...ntain_lion.html

according to the testimonies, it works well!

I also have a HD6770 I flashed into HD5770, but I didn't have time to try it!

I will do it in a few minutes!

Tell me if it works for you!

Good luck !


EDIT: i can confirm it, with the last Chameleon-2.1svn-r2054.pkg, it work well on 10.8.2 Build 12C43 !!! :thumbsup_anim:

No more need to flashing HD 6770 into HD 5770 to have QE/CI !!!

So just add your ID (0x68BA1002) into ATI5000Controller.kext, ATI6000Controller.kext and AMDRadeonAccelerator.kext


<key>AMDJuniperGraphicsAccelerator</key>
<dict>
<key>ATIEnableWideBlitSupport</key>
<true/>
<key>ATIUseTearingWideBlit</key>
<false/>
<key>CFBundleIdentifier</key>
<string>com.apple.AMDRadeonAccelerator</string>
<key>GpuDebugPolicy</key>
<integer>0</integer>
<key>IOClass</key>
<string>AMDJuniperGraphicsAccelerator</string>
<key>IODVDBundleName</key>
<string>AMDRadeonVADriver</string>
<key>IOKitDebug</key>
<integer>0</integer>
<key>IOMatchCategory</key>
<string>IOAccelerator</string>
<key>IOPCIMatch</key>
<string>0x68BA1002 0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002</string>



Posted Image


Any thing for AMD 6770M 2GB laptop version Graphics Card ??????

#22
The-Hackintosh

The-Hackintosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
Fantosmas1,i not understand how to Add My Graphics ID IN DSDT!

#23
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,834 posts
  • Gender:Male
@Maverick

Mobile is not the same as desktop. I think the 6770M is closer to a 5670 desktop if I recall.



#24
verleihnix

verleihnix

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male

Fantosmas1,i not understand how to Add My Graphics ID IN DSDT!


look at post #20

#25
The-Hackintosh

The-Hackintosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
where is the post #20???

#26
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,002 posts
  • Gender:Male

where is the post #20???


#20

#27
The-Hackintosh

The-Hackintosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
Thanks
where i found the DSDT?

#28
verleihnix

verleihnix

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male

Thanks
where i found the DSDT?


please read the pinned posts in DSDT forum to get an idea what DSDT is, how to find it and handle it.

#29
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,834 posts
  • Gender:Male
@verleihnix

can you put your dsdt and ioreg, pls? :)



pfff, finally I did it :weight_lift:


Attached File  Capture d’écran 2013-03-22 11.42.38.png   83.33KB   73 downloads Attached File  Capture d’écran 2013-03-22 11.42.54.png   83.93KB   85 downloads

HD 6770 with HD 5770 ID :P In this example, I think changing HD 6770 to HD 5770 is only cosmetic :)

Attached File  Capture d’écran 2013-03-22 13.33.56.png   83.03KB   72 downloads Attached File  Capture d’écran 2013-03-22 13.34.08.png   85.9KB   50 downloads


I don't think so

GraphicsEnabler injects the info of your graphics card but for this one, it isn't enough

the DSDT method doesn't works, this is the only way to get this card work (as hd6770) under ML

at the same time, it's not so hard to put your ID into the Info.plist, it takes 2 minutes -_-



I was wrong. :(

big thanks to RD ;)

#30
verleihnix

verleihnix

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
Congrats,

please post your dsdt inserts. What's the difference between those two?

What is about AppleGraphicsPowerManagement, does it make sense?

cheers
verleihnix

#31
The-Hackintosh

The-Hackintosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
i added Radeon 6770 ID IN to 6000 controller,and in amdaccelerator but not working!

#32
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,834 posts
  • Gender:Male

i added Radeon 6770 ID IN to 6000 controller,and in amdaccelerator but not working!


add it to 5000 controller too

or as Rampage Dev suggested it, try to inject it in your dsdt

#33
aoalvo

aoalvo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
hey , i need help , i need 1 driver that works on clover bootloader , my computers refuses to work with chimera or chameleon after the graphics card upgrade

its a xfx 6770 1gb ..

what did I do ???

#34
The-Hackintosh

The-Hackintosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
Hi fantomas1,
i've a problem with this Graphics Card,Mountain Lion Know this Card As ati 5000 series,but this is the 6000 series.
And another problem is in the picture.
Why?can i resolve it?
Posted ImagePosted ImagePosted ImagePosted Image

#35
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,002 posts
  • Gender:Male

Hi fantomas1,
i've a problem with this Graphics Card,Mountain Lion Know this Card As ati 5000 series,but this is the 6000 series.


No, this is a 5000 series card just rebranded... Thats what this topic is all about...

#36
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
The-Hackintosh, are you running Mountain Lion on an AMD CPU? This kind of corruption is typical of ATI card (nVidia is even worse) + AMD CPU setups.

If that's the case, i'm afraid there's not much you can do, since it's a bug in the kernel, and this bug isn't squashed yet, so the options you have by now are 1) disable/remove the AMDRadeonAccelerator.kext, which will solve the glitches but you'll have absolutely no QE/CI or 2) swicth to a card that's proven to work with AMD CPUs under the current Mountain Lion kernel for AMD, such as the Sapphire HD5450 silent, the Powercolor HD6570 and most of the HD4xxx series (ask Bitcore, gils83 or mac_carol, they can instruct you better about getting 4xxx series to work). Check out this topic for more info: http://www.insanelym...t/#entry1901642

All the best!

#37
The-Hackintosh

The-Hackintosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
theconnactic,yes i running Mountain lion(Niresh's 10.8.2 build 12C54) on Amd Cpu,my Graphics card is Ati Radeon 6770 not 4xxx series.
so i can't resolve it?

#38
The-Hackintosh

The-Hackintosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
i see that my graphics card working with ati 5000 controller,but with ati 6000 don't work only with ati 5000 controller.

#39
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,834 posts
  • Gender:Male

hi The-Hackintosh

did you try to inject your card (ID) via dsdt?


i see that my graphics card working with ati 5000 controller,but with ati 6000 don't work only with ati 5000 controller.


no, if you want to see your card working with a patched kext under 10.8, see the first post

or if you want use the original kext (without patching), you need to inject your card via dsdt

Device (GFX0)
{
Name (_ADR, Zero)
Name (_SUN, One)
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x12)
{
"AAPL,slot-name",
Buffer (0x07)
{
"Slot-1"
},

"@0,name",
Buffer (0x0D)
{
"ATY,Hoolock"
},

"@1,name",
Buffer (0x0D)
{
"ATY,Hoolock"
},

"@2,name",
Buffer (0x0D)
{
"ATY,Hoolock"
},

"@3,name",
Buffer (0x0D)
{
"ATY,Hoolock"
},

"@4,name",
Buffer (0x0D)
{
"ATY,Hoolock"
},

"device-id",
Buffer (0x04)
{
0xB8, 0x68, 0x00, 0x00
},

"model",
Buffer (0x13)
{
"AMD Radeon HD 6770"
},

"hda-gfx",
Buffer (0x0A)
{
"onboard-1"
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}

Device (HDAU)
{
Name (_ADR, One)
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x04)
{
"name",
Buffer (0x0B)
{
"HDMI Audio"
},

"hda-gfx",
Buffer (0x0A)
{
"onboard-1"
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}
}


#40
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male

theconnactic,yes i running Mountain lion(Niresh's 10.8.2 build 12C54) on Amd Cpu,my Graphics card is Ati Radeon 6770 not 4xxx series.
so i can't resolve it?


You can try, but you're own your own: there's no known solution yet, since it's a bug in the and_kernel patch set.





Also tagged with one or more of these keywords: HD 6770, QE/CI, OS X, ML, Mavericks, Yosemite

  Topic Stats Last Post Info

2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy