Jump to content

Radeon HD 6770 FULL QE/CI ML/Mavericks/Yosemite/ElCapitan/Sierra


116 posts in this topic

Recommended Posts

It seems that I need the last patch, I followed the tutorial very carefully, but still, my card doesn't get recognized as 6770.Dunno if it's my cards fault, it's an MSI 6770 1024 MB.

  • 2 months later...
  • 3 weeks later...

Hey Guys

 

Total noob in MAC OS here, just did my very first install of an OSX on a PC. But I am quite computer literate in general :)

 

My system is: i5 3570k, AsRock Z77 Pro3, 16GB Ram, Asus AMD 6770 1GB

I was able to get LAN, Sound, etc working (some out of the box, many through trial and error) except the *** 6770.

 

I'm quite sure I'm doing something wrong, but not sure what. The OS boots and works ok if I set from BIOS to use the integrated video (although I do have to force the resolution manually from the config), but it's sloppy and I was planning on using this for photo work. Is there a package/app that installs the 6770 kexts automatically or is there a step-by-step guide somewhere because I get lost in all this info.

 

Thanks so much for your help.

Hi Fantomas. Well, in the end I did get it to work partly - it boots and recognizes the card correctly (displayed as 6770), loads the kext but VRAM is 7Mb and everything is so slow... Tried to force Vram from clover config but didn't work. I'm stuck... :(

 

Later edit: It was not working because I had not rebuilt permissions and cache. After that worked perfectly. Also, after 10.9.3 update it crashed again but the solution was simple - delete all Intel HD kexts.

Howdy,

 

kind of an interesting and similar result here. Clean install, everything else works but the graphics. I fail to boot with GraphicsEnabler on, no matter if I use Vervet or Hoolock. With the enabler being off, I get an 5MB "Display" and fancy visual glitches all around. Patched kext method and using Chameleon r2278 with a Gigabyte GV-677UD-1GD on 10.9.3.

 

E: Nevermind, Kext Utility fixed it. Surprising how Kext Wizard and Disk Utility is supposed to help with it and doesn't really fix that...

  • 4 weeks later...
  • 4 months later...
  • 4 weeks later...
  • 1 month later...

I updated to 10.10.2 last night, which somehow broke the QE/CI.

My 6770 was working fine with the kexts in the first post. Is anybody on here experiencing the same issues?

"About this Mac" is just showing 5MB Monitor for graphics.

I´m using clover, if thats important for my situation.

 

Hope somebody has a fix! :-(

Oh, thats embarrassing did not know about that!

 

Tried your config.plist, now its showing up as Radeon 6770 Series but still with 5MB Memory.

Still really slow and full of artifacts.

 

I was booting with kext-dev-mode=1

ok

 

open Terminal and tape this

 

cd /System/Library/Extensions

 

sudo chown -R 0:0 AMD5000Controller.kext AMDRadeonX3000.kext

 

sudo chmod -R 755 AMD5000Controller.kext AMDRadeonX3000.kext

 

sudo kextload -v AMD5000Controller.kext AMDRadeonX3000.kext

 

sudo touch /System/Library/Extensions

 

or

 

sudo kextcache -prelinked-kernel

 

reboot

AMD5000Controller.kext - no compatible dependency found for com.apple.kext.AMDSupport.

 

 

it means that AMD5000Controller.kext version is not the same as AMDSupport version

 

could you check it, please? open the version.plist file from both kexts and compare

 

 

EDIT

 

Your first solution didn't do anything after the reboot.

 

 

 

did you successfully loaded those both kexts... before reboot?

Hi fantomas1,

I had this card working on ML 10.8.2, but after updating to 1.8.5 and with kext modifications it didn't work anymore (a grey screen appears just after startup). Well, in fact, I have 2 cards running (quad monitor), and both worked well in 1.8.2.

Can you explain me how to inject that code in DSDT?

Thank you!

  • 1 month later...

Dear all,

 

I am trying to make my video card (AMD Radeon 6770 0x68ba1002) works on Maverics 10.9.5.

 

It was working on 10.9, but not after the update (just to have XCode with Swift, that I am learning)

 

I have tried the two kexts (AMD5000Controller and RadeonX3000) but the computer won`t boot. Shows a lot of: "change trust on" " process name YYYYY (pid XXX)" and never finishes. (both GE=Yes and No).
 

After rm -rf the kexts and clean caches with single mode, I am able to boot with GE=No at Chamaleon. But the video card has poor performance.

It shows "ATI Radeon HD 5700 Series 7 MB" with one monitor on, or "ATI Radeon HD 5700 Series 3 MB" with two monitors on.
 

I was not able to figure out how to inject the DSDT of the post #20. (I looked for it, but was not able to find an easy how to)

 

Can anybody help me?

 

Tnks!

 

 

AMD FX 6100 3.3GHz Core 6.

ASUSTek M5A88-M

AMD Radeon 6770 0x68ba1002

  • 4 months later...
×
×
  • Create New...