Jump to content

[Guide] Installing Mountain Lion.


  • Please log in to reply
116 replies to this topic

#61
yonyz

yonyz

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts

Installation quite tricky on my Rampage III Formula.
I have never struggled so mush to install and run SL and Lion on Rampage III Extreme and Formula :/


Installation done, but after the restart a lot of trial and errors during the verbose boot. It gives me headaches :wallbash:

Plus problems, with C2RC5 rev 2013, rollback to rev 2005 to recognize my HDD/SSD. Some kexts switched with SL ones, etc,.

ouch :moil:



EDIT : almost done to reach the desktop... stuck at "IOBluetoothHCI controller ..... start completed"

No KP, no error, just stucked :/

Look at the last few lines above the line you mentioned. In my cases, the error doesn't necessarily appear as the last line of info.

#62
The Real Deal

The Real Deal

    InsanelyMac Legend

  • Donators
  • 858 posts
  • Gender:Not Telling
I can reach the desktop if i boot in safe mode. But in the console, i don't see anymore the kernel log tab to check the verbose mode more carefully.

The few lines above mainly about power management, SMC, some loaded kexts (ethernet/wifi). I think it's more about the few lines that should come after. In safe mode it boots 4 or 5 lines right after "IOBluetoothHCI controller ..... start completed"

:hammer:

#63
fallen101

fallen101

    InsanelyMac Geek

  • News Team
  • 101 posts
  • Gender:Male
  • Location:Florida
I added the files as I finally found em again.... sorry about that :(

#64
monto

monto

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male

How many have you installed? Move one by one to the desktop and restart, see which one solves the problem when moved out of the Extensions folder. Also, what tool did you use to install the kexts?


Thanks for the reply. What did you mean by move one by one to the desktop and restart? Did you mean move 10.8GM built-in kext one at a time from /S/L/E to desktop and boot without -x again?
I used kext wizard to install the kexts.

Following Tech Erra's guide I only have AtherosL1cEthernet in /E/E and VoodooHDA, FakeSMC & NullCPUPowerManagement in /S/L/E. Tried rebuilding the cache from kext wizard too.

If I don't boot into safe mode (-x), it stalls after loading network and BT kexts. Interestingly from the system.log attached below, there were more activities not shown at -v boot screen that may be the cause of the hang.


Jul 16 10:54:21 Supers-Mac-Pro.local com.apple.SecurityServer[18]: Succeeded authorizing right 'system.preferences.nvram' by client '/System/Library/PrivateFrameworks/Admin.framework/Versions/A/Resources/writeconfig' [99] for authorization created by '/usr/libexec/locationd' [43] (100002,0)
Jul 16 10:54:21 --- last message repeated 1 time ---
Jul 16 10:54:21 Supers-Mac-Pro.local locationd[43]: Incorrect NSStringEncoding value 0x8000100 detected. Assuming NSASCIIStringEncoding. Will stop this compatiblity mapping behavior in the near future.
Jul 16 10:54:21 Supers-Mac-Pro.local locationd[43]: NOTICE,Location icon should now be in state 0
Jul 16 10:54:21 Supers-Mac-Pro.local configd[16]: network changed: v4(en0+:192.168.1.142) DNS+ Proxy+ SMB
Jul 16 10:54:22 Supers-Mac-Pro.local awacsd[56]: Starting awacsd connectivity-77 (Jun 20 2012 15:40:49)
Jul 16 10:54:22 Supers-Mac-Pro.local awacsd[56]: InnerStore CopyAllZones: no info in Dynamic Store
Jul 16 10:54:24 Supers-Mac-Pro kernel[0]: Previous Shutdown Cause: 3
Jul 16 10:54:25 Supers-Mac-Pro.local stackshot[30]: Timed out waiting for IOKit to finish matching.
Jul 16 10:54:29 Supers-Mac-Pro.local apsd[58]: CGSLookupServerRootPort: Failed to look up the port for "com.apple.windowserver.active" (1102)
Jul 16 10:54:29 Supers-Mac-Pro kernel[0]: ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: VoodooHDADevice[0xffffff80d17ac000]::init
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Enabling input audio routing switching at node 26:
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Enabling input audio routing switching at node 27:
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Enabling output audio routing switching at node 28:
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Enabling output audio routing switching at node 29:
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Enabling input audio routing switching at node 30:
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Pin sense: cad 2 nid=26 res=0
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 0 on
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 1 off
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 2 on
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 3 on
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: setDesc change description CD (Analog) channel 1 assoc 1
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Pin sense: cad 2 nid=27 res=0
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 0 on
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 1 on
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 2 off
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 3 on
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: setDesc change description CD (Analog) channel 1 assoc 1
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Pin sense: cad 2 nid=28 res=1
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: setDesc change description Line-out (Green Rear) channel 0 assoc 0
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Pin sense: cad 2 nid=29 res=0
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Pin sense: cad 2 nid=30 res=0
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 0 on
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 1 on
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 2 on
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: switch nid 23 conn 3 off
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: setDesc change description CD (Analog) channel 1 assoc 1
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: [BroadcomBluetoothHCIControllerUSBTransport][start] -- completed
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: Sound assertion in AppleHDAController at line 397
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: DSMOS has arrived
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: [IOBluetoothHCIController][staticBluetoothHCIControllerTransportShowsUp] -- Received Bluetooth Controller register service notification
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: [IOBluetoothHCIController][start] -- completed
Jul 16 10:54:30 Supers-Mac-Pro kernel[0]: [IOBluetoothHCIController::setConfigState] calling registerService
---------------- (edit: the boot screen only showed until the line above) --------------
Jul 16 10:54:31 Supers-Mac-Pro.local loginwindow[42]: Login Window Application Started
Jul 16 10:54:31 Supers-Mac-Pro.local mds[38]: (Normal) FMW: FMW 0 0
Jul 16 10:54:32 Supers-Mac-Pro.local com.apple.SecurityServer[18]: Succeeded authorizing right 'com.apple.ServiceManagement.daemons.modify' by client '/usr/libexec/UserEventAgent' [11] for authorization created by '/usr/libexec/UserEventAgent' [11] (100012,0)
Jul 16 10:54:34 Supers-Mac-Pro.local ntpd[107]: proto: precision = 1.000 usec
Jul 16 10:54:35 Supers-Mac-Pro.local digest-service[112]: label: default
Jul 16 10:54:35 Supers-Mac-Pro.local digest-service[112]: dbname: od:/Local/Default

#65
121fred

121fred

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

Installed OK with Techerra guide, just be sure to follow every step EXACTLY if you don't know what you are doing and make sure you start with a really basic install and tweek it once you have it working otherwise you'll be chasing your tail trying to work out what mod has caused your problems



#66
The Real Deal

The Real Deal

    InsanelyMac Legend

  • Donators
  • 858 posts
  • Gender:Not Telling

If I don't boot into safe mode (-x), it stalls after loading network and BT kexts. Interestingly from the system.log attached below, there were more activities not shown at -v boot screen that may be the cause of the hang.


Just like me. :welcomeani:

#67
monto

monto

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
After more and more digging, this boot stall problem seems to be commonly occurring amongst G31 and G41 users. However, some with these boards are able to get ML working. It's still a myth to me.

#68
The Real Deal

The Real Deal

    InsanelyMac Legend

  • Donators
  • 858 posts
  • Gender:Not Telling
It's the first thing i have checked. Your board manufacturer. But i have an Asus. I guess it's not board related so.

On a side note, there is routinely during the boot, two brief spaced sound (pop) when i'm about to reach the desktop on Snow Leopard.


The same thing happens during the boot on Mountain Lion ; to me it's the signal the desktop is coming within the next seconds. But it's just stuck with no more HDD LED activity.


If i boot without -v flag, the GUI appears (Apple logo) and few seconds later, not a KP, but "you must restart your computer"


My graphic card is a 8400GS (512 Mo) like you.

Edited by The Real Deal, 16 July 2012 - 08:12 AM.


#69
monto

monto

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
I didn't even get to the spinning wheel stage. The boot process stalled before GUI loaded up. I have suspected 8400GS to be the culprit as well but again someone was able to run it successfully according to OSX86 Compatibility List for ML. 8400GS 256MB DDR2 (there is a DDR3 version) runs flawlessly in Lion even supporting 2 monitors at 1920x1080 + 1280x1024, and there is no reason to believe it's suddenly not working in ML.
I've tried 3 version of NVEnabler(64), and tried the following boot loaders all with the same result: Chameleon r1820 trunk, Chamelion Enoch r2011, Chimera 1.10.0. With Clover v2 r538, the screen actually went blank at the end of the booting process, but it rebooted after the blank screen. The last few lines from system.log is as following:


Jul 16 14:32:42 Supers-Mac-Pro kernel[0]: Previous Shutdown Cause: 3
Jul 16 14:32:43 Supers-Mac-Pro.local stackshot[30]: Timed out waiting for IOKit to finish matching.
Jul 16 14:32:47 Supers-Mac-Pro.local apsd[58]: CGSLookupServerRootPort: Failed to look up the port for "com.apple.windowserver.active" (1102)
Jul 16 14:32:47 Supers-Mac-Pro kernel[0]: ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
Jul 16 14:32:48 Supers-Mac-Pro kernel[0]: [AGPM Controller] unknownPlatform
Jul 16 14:32:48 Supers-Mac-Pro kernel[0]: Sound assertion in AppleHDANode at line 132
Jul 16 14:32:48 --- last message repeated 7 times ---
Jul 16 14:32:48 Supers-Mac-Pro kernel[0]: Sound assertion in AppleHDADriver at line 1570
Jul 16 14:32:48 Supers-Mac-Pro kernel[0]: Sound assertion in AppleHDADriver at line 2200
Jul 16 14:32:48 Supers-Mac-Pro kernel[0]: Sound assertion in AppleHDADriver at line 217
Jul 16 14:32:48 Supers-Mac-Pro kernel[0]: Sound assertion in AppleHDADriver at line 1055
Jul 16 14:32:48 Supers-Mac-Pro.local configd[16]: Could not establish network configuration: Success!
Jul 16 14:32:48 Supers-Mac-Pro.local loginwindow[42]: Login Window Application Started
Jul 16 14:32:49 Supers-Mac-Pro kernel[0]: DSMOS has arrived
Jul 16 14:32:49 Supers-Mac-Pro kernel[0]: [IOBluetoothHCIController][start] -- completed
Jul 16 14:32:50 Supers-Mac-Pro.local com.apple.SecurityServer[18]: Succeeded authorizing right 'com.apple.ServiceManagement.daemons.modify' by client '/usr/libexec/UserEventAgent' [11] for authorization created by '/usr/libexec/UserEventAgent' [11] (100012,0)
Jul 16 14:32:51 Supers-Mac-Pro.local digest-service[108]: label: default
Jul 16 14:32:51 Supers-Mac-Pro.local digest-service[108]: dbname: od:/Local/Default
Jul 16 14:32:51 Supers-Mac-Pro.local digest-service[108]: mkey_file: /var/db/krb5kdc/m-key
Jul 16 14:32:51 Supers-Mac-Pro.local digest-service[108]: acl_file: /var/db/krb5kdc/kadmind.acl
Jul 16 14:32:51 Supers-Mac-Pro.local digest-service[108]: digest-request: uid=0
Jul 16 14:32:51 Supers-Mac-Pro.local rpcsvchost[118]: sandbox_init: com.apple.msrpc.netlogon.sb succeeded
Jul 16 14:32:51 Supers-Mac-Pro.local digest-service[108]: digest-request: init request
Jul 16 14:32:51 Supers-Mac-Pro.local digest-service[108]: digest-request: init return domain: BUILTIN server: SUPERS-MAC-PRO

#70
The Real Deal

The Real Deal

    InsanelyMac Legend

  • Donators
  • 858 posts
  • Gender:Not Telling

Jul 16 14:32:47 Supers-Mac-Pro kernel[0]: ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out




Maybe a lead ?




PS : my 8400GS used to work in SL 10.6.X and Lion 10.7.1 (i gave up this OS after)

#71
121fred

121fred

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Have you tried boot with -v -f -x ?

#72
apav

apav

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I have a Zotac 8400 gs working with just graphics enabler=yes. I'm not
using nvenabler.

10.8 ML GM

Dual Xeon 5150's (4 cores total)
Tyan Tempest i5000XT (s2696)
ALC888
Zotac 8400 gs
Dlink DWL-520

#73
Sharon

Sharon

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:India
Same here Ggigabyte G31, geforce 8800GT 512MB stucks. Can only boot to safe mode. Any solutions ? NVEnabler cannot probe. Removed EVEnabler used GraphicsEnabler=YES,still same issue. Any solutions till now ???

#74
monto

monto

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
From what everyone here who encountered the same symptoms, it seemed the problem was not the video card. So far everyone having the issue is using Gigabyte G31 or G41 boards. Would it be possible one of the common Gigabyte BIOS setting is causing this? I am going to try toggling settings off and try again.

To 121fred, booting with -x worked but safe mode is not a long term solution. Also tried -f without any difference.

#75
The Real Deal

The Real Deal

    InsanelyMac Legend

  • Donators
  • 858 posts
  • Gender:Not Telling
Asus X58 in the same boat, i'd like to see a full verbose on a working Asus X58 setup to compare with mine.

It's not BIOS, Geforce 8xxx related or plugged accessories to me. Further investigation this WE.

#76
castrobaldin

castrobaldin

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
For people having problems with -Only boots in safe mode-

Try booting with UseKernelCache=No

If it succeed add this line to the Kernel Flags on the org.chameleon.boot.plist / org.apple.boot.plist

#77
douglasrp

douglasrp

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
Essential System Software, cannot be installed.

My HD is on dual boot, hybrid MBR/GPT, and I used the

OSinstall files.




Any Ideias?



#78
Hackintosh2000

Hackintosh2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Unites States of America

I use a DSDT that I found on OSX86.net. It's meant for a mobo that's similar to mine. Can I create one that fits my board perfectly? And what's a patched DSDT?


DSDTs can be quite board and setup specific. If you are going to extract your own DSDT do not boot up with another. Boot up without a DSDT if you want to extract your own native DSDT. A patched DSDT is simply one that has some lines of code added to add functionality so you don't have to use certain kexts. It makes for a more "vanilla" install. For example my patched DSDT enables me to forgo using the nullcpumpowermanagement Kext. There are patches for sound and other things. I am no expert on DSDTs. Someone patched mine for me many moons ago.

#79
yonyz

yonyz

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
I did extract a DSDT and the patch resulted with 2 optimizations and 28 errors. I don't even know if I'm currently using a DSDT. Will check when I'm home. Thanks.

#80
Sharon

Sharon

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male
  • Location:India

For people having problems with -Only boots in safe mode-

Try booting with UseKernelCache=No

If it succeed add this line to the Kernel Flags on the org.chameleon.boot.plist / org.apple.boot.plist


Will try this once I reach home and post the result.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy