Jump to content

Chameleon Wizard - Utility for Chameleon.

wizard speedsteep org.chameleon.Boot Chameleon SMBios Installer

  • Please log in to reply
683 replies to this topic

#521
sturzo

sturzo

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
For whatever reason, I cannot boot my octo-core hack pro using any Lion-compatible bootloader options, including this one - every time i try it gives me just a split second of the apple logo and immediately reboots. Any suggestions? i've tried everything, even replacing the motherboard.

specs:
Mobo: Asus Z8NA - D6
CPUs: 2 x Intel Xeon 5530
RAM: 24 Gb Hynix DDR3 1333
Sys Disk: Corsair Force GT 120gb SSD
Several other internal and iSCSI disks

If anyone has any suggestions i would be forever in your debt!

BTW: I use the chameleon wizard on my other HackPro - its an amazing tool

Thank you in advance

#522
jaxparo

jaxparo

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
I need a 10.5 version of Chameleon Wizard.

#523
janek202

janek202

    InsanelyMac Sage

  • Developers
  • 313 posts
  • Gender:Male
  • Location:Poland

I need a 10.5 version of Chameleon Wizard.

There won't be one. It would require much work.

#524
Majonéz

Majonéz

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Budapest
Hi janek,

I translated the Wizard to hungarian. :)
My files are here:

Attached Files



#525
SuperstarGoddess

SuperstarGoddess

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Female
Seems like builtbot has been broken for a long time on this, what's going on?

#526
janek202

janek202

    InsanelyMac Sage

  • Developers
  • 313 posts
  • Gender:Male
  • Location:Poland
I don't know. Buildbot was here: http://builds.voodooprojects.org
That's not my website, and I can't do anything about it.

#527
Greggen

Greggen

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
Been having some trouble with Speedstep and I just found out (thanks to Revogirl) that the model-id was incorrect. I was using a SMBios from Chameleon Wizard and the values from there was:

MacMini5,1
Mac Mini

Changed it to:

Macmini5,1
Mac mini

And got a bunch of new p-states.

#528
MacKonsti

MacKonsti

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
  • Gender:Male
  • Location:Muppet Show
Thanks, Greggen for your find. I honestly thought that with capitalized or not, it wouldn't make a difference. You actually got P/C states without changing anything else? Amazing...

Janek, can you please substitute these values for the Mac mini, in your SMBIOSes? "Mac Mini" to "Mac mini" and "MacMiniX,X" to "MacminiX,X". I must also find the "Mac Pro" ID if needs be the same... That includes "MacBook Pro" as "MacBook pro"? Anyone to confirm?


UPDATE: Just called a friend who owns a real Mac mini from 2007. He confirmed that the ID and model are as such (from System Profiler):

Model Name: Mac mini
Model Identifier: Macmini2,1



#529
Greggen

Greggen

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
By googling "macbook pro system info" and looking at images it seems like the correct value is:

MacBookProX,X
MacBook Pro

And for Mac Pro:
MacProX,X
Mac Pro

Can't confirm though but I guess it should be correct.

#530
MacKonsti

MacKonsti

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
  • Gender:Male
  • Location:Muppet Show
Thanks, Greggen, I have dug into the system files and in file /System/Library/CoreServices/Resources/SPMachineTypes.plist I see the following official descriptors:

<key>Macmini2,1</key>
<string>Macmini</string>

<key>MacBookAir1,1</key>
<string>MacBookAir</string>

<key>MacBookPro5,2</key>
<string>MacBookPro</string>

<key>MacPro4,1</key>
<string>MacPro</string>

I am afraid there's no space in the model e.g. Macmini or MacPro.

I am confused... remember that SMBIOS.plist doesn't necessarily need to be the value seen in System Profiler...!

#531
Greggen

Greggen

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

Thanks, Greggen, I have dug into the system files and in file /System/Library/CoreServices/Resources/SPMachineTypes.plist I see the following official descriptors:


<key>Macmini2,1</key>
<string>Macmini</string>

<key>MacBookAir1,1</key>
<string>MacBookAir</string>

<key>MacBookPro5,2</key>
<string>MacBookPro</string>

<key>MacPro4,1</key>
<string>MacPro</string>

I am afraid there's no space in the model e.g. Macmini or MacPro.

I am confused... remember that SMBIOS.plist doesn't necessarily need to be the value seen in System Profiler...!


True, but I guess the ID is the thing thats important. And I can guarantee that changing that M to lowercase made a difference.

#532
MacKonsti

MacKonsti

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
  • Gender:Male
  • Location:Muppet Show
Confirmed from another file at /System/Library/PreferencePanes/EnergySaver.prefPane/Contents/Resources/WOLShutOffList.plist

<dict>
<key>MachineList</key>
<array>
  <string>MacBook1,1</string>
  <string>MacBook2,1</string>
  <string>MacBook3,1</string>
  <string>MacBook4,1</string>
  <string>MacBook5,1</string>
  <string>MacBook5,2</string>
  <string>MacBookPro1,1</string>
  <string>MacBookPro1,2</string>
  <string>MacBookPro2,1</string>
  <string>MacBookPro2,2</string>
  <string>MacBookPro3,1</string>
  <string>MacBookPro4,1</string>
  <string>MacBookPro5,1</string>
  <string>MacBookPro5,2</string>
  <string>Macmini1,1</string>
  <string>Macmini2,1</string>
  <string>Macmini3,1</string>
  <string>iMac4,1</string>
  <string>iMac4,2</string>
  <string>iMac5,1</string>
  <string>iMac5,2</string>
  <string>iMac6,1</string>
  <string>iMac7,1</string>
  <string>iMac8,1</string>
  <string>iMac9,1</string>
  <string>MacPro1,1</string>
  <string>MacPro2,1</string>
  <string>MacPro3,1</string>
  <string>MacPro4,1</string>
</array>
</dict>

I guess the space could exist in the model itself, but as Greggen points out, the spelling for ID MacminiX,X is needed. Others are OK.

#533
MacKonsti

MacKonsti

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
  • Gender:Male
  • Location:Muppet Show
Guys I just noticed that RestartFix=Yes doesn't seem to be written in org.chameleon.Boot.plist with Wizard 4.1.0. Is this now embedded into chameleon bootloader and only RestartFix=No is needed?
Janek can you please confirm? Anyone else?

#534
DoiX

DoiX

    Homo discens

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,132 posts
  • Gender:Male
  • Location:Terra
  • Interests:Photography, design, beer.

Guys I just noticed that RestartFix=Yes doesn't seem to be written in org.chameleon.Boot.plist with Wizard 4.1.0. Is this now embedded into chameleon bootloader and only RestartFix=No is needed?
Janek can you please confirm? Anyone else?


I read in the chameleon source code some weaks ago that it's enabled by default.

#535
Roman78

Roman78

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
I just installed it but unfortunally it won't boot right. I get the the bootloader, than the white apple and than a blue screen. And than nothing happends. I can only boot whit the -x option. What did i do wrong? I tried serval options but nothing helped.

I'm running 10.6.3 from iAtkos on an Asus P5LD2/1333 mainboard.

#536
oswaldini

oswaldini

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
  • Gender:Male
  • Location:Cracow, Poland
New smbioses added:

MacBookPro10,1
MacBookPro9,1
MacBookPro9,2
MacBookAir5,2

Near future: iMac13,2 and MacBookAir5,1 (we have everything except smserial)

Feel free to make new HackPC based on 3rd gen of Intel "i" CPU.

#537
oSxFr33k

oSxFr33k

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 850 posts
  • Gender:Male
  • Interests:Sound and Graphic Design. Electronics in general.
How can we use Chameleon wizard if Buildbot is down? Maybe once the build is downloaded to your PC, you can use it again I suppose but to get it there in the first place is the real problem!!

#538
DarwinX

DarwinX

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 640 posts
  • Gender:Male
  • Location:Florida

How can we use Chameleon wizard if Buildbot is down? Maybe once the build is downloaded to your PC, you can use it again I suppose but to get it there in the first place is the real problem!!


You could simply download it from the official Chameleon 2.1svn Official PKG Installer & Binarie thread, then install it via the Chameleon Wizard.app Folder on disk or Dropbox functionality.


Latest Trunk [PKG r2030] ==> Posted Image Chameleon-2.1svn-r2030.pkg.zip

Latest Trunk [Binaries r2030] ==> Posted Image i386.zip



#539
Riley Freeman

Riley Freeman

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 936 posts
  • Gender:Male
  • Location:The Streets

How can we use Chameleon wizard if Buildbot is down? Maybe once the build is downloaded to your PC, you can use it again I suppose but to get it there in the first place is the real problem!!


I just build my own Chameleon from the svn. Save the following to a file called makechameleon.command (or whatever you like), make it executable (chmod +x) and double click it to run. It'll download the latest revision and build it. Then load the /trunk/sym/i386 folder into Chameleon Wizard to update.

#!/bin/bash -e
cd "$(dirname "$0")"
clear
svn co -r HEAD http://forge.voodooprojects.org/svn/chameleon/trunk
cd trunk
make clean
make


#540
Devilindisguise

Devilindisguise

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi,

Im looking to install Chameleon on my Hackintosh install but i dont get anything showing up in the target partition section.

its the same when i try and use kext wizard as well. nothing shows up on the target disk drop down.

pls help.





Also tagged with one or more of these keywords: wizard, speedsteep, org.chameleon.Boot, Chameleon, SMBios, Installer


6 user(s) are reading this topic

1 members, 5 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy