Jump to content

Mobility Radeon HD 5650 QE/CI WORK! (26/2 Update!)


  • Please log in to reply
112 replies to this topic

#1
eric028

eric028

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
26/2:
http://www.insanelym...p...t&p=1645442

Recently a post was published at a chinese Hackintosh forum, here I just translate the topic for you ;)
The original post available here if you can read chinese -_-
http://bbs.pcbeta.co...836915-1-1.html

OK! Here is the things

1.This bootloader
http://www.insanelym...howtopic=231768
2.Framebuffer "Nomascus"
3.GraphicsEnabler
4.ATI5000Controller.kext

However, they did not mention whether we need to modify X3000.kext but it seems to be no, you can have a try baby :P

He can get resolution of 1366x768, Dashboard effect, Transparent Menubar, QE/CI after do things above. Here are the evidences
Attached File  _____________2011_02_21_______05.47.34.png   242.68KB   1533 downloads
Attached File  _____________2011_02_21_______05.47.49.png   231.38KB   1445 downloads

Hope you guys success =]

#2
darwich

darwich

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
OH WAUW!

If this is true, that would be AWESOME ..


Anyone tried this?
Any response.. been looking for a way to get my HD5650 to work for a month now! -.-


I will be testing this sometime next week when i get home ..

#3
sh0td0wn

sh0td0wn

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
Awesome! I want to try this! I've been holding out installing OSX again until there's a way to get 5650m working!
Looks like the Chinese board is right! :censored2:

#4
darwich

darwich

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Awesome! I want to try this! I've been holding out installing OSX again until there's a way to get 5650m working!
Looks like the Chinese board is right! :censored2:


Can you report back? :(

#5
sh0td0wn

sh0td0wn

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
I'm gonna try it tomorrow after my midterm. Let's see how much of a headache this is going to be trying to get this to work.

#6
darwich

darwich

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
The chinese people have been posting positive feedback ..

Looks like it works..

http://translate.goo...836915-1-1.html


Sorry for spamming this thread so much :D .. im just so excited about it!! ;) ..
Cant wait to try it out! >.<

#7
Mushishi

Mushishi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 408 posts
  • Gender:Male
  • Location:Sveg, Sweden
Well without sounding like a partykiller...

I feer just like sucess we had on a toshiba model that it is this acer model only that it works on.

Not all laptop makers use the lvds some might use dvi or displayport to connect the screen. and as the problem is with lvds then it could be the case with the acer here that they are connected to the chip on a diffrent way.

So untill we test on other laptops other then that Acer model and it still works then i will not call it a full sollution...

Also in a way if it work on the 5650 with that framebuffer it should also be working on the rest of the 5xx0 series mobility cards with that framebuffer if that do indeed support lvds...

I will do a test after work on my HP G62 but i do not expect it to be working...

#8
lince5

lince5

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
When you type in the step number 4 "ATI5000CONTROLLER.KEXT", do you mean that i must download the kext from the chinese page? Or it is just the unmodified original kext from apple? And in step 3 you mean that we must write in com.apple.boot.plist "GraphicsEnabler=yes", right?

#9
ThE_MarD

ThE_MarD

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
Heyyo,

Hmm no luck here.. still just hangs on "Ati card POSTed, reading VBIOS from Legacy Space" and then goes black.. still a damn problem with that VBIOS.. can't extract it and can't seem to have a chameleon bootloader load it...

Gateway NV5909H
ATi Radeon Mobility 5650

#10
theakseffect

theakseffect

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Location:Netherlands
I think this translation:


Through observation, I think the card BIOS on the motherboard may be a chameleon. Three cases of success is the Acer Acer 4745g and 4820t, after investigation, are insyde bios, same Acer 5740 (hulinyun the students) are not, it's BIOS is Phoenix, the Lenovo y460 (my present), y560 does not work, their BIOS is Phoenix, another hellozhangxin students dell inspiron 5010 is the same problem, it's bios is the "Dell Inc A10" (Master Lu measured, not routine). So the BIOS may be the key, of course, could be purely coincidental.
If you do with the BIOS on the motherboard, there might be hope?



suggests this method may only work on the laptops: Acer 4745g, 4820t and 5740 (the 'three cases of success') or similar.

Source: http://bbs.pcbeta.co...8...ra=&page=15.

#11
nospheratus

nospheratus

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I could try on my hp dv6-3330el which have 5650 and the insyde bios, but... i can't understood how to use the bootloader! Someone could help me so i can make some test??

#12
ThE_MarD

ThE_MarD

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
Heyyo,

For the bootloader? Here I'll post my info.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>AtiConfig</key>
	<string>Nomascus</string>
	<key>Default Partition</key>
	<string>hd(0,2)</string>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>GenerateCStates</key>
	<string>Yes</string>
	<key>GeneratePStates</key>
	<string>Yes</string>
	<key>Graphics Mode</key>
	<string>1366x768x32</string>
	<key>GraphicsEnabler</key>
	<string>Yes</string>
	<key>Kernel Flags</key>
	<string>arch=i386 -v</string>
	<key>Legacy Logo</key>
	<string>Yes</string>
	<key>Theme</key>
	<string>Default</string>
	<key>Timeout</key>
	<string>6</string>
	<key>USBBusFix</key>
	<string>Yes</string>
</dict>
</plist>


#13
eric028

eric028

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
Here is newest translation from http://bbs.pcbeta.co...839862-1-1.html ;) :P

I delete some of the steps that were not important.

首先來介紹一下案例的硬件:
Here is the introduction of the succeeded notebook.

Acer 4745g:i5 430m(with intel hd graphics)+HM55+ ATI Mobility Radeon HD 5650 1GRAM VGA+HDMI輸出

如果你持有類似配置的筆記本,請看一下是否符合以下條件:

2.請下載並安裝原版10.6.4(最好不要用整合版系統或者從10.6.3升級)
Install 10.6.4 (Prefer clean install)

4.相信大部分使用5650m的筆記本都會搭配intel的CPU集成顯卡,請確定你的CPU顯卡可以被關閉。
If your notebook's hardware included intel CPUs intel hd graphics, please disable it in the BIOS.

5.請進BIOS,設置Graphic mode = Discrete ,如果沒有這個選項,請參看說明書
Set "Graphic mode = Discrete" in BIOS
Attached File  11022523031dd740cd3f4c143c.jpg   278.02KB   552 downloads

6.如果你的CPU顯卡無法關閉,將很可能無法驅動5650m
If you cannot disable your intel HD, your mobility may not be mounted successfully.

9.變色龍的版本很多,不要追求最新版本,如果你想驅動5650m,請使用我貼中的r700 boot
Use Chameleon r650 and r700 boot
Attached File  Chameleon_v2.0_RC5_r650.pkg.zip   1.08MB   459 downloads
Attached File  boot.zip   192.55KB   462 downloads
Files downloaded from the post.

14.請在WINDOWS下的設備管理器中確認5650m的顯卡硬件ID為1002_68c1
Check if your mobility device id is 1002:68c1
Attached File  110225230270e013d0cbf54484.jpg   35.87KB   815 downloads

15.請確認你的筆記本同樣具有VGA+HDMI 2個外置接口
Check if your notebook has VGA & HDMI output.

16.添加AtiConfig=Nomascus到com.apple.Boot.plist,如果你試了這個值不行,請嘗試其他全部30個ATICONFIG值
Add AtiConfig=Nomascus in com.apple.Boot.plist

17.驅動5650m不需要DSDT顯卡代碼,也無需設置smbios.plist
No DSDT and smbios.plist are needed.

18.安裝10.6.4系統前,請移動安裝盤System\Library\Extensions下的ATI5000Controller.kext到其他位置備用,替換好BOOT後再用B7安裝回去
Before installing 10.6.4, move ATI5000Controller.kext out from System\Library\Extensions.

19.另外建議刪除上述目錄裡AppleIntelGMA*****.kext,AppleIntelHDGraphics*****.kext 以及AppleIntelIntegratedFramebuffer.kext大約15個文件
Delete AppleIntelGMA*****.kext,AppleIntelHDGraphics*****.kext & AppleIntelIntegratedFramebuffer.kext if necessary.


*PCIRootUID=1may be needed if Chameleon hang

Attached File  11022523039c30f0c9500ba850.jpg   277.07KB   414 downloads
Attached File  1102252303097416636a8cfb22.jpg   246.22KB   277 downloads
---------------------------------------
Method for replacing bootloader:
1.Run Terminal
2.Type
sudo cp + Space + "boot location" + Space + /

It will be like this if you place your bootloader in "/Users/User/Downloads/"

sudo cp /Users/User/Downloads/boot /

-----

I think this translation:


Through observation, I think the card BIOS on the motherboard may be a chameleon. Three cases of success is the Acer Acer 4745g and 4820t, after investigation, are insyde bios, same Acer 5740 (hulinyun the students) are not, it's BIOS is Phoenix, the Lenovo y460 (my present), y560 does not work, their BIOS is Phoenix, another hellozhangxin students dell inspiron 5010 is the same problem, it's bios is the "Dell Inc A10" (Master Lu measured, not routine). So the BIOS may be the key, of course, could be purely coincidental.
If you do with the BIOS on the motherboard, there might be hope?



suggests this method may only work on the laptops: Acer 4745g, 4820t and 5740 (the 'three cases of success') or similar.

Source: http://bbs.pcbeta.co...8...ra=&page=15.

You are partly correct, here is the translation.

经过观察,我认为卡变色龙可能与主板BIOS有关。成功的三例是宏碁4745g和宏碁4820t,经查,都是insyde bios,同属宏碁的5740( hulinyun同学的本)却不行,它的BIOS是Phoenix,联想的y460(我的本),y560也不行,它们的BIOS也是Phoenix,另外hellozhangxin同学的dell inspiron 5010也是同样问题,它的bios是“戴尔 Inc A10“(鲁大师测得,不太常规)。所以说BIOS可能是关键,当然也可能纯粹是巧合。
如果确实与主板BIOS有关,可还有希望?

After my observation, Chameleon hanging while loading may due to the problem of the BIOS. Notebook which 5650m work are Acer 4745g & 4820t they were all "insyde bios".However Acer 5740, Lenovo y460 y560 with Phoenix BIOS not working. dell inspiron 5010 with Dell Inc A10 were also not working.

Sorry for poor english :P

So, BIOS might be a factor contributing the work of 5650m.

#14
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia
I got ATI Mobility 5650 working using kext's from Apple's Dev 10.7 build :( Lappy screen not work yet but external monitor port does, QE/CI.

http://www.insanelym...howtopic=249357

will also try this boot plist method.

#15
nospheratus

nospheratus

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
So i have to install Snow Leopard on my hdd from another laptop in which i can install it? And then i have to apply these tricks? is it correct?

For now i don't have another pc or laptop for try this method, so i'm trying to create an #####-Legacy cdboot with this new bootloader, because only with #####-Legacy i got no kernel panic when loads the Acpi kext at the beginnig of the installation; if i use the normal ##### or the latest Cahemeleon on USB drive i've got a kernel panic at this point (ACPI kext), but trying to use this bootloader with the USB drive i still have kernel panic on ACPI, but i think that the system recognizes my videocard... so i need to test this bootloader with #####-Legacy but i don't know how to create a new cdboot! Can i use Lizard for do that? And if yes, how can i do?? (sorry for my english)

#16
theakseffect

theakseffect

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
  • Gender:Male
  • Location:Netherlands

After my observation, Chameleon hanging while loading may due to the problem of the BIOS. Notebook which 5650m work are Acer 4745g & 4820t they were all "insyde bios".However Acer 5740, Lenovo y460 y560 with Phoenix BIOS not working. dell inspiron 5010 with Dell Inc A10 were also not working.

Sorry for poor english :(

So, BIOS might be a factor contributing the work of 5650m.


Thanks for your reply, too bad for me and my 5740G then :wacko: I was about to try this method, but I'm unable to boot into OSX or bootloaders (including #####) since my latest BIOS flash (I think my MBR may be corrupted because of the flash). Oh well..

#17
lince5

lince5

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
Well, a few months ago, i tried to update my hackintosh install from 10.6 to 10.6.4. It mustn't be problematic, but that combo update made a kernel panic in the finish, dont know why. Then i couldn't boot SL. Which was the problem?

#18
eric028

eric028

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male

Well, a few months ago, i tried to update my hackintosh install from 10.6 to 10.6.4. It mustn't be problematic, but that combo update made a kernel panic in the finish, dont know why. Then i couldn't boot SL. Which was the problem?

Oh Ya! It is very simple! because the proble of ATI5000Controller.kext. You should move it out after installed 10.6
.4 since ATI5000Controller.kext added in this version.

#19
PGHammer

PGHammer

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 282 posts

OH WAUW!

If this is true, that would be AWESOME ..


Anyone tried this?
Any response.. been looking for a way to get my HD5650 to work for a month now! -.-


I will be testing this sometime next week when i get home ..


It appears to be a variation of the method used to get the other HD5xxx cards to work (the reason for the variation is because the Mobility versions act different compared to the non-Mobility counterparts - further, it does NOT help that some Mobility parts, such as the HD5450, are *also* desktop parts as-is).

The HD5450 uses a sub-variation of this method to work - and work it does. (I'd know - I have a Visiontek HD5450 512MB in my WinHack dual-OS budget beastie, and just changed my Dashboard locale settings to where I want them.) My display is properly detected, I have proper resolution usage - if I wanted to, I could turn on Mirror (since both outputs are connected to the same display, I see that as Rather Useless). I've been shaking down the Hack side since I got things working (including installing NovaBench and scoring how well this BabyHack actually runs); I've even installed the first game that *requires* CI to run (the Mac version of Bejeweled 3, which I have installed on the Windows side already).

It takes getting used to, actually *having* proper hardware acceleration...

#20
atlee

atlee

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 688 posts
  • Gender:Male
  • Location:South NSW, Australia
I tryed to replicate pcbeta but nope no success, i can get my external working using my method with dev 10.7 kexts but when trying this method can't seem to work it, maybe will give it another shot mix and match pcbeta iinstreuctions with mine see what i get.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy