Jump to content

[Guide & Boot CD] D-Series Latitude/w NVIDIA or GMA950 and Intel Dual Core Retail Installs

- - - - -

  • Please log in to reply
1331 replies to this topic

#981
oetje

oetje

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

950 people, I suggest you look here and use it as starting point to patch your DSDT so that you can use vanilla kexts.


Thanks Consolation!!! This was the link I was looking for! Somehow I was to stupid to find it while searching. Thanks for pointing me there. This forum has been so helpful.

Frans

#982
Mikkp

Mikkp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
Noticing some artifacting when opening Stacks.
Also, when waking from sleep the Translucent menubar switches to the solid menubar.

Using Dell D620 with Nvidia graphics and patched DSDT provided in the first post along with the same Kexts.

M.

#983
muxion

muxion

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
I've had a good success with a D620 Nvidia, and OK with a D820 Nvidia. Sleep is the big issue with these, but leppy's install is amazing. I find I have to set up the GUID partition and immediately install, restarting gets me a blinking cursor even if the disk is properly partitioned and erased. The D820 also won't boot from OSX, I have to put in the D620SLV1 and choose the OSX hard disk. I have a lot of reading to do!!

Thanks to Leppy and you other genius contributors! I wouldn't have a mac without you guys!!

Thanks!!

Mux

#984
consolation

consolation

    I am not expendable, I'm not stupid and I'm not going.

  • Members
  • PipPipPipPipPipPipPip
  • 878 posts

Noticing some artifacting when opening Stacks.
Also, when waking from sleep the Translucent menubar switches to the solid menubar.

Using Dell D620 with Nvidia graphics and patched DSDT provided in the first post along with the same Kexts.

M.



Try getting rid of the device string in the plist and use the attached kext instead. It makes for a bit longer boot, but wake from sleep is much smoother. Also, if you get your NVCAP values sorted it should make for easy dual screen/dock, hell it might even work oob. More info here: http://www.projectos...p?showtopic=370
http://www.projectos...php?showtopic=4

Attached Files



#985
VFXRAVEN19

VFXRAVEN19

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
Has anyone else tried SleepEnabler on their D-series? I've also noticed when the computer is back from sleep, sound is static-scratchy... only remedy is to reboot.

#986
consolation

consolation

    I am not expendable, I'm not stupid and I'm not going.

  • Members
  • PipPipPipPipPipPipPip
  • 878 posts

Has anyone else tried SleepEnabler on their D-series? I've also noticed when the computer is back from sleep, sound is static-scratchy... only remedy is to reboot.


If you read the last few pages of the thread you will find your solution.

My attempt at NVCAP:

0400000000000500020000000000000700000000

And attached is my bios dump, although NVflash can't read it directly so I'm bit iffy about it.

Attached Files



#987
consolation

consolation

    I am not expendable, I'm not stupid and I'm not going.

  • Members
  • PipPipPipPipPipPipPip
  • 878 posts
Attached are my NV kexts:

NVDAResman & NVDANV40Hal with our device ID added; goes s/l/e

NVEnabler 64; the new hotness that should make all your ports etc work automagically - only hardcoded our device ID.

NVinjectGoD620 - Old school injector; hardcoded NVCAP and device ID, fast boot etc - Doesn't work well on SL... used to work well on 10.5.

Goes without saying; not for Intel folk.

OK upload went awol.

Here is a linky instead http://www.mediafire.com/?mr5j4zh2mhm

#988
consolation

consolation

    I am not expendable, I'm not stupid and I'm not going.

  • Members
  • PipPipPipPipPipPipPip
  • 878 posts
Arsecustard, I just dropped and killed my external LCD. %$^&* Managed to push it off the back of my desk with my laptop. Could NV D620s try the NVenabler kext and see how it works with external displays - I've got mirroring going but didn't get much past that...

#989
hansi-r6

hansi-r6

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi there,

my SL 10.6.2. runs pretty fine :P

the only"problem" i found actually is that i cant do "top" on the shell or open the "Activity monitor" in Utilities.
After opening "top" the system crashs...

any suggestions?

@Leppy

THANK YOU

#990
Harry P

Harry P

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I followed the instructions but i installed the osx on external drive. now when i am trying to run post script it is giving sudo password login in terminal. trying to put system password i set when i installed is not working also when i unmount the internal drive and run the post script command i just get blank terminal. I guess have to do manually what post script does...I have Dell 620D with Intel GMA 950 and intel wireless 3945 which i will be swapping with dell 1390 from another laptop....any pointers on how to fix postscript command or how to do manually what post script does. Thnx

BTW...very impressed with your work...this has been easiest and my first succesfull install on Intel

#991
Mikkp

Mikkp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

Try getting rid of the device string in the plist and use the attached kext instead. It makes for a bit longer boot, but wake from sleep is much smoother. Also, if you get your NVCAP values sorted it should make for easy dual screen/dock, hell it might even work oob. More info here: http://www.projectos...p?showtopic=370
http://www.projectos...php?showtopic=4


Works awesomely!
Although some strange artifacting going on in Stacks but when its okay its a lot faster than the ones provided by Leppy. Also it fixed the sleep problem i had and made all graphics a bit smoother. NICE!

M.

#992
consolation

consolation

    I am not expendable, I'm not stupid and I'm not going.

  • Members
  • PipPipPipPipPipPipPip
  • 878 posts

Works awesomely!
Although some strange artifacting going on in Stacks but when its okay its a lot faster than the ones provided by Leppy. Also it fixed the sleep problem i had and made all graphics a bit smoother. NICE!

M.


Try the kexts from here http://www.mediafire.com/?mr5j4zh2mhm

NVDAResman & NVDANV40Hal with our device ID added; goes into s/l/e

nvinject is there just for old times sake - bin it.

#993
Mikkp

Mikkp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

Try the kexts from here http://www.mediafire.com/?mr5j4zh2mhm

NVDAResman & NVDANV40Hal with our device ID added; goes into s/l/e

nvinject is there just for old times sake - bin it.


Installing them as we speak.
Do i need to hold the NVEnabler64.kext in e/e too?
Its working without them so im not sure if it should be somewhere!?


Also, as an update the 3945 drivers are going pretty smoothly. Mercurysquad has a new beta out for unsecured 11b and 11g connections.
Secured drivers with WPA and WPA2(if i remember correctly) are coming to beta in a few weeks time. So there might be a slight chance we can throw away our USB WiFi sticks and enjoy the summer with a solid Hack.

M.

#994
pgreg

pgreg

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Thanks Consolation!!! This was the link I was looking for! Somehow I was to stupid to find it while searching. Thanks for pointing me there. This forum has been so helpful.

Frans


Frans,
Since I upgraded my D620 to 10.6.3, I'm encountering the same problem as you described (GMA950 appears as NVIDIA graphic, no more Quartz acceleration). I'd rather not use the DSDT patch as I never managed to make the sound work with it. Can you explain with more details how you managed to fix the graphics problem? Thanks in advance!

#995
consolation

consolation

    I am not expendable, I'm not stupid and I'm not going.

  • Members
  • PipPipPipPipPipPipPip
  • 878 posts

Do i need to hold the NVEnabler64.kext in e/e too?
Its working without them so im not sure if it should be somewhere!?


I just added our device ids. I keep NVenabler in e/e the others in s/l/e where they usually live.
My next step is to have it load the extracted rom and patch it for our native resolution & allow it access to more than 64MB by setting beginning and end memory addresses. Since the dedicated memory is only 64bit GDDR, it might improve performance if we give it 128MB DDR2 to play with instead. It's slow going as I don't really have the free time to sit down for a long session. Also, before the next ice age, passing our native edids to boot so that we can get native res on boot -> no black bars or distorted grey apple.

But honestly, right now I'm just trying to get a clean vga rom out of the pos dell firmware, unfortunately it's not a separate video card bios and I'm not sure that the stuff I extract from shadow ROM is clean. Have a peak at the bios file I attached if you have any ideas.

I'm quite happy extracting bios and editing it from desktop cards, but this laptop thing is a whole bag of hurt.

#996
Mikkp

Mikkp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
Reporting from a CRT Display that is running on the side of my Hackintosh D620 usin consolation's drivers.
Pretty solid, the videocard is kind of coping with the 1280*800 resolution i get with the CRT. Artifacting in the Stacks region and while in screensaver mode.

The screensaver mode laggs on the CRT but completley artifacts on the LCD installed in the D620.

M.

#997
consolation

consolation

    I am not expendable, I'm not stupid and I'm not going.

  • Members
  • PipPipPipPipPipPipPip
  • 878 posts
hmmm...... can you get extended desktop or only mirrored displays? I'm going to get hold of another external display next week, right now my {censored} external LCD I used for testing is well and truly dead. I'll see if I can score something that can do more than 1024x768 this time.

Weird about artefacting, I only get some corruption on "magick" garageband.

#998
Mikkp

Mikkp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts

hmmm...... can you get extended desktop or only mirrored displays? I'm going to get hold of another external display next week, right now my {censored} external LCD I used for testing is well and truly dead. I'll see if I can score something that can do more than 1024x768 this time.

Weird about artefacting, I only get some corruption on "magick" garageband.


Mirrored display makes the LCD go black. Im running an extended desktop.

I did a restart and it seems that the artifacts are gone. The screensaver works but its a bit laggy.

M.

#999
rival92

rival92

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Go to Kexts.com and get the sleepenabler.kext for your version of osx. 10.6.2 snf 10.6.3 both have fixed kexts available on there.

Has anyone else tried SleepEnabler on their D-series? I've also noticed when the computer is back from sleep, sound is static-scratchy... only remedy is to reboot.



#1000
rival92

rival92

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Here is a dump of all the ACPI tables for an nVidia D620 with A10 Bios and T2500 CPU. These are decompiled but not fixed or optimized. Hoping someone can figure out the right fixes for C-State and AppleLPC.

Attached Files







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy