Jump to content

Cmedia 8738


  • Please log in to reply
226 replies to this topic

#21
Hydrasworld

Hydrasworld

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
i've got xcode installed btw, now sure how you go about debugging drivers and i'm very new to osx/darwin but i do code on XP in c/c++ and c# so if you want me to try anything let me know

#22
Hydrasworld

Hydrasworld

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
dogbert contacted me via irc (hi dogbert!) and he quickly hacked together a couple of test versions for me and the second one of them worked great! nic + sound even after a cold boot.

mad props (as they say) to dogbert :) :D :D :D

i'm sure he'll post a url below when he's uploaded it somewhere for you kidz

#23
dogbert

dogbert

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts
with the help of hydrasworld, I was able to find and eliminate the bug. thanks again, pal!

drivers: http://members.tripo...er-0.6.4.tar.gz
source: http://members.tripo....6.4-src.tar.gz

#24
Hydrasworld

Hydrasworld

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

with the help of hydrasworld, I was able to find and eliminate the bug. thanks again, pal!


no problem and thanks for the fast turnaround on this, there's a great many motherboards out there with the CMI8738 chip on so I'm sure lots of other people will be thanking you too!

now all we need is that 1.0.0 you've been talking about!

#25
nespric

nespric

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

with the help of hydrasworld, I was able to find and eliminate the bug. thanks again, pal!

drivers: http://members.tripo...er-0.6.4.tar.gz
source: http://members.tripo....6.4-src.tar.gz

<{POST_SNAPBACK}>


Can not download CMI driver :(

I'd like to mirror both drivers and source for you at kmric.com

would you send me a copy?

my email : kmnesp@163.com/nespric@gmail.com

#26
AceBR

AceBR

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

Can not download CMI driver :P

I'd like to mirror both drivers and source for you at kmric.com

would you send me a copy?

my email : kmnesp@163.com/nespric@gmail.com

<{POST_SNAPBACK}>


Sorry I'm late! I'll try the new version now and see if the problem with hydrasworld was the same as mine. Post back in a few...

#27
AceBR

AceBR

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

Sorry I'm late! I'll try the new version now and see if the problem with hydrasworld was the same as mine. Post back in a few...

<{POST_SNAPBACK}>


Posting from Mac OS X with sound loaded, which means it totally solved the problem! Thx for the great job man!

#28
Hydrasworld

Hydrasworld

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

Posting from Mac OS X with sound loaded, which means it totally solved the problem! Thx for the great job man!

<{POST_SNAPBACK}>


yeah, props to dogbert for fixing that!

#29
Pitr-

Pitr-

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Location:Sweden

can someone tell me if my sound card works with this kext...

The thing is i loaded the kext... it show like there's a card detected, but it doesn't make sound... i tried:
-The MIDI Audio Setup
-Change the speakers to the mic input...
-I don't have front output for audio

I have tried the info about AppleAC97Driver...

i put 0x70121039 in the Info.plist... but i don't have sound...  :)

Thanks if anybody can help...
----------------

From C-Media 3D Audio Configuration:

Audio Codec: CMI9739A
Audio Controller: SIS 7012 Series Audio Controller


You're not alone. I also have problem getting any sound of my cmi9739a-chip. The chip is detected succesfully and the appleac97driver-module loads without problems but there is no sound playback :D

#30
bebox

bebox

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts
  • Location:FRANCE
version 0.6.3 work fine with my lowcost Asound Express III pci sound card (CMi-8738)

really thanks great job :P

#31
Hydrasworld

Hydrasworld

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts

version 0.6.3 work fine with my lowcost Asound Express III pci sound card (CMi-8738)

really thanks great job ;)

<{POST_SNAPBACK}>


you should definately use 0.6.4 as 0.6.3 has a bug which may cause other pci devices to not function correctly.

#32
bebox

bebox

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts
  • Location:FRANCE
v 0.6.4 works well too thank you

#33
Silvos

Silvos

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
I would like to thank dogbert for the work done on the CMi-8738 driver.
I now have sound!! Awesome Thanks! :angry:

#34
fwt11

fwt11

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

new version: http://members.tripo...er-0.6.1.tar.gz - mute and volume changing works now

installation: Open a terminal, cd to the download directory, tar xzvf CMI8738PCIAudioDriver-0.6.1.tar.gz, ./install.sh, enter your root password and you're done.

source code: http://members.tripo....6.1-src.tar.gz



Sir,i can't download the driver. And i googled it , but didn't find it in some where else. so can you send it to me .

my email address is wutong.feng@gmail.com


thanks.

#35
dogbert

dogbert

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 127 posts

Sir,i can't download the driver. And i googled it , but didn't find it in some where else. so can you send it to me .

my email address is wutong.feng@gmail.com
thanks.


backup servers:
drivers: http://home.pages.at...er-0.6.4.tar.gz
source: http://home.pages.at....6.4-src.tar.gz

MD5 (CMI8738PCIAudioDriver-0.6.4.tar.gz) = a304afa0e703a8e9c89fa46e10ac4f78
MD5 (CMI8738PCIAudioDriver-0.6.4-src.tar.gz) = 918d99c7073df89b3183eac406173a01

#36
fwt11

fwt11

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

backup servers:
drivers: http://home.pages.at...er-0.6.4.tar.gz
source: http://home.pages.at....6.4-src.tar.gz

MD5 (CMI8738PCIAudioDriver-0.6.4.tar.gz) = a304afa0e703a8e9c89fa46e10ac4f78
MD5 (CMI8738PCIAudioDriver-0.6.4-src.tar.gz) = 918d99c7073df89b3183eac406173a01



thanks

#37
Sky Bot

Sky Bot

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Location:Lebanon
Works like a charm, now time to work on the kworld tv card (bttv driver), I love macs but can't afford them!

#38
munky

munky

    Agent of Evolution

  • Retired
  • 2,900 posts
  • Location:The Land of Hairy-Arsed Highlanders
anyone know if these work on 10.4.3? might be worth a swift recompile.

EDIT: 10.4.3 compiled version is here: http://www.win2osx.n...read.php?t=1729 :D

#39
WaxTrax!

WaxTrax!

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 107 posts
I posted this over on win2osx as well, but maybe I'll get a response here.

Using a PCI card version of the CMI 8738 on 8F1111a(g), I went to install the last compiled 0.6.4 version of dogbert's driver, compiled for 10.4.3, and it didn't work. I opened up the project in Xcode and without changing anything, built the driver for my system, and it seemed to work.

The sound card did work, until the system would randomly crash. For example, I used GarageBand for about 10 minutes with no problems, but a random sound like emptying the recycle bin, would make the computer crash. And if I tried to use iTunes, it'd crash the system after about 30 seconds of playback.

Here's my portion of the thread over at win2osx: Page 6

#40
Nanau

Nanau

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
YAHOO!!! I finally got sound!!!

Thank you guys for the excelent work.

Just one question. The microphone isn't working. What I did wrong?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy