Jump to content

VoodooHDA


  • Please log in to reply
363 replies to this topic

#41
sebus

sebus

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 276 posts
  • Gender:Male
  • Location:UK

i think you need the vanilla kernal to get this working properly


In that case it can not be on this (reused) mobo/CPU, as vanila does not work on this spec

sebus

#42
brambo

brambo

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Voodoo people,

I used the kext found on this forum on the Aspire D150 with the ALC272 chipset and
it works beautifully!

I got sound out, will perform more tests on mic, headphone, etc... and come back with report any bugs
that I may encounter.

Nice work!

#43
JorgeCCastro

JorgeCCastro

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
tried it on my DX58SO mobo, it's got ALC889. it's the only kext that worked so far. well, at least i get stereo output. no input is working properly. thanks and keep up the EXCELLENT work. btw i didn't actualy compile it, just grabbed the kext that Napster put out (thanks)... don't know if that makes a difference... anyway it's basically working... all DX58SO users will be very grateful...

#44
Dismounted

Dismounted

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Australia
Working great on ALC262 - all input and output detected. Output working, input looks a bit scratchy though.

#45
Hanx86

Hanx86

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
It's also working here (ALC883), with the common bugs people have reported so far: sound is distorted after waking up from sleep, and the internal mic can be heard, but with a lot of strange noises. Thank you very much to the creators for the efforts, it's getting really close.

#46
Monkey_@@

Monkey_@@

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male
Well, installed and after returned to AppleHDA for my ALC286. The problem? NO MIC. It's true that there was two available mics into the pref pane but none of them worked... so I went back...

Another question: how do I get this working for a Vanilla /Extra folder? Just the fact of putting it into the /Extra folder didn't work

#47
dandaman1976

dandaman1976

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:VA
Hello all I am getting this error - what am i doing wrong?


EDIT: Nevermind - needed full install of xcode, now is there a way to get this to work on boot without typing the " sudo ./helper.sh load" command everytime?

#48
ugokind

ugokind

    InsanelyMac Deity

  • Donators
  • 1,713 posts
  • Gender:Male
  • Location:10100
  • Interests:Apicoltura
    Mac
    Linux
    Homebrew
    Australia
    Spremermilcervello
on acer 5930 desn't work
it shows a lot of node in output and input (always the same)
but only output and auto switching hp works

#49
etx

etx

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts

Hello all I am getting this error - what am i doing wrong?
AsusMac:voodoohda - sudo helper.sh dholmstock$ sudo ./helper.sh build
+ xcodebuild -configuration Debug -target FloatSupport -target VoodooHDA
./helper.sh: line 17: xcodebuild: command not found
+ gcc getdump.c -o getdump -framework IOKit -framework CoreFoundation -Wall -Wextra -Werror
./helper.sh: line 18: gcc: command not found


You must have XCode installed to compile kernel extensions, or anything for that matter.

Voodoo team, great great work. Thank you so much for your hard work!

#50
Konami®

Konami®

    InsanelyMac Legend

  • Donators
  • 956 posts
  • Gender:Male
  • Location:Pennsylvania
VoodooHDA needs a lot of work, it would be awesome if one or few talented driver developer from the community took this work to improve the driver.

#51
0m3gA

0m3gA

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
I have Xcode 3.1.2 installed (default components), but if I run "sudo helper.sh" I get "command not found". I can open the VoodooHDA project file though Build and Go is disabled.

#52
DB1

DB1

    InsanelyMac Sage

  • Donators
  • 407 posts
Om3jA

sudo ./helper.sh build

#53
0m3gA

0m3gA

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts

Om3jA

sudo ./helper.sh build


Cheers that worked!

#54
mattrb

mattrb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
  • Location:Chicago, IL
Everyone, if you have an issue, first you NEED to tell the developers of VoodooHDA by going to the VoodooHDA issues forum on google Code site. As well, Don't address problems that are already addressed on that forum. Then after you have gone on Google Code, you should tell people about your problem on the VoodooHDA issues forum on the Chameleon site. Afterwards, you can tell your problems to the neophytes on this thead.

Remember in order of sites to tell your problems, first Google Code site, then Chameleon site, then here.

Now that you all know that little tidbit, lets hear the silly post of the day.


VoodooHDA needs a lot of work


Obviously, this is the first release. Tell me something I don't know.

#55
Dr. Hurt

Dr. Hurt

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,507 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.
Result for ALC662 using pre-compiled kext:

Sound out working. Sound in thru front panel not working. When I speak in the microphone, I hear myself in the speakers. I fixed it by muting all input options in the output section (sys pref).
System profiler doesn't show any info.

In system preferences > sound, I have:

Output: (why do I have input here - have to mute them to avoid hearing myself thru speakers)
Master
PCM
Line in
Microphone
Input mix
Recording level
Output gain
Recording Level
Digital

Input: (none work)
Line in
Microphone
Input mix
Microphone 2

Very Strange. With a few tweaks, this will be the best Audio driver for osX86. Will it make any difference if I compile the kext myself?

#56
yohko101

yohko101

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
confirmation: ALC272 - Acer Aspire One D150 - the internal speakers are producing sounds!!!! :) thanks!

OS X: iDeneb 1v4 (10.5.6)

#57
mehmed

mehmed

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi all

I donwloaded the files. installed xcode. changed directory in terminal but it says "command not found". i tried all there commands:

sudo ./helper.sh build
sudo /helper.sh build
sudo helper.sh
sudo helper.sh build

none of them works.. can you guys tell me where I am doing wrong??

thanks

#58
yohko101

yohko101

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Hi all

I donwloaded the files. installed xcode. changed directory in terminal but it says "command not found". i tried all there commands:

sudo ./helper.sh build
sudo /helper.sh build
sudo helper.sh
sudo helper.sh build

none of them works.. can you guys tell me where I am doing wrong??

thanks


hey mehmed,
# cd voodoohda-read-only# su rootenter the root password# ./helper.sh buildor #sudo ./helper.sh build

hope this helps ^_^

#59
bluelovemac

bluelovemac

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
it work on my Realtek ALC862 @ Intel 82801GB ICH7!!!!!!!

Attached Files

  • Attached File  ___1.jpg   41.65KB   301 downloads


#60
filosofem

filosofem

    InsanelyMac Protégé

  • Donators
  • 64 posts
  • Gender:Male
  • Location:Finland
Works great on my VIA 1708S. Thank you VoodooTeam!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy