Jump to content

GMA X4500


  • Please log in to reply
1614 replies to this topic

#1601
arikstress

arikstress

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
  • Location:indonesia
Neither do i , i cant see why i cant set it into correct resolution, no option to allowed me choose 1280x800 in my lifebook fujitsu. That is my problem till now

#1602
Biso007

Biso007

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 183 posts
  • Gender:Male
  • Location:Cairo, EG
Try setting it manually while booting as : "Graphics Mode" = 1280x800x32
if worked correctly put it in boot.plist file.

#1603
arikstress

arikstress

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
  • Location:indonesia

Try setting it manually while booting as : "Graphics Mode" = 1280x800x32
if worked correctly put it in boot.plist file.

Already did it :D
Custom chameleon boot.plist, com.apple.Boot.plist, tried that all

#1604
endia

endia

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

if worked correctly put it in boot.plist file.


how to put an option in boot.plist file?

i tried this kext and while booting i entered "arch=i386"
and it works.. it opened native 1680x1050 with no problem..
but i have to boot with this command every time..
also i did a search and found only chameleon boot.plist.
what should i do?
thanks in advance..

edit: thinkpad t500, c2duo p8400 2.26, 8gb ddr3, intel x4500hd, 160gb hitachi hdd

#1605
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,472 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
hello

in org.chameleon.boot.plist or apple.com.boot.plist located in Extra

edit with text editor

key>kernel flag

string>arch=i386

puth there

good hack

#1606
Falling Idols

Falling Idols

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Boca Raton

hello

in org.chameleon.boot.plist or apple.com.boot.plist located in Extra

edit with text editor

key>kernel flag

string>arch=i386

puth there

good hack

does that only make it boot with the kext or is that for qe as well? ive been waiting a long time and have almost given up.

#1607
endia

endia

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
solved:

org.chameleon.Boot.plist
<key>Graphics Mode</key>
<string>1680x1050x32</string>

artur-pt, thank you.. will try your solution too..

#1608
Biso007

Biso007

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 183 posts
  • Gender:Male
  • Location:Cairo, EG

hello in org.chameleon.boot.plist or apple.com.boot.plist located in Extra edit with text editor key>kernel flag string>arch=i386 puth there good hack


I can't recall it now, but I do remember I had an issue with Chameleon v166x where it didn't recognize this flag on org.chameleon.boot and it worked only in com.apple.boot.

I didn't check whether it's solved in later versions or not.

does that only make it boot with the kext or is that for qe as well? ive been waiting a long time and have almost given up.

No QE/CI for this chip afai :(

#1609
Tiger Matoshi

Tiger Matoshi

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I'm going to just be straight up here--after searching this site and others, I've tried several different tricks, various kexts etc. and nothing is working for me. I *have* achieved 1440x900 resolution, however, though at boot I specifically set "Graphics Mode"="1920x1080x32@60" as my monitor is 1920x1080. Anyone know how I can actually get the proper resolution going? I'm not concerned about qe/cl at the moment.

I have the G45 chipset with X4500HD in a desktop (Hardware ID 2E22) and I am in a 64-bit environment, thus 32-bit patches will not work for my system.

Thank you!

EDIT: I'm an experienced Windows and Linux administrator so I have no qualms about jumping in and getting my hands dirty if need be. I'm very comfortable with the command line.

#1610
Biso007

Biso007

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 183 posts
  • Gender:Male
  • Location:Cairo, EG

I have the G45 chipset with X4500HD in a desktop (Hardware ID 2E22) and I am in a 64-bit environment, thus 32-bit patches will not work for my system.


But we all here know that there is no 64-bit kext for this chip .. how do you expect to get it working let alone changing the resolution ???

#1611
Alec Stone

Alec Stone

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
  • Gender:Male
  • Interests:Computers, Coffee, Computer Science III, Hacking, Computer Hardware Engineering. (Computers) (...
Has anyone tried this? It appears that the OP is claiming to have Software QE working using a different mechanism routing graphics through the CPU.. Please inform me if it is legitimate. http://www.osx86.net...&id=2866&page=2

#1612
Biso007

Biso007

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 183 posts
  • Gender:Male
  • Location:Cairo, EG
Anyone got this card to work in ML ?

we need 64bit version for X3100FP kext modified to device code 2a42

Update: I patched the X3100FB next from SL and it works perfectly (kext attached).

Attached Files



#1613
ghostanime2001

ghostanime2001

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
I also have a Dell Latitude E6400 with Intel GMAX3100. Anyone have any sort of workaround or partial solution to this problem yet ? Also, I have hazard's 10.6.6i disk and I tried to install this in this laptop (Dell latutide E6400) but it failed... snow leopard set up gives a kernel panic when I boot from ######. However installing snow leopard 10.6.3 on this laptop works perfectly with the retail version. The reason i say this is because when I used Hazard's disk in my old laptop (Dell Studio 1555) i can see a kext for Intel GM45/X3100 graphics. But when i try to install hazard 10.6.6i to this laptop (Dell Latitude E6400) it gives a kernel panic so I can't install it. Anyone know how to make Hazard's 10.6.6i work on this latitude E6400 because hazard's 10.6.6i disk has that GMAX3100 driver.

#1614
Gordio

Gordio

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male

Anyone got this card to work in ML ?

we need 64bit version for X3100FP kext modified to device code 2a42

Update: I patched the X3100FB next from SL and it works perfectly (kext attached).

Thx. Work, but I have "black screen" Screen backlight switch to off mode.



#1615
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,472 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

Anyone got this card to work in ML ?

we need 64bit version for X3100FP kext modified to device code 2a42

Update: I patched the X3100FB next from SL and it works perfectly (kext attached).

 

 

hello

 

u patched with what ?

 

thanks

 

good hack







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy