Jump to content

arikstress

Members
  • Content count

    28
  • Joined

  • Last visited

About arikstress

  • Rank
    InsanelyMac Protégé

Contact Methods

  • MSN
    arikstress@hotmail.com
  • Yahoo
    arikstress

Profile Information

  • Gender
    Male
  • Location
    indonesia
  1. arikstress

    GMA X4500

    Already did it Custom chameleon boot.plist, com.apple.Boot.plist, tried that all
  2. arikstress

    GMA X4500

    Neither do i , i cant see why i cant set it into correct resolution, no option to allowed me choose 1280x800 in my lifebook fujitsu. That is my problem till now
  3. #1. Tested on Lion Retail 10.7.2 I just try re-attach my ATI HD 4350 , but i think i'm too lazy to use Kexts such as ATY_Init.kext, Patch Kexts, in my case, you all know it as 4350Fix2.kext mostly. well, since chimera has built in mode that we can use, i just found out how to make this card working without using any kext. Thanks to Chimera Developer i guess... so here's how to make it. note: you may also try with chameleon, since i'm not using chameleon version of boot loader, so i recommend you can be testing it. Pre-beginning : based on help in chimera or chameleon with ? command on boot prompt : Press Enter to start up Darwin/x86 with no options, or you can: Type -v and press Enter to start up with diagnostic messages Type ? and press Enter to learn about advanced startup options boot: The boot: prompt waits for you to type advanced startup options. If you don't type anything, the computer continues starting up normally. It uses the kernel and configuration files on the startup device, which it also uses as the root device. Advanced startup options use the following syntax: ===cut=== GraphicsEnabler=Yes|No Automatic device-properties generation for gfx cards. AtiConfig=<cardcfg> Use a different card config, e.g. AtiConfig=Megalodon. AtiPorts=<value> Specify the number of ports, e.g. AtiPorts=2. UseAtiROM=Yes|No Use an alternate Ati ROM image ===cut=== What do you need : Chimera *still not testing it with latest chameleon, may be you guys can try it out. modify org.chameleon.Boot.plist *it lays on /Extra/ folder by default. Advantages : [*]no need patched kext [*]Keep system as clean as possible [*]You all can use 32/64 bit mode, since you were using original unmodified kexts. [*]No need input your PCI ID e.g.: 954f into corresponding kexts. which usually do the trick for us. [*]No need to use Graphics Enabler to Yes , although, if you use GE=Yes, it's still working after all [*]All ports is working without a doubt (VGA/DVI/HDMI) [*]No more has to use DVI port, you can freely choose what port without limitation. Steps 1. Download and install Chimera 2. Modify your org.chameleon.Boot.plist, here's what you need to add: Must Be: <key>AtiConfig</key> <string>Motmot</string> or <string>Gliff</string> *use and pick one of them , neither Motmot or Gliff <key>AtiPorts</key> <string>1</string> Optional: <key>UseAtiROM</key> <string>Yes</string> so, the result, i will use my own bootplist to be an example, don't just copy paste my setting, because it depends on your hardware and different hardware may not work. sample of my config: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>AtiConfig</key> <string>Gliff</string> <key>AtiPorts</key> <string>1</string> <key>CSTUsingSystemIO</key> <string>Yes</string> <key>DSDT</key> <string>/Extra/DSDT.aml</string> <key>EnableC2State</key> <string>Yes</string> <key>EthernetBuiltIn</key> <string>Yes</string> <key>GUI</key> <string>No</string> <key>GenerateCStates</key> <string>Yes</string> <key>GeneratePStates</key> <string>Yes</string> <key>Graphics Mode</key> <string>1280x800x32</string> <key>Kernel</key> <string>mach_kernel</string> <key>Kernel Flags</key> <string>-v npci=0x2000 darkwake=0</string> <key>Legacy Logo</key> <string>Yes</string> <key>SMBIOS</key> <string>/Extra/SMBios.plist</string> <key>SystemType</key> <string>3</string> <key>Theme</key> <string></string> <key>Timeout</key> <string>1</string> <key>UseAtiROM</key> <string>Yes</string> <key>VBIOS</key> <string>Yes</string> <key>arch</key> <string>i386</string> </dict> </plist> I put that <key>UseAtiROM</key>as an optional, because when i testing it , without put that flag i still can make my card working, i don't know if it's can make another ATI/AMD Graphics card will working, well perhaps all you can try it using this simpler method. without finding proper patched kext. well, in kernel message while booting, it's shows error when loading ATIRadeonX2000, but still, it's loaded though error shows: arik$ sudo dmesg | grep ATI Kext com.apple.ATIRadeonX2000 - library kext com.apple.iokit.IOGraphicsFamily not found. Can't load kext com.apple.ATIRadeonX2000 - failed to resolve library dependencies. Kext com.apple.ATIRadeonX2000 failed to load (0xdc00800e). Failed to load kext com.apple.ATIRadeonX2000 (error 0xdc00800e). Kext com.apple.driver.AppleHDAController - library kext com.apple.iokit.IOGraphicsFamily not found.Couldn't alloc class "ATIRadeonX2000" Preview note: to test it, i'm not using kernel cache so it would be scanning all drivers first while booting, you may try using kextcache if you want. may be, you can also try it using chameleon edition not chimera, i personally only testing it with chimera. hope this help, good day guys.
  4. arikstress

    GMA X4500

    correct... unfortunately i can't set native resolution into 1280x800 which is fit on my screen . well it's only have 1280x768 or 1280x9xx which is gonna be weird in my lcd screen, tried so hard to make custom resolution manual or with switchresx , but still unlucky
  5. arikstress

    GMA X4500

    Well, i just try it and apparently not working, i'm using lion 10.7.2. well, with lion, card detected as GMAX3100, but no next loaded, so i stuck with standard 1024x768 resolution. i was trying hacked FB but it makes my battery drain because there's error in Graphics ACPI and it's not good for me cuz i can't set my resolution and brightness into the correct one for my life book fujitsu t4310. Frankly, i also not sure that bijan55 really make that happen because where is his screenshot to convince? i still trying modify appleintelgma x binary also the controller, one thing i afraid is, there is INTELHDGRAPHICS.kext , i wonder if this kext really must be loaded such as nvdaresman for nvidia graphics? Hihihi apparently i was trying edit GMAX3100 binary, which i search this hex value, from 86 80 02 2a or if i'm not wrong, that would be 20 2a 80 86 on Info.plist well. I'm not programmer so i just try who knows i would be luck but may be i change in a wrong direction ..hihihi from 86 80 02 2a i change it into 86 80 24 2a since my id is 2a42 not 202a again , still no luck anyways. still looking inside other kext, such as AppleIntelHDGraphics.kext also it's FB. well, apparently there are also HD3000.kext and it's FB.. hahaha so it's more complicated i guess..
  6. arikstress

    GMA X4500

    hmm i'd like to try, but the patch that you give us is wrong and make failed to compile. here is the correct one to make compiling has no problem note : use DTGP patch also. credits : oldnapalm save this code as file.txt and patch it with your patcher tools # Insert method _DSM into device with _ADR 0x00020000 # into method label _DSM parent_adr 0x00020000 remove_entry; into device name_adr 0x00020000 insert begin Method (_DSM, 4, NotSerialized)\n {\n Store (Package (0x06)\n {\n "AAPL,HasPanel", \n Buffer (0x04)\n {\n 0x01, 0x00, 0x00, 0x00\n },\n "model", \n Buffer (0x07)\n {\n "GMA4500MHD"\n },\n "device-id",\n Buffer (0x04)\n {\n 0x42, 0x2A, 0x00, 0x00\n },\n }, Local0)\n DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n Return (Local0)\n } end
  7. arikstress

    Another method to gain your "NVIDIA" QE/CI, more cleaner way

    Hi Guys, sorry for late replying. apparently i have to apologize first because i was wrong put url inside tutorial, i was put url to download = http://us.download.nvidia.com/Mac/Quadro_C....01.00f03v5.dmg --> wrong revision = http://uk.download.nvidia.com/Mac/Quadro_C...6.02.25f1v1.dmg --> correct GE= it depends , if you can try without GE, just run it, but if you can't , set it to yes.
  8. arikstress

    [Solve]Nvidia 7200 GS / 7300 SE 256MB PCIe with LION 10.7

    Guys did your card support Quadro or Cuda eventually?
  9. arikstress

    nVidia Quadro 2000 PNY

    have you tried using official nvidia quadro updates? i just found out that it works flawlessly , perhaps you want to test it? follow just like this guide n let me know if its working for you or not
  10. REVISED!!! Hello Guys! I'm so happy and relieved that apparently i found a way to make my NVIDIA Graphics Cards works "OOB" I testing it using "Zotac NVIDIA 8400 GS 512 MB DDR3" I already testing in Snow Leopard 10.6.8 , and also Lion 10.7 - 10.7.2 Below version i didn't test it yet. preparation : 1.Retail Snow Leopard 10.6.x (bought from apple) 2.Official Combo Update 10.6.8 v.1.1 3.[url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] , or another boot loader 4.[url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] note : you can find [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] and [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] from here 5.Nvidia update QUADRO MAC OS X DRIVER RELEASE 256 which u can direct download it here *TESTED* optional and need to be tested: i still didn't try it, but if your card support NVIDIA CUDA 4 FOR MAC DEV RELEASE, direct download it in here .You may post if you testing it and works, share with your friends and colleagues. So sorry i was giving wrong url, because i'm confuse, i already try usa nvidia sites and uk nvidia sites, apparently the best support is at uk sites. Steps: 1.Install Snow Leopard 2.SL 10.6.8 Official Combo Update 10.6.8 v.1.1 you may test it first by reboot, is your card known ? or ... go to step 3 3.Do not reboot, let it finish until he told you to restart, let it be and install [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. i like [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] 4.0.x because i can boot snow leopard also lion , you may try another such as chameleon latest version . 4.Reboot , and voila... my Graphics card running without injecting, without EFI, without dsdt , and natively working!!! and of course, ALL PORT ARE WORKING including HDMI, you may try dual monitor to try it. i already tried and all working great. i was trying with injecting method, nvenabler, etc. but i never has like this smoothness. oh well better use original driver than using modified or hacked driver. less hack is better to make stability of the system. want to know fun fact? based on : nvidia link Supported Type for this driver is : GeForce 300M series: GT 330M, GT 320M GeForce 200 series: GTX 285 for MAC GeForce 100 series: GT 120 GeForce 9M series: 9400M GeForce 8 series: 8800 GT GeForce 8M series: 8800M GTS, 8800M GS Quadro series: 4000 for Mac Quadro FX series: FX 5600, FX 4800 for MAC If you had run perfectly on Snow Leopard 10.6.8 , then you shouldn't be problem upgrading and running LION 10.7 - 10.7.2 after you installed this official driver on your system. i personally testing it, without install and with installing this drive it feels so different. After upgrading to Lion, yup it will not work, but hey, you can see Apple Logo on start up after booting just like when your card working in QE. It will still detect your card name and id, but main dependencies kext will not loading. Why? Because Lion driver is newest, and Don't worry, you just have to do this after your upgrade , even only upgrading from 10.7 - 10.7.1 , or so on. *Copy your /System/Library/Extensions/NVDANV*Hal.kext into your desktop *Install it again with Kext Utility for Lion, and reboot. to make sure, boot and choose verbose mode ( -v ) and if you see NVDANV*Hal Loaded and Registered , voila, congratulations... you will have no trouble now and can use it freely without afraid being freeze wait wait, there's another bonus... you will make it work on 32Bit or 64Bit Yup... my 8400GS is not listed. but yeah it's working. i think another card also supported, especially nvidia released at 2011 Come on Guys, testing and report it!
  11. arikstress

    NVEnabler with 10.6.8 and With LION issues

    if you use 10.6.8 or lion, what boot loader did you use? Chameleon or Chimera? Mine is having none issues using Chimera. I'm using Nvidia 8400GS 512 MB DDR3
  12. arikstress

    ATI card with 10.7.2

    I think i the only one has that problem, but it seems not as i see now in your experience. my vga is different, ati hd4350 . just like you said, if it set to "No" it would be just fine, but loading time is slower. if you set yes, loading time is faster, but it's always stuck and never going right just like broken next or panic, or whatever. my solution is for ati mostly using this step below. 1. use kextcache load on boot manually. *this is usually used if my string on org.chameleon.Boot.plist key for UseKernelCache value sets to No To do that, simply open Terminal on Applications --> Utility folder, input this command as root steps : a. Login as root, type : sudo -s and press enter or return. it will ask you password, give your mac user password. b. type after you successfully login : kextcache -v 1 -a i386 -a x86_64 -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions /Extra/Extensions , press enter and quit terminal, reboot. Lets see the result after reboot, if it stuck after reboot and not going into the system, try power off cpu first, and then power back on. if it's also still stuck whether normal boot, verbose boot, save boot, then now you try to make your settings back as usual to make it work fine, and do this second try. Another Try 2. After succeed booting with everything works fine, change your org.chameleon.Boot.plist string for key UseKernelCache to Yes because u mention if you set NO it's always been good. after changing this again to yes, then reboot. Thats it. i inspect this with trying install Lion in 1 CPU, but dual boot Lion , First lion used for ATI, second Lion used for NVIDIA , both of them is having same os, same hardware , same boot loader except for vga. which is seemly different result in handling. if all thise trick doesn't help you , perhaps you need to use another driver that support and more stable. as far as i know, if we can install properly at 10.7 - 10.7.1 and driver seems good, my solution is like these two steps. the different is, step 1 is for ATI, step 2 is for NVIDIA hope this thing can help u
  13. I ever had this problem, but with NVIDIA Card only. I don't know why, but here's the trick for you to try to resolve it. first try , 1. use kextcache load on boot manually. *this is usually used if my string on org.chameleon.Boot.plist key for UseKernelCache value sets to No To do that, simply open Terminal on Applications --> Utility folder, input this command as root steps : a. Login as root, type : sudo -s and press enter or return. it will ask you password, give your mac user password. b. type after you successfully login : kextcache -v 1 -a i386 -a x86_64 -m /System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext /System/Library/Extensions /Extra/Extensions , press enter and quit terminal, reboot. Lets see the result after reboot, if it stuck after reboot and not going into the system, try power off cpu first, and then power back on. if it's also still stuck whether normal boot, verbose boot, save boot, then now you try to make your settings back as usual to make it work fine, and do this second try. Second try 2. After succeed booting with everything works fine, change your org.chameleon.Boot.plist string for key UseKernelCache to Yes because u mention if you set NO it's always been good. after changing this again to yes, then reboot. Thats it. i only do that few tricks to make that warning missing. i don't know what i'm doing, but i just feel strange, because i have 2 graphic card, one is ATI which is working with method 1 , and my NVIDIA card is working with method 2. I also confuse why these happened, but strange because i install os in one cpu with both partition hard disk installed with Lion, one system for Nvidia Card, one system with ATI card, which is seemly different result in handling. if all thise trick doesn't help you , perhaps you have error on your DSDT. try remove DSDT first and try boot without it. even it's not full accelerate, you may try if it still error or not. for me, i never use DSDT because my skill is not good enough compiling dsdt even with tool dsdt patcher or etc..hihihihi hope this thing can help u
  14. arikstress

    Best laptop for Hackintosh out of these

    If you want to ask what is the best, you must revised full specification , what Graphic Card do they use, and you better try search and compare in here : Mac OSX Lion (Nowadays) MacOSX Snow Leopard (Before Nowadays but still good ) about how to install, you can see in this forum
  15. arikstress

    IDeneb 10.5.7

    Hmm, no offense, but i'm suspicious if you come here and offer install distro and give reward with buying that original windows product. be careful though, it's forbidden to post piracy, if your pc brand new and still around 2011, why you still want to install that old system ? better if you waste your money to buy windows original OS with genuine key, i would rather you bought MACOSX LION or SNOW LEOPARD original dvd. You can buy it in apple store around the world. Or you can go to iStore in your country and residents. Because i think it's cheaper than windows os. ps: well, you know windows, how is windows and characteristics. you offer people original key, r u trying to fooling somebody else by giving many windows product key? FYI and AFAIK, it's easy to search genuine key for every windows product Peace
×