Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
U.C.

[HowTo] Enable Quartz 2D Extreme

51 posts in this topic

Recommended Posts

The methods below will work only for accelerated graphic cards ie. Cards which have Driver support. To check goto System Profiler -> Graphic/Display. If it says No Kext Loaded. It means u DONT have driver supoort. As of now, NOT working on All nVidia, 855, 853 etc cards.

Mostly WORKS on ATI Cards and the GMA 900.

 

 

 

Method 1

  • Open com.apple.windowserver.plist
     
  • This file is located in /Library/Preferences
     
  • Change the Quartz2DExtremeEnabled value to YES.

Method 2

 

If you would like to enable Quartz 2D Extreme (see this hint for more info on it), but don't have the VRAM to support it, you can change the minimum requirements by following these steps in the Terminal:

 

$ cd /System/Library/Frameworks/ApplicationServices.framework/Versions\

/A/Frameworks/CoreGraphics.framework/Versions/A/Resources

$ sudo pico Configuration.plist

 

Once in the editor, change these values to match your machine (use System Profiler to get the required details):

 

<dict>

<key>Quartz2DExtremeEnabled</key>

<true/>

<key>Quartz2DExtremeMinimumVRAM</key>

<integer>64</integer>

<key>Quartz2DExtremeMinimumDRAM</key>

<integer>512</integer>

<key>Quartz2DExtremeVendorDisabled</key>

<array>

</array>

</dict>

 

 

 

Both of these methods keep Quartz 2D Extreme enabled across reboots.

Share this post


Link to post
Share on other sites

Dood how fast are u??? Are you seriously that bored in life to keep refreshing this page constantly?............I dont mean to offend you, but you must spend a whole lotta time on this forum!!

 

;)

Share this post


Link to post
Share on other sites

Lol - I just happened to hit it right, I suppose.

 

That and the fact that I hvae an all seeing eye for this forum... ;)

Share this post


Link to post
Share on other sites

If you have installed the developer tools (Xcode), there is a much easier way than "Method 1" to enable Quartz 2D Extreme on supported hardware. Launch Quartz Debug (in performance tools), select Enable Quartz 2D Extreme from the main menu and then Force Quit the Quatz Debug application to make the changes "stick". Apple has choosen not to enable Quartz 2D Extreme for a good reason and that is because it currently does not provide any significant performance advantage and in some cases actually might be slower. Hopefully, Apple will fix whatever is wrong with Quartz 2D Extreme in 10.5 (Leopard). This article at Ars Technica is excellent overview of OS X 10.4 (Tiger) and shows how Quartz 2D Extreme is "supposed" to work: http://arstechnica.com/reviews/os/macosx-10.4.ars/14

 

However, disabling Beam Sync. on OSx86 boxes make a huge difference in performance (but perhaps only on LCD flat panels which have no electron beam to sync, course). Beam Sync. can be disabled using the same Quartz Debug / Force Quit trick but has some quirks, see here for more details and Xbench results: http://forum.osx86project.org/index.php?showtopic=7288

Share this post


Link to post
Share on other sites

I just went to have a go at method one for enabling QE on my Intel 865 board, and I don't even seem to have that plist file in Library/Preferences !

Am I going blind or is there something else I have to do ?

btw. I'm running 10.4.3 8f1111 :)

 

Cheers

Share this post


Link to post
Share on other sites
Method 1
  • Open com.apple.windowserver.plist
     
  • This file is located in /Library/Preferences
     
  • Change the Quartz2DExtremeEnabled value to YES.

Method 2

 

If you would like to enable Quartz 2D Extreme (see this hint for more info on it), but don't have the VRAM to support it, you can change the minimum requirements by following these steps in the Terminal:

 

$ cd /System/Library/Frameworks/ApplicationServices.framework/Versions\

/A/Frameworks/CoreGraphics.framework/Versions/A/Resources

$ sudo pico Configuration.plist

 

Once in the editor, change these values to match your machine (use System Profiler to get the required details):

 

<dict>

<key>Quartz2DExtremeEnabled</key>

<true/>

<key>Quartz2DExtremeMinimumVRAM</key>

<integer>64</integer>

<key>Quartz2DExtremeMinimumDRAM</key>

<integer>512</integer>

<key>Quartz2DExtremeVendorDisabled</key>

<array>

</array>

</dict>

Both of these methods keep Quartz 2D Extreme enabled across reboots.

I have tested this on 855GME with 15MB VRAM and 512MB Total System RAM.

Works perfect. dont know about xBench. But animations, GUI etc are much smoother and nicer.

i have an 855gm and i dont seem to have com.apple.windowserver.plist in /Library/Preferences... so i tried method 2 and i dont know what values to change

Share this post


Link to post
Share on other sites

Method 2 is by far the easiest. I also didnot have the plist in my /Library/Pref...

 

My 855 has 15 mb vram and my ram is 512 mb but is shared with the video. So heres what i did

 

1)Logged in as root.

(I dont remeber wht i did. Though if u want PM me, i could help u out.)

 

2)Browsed to /System/Library/Frameworks/ApplicationServices.framework/Versions\

/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/

 

3)Used Textedit to open Configuration.plist

 

4) Changed the following

 

<dict>

<key>Quartz2DExtremeEnabled</key>

<true/>

<key>Quartz2DExtremeMinimumVRAM</key>

<integer>10</integer> Changed from 64 to 10, just be safe

<key>Quartz2DExtremeMinimumDRAM</key>

<integer>256</integer> Changed from 512 to 256, just be safe

<key>Quartz2DExtremeVendorDisabled</key>

<array>

</array>

</dict>

 

Weeee it works. Anims are better atleast in my opinion. Smoother too.

 

Also heres Quartz Debug.app for all those like me, too lazy to install XCode.

 

Or if u want to just try it

Quartz_Debug.zip

Share this post


Link to post
Share on other sites

Hmm.. well I changed the values in method 2 just incase, even though System Profiler reports 128MB VRAM but I still can't enable QE. It says not supported in QE Debug and in System Profiler.

UC: Is your card actually being detected as an Intel 855?? Mine isn't its just Standard VGA with no kext loaded. Maybe thats my problem ?

 

Cheers

Share this post


Link to post
Share on other sites
Both of these methods keep Quartz 2D Extreme enabled across reboots.

I have tested this on 855GME with 15MB VRAM and 512MB Total System RAM.

Works perfect. dont know about xBench. But animations, GUI etc are much smoother and nicer.

 

I used Method 2 and have noticed a dramatic increase in GUI speed. I do get an occasional artifact - I suppose this is the instability people are refering to - but it's nothing major. I think it's well wortht he effort to try this out...

Share this post


Link to post
Share on other sites

QE= Quartz Extreme. Quartz 2D Extreme is something meant only for 2D not 3D. You can find more info on macosxhints.com

Share this post


Link to post
Share on other sites

I just realized this and am really sorry for this, but Quartz 2D Extreme is not supported on the 855, even after editing of both the plists in Method 1 and 2. Though this does work very well for cards having harware acceleration. The ones that are supported eg ATI

Share this post


Link to post
Share on other sites
QE= Quartz Extreme. Quartz 2D Extreme is something meant only for 2D not 3D. You can find more info on macosxhints.com

 

Ahhhh now it makes sense :graduated:

Thanks for clearing that up, I hadn't realised they were two different things.

Sorry for my ignorance, i'm relatively new to Mac's :hysterical:

 

Thanks

Share this post


Link to post
Share on other sites

Anyone have any luck with this on a GeForce based card? Also, how to get CI running as well? I hate having a 256mb card and being able to have it work with a wonderful OS such as OS X. Any idears?

Share this post


Link to post
Share on other sites
Anyone have any luck with this on a GeForce based card? Also, how to get CI running as well? I hate having a 256mb card and being able to have it work with a wonderful OS such as OS X. Any idears?

 

you will have to wait for the new macvidia driver to come out, and even then im almost sure that QE or CI will not be supported.

Share this post


Link to post
Share on other sites

Thanks for the great tip on using Quartz Debug. I was able to disable Quartz Extreme and Enable Quartz 2D Extreme. Is there anyway to make the settings stay when quitting Quartz Debug?

 

For some reason my system defaults to QE on and Q2DE off.

Share this post


Link to post
Share on other sites

hey,

 

does anyone know where to find (if indeed it exits) the plist for editing similar options as we've changed above, but for Coregraphics or QuarzExtreme? I would be interested in lowering the vram needed on boot...or any similar option.

 

thanks,

 

Urby

Share this post


Link to post
Share on other sites

I, need to Know how i enable Quartz Extreme, in a VIA/S3 Unichrome IGP

 

I need a .Kext or someting else?

A QE Support?

 

Need Heeeeeeeeeeeelppp!!!!

 

Tnx! :thumbsdown_anim:

Share this post


Link to post
Share on other sites

QE gets enabled if u have driver support for ur card

 

Pls correct me if I am wrong

Share this post


Link to post
Share on other sites

according to Quartz debug, my system does not support quartz 2d extreme?! I'm running an AMD 64 system with a Geforce 6800! Any clue?

Share this post


Link to post
Share on other sites
I, need to Know how i enable Quartz Extreme, in a VIA/S3 Unichrome IGP

 

I need a .Kext or someting else?

A QE Support?

 

Need Heeeeeeeeeeeelppp!!!!

 

Tnx! :star_smile:

 

There are no drivers at all for an S3 UniChrome GPU. Your stuck in VESA on OS X x86, for ever.

 

according to Quartz debug, my system does not support quartz 2d extreme?! I'm running an AMD 64 system with a Geforce 6800! Any clue?

 

It would, if the nVidia drivers worked.

Share this post


Link to post
Share on other sites
QE gets enabled if u have driver support for ur card

 

Pls correct me if I am wrong

 

 

correct. a kext is basically (or part of) a driver package.

Share this post


Link to post
Share on other sites

Arg, Quartz 2D extreme will only work on Shader 2.0 or higher capable video cards. NOT just video cards with driver support.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×