Jump to content

LS8v17 # Mac OS X 10.5.7 # GA-P35-DS4 # GA-EP45-DQ6


1,296 posts in this topic

Recommended Posts


LS8v17 is a collection of drivers for installing Mac OS X Leopard from your legally purchased original installation DVD on GA-P35-DS4 and GA-EP45-DQ6 motherboards, but it known to work on some other GA-(E)P-35 and GA-(E)P-45 boards.


By default the system sritical kexts are installed to /Extra/Extensions, so you should be safe to install any updates from Apple. If any hardware stops working after update (audio, network etc.), just reinstall LS8v17.



update: version 2, ICH9R ATA drivers added

update: version 3, Realtek ethernet drivers updated

update: version 4, Jmicron JMB363 driver added

update: version 5, owners enabled on destination volume by default, ALC889a driver updated (by Alex), RTL1xxx returned, JMB363 not installed by default, EFI strings included

update: version 6, more EFI strings, pack updated for Leopard 10.5.2

update: version 7, scripts updated, AppleSMBIOS-27-default included, sleep/shutdown fixed kernel 9.2.0 included

update: version 8, drivers updated, tested with original Apple Leopard 10.5.2 DVD

update: version 9, updated for 10.5.3, old kernels removed

update: version 10, new version for EFI string users

update: version 11, JMicronATA fixed for 4GB RAM, Realtek R1000 1.04

update: version 12, AppleSMBIOS-28, AppleACPIPlatform (aka Reboot fix, thx karaakeha1) updated

update: version 13, first release compatible with GA-EP45-DQ6

update: version 14, interactive install script

update: version 15, major improvements: AppleSMBIOS-33, new IOAHCIFamily, AppleHDA, HDAEnabler

update: version 16, script completely rewritten, compatible with Mac OS X 10.5.7 and Chameleon 2.0 RC1, kexts can be installed to /Extra/Extensions (recommended)

update: version 17, script updated, safe installation



1/ Use any method to install Mac OS X Retail DVD (BOOT-132, GRUB-DFE, install from another Mac etc.)

2/ Install Mac OS X 10.5.7 Combo update

3/ Install Chameleon 2.0 RC1

4/ Install LS8v17 (installation script must be run from its location: ./install-ls8v17.sh)

5/ Reboot



LS8v17: mirror mirror mirror

LS8v16: mirror

LS8v15: mirror mirror mirror mirror mirror mirror

LS8v14: mirror mirror mirror mirror mirror mirror

LS8v12: mirror mirror mirror mirror mirror

LS8v11: mirror mirror mirror mirror



Shutdown Fix

Mac OS X 10.5.6 Mouse Lag Fix



Front panel audio out does not work on GA-P35-DS4 (it's OK on GA-EP45-DQ6).

Power button must be pressed to wake from sleep (it's OK on GA-EP45-DQ6).



gap35ds41054em5.th.png 2107081042ga7.th.jpg 2107081043lw3.th.jpg 2107081044ol2.th.jpg



ls8v14vv5.th.pngthpix.gif img0018il6.th.jpg img0019df2.th.jpg img0020xe5.th.jpg img0021wh5.th.jpg img0022uh8.th.jpg img0023tf1.th.jpg img0024kn9.th.jpg

Link to comment
Share on other sites

LAN worked out of the box for me, no drivers required.


I've tried several installations of leopard, none of them worked for me :

- ToH does give me a strange screen on startup (all black and white and nothing readable). This is just after the file copy is complete, when the computer restart

- IATKOS 1.0i : reboot in a loop

- Kalyway 10.5.1 : same problem as Toh. Maybe this is due to my radeon 2600 XT ....

Link to comment
Share on other sites

The pre- and post-install scripts are well commented, so can be easily edited for your specific needs.


update: version 2, ICH9R ATA drivers added




1/ connect empty HDD to your Leopard machine (Apple or Hackintosh)

2/ create partitions, apply pre-patch (edit parameters!)

3/ insert Leopard DVD, open terminal, enter: cd "/Volumes/Mac OS X Install DVD/System/Installation/Packages"; open OSInstall.mpkg

4/ follow instructions

5/ apply post-patch (edit parameters!)

6/ connect HDD back to your Hackintosh



Ls8 the link has been deleted? Have you got another host?


BTW are you running GUID or MBR partitions?

Link to comment
Share on other sites

file reuploaded to http://www.filefactory.com/file/ba6f9d/

I use guid


Thanks ls8. How did you make the GUID partition bootable. If I try the method using the scripts you posted everything patches installs perfect. It just will not boot after post BIOS Drive detection. I just get a flashing cursor.


The only way I have ever been able to install Leo has been to use a Jas 10.4.8 install which creates a bootable MBR partition and install over that the apply kexts and EFI v8. I have not been able to make it bootable any other way. I see you have the same board and HD as me?


This what I tried to get it to boot:


fdisk -e /dev/rdiskX (my drive)

fdisk: 1> update

Machine code updated.

fdisk:*1> f 1

Partition 1 marked active.

fdisk:*1> w

Device could not be accessed exclusively.

A reboot will be needed for changes to take effect. OK? [n] y

Writing MBR at offset 0.

fdisk: 1> q


Then I blessed:


bless -device /dev/diskXsY -setBoot –verbose



It Still wont boot. Can you help on this What did you do?

Link to comment
Share on other sites

I always partition and format HDD from another OSX install.


The problem was the disk I was using. It was an old Maxtor 80gb Sata. Drive firmware didn't support GUID.


Backed up all the files on one of my WD 500GB AAKS to another drive, then partitioned and installed to it.


Worked first time.


Thanks for the install guide and files ls8.

Link to comment
Share on other sites

Great news. Do you notice any performance gains or improvements?


I hope when the new mac pro's and 10.5.2 are released that some strings for the 8800GT will surface. I really hope!


Not sure about performance gains. Will test later

Link to comment
Share on other sites



Probably my previous post is not well formatted.

I was asking about the high score u get with xbench , seen others on IM with same MB got scores less good.


My HW specs is in my sig. Good luck!

Link to comment
Share on other sites


  • Create New...