Jump to content

Vanilla Hackintosh Alder Lake Z690 with i9-12900K and AMD Radeon RX 6600 - Full DSDT Patched - OpenCore or Clover Bootloader


MaLd0n
 Share

32 posts in this topic

Recommended Posts

Donation with Paypal https://tinyurl.com/r7fchn9

Donation with Binance 0xdbe48ef6b158f1dd0035d7f49555c99e52f72714

Donation with Stripe https://tinyurl.com/2ssnydn6

 

-Tutorial https://tinyurl.com/y2dmt5af

-USB Remap https://tinyurl.com/2p88p2ff

-Request your DSDT on forum https://tinyurl.com/yc2zrkam

 

A very custom DSDT for best experience under macOS. Removed all unused devices, injected all Apple devices, essentials, cosmetics, real improvements. 

 

 

-My Hardware

Mobo MSI PRO Z690-A

Processor i9-12900K

GPU AMD Radeon RX 6600 PowerColor

 

-My DSDT

Untouched 

DSDT.ORIGINAL.zip

 

Full Patched

DSDT.FULL PATCHED.zip

 

 

-ScreenShots

n707ORV.png

c7ElA8S.png

VZalwfy.png

8srCaOz.png

P466Qv9.png

ZrjAXgW.png

7Tsj5Bg.png

RxlXFnj.png

RzGRSoO.png

Z0wITIl.png

kB3oDRT.png

T4D3hqo.png

59P8WCe.png

sv30fTi.png

tSIveNS.png

mdgnKBJ.png

JLIiZrw.png

3xJFdmP.png

 

Credits: Opencore and Clover team, Mieze, RehabMan, etorix, metacollin and many others!

  • Like 11
  • Thanks 3
Link to comment
Share on other sites

  • MaLd0n changed the title to Vanilla Hackintosh Alder Lake Z690 with i9-12900K and AMD Radeon RX 6600 - Full DSDT Patched - OpenCore Bootloader

"12 cores, 20 threads" is 4 cores/threads short of the expected 16 cores, 24 threads for an i9-12900K.

The motherboard is not "Acidanthera", so I guess this result is from your Clover EFI, using SSDT-CPUR-Z690. Correct?

 

Elsewhere, similar results are reported from all i9, i7 and i5 Alder Lake CPUs using OpenCore and SSDT-PLUG-ALT: All E-cores appear in ActivityMonitor, but half of them remain inactive and Geekbench reflects that, showing "(P+E/2) cores, (2*P+E/2) threads" instead of "(P+E) cores, (2*P+E) threads". It's as if OS X created phantom "E-cores hyperthreads" and allocated these in place of every second actual E-core.

  • Like 1
Link to comment
Share on other sites

3vusFRV.jpg

1 hour ago, phantom8 said:

I noticed that your single core speed is a bit low.  Most are getting around 2000 points in Geekbench 5.  Are you using Clover or Opencore when performing benchmark?

some bug with xmp profile ;) 

3 hours ago, etorix said:

Elsewhere, similar results are reported from all i9, i7 and i5 Alder Lake CPUs using OpenCore and SSDT-PLUG-ALT: All E-cores appear in ActivityMonitor, but half of them remain inactive and Geekbench reflects that, showing "(P+E/2) cores, (2*P+E/2) threads" instead of "(P+E) cores, (2*P+E) threads". It's as if OS X created phantom "E-cores hyperthreads" and allocated these in place of every second actual E-core.

ofc

  • Like 1
Link to comment
Share on other sites

11 minutes ago, phantom8 said:

Very nice!  I think I'm gonna get the same motherboard.  Are you satisfying with MSI Pro Z690-A?

ye. but in this case is z690 ud ax. is a second.

Link to comment
Share on other sites

  • 5 weeks later...

hello

I follow your perfect guide and I success to install Monterey on my pc

i9 12900 k

 z690 msi

 with intel internal gpu but I get display 14 mb any solution to get full graphic resolution 963131142_Screenshot2022-01-19at21_21_11.png.a6200e31b5559a39d793e919927cccb8.png

everything working 

Edited by fronskild
Link to comment
Share on other sites

22 minutes ago, fronskild said:

I follow your perfect guide and I success to install Monterey on my pc

this igpu don't have support. u need use one amd card like rx560+

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...
9 hours ago, MifJpnAlphaPlus said:

I admire you for always producing great results. I think Slice wanted to know, was it possible for Clover5144 to use E core? Please let us know!

Use efi clover folder serie 600 from here

https://www.olarila.com/topic/5676-hackintosh-efi-folders-for-all-chipsets-clover-and-opencore/

don't use Configurator for now, just paste into efi partition and go

Link to comment
Share on other sites

  • MaLd0n changed the title to Vanilla Hackintosh Alder Lake Z690 with i9-12900K and AMD Radeon RX 6600 - Full DSDT Patched - OpenCore or Clover Bootloader

I have almost the same configuration as yours but my multicore score is around 13408.

Specs:

MSI PRO Z690-A DDR4

Intel Core i9-12900K - Processor 3.2 GHz 16 core

RX 580 8 GB

 

Running 12.2

 

two question's:

1-Why is system showing and using only 12 cores?
2-Why is my Geekbench score much lower than yours?

I used your config files, SSDT and DSDT

 

Thanks

Edited by Edkroket
Link to comment
Share on other sites

1 hour ago, MaLd0n said:

Yes

I that case I will extract virgin DSDT from mobo and wil send it at orilia site for you. I used both SSDT-OLARILA600.aml and your patched DSDT.

I thought my system won't boot without the DSDT?

 

Thanks

Link to comment
Share on other sites

 Share

×
×
  • Create New...