Jump to content
73 posts in this topic

Recommended Posts

@ludufre

 

So...

 

This morning I updated Clover (freshly installed it on my EFI after deleting it all and keeping a copy) and then pulled over my SSDT, my kexts & Config and then updated the Kexts to all the latest versions.. and everything booted and is still working great (a bit faster to boot actually)..

 

Is it possible/advised to go ahead and use the built in system updater to upgrade to the latest Catalina from 10.14.6 Mojave where I am now?

Edited by TurbineSeaplane
4 hours ago, Hunterx755 said:

Hey Friend How did u manage to make work the iMessage and facetime

 

It has always worked. Open your config.plist in Clover Configurator and generate new serials then restart.

 

5 minutes ago, TurbineSeaplane said:

@ludufre

 

So...

 

This morning I updated Clover (freshly installed it on my EFI after deleting it all and keeping a copy) and then pulled over my SSDT, my kexts & Config and then updated the Kexts to all the latest versions.. and everything booted and is still working great (a bit faster to boot actually)..

 

Is it possible/advised to go ahead and use the built in system updater to upgrade to the latest Catalina from 10.14.6 Mojave where I am now?

 

I strongly recommend creating an installation flash drive first. If it starts normally then you are safer if you cannot start your current installation.

About using the system updater, I always prefer to do a clean install.

Edited by ludufre
  • 2 weeks later...

Hi I have the same hardware as you except the graphic card, which I have rx570 installed. The audio for mine is not working unless I use HDMI monitor for audio output or bluetooth headset. I wonder do you have encounter this problem before when installing Catalina?

Edited by paperbag
On 12/25/2019 at 12:55 PM, paperbag said:

Hi I have the same hardware as you except the graphic card, which I have rx570 installed. The audio for mine is not working unless I use HDMI monitor for audio output or bluetooth headset. I wonder do you have encounter this problem before when installing Catalina?

 

Sorry, I never used dGPU.

On 12/25/2019 at 9:55 PM, paperbag said:

Hi I have the same hardware as you except the graphic card, which I have rx570 installed. The audio for mine is not working unless I use HDMI monitor for audio output or bluetooth headset. I wonder do you have encounter this problem before when installing Catalina?

 

I have RX580 installed and have no issues whatsoever with the audio.

On 12/27/2019 at 9:30 AM, ludufre said:

 

Sorry, I never used dGPU.

@ludufre I have almost the same setup as your build just the wifi card is different. I manage to get the wifi card to work. But I just notice the usb type-c don't work. I can charge my iPhone and iPad but the system will never recognise or detect the device connected to it. No data transfer what so ever. Any advice? The usb type-c work well under High Sierra before.

11 hours ago, saifuru said:

@ludufre I have almost the same setup as your build just the wifi card is different. I manage to get the wifi card to work. But I just notice the usb type-c don't work. I can charge my iPhone and iPad but the system will never recognise or detect the device connected to it. No data transfer what so ever. Any advice? The usb type-c work well under High Sierra before.

manage to make the usb type-c working by changing the SMBIOS but the Airplay still not working and still cannot use sidecar.

Already try as per advise but still usb type-c and sidecar won't work on SMBIOS iMac 19,1. I switch to iMac 19,2 and only the usb type-c is working but still can't get sidecar to work. I have same motherboard and cpu as yours, but with RX580 gpu. The GPU is working but sometimes during login, wake up and shutdown, the gpu fan spin like crazy for about a minute which freaking me out. Its sound like jet engine or something. I install Mojave on my other NVME (using your guide), same thing happen, usb type-c only working with iMac 19,2 SMBIOS and the system much more stable than Catalina. I think I will use Mojave as my main system while figuring out the problem with Catalina... 

On 12/25/2019 at 12:55 PM, paperbag said:

Hi I have the same hardware as you except the graphic card, which I have rx570 installed. The audio for mine is not working unless I use HDMI monitor for audio output or bluetooth headset. I wonder do you have encounter this problem before when installing Catalina?

 

Had the same problem. So I followed the instructions from AppleALC developer.

 

Quote

Note: It is necessary to set value layout-id in Devices-Properties or boot arguments.
HDEF device locations PciRoot, gfxutil may be used: gfxutil -f HDEF
Do not use renaming HDAS to HDEF, B0D3 to HDAU, etc.
Disable FixHDA, AddHDMI and UseIntelHDMI.
Set Devices → Audio → Inject = NO (Necessarily type string!)

 

So basically remove those Inject and add alcid=1 (or your layout) to boot args.

 

  • 2 weeks later...

Regarding the Airplay and sidecar issue, I think it has nothing to do with my wifi card. I manage to make all function work using BrcmPatchRAM3.kext. It had something to do with iGPU setting in BIOS. I disable iGPU and set my dGPU as a primary GPU in BIOS because I'm using RX580 as display output. Airplay and sidecar don't work when I set iGPU to disable or auto. It need to set as enable. The problem is, if I set iGPU enable while maintain the dGPU as primary output, Catalina won't boot and the system will restart. Need to find a solution for this.

Edited by saifuru
  • 2 weeks later...

updated: everything going well after recreated the usb installer from a real mac....

 

hello guys, im following this guide to do fresh install on same setup except my processor is 8700 not 8700K...build in graphic processor...im able to run the setup but when come to the final, the screen is with the loading bar (full) and mouse cursor....and it wouldn't do anything else...can some one take a look on my config and efi folder to pin point what am i missing..thanks

config.plist

EF

Edited by blackjedi1345

I was able to get sound working by looking at your mojave guide and applying these settings in clover, ordered another Broadcom card and going to see if it was defective. 

DEVICES Page

- Change: Audio - Inject - 11

- Uncheck: Audio - AFGLowPowerState

- Uncheck: Audio - ResetHDA

  • 2 weeks later...

Thanks. I have one question. When i type: sudo kextcache -i / 

The output is:

Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb4ebcf0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC.kext/", ID = "org.netkas.driver.FakeSMC" }
Kext with invalid signature (-67030) allowed: <OSKext 0x7fd6cb4e9ce0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/SmallTree-Intel-211-AT-PCIe-GBE.kext/", ID = "com.smalltree.driver.SmallTreeIntel82576" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb4e3460 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC_CPUSensors.kext/", ID = "org.hwsensors.driver.CPUSensors" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb4c51f0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/VirtualSMC.kext/", ID = "as.vit9696.VirtualSMC" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb40c7e0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/Lilu.kext/", ID = "as.vit9696.Lilu" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb4b6cb0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC_ACPISensors.kext/", ID = "org.hwsensors.driver.ACPISensors" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb658210 [0x7fff8f924690]> { URL = "file:///Library/Extensions/USBInjectAll.kext/", ID = "com.rehabman.driver.USBInjectAll" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb694bb0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/SMCProcessor.kext/", ID = "as.vit9696.SMCProcessor" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb5016a0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/WhateverGreen.kext/", ID = "as.vit9696.WhateverGreen" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb500ac0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/SMCSuperIO.kext/", ID = "ru.joedm.SMCSuperIO" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb45ac60 [0x7fff8f924690]> { URL = "file:///Library/Extensions/IntelMausiEthernet.kext/", ID = "com.insanelymac.IntelMausiEthernet" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb430260 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC_LPCSensors.kext/", ID = "org.hwsensors.driver.LPCSensors" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb60c970 [0x7fff8f924690]> { URL = "file:///Library/Extensions/CodecCommander.kext/", ID = "org.tw.CodecCommander" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb6045e0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/AppleALC.kext/", ID = "as.vit9696.AppleALC" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fd6cb40e2b0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC_SMMSensors.kext/", ID = "org.hwsensors.driver.SMMSensors" }
Invalid signature -67030 for kext <OSKext 0x7fd6cb4e9ce0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/SmallTree-Intel-211-AT-PCIe-GBE.kext/", ID = "com.smalltree.driver.SmallTreeIntel82576" }
kxld[as.vit9696.VirtualSMC]: The following symbols are unresolved for this kext:
kxld[as.vit9696.VirtualSMC]: 	KernelPatcher::routeMultipleLong(unsigned long, KernelPatcher::RouteRequest*, unsigned long, unsigned long long, unsigned long, bool, bool)
Link failed (error code 5).
Prelink failed for as.vit9696.VirtualSMC; omitting from prelinked kernel.
Can't use /Library/Extensions/VirtualSMC.kext - not linked.
Prelink failed for as.vit9696.SMCProcessor; omitting from prelinked kernel.
Can't use /Library/Extensions/VirtualSMC.kext - not linked.
Prelink failed for ru.joedm.SMCSuperIO; omitting from prelinked kernel.
KernelCache ID: 25212C1851C07B5870B65C0AA17EE091
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51bd33540 [0x7fff8f924690]> { URL = "file:///Library/Extensions/Lilu.kext/", ID = "as.vit9696.Lilu" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51bd36480 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC_SMMSensors.kext/", ID = "org.hwsensors.driver.SMMSensors" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51bd502d0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/AppleALC.kext/", ID = "as.vit9696.AppleALC" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51bdca4d0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/IntelMausi.kext/", ID = "as.acidanthera.mieze.IntelMausi" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51bd628f0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/CodecCommander.kext/", ID = "org.tw.CodecCommander" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51be01db0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC_LPCSensors.kext/", ID = "org.hwsensors.driver.LPCSensors" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51b8035e0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/IntelMausiEthernet.kext/", ID = "com.insanelymac.IntelMausiEthernet" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51b815560 [0x7fff8f924690]> { URL = "file:///Library/Extensions/SMCSuperIO.kext/", ID = "ru.joedm.SMCSuperIO" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51b81ca50 [0x7fff8f924690]> { URL = "file:///Library/Extensions/WhateverGreen.kext/", ID = "as.vit9696.WhateverGreen" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51b822460 [0x7fff8f924690]> { URL = "file:///Library/Extensions/SMCProcessor.kext/", ID = "as.vit9696.SMCProcessor" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51b82dc80 [0x7fff8f924690]> { URL = "file:///Library/Extensions/USBInjectAll.kext/", ID = "com.rehabman.driver.USBInjectAll" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51b85c970 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC_ACPISensors.kext/", ID = "org.hwsensors.driver.ACPISensors" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51b869690 [0x7fff8f924690]> { URL = "file:///Library/Extensions/VirtualSMC.kext/", ID = "as.vit9696.VirtualSMC" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51b877f30 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC_GPUSensors.kext/", ID = "org.hwsensors.driver.GPUSensors" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51b88a7a0 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC_CPUSensors.kext/", ID = "org.hwsensors.driver.CPUSensors" }
Kext with invalid signature (-67030) allowed: <OSKext 0x7fc51b88c990 [0x7fff8f924690]> { URL = "file:///Library/Extensions/SmallTree-Intel-211-AT-PCIe-GBE.kext/", ID = "com.smalltree.driver.SmallTreeIntel82576" }
Kext with invalid signature (-67062) allowed: <OSKext 0x7fc51b88f450 [0x7fff8f924690]> { URL = "file:///Library/Extensions/FakeSMC.kext/", ID = "org.netkas.driver.FakeSMC" }

 

Is this normal or is it a mistake?

 

  • 3 weeks later...
On 12/12/2019 at 6:40 PM, TurbineSeaplane said:

@ludufre

 

So...

 

This morning I updated Clover (freshly installed it on my EFI after deleting it all and keeping a copy) and then pulled over my SSDT, my kexts & Config and then updated the Kexts to all the latest versions.. and everything booted and is still working great (a bit faster to boot actually)..

 

Is it possible/advised to go ahead and use the built in system updater to upgrade to the latest Catalina from 10.14.6 Mojave where I am now?

@TurbineSeaplane have you upgraded your install? what method did u use?

@ludufre hi, did everything according to your guide. right now I can see 2 things missing:

1. sound - it doesn't even recognise my sound card

2. wifi - no card in network list

 

my setup is very similar to yours:

- Gigabyte z370N

- i5-8500

 

I was previously running Mojave installed to by your directions, everything was working great!

https://www.insanelymac.com/forum/topic/335847-guide-gigabyte-ga-z370n-wifi-i7-8700k-uhd-630-mojave-10146/

 

On 3/21/2020 at 2:06 AM, kisyu said:

@ludufre hi, did everything according to your guide. right now I can see 2 things missing:

1. sound - it doesn't even recognise my sound card

2. wifi - no card in network list

 

my setup is very similar to yours:

- Gigabyte z370N

- i5-8500

 

I was previously running Mojave installed to by your directions, everything was working great!

https://www.insanelymac.com/forum/topic/335847-guide-gigabyte-ga-z370n-wifi-i7-8700k-uhd-630-mojave-10146/

 

Hi guys,

so I've managed to solve the sound issue by myself and so the issue with the wifi remains. its not that critical for me as I'm using ETH which is working great.

In the meantime, another problem I've noticed - when the Mac wakes up from sleep it usually crashes.

How do I work on that?

  • 4 weeks later...
On 1/14/2020 at 8:36 AM, saifuru said:

Regarding the Airplay and sidecar issue, I think it has nothing to do with my wifi card. I manage to make all function work using BrcmPatchRAM3.kext. It had something to do with iGPU setting in BIOS. I disable iGPU and set my dGPU as a primary GPU in BIOS because I'm using RX580 as display output. Airplay and sidecar don't work when I set iGPU to disable or auto. It need to set as enable. The problem is, if I set iGPU enable while maintain the dGPU as primary output, Catalina won't boot and the system will restart. Need to find a solution for this.

I've solved iGPU kernel panic editing patch into the info.plist. If you're interested pm me 

hello.  i followed the guide and got my setup working 95%.  the remaining item is speedstep.  my geek bench 5 score ~ 7000.

is speedstep or native power mgmt working in my build?  I'm using the 8700k @ stock speed.

any of the ACPI or SSDT steps I should recheck?

 

thanks.

 

dh22r 

7 hours ago, dh22r said:

hello.  i followed the guide and got my setup working 95%.  the remaining item is speedstep.  my geek bench 5 score ~ 7000.

is speedstep or native power mgmt working in my build?  I'm using the 8700k @ stock speed.

any of the ACPI or SSDT steps I should recheck?

 

thanks.

 

dh22r 

 

Certainly your speedstep is activated. See my:

 

https://browser.geekbench.com/v5/cpu/1857029

1 hour ago, ludufre said:

 

Certainly your speedstep is activated. See my:

 

https://browser.geekbench.com/v5/cpu/1857029

 

hmm...  your geekbench 5 scores of 1129/5943 are inline with mine.

 

in your catalina guide, you'd mentioned the geekbench performance with your UEFI stock and 5GHZ profiles.

"It's two versions. One stock (Geekbench 4: 5840/27384) and another with overclock [5.0 GHz] (Geekbench 4: 6360/30348)"

 

i didn't run geekbench 4 on my build to see the scores.  has geekbench 5 testing methods "flattened" the scores of prior versions?

 

thanks again.

 

dh22r

×
×
  • Create New...