Jump to content
ludufre

[GUIDE] Gigabyte GA-Z370N-WIFI + i7 8700K + UHD 630 + Catalina 10.15.5

68 posts in this topic

Recommended Posts

Installing macOS Catalina 10.15.5 on Gigabyte Z370N WIFI + i7 8700K + UHD 630

image.thumb.png.5ae699513a2e4e5fb095b93757238fb2.png



Changelog:

 

06/10/2020 14:51h GMT-0

- Fixed dual screen issue in 10.15.5. Thanks @khamsakamal48

 

05/27/2020 20:02h GMT-0

- Update instructions 10.15.5.

 

03/24/2020 20:23h GMT-0

- Update instructions 10.15.4.

 

01/30/2020 23:54h GMT-0

- Update instructions 10.15.3.

 

12/11/2019 03:58h GMT-0

- Update instructions 10.15.2.

- Updated EFI folder attached.

 

11/30/2019 18:03h GMT-0

- Changed Device -> Graphics platform to fix dual HDMI monitor.

- Updated EFI folder and config.plist

 

11/29/2019 21:28h GMT-0

- Added full EFI folder as requested.

 

11/27/2019 02:33h GMT-0

- Added BIOS profiles for ease.

 

11/25/2019 22:45h GMT-0

- Fixed wrong ethernet link (IntelMausi.kext).

- Thanks to @MiMoHo

 

11/24/2019 04:56h GMT-0

- First version.

 

What works and what does not
 
- Processor: Intel Core i7-8700K -> Tick.png Work. All SpeedStep stages.
- Video Card: Intel UHD 630 -> Tick.png Work. QE/CI and Metal.
- Chipset: Intel Z370 -> Tick.png Work.
- HDMI 2.0 (1st) -> Tick.png Work.

- HDMI (2nd) -> Tick.png Work.

- DP -> Tick.png Work.

- Audio: ALC1220 -> Tick.png Work.

- HDMI Audio -> Tick.png Work.
- WiFi/Bluetooth -> Cross.png Not work. Replaced with BCM94360CS2.

- Ethernet (1st) -> Tick.png Work.
- Ethernet (2nd) -> Tick.png Work.
- USB3.0 -> Tick.png Work.
- Sleep -> Tick.png Work.

- Airdrop, Handoff, Instant Hotspot and Continuity -> Tick.png Work after replaced wireless.

 

 
Todo

 

- Empty

 

What you need to install
 

- Running install of macOS
- One USB flash drive of 8GB or bigger
- macOS Catalina install app
- Clover EFI

- Clover Configurator

- Some KEXTs and SSDT patches


How create create the install flash drive
 
Prepare install flash drive


Format the flash drive with GUID partition mapping and name it "Install".

- Open Disk Utility.
- Click in View, then "Show All Devices".
- Select the destination flash drive, then Erase.
- Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map

 

Create install flash drive

Open terminal and run this command:

sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction

 This will take about 30 minutes.

 

image.png.dbfbb044438583c128d2b973252bc02e.png


Install bootloader

 

Download the CloverEFI from official repository (used 5099) and install only with these options on "Install macOS Catalina":

 
- Install for UEFI booting only
- Install Clover in the ESP
- UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)

- UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)

- UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)

- UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)

- UEFI Drivers - Additional drivers - NvmExpressDxe (If you are going to use NVMe)

 

FileVault 2

 

If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.

Follow instructions bellow:

 

From current Clover installation, check these options to USB keyboard/mouse work on password screen:

- UEFI Drivers - Human Interface Devices - UsbKbDxe

- UEFI Drivers - Human Interface Devices - UsbMouseDxe

 

After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.

 

Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases

We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.

OR download attached bellow.

 

Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/

 

That's it! FileVault 2 will work without problems.

 

1706109418_CapturadeTela2019-11-24as02_09_11.png.53d232f32fb3b4026db757ab3ea2eff1.png564245242_CapturadeTela2019-11-24as02_09_16.png.08bad629cb449d2ffb7cedc4904594dd.png1196653437_CapturadeTela2019-11-24as02_09_40.png.cdfeb89253cd5a676b2b0a507745a424.png

 

 

 

Make things works
 

After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.

 

- Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below according to your processor version.

- Put all SSDT-*.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/

 

Generate your Serial, MLB and SmUUID

 

- Open the replaced config.plist with Clover Configurator (used 5.8.0.0)

- Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.

 

Copy the Clover Configurator to flash drive because you will need later.

 

Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/Other/

 

- Download the VirtualSMC.kext, SMCProcessor.kext, SMCSuperIO.kext and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/). I used the version 1.0.9.

Download the Lilu.kext from here. I used the version 1.3.9.

Download the WhateverGreen.kext from here. I used the version 1.3.4.

Download the AppleALC.kext from here. I used the version 1.4.3.

Download the USBInjectAll.kext from here. I used the version 2018-1108.

- Download the IntelMausi.kext from here. I used the version 1.0.2.

- Download the SmallTree-Intel-211-AT-PCIe-GBE.kext attached bellow to enable second ethernet.

 

Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.

 

Wifi and Bluetooth (BCM94360CS)

 

Works out of box (plug 'n' play).

 

 

Now you can start the installation without problem (I guess).

 

 

How install

 

UEFI Setup Configuration and Installation

UEFI configuration
 

My BIOS is F10 (I use an 8th generation processor, so I don't need to upgrade)

 

You can configure manually or load my BIOS profile.

 

Manually:

- Shutdown and insert the flash.
- Power on with DEL pressed to enter BIOS setup.
- Change value: BIOS - CSM Support to Disabled
- Change value: BIOS - Secure Boot to Disabled
- Change value: Peripherals - Initial Display to IGP
- Change value: Chipset - VT-d to DISABLE
- Change value: Chipset - Internal Graphics to ENABLE
- Save & Exit Setup

 

or, BIOS profile

You can use one of my BIOS profiles attached bellow.

It's two versions. One stock (Geekbench 4: 5840/27384) and another with overclock [5.0 GHz] (Geekbench 4: 6360/30348)

- Put the profile in the root of the flash drive at EFI partition.

- Restart with DEL pressed to enter BIOS setup.

- Go to Save & Exit.

- Select Load Profiles.

- Select last option and then the flasdrive in the list.

- And finally choose MACOS_STOCK or MACOS_5GHZ.

- Save & Exit Setup

 

Then:

- Now, hold the F12

- In the list, select your flash drive.

Choose the flash drive (white icon).

 

The installer will start. 



Format destination disk

Format the disk with GUID partition mapping and name it "Macintosh".

- Select Disk Utility in the list, then press Continue.
- Click in View, then "Show All Devices".
- Select the destination Disk, then Erase.
- Name: HD, Format: APFS and Scheme: GUID Partition Map

Close Disk Utility.

Select "Install macOS", then Continue.
Follow instructions in screen.

After install

After first part install the system will reboot. Maybe you have to press ESC again and select the flash drive.
 

Choose the internal disk (gray hdd icon) if not already selected.


The second part of the installation will begin. This will take 16 minutes.


 

Post installation
 

Bootloader


When the second part of install finish, the system will reboot again.

After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

Open the Clover Configurator from flash drive that you copied before.

Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)

 

Copy the EFI folder to desktop.

 

Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.

 

Move the EFI folder from Desktop to EFI partition of the internal disk.

 

Eject the flash drive.

 

Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:

sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/
sudo chmod -R 755 /Library/Extensions
sudo chown -R root:wheel /Library/Extensions
sudo kextcache -i /

Restart the system.

 

Last thing

 

Run this command in Terminal to disable hibernation (doesn't work in macOS):

sudo pmset -a hibernatemode 0

 

 

It's done!

 

 

System Updates

 

10.15.2

 

Before install, update the following kexts:

- Lilu.kext. I used version 1.4.0.

WhateverGreen.kext. I used version 1.3.5.

- AppleALC.kext. I used version 1.4.4.

(all download links above)

 

Download the latest CLOVERX64.efi.zip build. I used version 5100.

Mount EFI partition and unzip to:

- /Volumes/EFI/EFI/CLOVER/CLOVERX64.efi

- /Volumes/EFI/EFI/BOOT/BOOTX64.efi (rename the copy of CLOVERX64.efi to BOOTX64.efi

 

Install update. Will reboot at least four time.

 

 

10.15.3

 

Updated with success without changing anything.

 

 

10.15.4

 

Before install, update the following kexts:

- Lilu.kext. I used version 1.4.2.

WhateverGreen.kext. I used version 1.3.7.

- AppleALC.kext. I used version 1.4.7.

- VirtualSMC.kext. I used version 1.3.7.

(all download links above)

 

Download the latest CLOVER installer. I used version 5107.

- Install respecting the configuration mentioned above in "Install bootloader" section.

 

Install update. Will reboot at least four time.

 

 

10.15.5

 

- Same as usual, update all Kexts and Clover.

- Install Update, reboot.

 

If you like me, I had a problem with two monitors. I needed to roll back two Kexts of video from 10.15.4: FixGraphics10.15.5.zip

After replace, fix permissions and cache. Change AAPL,ig-platform-id to 00009B3E to fix it.


 
And last but not least
 
I would like to thank the following community members, by making these dream possible:
@crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @khamsakamal48 and all others members involved directly or indirectly.

 

Attachments

 

config.plist v2.zip

EFI v4.zip

Filevault 2 additional drivers.zip

SmallTree-Intel-211-AT-PCIe-GBE.kext.zip

SSDTs.zip

MACOS_5GHZ

MACOS_STOCK

 

 

 

Edited by ludufre

Share this post


Link to post
Share on other sites
Advertisement

I had everything working fine before with Mojave... when I updated to 10.15.1 everything works except for bluetooth. I updated to the latest on everything and even used the brcmpatchram3 and no luck.

Share this post


Link to post
Share on other sites

Hi @hatemjaber. I could never get bluetooth to work int he past, even in Mojave. The only solution that I found is use native wifi like BCM94360CS2 that I use. With that I have all bluetooth features working perfecltly, even personal hotspot.

 

But, bluetooth in Catalina in unsupported wireless cards is a know problem. (like DW1560, some people get work and some not)

Edited by ludufre

Share this post


Link to post
Share on other sites

I'll try to help you, even though I never made it work ... Let's go:

 

From what I understand, your wifi already works, right?
So you already have AirportBrcmFixup.kext, correct?

 

For bluetooth to work, theoretically we have to have the following kexts in /S/L/E:

 

BrcmPatchRAM3.kext

BrcmBluetoothInjector.kext

BrcmFirmwareRepo.kext

 

You have, right?

 

Try and older version that some peopply said is better: https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=335073

Share this post


Link to post
Share on other sites
On 11/28/2019 at 2:35 AM, ludufre said:

11/27/2019 02:33h GMT-0

- Added BIOS profiles for ease.

 

Hi ludufre

 

I have a very similar set up and am having problems getting ALC1220 sound to work. Would it be possible to share your EFI folder so I can compare? 

 

Thanks and kind regards.

Share this post


Link to post
Share on other sites

11/29/2019 21:28h GMT-0

- Added full EFI folder as requested.

 

@gcc1 don't forget to open the config.plist with Clover Configurator and generate Serial, MLB, etc.

 

On 11/24/2019 at 2:24 AM, ludufre said:

Generate your Serial, MLB and SmUUID

 

- Open the replaced config.plist with Clover Configurator (used 5.8.0.0)

- Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.

 

Share this post


Link to post
Share on other sites

11/30/2019 18:03h GMT-0

- Changed Device -> Graphics platform to fix dual HDMI monitor.

- Updated EFI folder and config.plist

 

1667653688_CapturadeTela2019-11-30as15_07_44.png.216e24a43ff1d673d50edbd9f0a44044.png

Edited by ludufre

Share this post


Link to post
Share on other sites

Thanks a lot for your guide @ludufre!

 

I have a Gigabyte Z370 Gaming 7, and using your config.plist (with my own 'legit' Serial!) totally fixed my 8700K's IGP output to my 4K Dell monitor.  I had figured out how to fix the "pink" image by setting the display with Whatevergreen to "HDMI" instead of DisplayPort, but your config got Mac OS to recognize the Display as 4K and now the display scaling looks great!

 

I'm using the IGP as a hack while I decided what AMD card to get.  I do miss the RTX 2070 I can use in Windows a little!

 

I'm using a "IOGEAR Bluetooth 4.0 USB Micro Adapter" for Bluetooth and handoff and copy/paste work perfectly, for what that's worth.

 

I also have a ALC1220 like @gcc1 and the sound isn't quite right.  It has "Headphone output," two 2 Line outs, and a Digital Out, but "headphone output" sends it out the "line out."  I will experiment with a different "layout" from https://github.com/acidanthera/AppleALC/tree/master/Resources/ALC1220 and see that helps, like 27 or 28.  But I have a FIIO E10K DAC which works fine, so it's not an emergency.

 

I just wanted to thank you!  Thanks so much for taking the time to post and share.  I've got 4 kids so time to reboot and test config.plist settings is very precious :)

Share this post


Link to post
Share on other sites
14 minutes ago, ludufre said:

 

Links is not dead. Did you click when you were not logged in? 

 

Oops! Sorry, my bad. I did not realize I had to be logged in.

Share this post


Link to post
Share on other sites

May I ask what would change if I were to use my RX 570 instead of iGPU?

 

I am on a fully functional Mojave build with this Mobo and 570 and just mapping out my move to Catalina and eventual sourcing of a 5700xt

Share this post


Link to post
Share on other sites

Hi @TurbineSeaplane.

 

I have never used AMD cards.

 

But if you already have a perfectly working installation on Mojave, theoretically you just need to update Kexts/Bootloader and keep the same config.plist.

 

Take a test: Create the installation stick with your config.plist and the authorized Kexts and see if you can start the installer.

Share this post


Link to post
Share on other sites
1 minute ago, ludufre said:

Hi @TurbineSeaplane.

 

I have never used AMD cards.

 

But if you already have a perfectly working installation on Mojave, theoretically you just need to update Kexts/Bootloader and keep the same config.plist.

 

Take a test: Create the installation stick with your config.plist and the authorized Kexts and see if you can start the installer.


excellent idea...

 

when you say “authorized kexts” - I’m confused. From in your guide?  Or ones I use on Mojave?

Share this post


Link to post
Share on other sites
Just now, TurbineSeaplane said:

when you say “authorized kexts” - I’m confused. From in your guide?  Or ones I use on Mojave?

 

Sorry, it was the spell corrector. The right word is "updated".

 

Take a test: Create the installation stick with your config.plist and the updated Kexts and see if you can start the installer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      macOS Installation
      See macOS installation steps here See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the SSDT-UIAC.aml here) Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers AptioMemoryFix Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here  
      Current Versions
      Catalina 10.15.5.02 Clover (UEFI) r5119 Lilu.kext 1.4.5 WhateverGreen.kext 1.4.0 AppleALC.kext 1.5.0 IntelMausi 1.0.3 (Not IntelMausiEthernet)  
      Credits To be provided
       
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk800 G4 Mini - Rev 0.91.zip
    • By jlrycm
      Finally I was able to move from Clover to OpenCore 0.5.9 on my hackintosh build. It boots really fast and even with the famous boot chime. I attached the OC config.plist for anyone who wants to give it a try. I followed the Github step-by-step guide:
      Haswell · GitBook
        dortania.github.io My build specs are:
      Gigabyte Z97-HD3 rev. 2.1, i5-4690K, 16 GB RAM, Gigabyte Aorus AMD RX 580 8gb GPU.
      I used OpenCanopy to give a Clover feeling to the OpenCore boot menu (I don’t like list-type boot menus). 
      config.plist
    • By verrwirung
      Hi!
      Just finished installing hackintosh Catalina on my Razer Edge Pro tablet.
      I need help making the touchscreen work.
      I've tried installing VoodooI2C kexts (I2cHID, I2CELAN, etc) but still not working.
      can someone help me on this project? it would be really really be much appreciated 
       
      Thanks!
       



    • By UsamaShahid036
      I was previously using clover with Catalina and on that everything worked very good, now i shifted to Opencore everything is working on laptop except trackpad, from windows is searched that my trackpad is "Microsoft HID" and i have tried all the VoodoI2 kexts, seperately like VoodoI2CHID, VoodoI2CELAN, VoodoI2CSynaptics but trackpad won't work. Previously i was using VoodoI2CHID on clover and trackpad was working very fine.
      Kindly help me in that, a little help would be appreciated.
       I have attached my OpenCore EFI Folder
       
      OC EFI.zip
    • By ltooz_audis
      So, I cheap out and got a $20 dw1820a for my laptop hackintosh - EliteBook 820 G3 macOS Catalina 15.5. Clover wouldn't boot or work properly, OpenCore works perfectly with some adjustment.
      https://www.youtube.com/watch?v=46hanWDwZLA
      Cheers,
      Louis
×