Jump to content

New Ralink RT2500-USB Driver [a la Airport Driver] - V 1.5


381 posts in this topic

Recommended Posts

Hey guys,


One of the beauty of Open Source Drivers that it would work just about any platform. Thats the beauty of Ralink Drivers [RT2500-USB]. It works on Linux , MacOS X and of course on Windows. But there were few problems on the MacOS X port , particularly on hackintohses . Certainly it had some good stuff , enabled us to connect to Wireless Networks , but then the GUI was sort of crippled and it lacked the 'Airport' thingy , the cooling icon. So what I did was to modify the GUI , the driver and added RT2500Replug so that all these issues would be fixed and we could enjoy a better Driver !.



Features :-


1. A New Makeover

The USB now comes with new makeover. Now I have fixed some of the problems in the GUI and edited the menu preferences [removed all the unwanted stuff such as preferences] and I also have changed the Icons and the application Icon to be like OSX Style [a la Airport/OSX Style]. These are little cosmetic changes. More to come of course !



2. RT2500Replug - Fix It !

I have included the in-famous RT2500Replug that fixes the USB Plugging-in and Plugging out dilemma for RT2500-USB Users. So , you dont have to re-plug it each time you use OSX. It would just work instead. Its a pretty nifty patch , of course you got to thank the original developer.




3. Packet Compression

This is something new to the RT2500 World. The driver actually supports Packet Compression , but it was not implemented for a reason. So I fixed it by turning it on and adding an option in the GUI. Certainly , it helps to 'speed' up the overall network performance.It does it by sending the data packets in '1Mbps' Mode. Certainly its not ideal for transferring large files. But if your Signal Strength is low , then you might want to try to use Packet Compression. Oh yeah , you might have occasional kernel panics , thats one of the drawbacks. -----USE THIS AT FEATURE AT YOUR OWN RISK--------



4. Airport Detection [Menu] - BETA-

This is something new , many of us do want that cute little tiny Airport logo in their menu bar. So I have included it in my package installer. Notice that its still new and beta , and sometimes it does not work right. I am working on it. It might work or might not for you


5. SuperG+ [bETA]

This enables SuperG+ Mode on most [err just about any supported RT2500 Devices]. It gives you 108Mbps/72Mbps/22Mbps [Theoretically]. Pretty much it boosts network transfers on supported routers only









1. Download the program from





2. Install it. Once its done , repair its permissions using disk Utility . Once its fixed , you would need to build kext-cache back [To do this , press F8 before the Darwin X86 booting screen and type -f in the boot prompt]


3. Download the V 1.5 from http://www.rakis.net/~prasys/ralinkv015.zip


Alternate download location:




Change log


Changelog - version 0.15

1. New Ralink Tool [A Total New Look]

2. 802.11G+ [enables 802.11G+ Booster]

3. Optimisation ....A lot of them this time. It should be much much more faster on SSE2 Hackintoshes. More to come

4. Leopard Ready - Thats right , it works with Leopard [with some kernel panics]


Changelog - version 0.12

1. Added Linksys WUSB54GC Support [Thanks SilverTab and Simania_NL] and wrapped with the new RT7 Series Driver

2. RT2500's Driver version has been upgraded from 1.1.3 to 1.1.5 [Thanks toshi for the drivers]

3. Fixed Airport menu thingy [For now it should at least show up the Airport icon but I am not too sure if it really works or not. This is the first stage getting the Airport logo Icon thingy working]

4. Added lots of optimisation to the code to make it even better





I would like to thank :-


nVidia_user - for testing it

toshi - for the new driver thingy

Simania_NL - for the Linksys WUSB54Gs support thingy !





If you're having any problems , feel free to send me a PM or meet me on IRC - macspeak , #scripts. Oh yeah if you like to support me [to pay up my Tuition fees , then you could PM me ]. I will be working on other stuffs as well. Just a guy who is helping the OSX86 World !

Link to comment
Share on other sites

hey, nice work


i was just cheking out your driver.

unfortunately the airport-thingy doesn't work.


quick question: remove the previous rt2500 driver before installing yours?


will you keep us updated on your development via this thread?



Link to comment
Share on other sites

Yes , for thats for sure and I am hoping to start a X-Labs Project on this. Plus I might be working on some extras to give some extra umph


Here you go the airport menu thingy , its still in beta.




How to install , well simply put it to /System/Library/CoreServices/Menu Extras and then from that folder drag it to the menubar to test it out. Oh do not forget to fix its permission. Its still work-in-progress thingy

Link to comment
Share on other sites

Again , its still new


Waiting for menu - I am fixing the bug and it might take sometime. I am doing this without any pay plus I need to pay up my tuition fees for my U and I got my studies as well . So do expect some 'slowness' on this project. Not ranting what-so-ever. Just explaining my situation right now !

Link to comment
Share on other sites

Good work on the RT2500-Home style driver. (I have yet to try it)


I thought I may be able help a little. I have a driver from RA-Link that's only 6 weeks from their development house.


It's reliability is excellent as is it's thruput. NO MORE replugs required with this beasty for me.


Let me know this one helps!




Link to comment
Share on other sites

I am very confused. I have a linksys WUSB54GS v2.1. The vendor id is 13b1 in hex so that should be 5041 in Decimal. This thread http://forum.insanelymac.com/index.php?showtopic=33913 talks about the WUSB54GC. It shows the same vendor ID. Does that mean mine is ralink or does that 5041 refer to the manufacturer (linksys)? Also, in mac os, system profiler shows my device and says the manufacturer is broadcom. The product ID is 0x0014. Anyone know what I should do?

Link to comment
Share on other sites

Hey dude! The new drivers and software is working like a charm.... thanks so so much on it!!! U're the man!!!


Well, for wish list, i was hoping to get a new revamp on the GUI..... the current GUI looks quite boring... maybe u can help spice it up?? maybe make it look more integrated with the OS... more Appleish or something....


Thanks!! Will be willing to beta test all versions for you if neccessary......



EDIT: Just my 2 cents worth... maybe the dock icon could be designed to look cool too... :( currently its just using airport config util icon....

Link to comment
Share on other sites

I need someone to make the Icon , at the moment I am re-doing the whole thing. So I need someone who is good at making icons and graphics to help me. I will integrate the latest driver as well and include a fix for WUSB by Linksys as well


oh yeah , sambo60 yours is Ralink !

Link to comment
Share on other sites

darn, i'm not good at graphics..... i only know basic photoshop and some 3d modelling skills..... fairly pathetic....


all i can help is to beta test....


oh, it would be nice if the menu bar icon could be integrated... like a real airport.... haha... jus a wish list.... anyway, keep up the good work.. post new stuff here and i'll beta test and report back for u...

Link to comment
Share on other sites



Awesome driver package - well done, rock solid performance and extra thruput again me thinks with the "compression box checked"


Also I installed the Airport2.menu - It works great - looking forward to rev2 for more functions.




No it does not register as a true airport - but Prasys homebrew & Airport2.menu is the next best thing.

Link to comment
Share on other sites

I am very confused. I have a linksys WUSB54GS v2.1. The vendor id is 13b1 in hex so that should be 5041 in Decimal. This thread http://forum.insanelymac.com/index.php?showtopic=33913 talks about the WUSB54GC. It shows the same vendor ID. Does that mean mine is ralink or does that 5041 refer to the manufacturer (linksys)? Also, in mac os, system profiler shows my device and says the manufacturer is broadcom. The product ID is 0x0014. Anyone know what I should do?

At first I would like to say that my product ID is 0x0020, but I'm not sure that it's the only version that works.

*edit: your product ID is 0x0014 = 20 decimal so change 32 for 20 in the info.plist and try again.

Just follow the thread and please report the outcome, in the case it won't work we can try to find a solution.



I'm pretty good with Photoshop, please sent me a pm about what you're looking for.

Continue with your great work and hopefully you've full WUSB54GC support as well.

Link to comment
Share on other sites

Is this for the USB ralink adapters only or does it work on the PCI variety as well ?


testing it with my USB adapter right now, but would love to use my PCI linksys adapter.

Link to comment
Share on other sites

Good to know , I will be adding more stuff in. Just trying to make the driver even better for us all. Making it usable for all


Oh , I am looking for someone to donate their PCI card or I might have to fork out to get some. I will do my best for PCI Support , but first USB. Plus I might have to 'pause' the project for a while as I have my studies [need to pay fees and stuff like that]. So I hope , I will resume it back once I get everything kickin'

Link to comment
Share on other sites

sure thing!!!! ok, manage to fiddle the driver and the utility around last nite at home, admist my studying for my exams this monday...


apparently the packet compression can be checked, but it cant be applied.... the appy button is greyed out even if i made those changes.... the other two check buttons trigger the apply button well, but the packet compression doesnt....


is it me or is the wireless disconnecting at a rate of once every two or three hours? cos i'm connected to my sch network which says 99% signal strength and yet it disconnects once every 2 or 3 hours.... something wierd....


as for the startup, sometimes the wireless utility startsup after login, sometimes it doesnt... i still cant determine the reasons for it not being able to start.... either that or it takes really forever to start, which happens sometimes...


this is just the results of the beta testing.... the menu airport indicator is great.... it stays active and there even when i reboot and there is no usb attached to my com... thats a bit wierd.... maybe it could detect and grey itself out if the wireless is not present or something??? hmm...


so much for this round of beta testing.... post your next build when u r free!! i will be checking back this page regularly...



Link to comment
Share on other sites

Doojse, what is the chipset inside your Belkin F5D7050? The driver here works for the RT2500 and the RT3X series....


Apparently i went to the website to check, only the Belkin F5D7050 V2000 has the RT2500 chipset.... if your hardware revision is not that, then i'm sorry, this driver might not work for you...

Link to comment
Share on other sites

Prasys I adapted the RT2500Replug so it works with with the WUSB54GC from linksys, I think all RT73 usb sticks can work with the RT2500Replug since it's only a USB-thingy, not an actual driver.

The change I made in the Info.plist:




















If you would like to use it with your WUSB54GC just go to: RT2500 Replug

Download the kext and add this information to the info.plist

If you like it donate some money to the official maker

Link to comment
Share on other sites

This driver works really great for me with my DWL-G122 on WPA.


However, yesterday I tried to connect to a WPA Enterprise network and the driver said "It is no YET supported". Is there any plan to implant WPA Enterprise for this driver???


Thanks a lot for this wonderful driver :huh:

Link to comment
Share on other sites

jhonnypolak: I'm not sure if this is what your after but I have a PCI based adaptor (that came on the laptop) with the TR2500 chipset and I just went to the Ralink website and downloaded their driver for the Mac pci. When I install the program it works great, connects to the internet etc.

The only problem I'm having is that when I restart it doesn't detect the internet until I reinstall the program (only takes a couple secs) and restart the computer.

I'm going to try the Replug driver and see if it works even though it's not USB.

Link to comment
Share on other sites

Hi Prasys, and other geeks like me lol :compress:

Prasys, you advised me to get a Ralink USB wireless, actually I didnt know, but I had one already (the v2000, lucky me) which I used on another old PC...

So initially not aware of this thread, I found the Ralink website and got the latest driver (usb wireless assistant), it installed nicely, and I started getting some network connectivity.

Using the PCI NIC is useless on my system, (or maybe its only because of the NIC's I got)...

Anyhews, I finally installed your gear, and it works too.

I can network all computers, but I still can't get an internet connection through the PC, or via airport.

I can ping the PC (which has the Ralink and is connected to the internet), I can ping airport, and I can get network connections, but no DHCP or internet connections...

Any idea?

Cheers dude/s

Link to comment
Share on other sites


  • Create New...