Jump to content

Atheros wireless driver OS X 10.11/12 for unsupported cards


631 posts in this topic

Recommended Posts

19 minutes ago, nuclear0077 said:

 

I so understand it is necessary to use correction v15 or v16 at you casually links to it are not present? I can not find

just follow the thread.

test with this https://www.insanelymac.com/forum/forums/topic/312045-atheros-wireless-driver-os-x-101112-for-unsupported-cards/?do=findComment&comment=2509900

and do not forget to add in clover plist "kext to path" as mentioned before

 

15 minutes ago, jalves said:

just follow the thread.

test with this https://www.insanelymac.com/forum/forums/topic/312045-atheros-wireless-driver-os-x-101112-for-unsupported-cards/?do=findComment&comment=2509900

and do not forget to add in clover plist "kext to path" as mentioned before

 

That's just all set again But WiFI does not even find a network if you do not mind, can you write in order and in what order should you set everything up? Thank you

Edited by nuclear0077
14 minutes ago, nuclear0077 said:

 

That's just all set again But WiFI does not even find a network if you do not mind, can you write in order and in what order should you set everything up? Thank you

 

install version 21  https://www.insanelymac.com/forum/forums/topic/312045-atheros-wireless-driver-os-x-101112-for-unsupported-cards/?do=findComment&comment=2509900  with kext utility ( according to your hardware and OS version )

After that, reset your network interfaces by, opening terminal and typing:

sudo rm /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist  

sudo rm /Library/Preferences/SystemConfiguration/preferences.plist

sudo touch /System/Library/Extensions 

sudo kextutil -u /

Reboot.

40 minutes ago, jalves said:

 

install version 21  https://www.insanelymac.com/forum/forums/topic/312045-atheros-wireless-driver-os-x-101112-for-unsupported-cards/?do=findComment&comment=2509900  with kext utility ( according to your hardware and OS version )

After that, reset your network interfaces by, opening terminal and typing:

sudo rm /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist  

sudo rm /Library/Preferences/SystemConfiguration/preferences.plist

sudo touch /System/Library/Extensions 

sudo kextutil -u /

Reboot.

 

Did everything as you said restored the factory kext after that rebooted and executed your instruction WiFI also does not have a network ( Is there any other thread options? what to do? though the sudo command did not work. kextutil -u / says not a valid parameter

7 minutes ago, nuclear0077 said:

 

Did everything as you said restored the factory kext after that rebooted and executed your instruction WiFI also does not have a network ( Is there any other thread options? what to do? though the sudo command did not work. kextutil -u / says not a valid parameter

sorry. 

sudo kextcache -u /

 

 

9 minutes ago, nuclear0077 said:

 

Thank you! Now on trying to put updates on 10.12.6 can help

after update

make a copy of IO80211Family.kext in case you need to restore it

if you have /System/Library/Extensions/AirPortAtheros40.kext, delete and rebuild caches.

Before attempting any other method, try this https://github.com/black-dragon74/ATH9KFixup

 

Edited by jalves
1 hour ago, jalves said:

after update

make a copy of IO80211Family.kext in case you need to restore it

if you have /System/Library/Extensions/AirPortAtheros40.kext, delete and rebuild caches.

Before attempting any other method, try this https://github.com/black-dragon74/ATH9KFixup

 

 

updated all reinstalled the sense of 0 even tried the other option also does not see the network there are still any options

5 hours ago, nuclear0077 said:

 

Tried 2 options for just that business mac os 1) option with kext v21 2) option https://github.com/black-dragon74/ATH9KFixup and ran with the argument -ath9565 in both cases the result is on

config.plist

well, to use fork blak.dragon74 , you need to be with the stock IO80211Family.kext (original kext) and Lilu.kext, ATH9KInjector.kext, ATH9kFixup.kext should be in instaled on /S/L/E, as well as the initialization argument in clover.

when installing v21, make sure you have removed. probably it is in /S/L/E/AirPortAtheros40.kext

 

 

 

 

I have WiFi working now on 10.13.3 (AR9565) with the v21 patched kext (ATH9KFixup didn't work for me), but I don't know if I should update to 10.13.4 since someone said in the previous page that it stopped working for them.Does anyone still have it working with that method on 10.13.4?

Glad to see this thread still usefull for some people

By reading a bit back  you can check the devs work on making some cards alive

not easy but i hope others post their work here - goal is share methods to make this dam cards work

 

As for the end users - i'm sorry if u get some bugs 

just come check this thread and wait for some dev fix

×
×
  • Create New...