Jump to content

USB-Fix for El Capitan


spakk
 Share

93 posts in this topic

Recommended Posts

no dsdt.  can't figure out how to patch correctly, but here are some screenshots of system info

delete the driver that I have posted you and install this patched driver for (3483:1106) in to /Extra/Extensions, use Kext wizard, fix the permissions etc ... and report with a picture of SystemInfo.app

SuperVIAATA.kext.zip

Link to comment
Share on other sites

 I have  Intel  DXR79SR  motherboard with  Renesas Electronics  3.0 USB ports ,and  Intel 2.0 ports. I tried  various methods to get  them all working , but  best solution was to edit SSDT ,which is not recommended and my system will not shutdown,only reboots ,I'm on Yosemite now  with GenericUSB.kext .To get  3.o usb to work but it's buggy you have to hot plug them  a few times to get them to pop onto the desktop any idea if this solution will work on my board ? 

Link to comment
Share on other sites

  • 1 month later...

I have an interesting information here for Clover users, which may be very helpful... Yesterday I have faced USB problem, which I didn't faced before, I was as usually installing all USB-Fix package (or just IOUSBFamily.kext, IOUSBMAssStorageDriver.kextIOUSBMassStorageClass.kext from the package), then I was repairing permissions, rebuilding cache etc. Everything was perfect with the Enoch bootloader: mouse - working, keyboard - working, actually all USB ports were working, that method also always worked for Clover. With Enoch bootloader I always using USBLegacyOff=Yes boot flag (in Clover you should use FixOwnership), so while I was booting my system with clover and in verbose mode, I noticed that in some reason all USB Ports are injecting, the same happening when you are using USB injection in Clover config file, which you don't actually need. And as the result, all my ports were not working, not mouse, not even keyboard. My BooterConfig was set as "0x28" and my CsrActiveConfig was set as "0x67", so everything was correct. Then I just put all USB-Fix drivers on my EFI partition (EFI/EFI/CLOVER/kexts/10.11) and after that everything worked as I expected. I don't know exactly why it's happening, maybe it has something to do with SIP protection, I don't know, but if you're facing same problems, then you have to add USB-Fix package both in S/L/E and EFI/EFI/CLOVER/kexts/10.11! Also you can add AHCIPortInjector.kext inside clover location (from where kexts are injected). And very important thing, as marius described, in clover config you need to disable all ACPI patches for USB (e.g. USBFix).

p.s. I've uploaded kexts, which I've used for Clover.

package.zip

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

upload your extra-folder including raw dsdt and ioreg file, then we check what is the possible cause.

Link to comment
Share on other sites

  • 4 weeks later...

Hi,

10.11 is always really painful for me. I'm currently stuck on the installation already.

i tried to get this USB Fix working on my system for more than 4 hours now, i really need a brake.... it solves the EHCI log spamming and the system boot successful, but it kills my whole input(excluding ps2 keyboard, which shall work with ps2 drivers :) )

 

I followed the thread and already see users with my mainboard, but they just don't write anymore here, so i guess they solved it already...

My config:

USB: Logitech Mouse

USB: Dedicated USB Numpad

PS2: Logitech Keyboard

 

Things i tried so far:

- Using u'r v3 fix

- Using the AHCIPortInjector.kext in E/E and S/L/E

- Using Shanee's fix (Basically the same)

- Booting with USBBuxFix=Yes/No same for USBLegacyOff=Yes/No

- Using old known working kexts from yosemite.

- Using different mouses, keyboards...

 

 

My Bootargs are "-v UseKernelCache=No dart=0 npci=0x3000" and my Mainboard is a ASUS M5A97 EVO R2.0. Anything we can do here? Thanks :)

 

Edit: Works now, no future investigations needed, i just used a ps2 keyboard only :) with a proper voodoops2 installation

Link to comment
Share on other sites

  • 4 months later...
Hi!

I tested Shaneee's USB Fix and Spakk USB Fix

Shaneee's USBEHCI (USB2.0) not work, but there are USB info

Spakk USB is fully working, not working USB audio, and there is no info USB

Tested El Capitan and macOS Sierra

post-1166679-0-41202300-1478711723_thumb.png

post-1166679-0-00055700-1478711725_thumb.png

post-1166679-0-37627700-1478711728_thumb.png

  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...
Hello!

USBAudio still does not work!

I found a USB Prober application earlier versions of Xcode.

I have attached results generated by the program to see if it will help you find the cause of the problem!

 


 

Thank you in advance for your help!

post-1166679-0-30440300-1481050618_thumb.png

post-1166679-0-06647400-1481050620_thumb.png

USB Bus Probe.txt

Link to comment
Share on other sites

  • 8 months later...

 

Hi folks,
I see it as appropriate, when we talk here about the USB problems that arise when installing El Capitan on intel/AMD Hackintosh, or my approach to use Yosemite kext drivers to fix the USB problems.
 
the first attempt V1, was for me the proof that it is the right way, the packet V2 has ultimately convinced me that it works. I do not need to patch any DSDT and all USB drives/ Ports operate as they have previously worked with Yosemite.
 

 

 

The dowload page seems down.

Link to comment
Share on other sites

The dowload page seems down.

first save your S/L/Extensions folder and use an unchanged S/L/Extensions folder.

Then install this content of the USB-Fix package and generate a new prelinked kernel.

If the system should stops after starting with a panic message, with various problimatic

Extensions, so upload a picture with the Panic message.

Finish the installation of El Captain without problems, restart automatically; not boot, not in the Enoch menu to choose the hard drive, verify that the files are on the hard disk, help me

First of all write your hardware in ur signature. Then describe your problem,

If you find it difficult to describe this problem in English, so write it in your language.

if necessary add a pictures or bug reports

USB-Fix.zip

Link to comment
Share on other sites

Hello,

 

My problem is not to boot after completing the installation of El Capitan, 

 

1. I select the HDD where El Capitan installs, IMG_0700_.jpg

2. Show the message Reboot and Select proper Boot device, IMG_0701_.jpg

3. I select the USB installation, IMG_0702_.jpg

4. Does not show El Capitan HDD, IMG_0703_.jpg

5. Start the installation to repair disk, IMG_0704_.jpg and IMG_0705_.jpg

6. Repair disk OK, but not boot, IMG_0706_.jpg and IMG_0707_.jpg and IMG_0701_.jpg

 

Help me please, 

 

 

GA 990 FX-GAMING / AMD Phenom II X4 945 / 8 GB / 2 x NVIDIA GeForce GTX 550 TI 1GB - SLI

post-2163146-0-06145400-1504358946_thumb.jpg

post-2163146-0-54151900-1504358952_thumb.jpg

post-2163146-0-91292400-1504359177_thumb.jpg

post-2163146-0-42430700-1504359191_thumb.jpg

post-2163146-0-19838600-1504359206_thumb.jpg

post-2163146-0-72613000-1504359215_thumb.jpg

post-2163146-0-83301500-1504359315_thumb.jpg

post-2163146-0-50151400-1504359326_thumb.jpg

Link to comment
Share on other sites

  1. start from the USB installer and format the hard drive with the Guid partions table, create two partitions with "Mac OS Extended journaled", then install El capitan on the first partition.
  2. install Enoch Bootloader into El Capitan partition and add the amd kernel into /System/Library/Kernels/
  3. Then replace the contents of my Extra folders in yours
  4. Then add the content of the USB-FIX package into S/L/E
  5. and finally restart your system

(all files can be found in Archiv.zip)

Archiv.zip

Link to comment
Share on other sites

  • 2 months later...
 Share

×
×
  • Create New...