Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Aju Deeju

HD 5450 on Mavericks

36 posts in this topic

Recommended Posts

Anyone having full QE/CI on this device....

It had full QE/CI under 10.8.4 but now it doesn't work not even full resolution.

If anyone finds a solution please notify me.

Share this post


Link to post
Share on other sites

hello

 

check the kext...

 

no more amdradeonaccelerator.. now is amd3000x

 

see and apply wath u have donne to run in 10.8

 

u car is not native in mac os x

 

good hack

Share this post


Link to post
Share on other sites

Just had a similar problem with my 5750, hope my solution also works for you.  First make absolutely sure that you have the correct device ID (sorry if that goes w/o saying).  Putting it in ATI5000Controller.kext should give you full resolution support.  Putting it in AMDRadeonX3000.kext should give you QE/CI support.  In AMDRadeonX3000 there are sections for various graphics card families or code names.  Be sure to put you DevID in the correct section.  Your card should go in the AMDCedarGraphicsAccelerator section.  (I do not have this card, so I cannot verify that it is Cedar).  

 

Also, I don't think your card is a natively supported card, so you may need GraphicsEnabler=Yes.  Try both Yes and No.

 

I hope there's something here that you haven't tried yet.  Good luck.

Share this post


Link to post
Share on other sites

nope…

I installed ATI5000Controller kext, I installed ATI5000Injector kext, I modified AMDRadeonX3000 and AMD5000Controller kext with vendor/revision ID 0x68F91002 and I confirm that's a Cedar personality. The best result I had was that the card was recognized as a Radeon HD 5450 but with just 5 Mb of vram and no QE/CI support. I tried to remove ATI kext letting just the AMD ones like it was with the original DP1 build. Same problem.

 

​I have to mention that It worked perfectly with the original DP1 build, the problem occurs with the new seed proposed via Software update. It seems that Apple changed something with the graphics drivers as I noticed that the ATI kext disappered after the update.

I'm still looking for a way to solve the issue but I really don't know what's going wrong.

 

I've attached all the kext used in this post if it can help someone to fix this out

Good luck !

Radeon HD 5450 (OS X 10.9 DP1).zip

Share this post


Link to post
Share on other sites

The original one was 13A476s, I got it a few days after its announcement. It's marked as the OS X 10.9 Developer Preview and the dmg was named OS X Mavericks 10.9 DP1. The actual build I'm running is 13A491, I've downloaded it via Software Update from the AppStore.

Share this post


Link to post
Share on other sites

your device and  vendor id(0x68F91002) goes in the  AMDJuniperGraphicsAccelerator in the Info.plist   AMDX3000...kext  (if that aint working try in the  AMDEulemurGraphicsAccelerator part aswell ) im not shure anymore 

 

and also in the ATI5000Controller.kext   like the others said above

 

save your edits install them with Kext Utility  and boot with GE=Yes  ( you could add AtiConfig=Vervet  or /Eulemur at boot  to enshure you get to correct Framebuffer set for it ) 

 

 if no Prep. DSDT is in place 

 

 

and u should be happy i guess 

Share this post


Link to post
Share on other sites

Thanks for help but it doesn't works. I did edit the AMDRadeonX3000 kext and added the vendor/revision ID to the Juniper Personality part but the card still shows 5 Mb of vram and no QE/CI full support. Also edited the ATI5000Controller (in fact I didn't touch it as it was already modified). Do I have to remove the ID in the Cedar Personality part ? I left it and didn't tried without it. I also tried to boot with Vervet and Eulemur AtiConfig with Graphics Enabler=Yes but nothing changed.

 

What do you mean by DSDT is in place, do I have to edit it ? I have a modified DSDT file I use with chameleon boot.plist file but I'm really not sure that it's useful (I disabled it several times and It didn't change anything, it's purpose was originally to fix some power management issues but it never really worked).

 

So I'm still stucked at the same point. But once again, thanks for the help !!!

Share this post


Link to post
Share on other sites

If you have the 13A476s mount it and go to system/Library/Extensions and take the amdradeonaccelerator kext and post it here please ....

The card was working and loaded in 13A476s right?

Share this post


Link to post
Share on other sites

Yeah the card worked under 13A476s but the AMDRadeonAccelerator kext was not in the build, it was a kext I've downloaded from the 10.8.4 installing Guide. I tried to add it but it's not working. Attached is the Origianl kext from the Guide and the modified one with vendor/revision ID if it can help.

 

 

AMDRadeonAccelerator.zip

Share this post


Link to post
Share on other sites

hello

 

something is wrong with u install

 

mine is a cedar and work and all kext are in the build

 

Captura de ecrã 2013-06-30, Ã s 18.37.45.png

 

good hack

Share this post


Link to post
Share on other sites

Finally fixed it .... I got full QE/CI. The problem was that AMDRadeonAccelerator doesn't work for 10.9...

 

-Remove AMDRadeonAccelerator kext.

-Install ATI5000Injector kext attached below in /E/E.

-Install ATI5000Controller and AMDRadeonx3000 attached below in S/L/E

-In org.Chameleon.boot.plist add :

<key>AtiConfig</key>
<string>Eulemur</string>

Reboot and Voila!!

 

:D  :thumbsup_anim:  :D

 

HD 5450.zip

 

 

post-689606-0-95713800-1372670713_thumb.png

Share this post


Link to post
Share on other sites

Hi Aju Deeju !

 

Could you send me your AMD5000Controller kext, I can't find it on my system and I think that's the problem ? I can't figure out where it is !

Share this post


Link to post
Share on other sites

Thanks but it's the ATI5000Controller, not the AMD5000Controller. But no matter, I found one on the web and modified it and it's still not working whereas it's the ATI or the AMD. I don't understand where I made a mistake, I have followed every step, I even reinstalled the DP1 from scratch but when I update it, it stops to work.

Share this post


Link to post
Share on other sites

Aju Deeju, are you using the DP 2 or the DP 1 ? Could you list all your AMD & ATI kexts that's are in your S/L/E folder please ? I just want to check if I have them all ?

Share this post


Link to post
Share on other sites

hi.i followed your instructions but I do not have qe/ci .my id card is 0x68F91002

ps I updated to dp2

I am not sure about dp2....but you can try removing all and or ati kexts in the S/L/E folder and install only the kexts I posted...

P.S. Use the latest chameleon version and GE=Yes

 

 

Aju Deeju, are you using the DP 2 or the DP 1 ? Could you list all your AMD & ATI kexts that's are in your S/L/E folder please ? I just want to check if I have them all ?

I'm using DP1. The kexts I have are:

 

AMDRadeonX3000.kext
AMDRadeonX3000GLDriver.bundle
AMDRadeonX4000.kext
AMDRadeonX4000GLDriver.bundle
ATI2400Controller.kext
ATI2600Controller.kext
ATI3800Controller.kext
ATI4600Controller.kext
ATI4800Controller.kext
ATI5000Controller.kext
ATI6000Controller.kext
ATI7000Controller.kext
ATIFramebuffer.kext
ATIRadeonX2000.kext
ATIRadeonX2000GA.plugin
ATIRadeonX2000GLDriver.bundle
ATIRadeonX2000VADriver.bundle
ATISupport.kext

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • @MegaCookie   ok, I have no solution for that Trial 7 good for the release?
      Is this codec good enough for you?
    • @onejay09  - thanks again for your help and advice.  I tried various combinations of Info.plist mods (Adding a new Machine entry with my Board ID and GFX0, adding GFX0 to the MacBookPro6,1 Machine entry and adding a Vendor/Device entry to the Board ID and MacBookPro6,1 Machine entries. I thought these might make a difference, but after comparing GPU temps and frequencies to those reported in Windows 7, I'm not seeing any difference.  It appears as though AGPM is natively detecting and handling power management of the NVidia Quadro NVS 140m without any Info.plist mods.   Thanks again.
    • My rig is not booting without the "XCPM bootstrap patch" and "xcpm_program_msrs (c) Pike R. Alpha" patch. Already tested that.  Booting without the TSCAdjustReset.kex is working great and booth sleep and wake is working. The new bios 0603 has an updated microcode and that might be the reason  for the fact that everything is working as it should without the kext.
    • Hello folks,   I may be a privileged user since i own a real mac aka a MBPro 15" mid 2012 runing fine HS... So i wanted to try a personal tip: I hooked my Sandisk 100 GB USB SSD to the real Mac and performed a clean install of High Sierra on it. Then i installed the latest CLOVER on this USB disk and copied the Urashimataro previously provided EFI partition. Then i pluggued this USB to my Xiaomi laptop i5 and tried to boot from this USB SSD. INCREDIBLY BUT TRUE: YES it worked fine. ;-)) Of course i also removed the serials to put mine previously blessed on Sierra...   Happy to share this new tip that lets me boot again my Xiaomi laptop on MacOs, and proud for my own personal solution, since i couldn't retrieve here any workable solution and it drove me crazy and nuts...   Enjoy!
    • Venduto altrove potete chiudere


×