Jump to content

New Nvidia Retail Driver Install Solution

98 posts in this topic

Recommended Posts

  • 1 month later...

Hello !


I'm using a 8800 GT 512 Mb with no injectors, just NVEnabler64.kext with Boot Flags Npci=0x2000 & GE=No but the package says that my system doesn't have any supported supported card ! So no drivers installation, any ideas ?

  • 4 weeks later...

I still don't understand what you're asking.


There is no official web driver out for Mavericks. The leaked beta driver breaks CUDA 5.5.28 and does not fix the OpenCL downclocking bug on the 660 GTX.


/EDIT - CUDA 6.0.26 Release candidate here


The way to modify the installer is the same no matter what OS you're running or what video card you have.


The driver is universal and works with the same cards that are supported by the original nvidia drivers.

There's a retail driver solution also for osx 10.7.5??


nvidia drivers didn't have a preference pane at the time of 10.7.5, therefore the NVRAM module was not required. Also, the nvram module did not exist :D


Nothing in the first post applies to 10.7.5.


So what are you asking?

  • Like 1

I've been using the Apple supplied drivers for my GTX660ti since upgrading to Mavericks, but kept the nvidia pref pane installed. An ta-da! Today it just updated the nvidia web drivers to 331.01.01f01 - still CUDA is broken, presumably they'll release the latest CUDA drivers soon as well.


Current issue - osx doesn't seem willing to use them and every time I log in on startup the cuda system pref pane opens up and demands an update before saying none available :)  Perhaps these issues are related.


Added nvda_drv=1 to clover kernel args, but doesn't seem to help.

And today it said a CUDA update was available, downloaded and installed 5.5.43, restarted and now it's still not loading the web drivers and still saying a CUDA update is required. Weirdness.



Today i prompted to install CUDA 5.5.47 which installed happily and removed the CUDA update message – but still the nvidia web drivers aren't enabled after a restart. I'm guessing something changed with regards to what the web drivers write to NVRam...



It seems the web drivers are loaded, according to System Information app, just the nvidia system prefs panel that says otherwise.

Edited by ZenGiga
  • 3 weeks later...

Hello ..

I configured a Hackintosh with P6T7 WS Super Computer, everything ok ... works great ...

But if I select as Web Graphics Driver NVidia Driver (the Quadro K5000), the system will not start, the indicator remains endlessly boot.

As if I enable OS X Default Graphics Driver Mavericks, all ok ....

I noticed that if I enable the default ones, the apple logo is flat, but if I enable nvidia ones, the logo becomes 3D ...

Will you help me figure out the problem? Maybe I have to set some flag before booting??

Thank you.

  • 2 months later...

What kind of test can I do to test that the driver is working correctly.  I think my driver is installed correctly but some times I see lag on a browser which doesn't seem right since have a overclocked 3930K and GTX 780 I don't expect to see much lag.

You can check that it's loaded - look for nvidia web driver kexts in System Profiler under "extensions", or you can do kextstat -k from Terminal.


Also the nvidia web driver control panel will tell you if you're using the Apple drivers or the Nvidia Web driver, and, if you have working NVRAM emulation, let you switch between them across reboots.


General lag issues can also be a consequence of power management not working correctly.


For example if OS X thinks your base clock is 100Mhz when it is in fact 103 MHz. Yes, that's all it takes.

  • 2 weeks later...

Hi !


I'm new here and I've got a strange issue. Maybe strange because I'm a newbie.

This is my configuration :


10.9.3 (With last version of clover)

X79 Deluxe (Last bios 0701)

8x4GB G-Skill 

i7 4930k (no OC)

EVGA GTX Titan Black SC



My main problem is that I got black screen (Always seems to work fine because I heard sounds but my monitors turn off after boot).

Meanwhile the installation I always boot with nvda_drv=1 & nv_disable=1.

After the installation of SSDT and kext (From the rampage website) I install the last nvidia web drivers, restart, choose the web driver in the control panel and restart again but this time just with the flag "nvda_drv=1".


At the first I got sometimes blank screen, but today after many tries this issue is permanent, I have to boot with nv_disable=1..

I already re-install drivers but without success....any idea ?




Try to add your system board ID from SMBios in the infoplist of  AppleGraphicsControl.Kext/Contents/Plugings/AppleGraphicsDeviicePolicy.kext/Contents/Info.plist as last line of the Configmap with the other models in this way:




Chanche xxxxxxx with your digits.


Have fun.



Try to add your system board ID from SMBios in the infoplist of  AppleGraphicsControl.Kext/Contents/Plugings/AppleGraphicsDeviicePolicy.kext/Contents/Info.plist as last line of the Configmap with the other models in this way:





Chanche xxxxxxx with your digits.


Have fun.


Hi Styrian !


Thanks for your advice, but that's not better.

After adding sys board ID in the info.plist I can indeeed boot without the flag "nv_disable=1" but the now the web drivers won't be loaded.

As you can see in my screenshot here, the about this mac tells me "NVIDIA Chip Model 8Mo" instead of "NVIDIA GTX Titan Black 6GB", so it's looks like drivers are disable at boot.

I've got another strange issue now, the extensions are not showed into the system report windows, but we can see it with the command terminal. And the list of loaded kext doesn't show the GK100Halweb, so no drivers are loaded...We have the invert issue now lol, I can boot without flag but drivers are not loaded... ;)





Try to set ndrv boot key to zero and look, if the stock nvidia drivers are loading. For me is it working on a laptop, like I have written the key value before . But in the configmap there is one entry set with an other value. Perhaps you can find the model name, in wihich this system board is used.


If the stock drivers are working again, remove webdrivers from system and chaches and try if a new install is helping. I have somewhere read, that during the install of webdrivers the NVDAStartup.kext is changed. I think you have also to reinstall the stock one before reinstalling the web drivers and get stock drivers working again.


Have fun.

Sorry, what does that mean "reinstall the stock one".

this is what I have already do :

Boot with nvda_drv=0 > Drivers are not loaded

Boot with nvda_drv=0, remove web drivers, reboot, install web drivers, reboot with nvda_drv=1 > Drivers not loaded.

Boot with nvda_drv=0, check web drivers into the panl pref, reboot with nvda_drv=1 > Drivers not loaded...



Sorry but I've maybe some troubles to understand correctly your advices...  :blush:

Edited by Gringo Vermelho
Overquoting removed. Please don't quote entire posts when replying directly below them.



Sorry for having not written a total clear advice.


In short:  NVDAStartup.kext is altered by installing the webdrivers. Reinstall the original Apple version of it again.

Remove chaches.

Set nvda_drv=0 and reboot -f -v.

I think, that the Apple drivers should work again.

If they work, remove rest of webdrivers and reboot.

Install webdrivers and look if they are working again.


Have fun.

No problems dude, thanks for your time !

Meanwhile I was testing another trick. 

I decide to boot on my usb stick, format my boot drive and restore an .img (a clean version I've made just after installing SSDT, kext and drivers.) and it's works fine for now.

So I'm trying to restore a complete .dmg file (Who worked a few days ago, with all apps, files etc...) on the same drive to see whats happen.


Because, that's why it's very strange, this issue about blank screen appear suddenly last morning, at first randomly, but now every time I was trying to start OSX, and before this morning I had never touch to any system files or anything important, I was just working on my station. So even my .dmg backup resolve the issue, I'm affraid to see the same issue re-appear again one of these days...I'm really not an expert, but I love learning stuffs, but here with this issue, it looks like very randomly and strange.

I'll let you know quickly after the .dmg restore step how it goes.


Thanks for your help again, very appreciated.

EDIT : Ok, so after restoring my latest .dmg file on my boot drive, everything start fine. Is there anyway to understand what's happened on my system ?

  • Create New...