Jump to content

[GUIDE] 1st Generation Intel HD Graphics QE/CI


GhostRaider
2,093 posts in this topic

Recommended Posts

On 8/4/2020 at 12:18 PM, startergo said:

Mine is actually white screen, not black.

Sorry, no idea since you haven't provided us some details; macOS version, which Link Width used, DSDT, etc.

 

With HighSierra and below, now Whatevergreen has ability patching AppleIntelHDGraphicsFB* for Graphics Acceleration via 'config.plist - Devices - Properties' w/o touching SLE.

 

With Exception under Mojave++, rolling back some deprecated system files is needed b4 patching (*.kexts, *.bundle, OpenGL frameworks, platform patch, etc) eg. with the help of dosdude1's Patcher app.

 

As for White screen issue, try with different Link Width (1-4). Thanks.

 

#EDIT: I remember that for patching method to works, we need at least kernelcache / prelinkedkernel are rebuilt.

Edited by Badruzeus
Link to comment
Share on other sites

  • 4 weeks later...

Hi, if someone has an answer, I'd really appreciate it, as I'm unable to find a solution. I want to install High Sierra on an HP Elitebook 2740p (Arrandale i5, Intel 1st Gen graphics). I did follow the guide to the letter, but cannot for the life of me reach the actual installer screen. I've tried this guide, Ollarila's image, createrestoremedia + clover, and I always get stuck at EndRandomSeed, in which point the laptop just reboots. Does anyone have any tips for this model, or even better an EFI folder, or for a similar one (like the 2540, which is the same h/w, mobo etc but without the swivel screen) ?

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...
On 8/1/2020 at 6:35 AM, Badruzeus said:

Good Old Day! :D

Just installed latest macOS Catalina 10.15.6 on Toshiba Satellite L640 with Intel HD 1st Gen (Arrandale):

 

1. Using dosdude's Catalina Patcher app for creating Bootable USB Installer plus Post Install (rolling back deprecated Graphics kexts, OpenGL frameworks, Platform patch, etc) for unsupported mach << needs 2 x USB Boots for OS Install and then Post-Install

 

2. config.plist - Devices - FakeID - IntelGfx=0x12345678 for Pre-Install

 

3. To achieve QE/CI or Graphics Acceleration with WEG (+Lilu) installed, add Properties for Graphics on config.plist - Devices (plz refer to the manual, or see my screenshot & sample below. Thanks to GoldFish64). Remove IntelGfx FakeID on this case

 

4. For Native (ACPI) Brightness to works, patched DSDT is needed following old mnorthern's guide. Take a look attached DSDT below. For reference, find: LEVL, os-info, LGD018B, PNLF, _WAK. Also, replace DisplayServices.framework from 10.12.4 located on /System/Library/PrivateFrameworks/ and add Rehabman's IntelBacklight.kext v1.0.12 (attached) to \EFI\CLOVER\kexts\Other.

 

On my case, Display Brightness Slider is working (or Fn + Keys if remapped already) with no longer need BergDesign incompat 32-bit app. If you have better idea, then let me know.

 

#SomeHINTS:

- Platform patch is needed when using unsupported SMBios (eg. MBP6,x) under Catalina. For me, simply change to MBP10,1 BUT.. hey, there will be few issues with PowerManagement, USB Ports, etc (though I've manually fixed them via ACPI) so.., DWYOR!

- Use only one PNLF method, choose between Clover Patch, or ACPI (DSDT / SSDT)

- Graphics glitch on some apps is known issue with Legacy OpenGL / Metal incapable Graphics under Catalina (and Mojave), but thanks to @AsentientBot for bringing QE/CI back to unsupported mach anyway (Oops, I have no idea with BigSur, my Beta1 download has not finished yet once later Beta was seeded #LOL)

 

Good luck!

macOS-Catalina-10.15.6-01.jpg

macOS-Catalina-10.15.6-02.jpg

 

config_devices_properties.plist.zip

DSDT_Sample_Only.aml.zip

DisplayServices.framework_10.12.4.zip

IntelBacklight.kext_v1.0.12.zip

 

Hi buddy, you gonna try Big Sur final version ?

Link to comment
Share on other sites

  • 1 month later...

 

Here in my Github EFI Legacy OC, the brightness control is missing

 I am working on SSDT Hack

 

EDIT:
adding IntelBacklight.kext the brightness bar appears, the control with FN keys works, but does not change the brightness

2070106615_Schermata2020-12-22alle10_01_51.png.bd5acf7a99a2de7f1acdd752a591d320.png1856565977_Schermata2020-12-22alle10_04_14.png.7df5552f571b06681871e90dbac8d3f4.png

https://github.com/Baio1977/HP-630-CPU-Arrandale-Bios-Legacy-

 

SSDT-HP 630 Arrandale.aml

Edited by Baio77
  • Like 2
Link to comment
Share on other sites

  • 2 months later...

Asus K52F

CPU i3-350m

GPU 1st Intel HD Graphic

RAM 4gb

SSD Lexar

WiFi Broadcom

Mac OS High Sierra

 

i have issue with glitch screen all the time, been patch vram and core clock but still not fixed.

Screen Shot 2021-03-13 at 3.03.17 pm.png

opencore-2021-03-12-144421.txt config.plist

Link to comment
Share on other sites

  • 1 month later...
  • 5 months later...

Good evening all,

 

After a few years with the Lenovo T410 collecting dust, i recently installed Catalina (10.15.7) on it. Naturally, i went at it to try to get the Arrandale HD graphics working, first trying my "old" frambuffer from Sierra which did not work. While browsing this thread, i learned that GioFridas tool was now obsolete and that ordinary clover patching was the way forward. I found a reference on P79 but that only involved single-link settings unfortunately. I use the 1440x900 lcd on this machine and i wonder if anyone did manage to get a dual-link lcd working with some clover replacements?

Link to comment
Share on other sites

Hey Thx Baio77. But for the time being, i'm using Clover. This will change when i try Big Sur :)

But i got it working finally (well, mostly) but following the advice here a few pages back where i basically updated DosDudes USB patcher and placed my earlier patched files on there and re-ran the patch installer. At first i was baffled because it said "nVidia 288 MB" (but still worked). I then found this old "natit.kext" in my clover kext folder and removing that it now says "Intel HD Graphics 288 MB".

 

Mostly working because the dock is not transparent (i saw that @MacPeet managed to get this transparent in this thread). Would anyone know how he managed that?

Edited by my03
Link to comment
Share on other sites

×
×
  • Create New...