Jump to content

AMD Radeon HD 6650M / Graphics Enabler / DSDT / HDMI Audio / Acer Aspire 7750G - 2674G50Mnkk [Gradients Fixed]


Trucker MK
 Share

973 posts in this topic

Recommended Posts

What's working for you with this kext?

ATOM BIOS Rom: 
	SubsystemVendorID: 0x1043 SubsystemID: 0x2001
	IOBaseAddress: 0xd000
	Filename: k53y0524.001
	BIOS Bootup Message: 
Asus K53LY SEYMOUR M2 XT DDR3                                               

PCI ID: 1002:6760
Connector at index 0
	Type [@offset 44786]: LVDS (7)
	Encoder [@offset 44790]: INTERNAL_UNIPHY (0x1e)
	i2cid [@offset 44860]: 0x96, OSX senseid: 0x7
Connector at index 1
	Type [@offset 44796]: HDMI-A (11)
	Encoder [@offset 44800]: INTERNAL_UNIPHY1 (0x20)
	i2cid [@offset 44883]: 0x91, OSX senseid: 0x2
Connector at index 2
	Type [@offset 44806]: VGA (1)
	Encoder [@offset 44810]: INTERNAL_KLDSCP_DAC1 (0x15)
	i2cid [@offset 44910]: 0x97, OSX senseid: 0x8
Asus K53LY SEYMOUR M2 XT DDR3                                               

Subsystem Vendor ID: 1043
       Subsystem ID: 2001
Object Header Structure Size: 199
Connector Object Table Offset: 34
Router Object Table Offset: 0
Encoder Object Table Offset: 99
Display Path Table Offset: 12
Connector Object Id [14] which is [LVDS]
	encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false
Connector Object Id [12] which is [HDMI_TYPE_A]
	encoder obj id [0x20] which is [INTERNAL_UNIPHY1 (osx txmit 0x21 [duallink 0x1] enc 0x3)] linkb: true
Connector Object Id [5] which is [VGA]
	encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false
localhost:VBIOS Trucker$ 

Your patched framebuffer

02 00 00 00 40 00 00 00 09 01 00 00 10 00 02 01
10 00 00 00 10 02 00 00 00 01 00 00 00 00 04 03
Link to comment
Share on other sites

I tried you hdmi kext interesting when i use the screen changer (on my computer Fn + f8) it gets this 

but if i boot up with hdmi plugged in it works like a boss :D of course lvds is working too
i upload some picture for you, youre great
PS if i upload a 10.9.2 AMD6000 controller would you make the same patches on it (like pithecia and hdmi) ? 

post-1133216-0-71396200-1401701780_thumb.jpg

post-1133216-0-55933400-1401701785_thumb.jpg

post-1133216-0-02093000-1401701797_thumb.jpg

Link to comment
Share on other sites

so i got these... clean chameleon install(2.1), no dsdt no kexts. Only fixed boot 0 error because of 1TB.This is the last picture of verbose booting and than instant reboot. if it is not in verbose mode its reboots immidiatly after i choose my OSX partition
 

post-1133216-0-56355100-1401811571_thumb.jpg

Link to comment
Share on other sites

freeuser16, with the help from Trucker, I managed to get my laptop to work with full qe/ci and without color banding.

There is 1 problem though. For work I have to use monitors. Now I have 2 23" monitors, and I want to use both of them, while not using the LVDS screen (6650m can only handle 2 screens at a time)

 

Have you ever tried to connect 2 external displays?

Hmm, how would you connect them? One through HDMI and the other one though VGA? There might be problems with getting VGA to work, it has been buggy all the time. Otherwise I think it should work, at least theoretically. I've never tried connecting 2 monitors at the same time.

 

---

 

I've just installed Yosemite DP1 and the card works fine. The whole system looks nice, yet I think that launchpad in Mavericks was better.

post-1048154-0-14122300-1401870760_thumb.png

Link to comment
Share on other sites

Yes. My VGA only detects a display if I plug or unplug a HDMI cable. Very strange.

They only way I have been able to get my 2 monitors to work is to set LVDS fb settings to all zero's. Then my LVDS turns off, and my 2 monitors turn on.

 

--

 

Looks awesome. I'm gonna wait till the full release though.

 

--

 

Trucker also helped me with Audio, but for some reason his kext and DSDT edit doesn't work. I also have ALC269, but we couldn't figure it out.

The latest VoodooHDA gives me audio, although hard bass tones crackle. I really need a solution to this - any suggestions?

Link to comment
Share on other sites

Nah, I don't really like it. On pictures, during the presentation it looked better. In reality I got tired of all these colors after just a few hours. And DP1 is buggy as hell.

Sound and microphone work fine with VoodooHDA 2.8.5 on my ALC269VB. Worse than with patched AppleHDA, but it works.

Link to comment
Share on other sites

EDIT: Ah ha! I just noticed there is a 2.8.5 as well!? Seems like it's not an official VoodooHDA is it? Anywho, 2.8.5 works perfectly. No crackling anymore. Love it!

Link to comment
Share on other sites

  • 2 weeks later...
  • Slice pinned this topic
 Share

×
×
  • Create New...