Jump to content

AMD Radeon HD 6650M / Graphics Enabler / DSDT / HDMI Audio / Acer Aspire 7750G - 2674G50Mnkk [Gradients Fixed]


Trucker MK
 Share

973 posts in this topic

Recommended Posts

I sorry for so long feedback, I am trying to make bootable USB using this guide 

http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-mavericks/

 

Now I have kernel panic while booting the Installer

I' try to from the beggining

 

 

Actually I dont need this USB3.0 that much, because I can power my keyboard with it anyway (for other devices I can use USB hub).

Sleepmode and other things is not very important too, because i have external audio card and use my notebook as desktop.

 

Wifi is more important, because I have router in another room. + Internal microphone for skype and gradient glitches.

Wifi kext is already working in 10.7.3, so if there any easy way to make internal audio work and remove gradient glitches in 10.7.3 -maybe I should return to it?

Link to comment
Share on other sites

I never had KP with these kexts. You also need to use the other files i made for you as org.chameleon.Boot.plist SMBios.plist, all of them. Anyways, if you mange to install and boot to the Desktop here is the archive for Post Installation. This works perfect on 10.9. I'll check your progress tonight after 1 AM.

Post Install.zip

 


I sorry for so long feedback, I am trying to make bootable USB using this guide 

http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-mavericks/

 

Now I have kernel panic while booting the Installer

I' try to from the beggining

 

 

Actually I dont need this USB3.0 that much, because I can power my keyboard with it anyway (for other devices I can use USB hub).

Sleepmode and other things is not very important too, because i have external audio card and use my notebook as desktop.

 

Wifi is more important, because I have router in another room. + Internal microphone for skype and gradient glitches.

Wifi kext is already working in 10.7.3, so if there any easy way to make internal audio work and remove gradient glitches in 10.7.3 -maybe I should return to it?

Try VodooHDA for Audio (you need to delete ApplaHDA otherwise you get kernel panic.

For gradients install DisplayMergeNub.kext from Post Install.zip to /S/L/E and look for the folder DisplayVendorID-30e4 and copy it to /System/Library/Displays/Overrides/. I assume you have 17.3" Display or not?

 

When i have some free time i will install 10.7.3 on spare partition and test everything. But for now this is it.


I found this kext in my old  Lion-kexts archive, worth to try.

AppleHDA.kext.zip

Link to comment
Share on other sites

So, what I've done:

1) Format usb, restore BaseSystem to flash drive, copy Packages, extract mach_kernel

2) install Enoch bootloader on flash drive

3) Copy your Extra folder with DSDT

4) rebooted and got kernel panic (foto of my screen is in attachments)

I will try 10.7.3 now.

 

 

post-1267548-0-65450400-1395605652_thumb.jpg

Link to comment
Share on other sites

You can solve this KP with NullCPUPowerNanagment.kext, Sleep won't work and native Apple CPU power managment. But you can still install and test other things how they work and we can fix this later. I won't be online for few days., just few more hours.

Copy it to Extra/Extensions and after installation in /S/L/E

Link to comment
Share on other sites

Could you send me all kexts that you were using in Lion?

Like for trackpad and others, I'll try some of them

 

And could you please explain how power managment and speedstepping will affect my computer?

Is it important things, or only to make sleep work?

 

btw, I have a strange partition on my USB flash drive,

Is it normal or I killed my USB with overformating? :)

post-1267548-0-25782200-1395619777_thumb.png

Link to comment
Share on other sites

These should work on Lion too, except AppleHDA but I already uploaded another earlier and not sure for AppleIntelCPUPowerManagment.kext.

If you mean the blue part that's the occupied spase on the drive, but you are using GUID Partition Table, IMHO you should use MBR on the USB Installer. You can re-partition it, Go to Partition Tab/Current - choose 1 Partition, than click below on Options and choose MBR than click Apply. If you still see the blue color select the USB partition on the left than go to the erase tab and click Security Options, move the slider to the right click Ok then click Erase.

Note. You will lose all data on the USB.

Link to comment
Share on other sites

I install clean Lion 10.7.3 with some files from our conversation and finally I've got almost fully working OS X!

Only two thing aren't working now: USB3.0 (not important) and sleep.

 

Thank you very much for your help!

 

If you can help me with sleep on Lion 10.7.3, please do :)

Link to comment
Share on other sites

Hi! I was trying to make power management work, no success : (

MSRDumper shows that I have only 8 and 23 P-states.

I removed NullCPUManagement, I can boot normally with patched AppleIntelCPUManagement.

I tried your SSDT and made my own

 

nothing works.

 

Could you tell me what am I doing wrong?

Thanks!

 

EDIT:

I've got a message in boot log:

3/25/14 9:25:49.000 PM kernel: ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
 
May this cause my power management problem? 
Link to comment
Share on other sites

Install this kexts AppleIntelCPUPowerManagement.kext.zip and ATI6000Controller.kext.zip. Remove NullCPUPowerManagment.kext, rebuild cache, repair permissions, use the SSDT.aml i already uploaded for you, (it's not mine, i made it for your CPU i7 2410M, i have i7 2670QM), place your VBIOS 1002_6741_050e1025.zip in /Extra/ and use this org.chameleon.Boot.plist.zip with Enoch 2286.

 

But first of all upload your DSDT.aml which you are using now, i want to apply few additional patches.

 

You need to update to 10.7.5 for USB 3.0 to work, read here http://www.insanelymac.com/forum/topic/286860-genericusbxhci-usb-30-driver-for-os-x-with-source/

Link to comment
Share on other sites

Now i will ask for some help. I am trying to switch from Chameleon to Clover but i can't boot to the desktop. I tried with injecting and without injecting video. I always end up with gray screen or stuck in verbose mode at the point where GUI should start. I tried both on my bootable  Mavericks USB and on my HDD installation. Tried with injecting VBIOS, without injecting VBIOS, Dual Link 0, Dual Link 1, Inject EDID, pretty much all options. Can someone share working config.plist and some tips? Thanks in advance.

I already have installed patched AMD6000Controller.kext with patched Ipomoea framebuffer, i am not using Clover to patch the framebuffer.

Here is my config.plist config.plist.zip

Link to comment
Share on other sites

hi,trucker

this is my ati config,try it straight, it s 8.2 smbios but doesnt hurt.

i didnt make it,someone had clover running with acer,don t remenber from where...maybe here.

 

if you have password enter it blindly on that screen,happen to me sometimes and work as well.

config.plist.zip

Link to comment
Share on other sites

Ok, I will. I tried it to boot Lion with Clover and it boots just fine,. I installed it on my test partition and I was able to boot and inject everything without problem but it doesn't work on Mountain Lion and Mavericks.

Hmm, are you sure this is the problem with graphics?

Yes, I am sure. When I boot Lion in verbose mode I see the

AMDTurksGraphicAccelerator - Device in Slot: Slot 1

and the GUI starts, but in 10.8/10.9 I don't see it at all or I see just

init
probe
start 

 instead and it takes too long to boot to the white screen.

With this config.plist.zip i can boot into 10.7 with and without Video injection but not 10.8 and 10.9.

Link to comment
Share on other sites

I had similar problem, but it was not related to video card. If I choose any SMBIOS except MacBookAir6.1 + generation of PStates, it stucks for a while at the end of boot and then I get a white screen. If I select MacBookAir6.1 SMBIOS or disable PStates generation, it boots fine. IMO it's related to X86PlatformPlugin in my case. Maybe something similar happens to you (I guess you are using custom SSDT for PStates).

  • Like 1
Link to comment
Share on other sites

Yes I am using custom SSDT, I also tried without it an Generate C + PStates, a little research shows that it also might have something with ACPI_SMC_PlatformPlugin.kext. I will try your suggestion. Thanks freeuser.

Edit.

Success with SMBIOS MacBookPro 6,1 . Thanks again freeuser16

Link to comment
Share on other sites

Never had such a problem with Chameleon with SMBIOS from MacBookPro 8.1, 8.2 and 8.3. If I don't use SMBIOS.plist my laptop by default is identified as MacBookPro 8,2 by Chameleon. I didn't had time today to test Clover on my HDD 10.9 installation, just one try but it didn't boot . With SMBIOS from MacBookPro 6,1 I was able to boot just my bootable Mavericks USB. I will test other options tonight or tomorrow.

Link to comment
Share on other sites

  • Slice pinned this topic
 Share

×
×
  • Create New...