Jump to content

Snow Leopard on Gigabyte Mobos

168 posts in this topic

Recommended Posts

- 7300 GT needs to use kernel 32, GeForce driver panics in 64 bits. Others process runs in 64 mode, so I don't think it's a real loss of performance. Perhaps I will use another graphic card, who doesn't need to use GraphicsEnabler in Chameleon.

I switch to a 9500GT, works fine in 64 mode with Graphic Enabler = y :D


- the launchd process (pid = 1) always run fsck at startup, cause of an ioctl error.

I replace /sbin/fsck with a "fake" (a sample script "echo"), now boot run faster : about ten seconds on a SSD disk :P . Bios boot take more time !


I'm now quiet for a while...

Link to comment
Share on other sites

  • 3 weeks later...

Hello MaLd0n,

I have a new Lenovo laptop and i want to ask you if you could please help me with generating a DSDT for it. I have attached the dsdt whitch i have generated from Lion. The main problem that i have is video, but i think you already know that Intel 4500MHD aren't recognized with QE/CE.Thank you verry much for your help, even if you don't have time, because i know you are verry busy, for reading this message.


Link to comment
Share on other sites

C-States breaks sleep on my GA EP45-UD3P.


I'm running the following configuration:

Motherboard: GA EP45-UD3P, Rev. 1.6, FD BIOS

Processor: Q6600

Memory: 8MB Kingston Value Ram

DSDT fixes: TMR, HPET, RTC, CMOS, PCI Root, HDEF, EHCI, SBUS, SATA icon, Gigabyte Shutdown, PWRB, LPC, Boot on Wake fix (LPCB AG3E field) ep45_ud3p_fd.dsl.zip

Kexts: FakeSMC

Chameleon (recent build): GraphicsEnabler, GeneratePStates


Runs at about 30-32 Celsius with SpeedStep. Even better, runs at 25-27 if I add C-States.


Problem is sleep breaks when I add C-States, either via DSDT or Chameleon.


System reacts to sleep key press, display shuts down and HDs spin down, but fans keep spinning, blue power light is on, and that little "chirp" and Motherboard LEDs flash bit never happens. System will not wake from this state, requires reset or holding power button in for four seconds for hard shutdown.


I've been working my way through the Gigabyte DSDT thread, the Vanilla SpeedStep thread and a few others for the last few days but can't seem to turn anything up.


Anyone heard of this before and can point me in the right direction? Sweet highly-vanilla rig now and just need to finish a few details :)

Link to comment
Share on other sites

  • 2 weeks later...

I nuked a klunky, but functional leopard install on my old GA-945GCMX-S2 system, so I have been stuck trying to do a modern Snow Leopard install. I have researched for the past two weeks and I still have problems with the install. Could someone please help me? Here is what I have so far:


My board is a Gigabyte GA-945GCMX-S2,revision 6.6 bios F6i.


I followed MaLd0n's instructions in this thread. I booted with the Gigabyte BIOS iso, installed 10.6.0 from a retail disk, extracted my DSDT and patched with the gma950 and other patches specific to this board MaLd0n posted to this thread:DSDT fixes for Gigabyte boards

I also manually fixed the (Local0,Local0) problem, and allowed the patcher to automatically fix a "Length is larger than Min/Max" error it found.


I renamed the "Extra_iMac9_1" folder to "Extra" and dragged it to my boot disk. I rebooted, installed 10.6.7 combo patch, rebooted and installed Chameleon 2.0 RC5 r1349. I used an older version because I wasn't sure the newer versions would work.


Now the system will boot on its own, but there are no resolution options in the system preferences other than 1024x768 which I specified in com.apple.boot.plist. Also, sleep freezes the system but not the display, and it won't wake.


Any ideas how I can fix this? Regarding the GMA950 issue I found this page:Intel GMA 950 Snow Leopard Fix

which claims that adding AppleIntelIntegretedFramebuffer.kext fixes the problem. Would removing the GMA950 DSDT patch and adding this help?


If I can't get the integrated graphics to work, what's the best way to add a 256MB BFG GeForce 7900GS to the system. Kext, DSDT edit or what?


On a basic note, if I do add kexts, should i use something like kexthelper to install them in System/Library/Extensions or just put them in Extra/Extensions?


I haven't done further tweaks, like adding a kext to fix the sound or seeing if I need to install something to support the ethernet chipset. If there are other fixes that need to be done, I'd like to know.


I know this is an old motherboard and an old thread. Thanks in advance to anyone who can help.




Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
  • 3 weeks later...

There actually is a snow 64 nvinject.kext for the 7300gs that probably works for the whole 7xxx series and a few more videocards if you search the internet. You need to edit it like I did though so search for my posts about video cards. When you switch between 32 an 64 bit you need to switch/replace the kexts though, thats the backside of it.

Link to comment
Share on other sites

  • 4 weeks later...

me using "GA-EP41T-UD3L+Pentium D 935" w/ASUS EN7600GS(256MB), 4GB DDR3, SATA II HD


i've got a retail DVD of SL, but what other files do i need to download?

i used to download bootloader, but it keeps restarting when i insert retail DVD


does the Pentium D Processor supported?


thanks for reading

Link to comment
Share on other sites

I am a new poster here and am hoping that some of the nice people here can help me. I have done a couple of builds over the last 2 years. I just installed SL on a eg45m-ud2h following this thread. I have been fairly successful. I have the Q9550 recognized and running at 38C. My network works also. I used one of the latest chameleon's(which generated the DSDT) and Hackboot v6.


I am stuck on the checksum error. Any help will be greatly appreciated.



Link to comment
Share on other sites

I hope someone can chime in. I did solve the checksum error by using the elliotforcerestart kext. It aint pretty but it works. I oc to 3.4 and get a geek bench of 7540 47 degree core on cpu 1 at idle. When I run one of the Logic Demo songs the rest of the cores also go up to 47 degrees, which seems really good. The sleep thing is totally not happening. When I hit sleep the desktop halts for a moment and then I get a usb disconnected wrong warning and the desktop gets sluggishly responsive. Shutdown and restart do work fine however.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Hey guys,


Just wondering. Is it totally inappropriate to ask for a Gigabyte AMD motherboard here? I have a GA-MA790FXT UD5P. I found the DSDT patcher, but no info for AMD mobos. Im having trouble with restart/sleep and trying to find some way to fix it. I just installed with Nawcom's boot CD, Updated to 10.6.8 and everything is working (at least it looks like) but when i restart, the pc turns off and doesn't turn on again. same thing when I try the sleep. It goes off, when I power it up again it keeps restarting (cd checking contiguously!)


Anyway, before I get more into detail, without being inappropriate, could please someone point me into the right direction? (or the right forum?!)


I would be eternally grateful! Thanks to everyone ...

Link to comment
Share on other sites

  • 3 months later...



Sorry, but I am a novice at this. I can not install ML on my SL 10.6.6 because I receive a message that this is only possible with SL 10.6.8 or above. I have tried many times with different kexts and through different methods to upgrade my system to 10.6.8 so that I could install Lion and now Mountain Lion, but have failed each and every time. Does anybody know a way around this, because I would like to install ML.


Thank you for your consideration



my system:

mobo: GA-X58A-UD3R rev: 1.0 BIOS: F6

CPU: Core i7 - 920 LGA: 1366

Graphic Card: XFX ATI Readon HD 5770

Audio: Realtek ALC889

Ethernet: Realtek 8111D

RAM: 6 GB of GSkills Trident DDR3-2000

Link to comment
Share on other sites

  • 3 years later...

Taken from nostalgia i will try to install Snow Leopard on my pc. (GA-H67N-USB3-B3 and Intel Core i5-2500k )

I have just installed successful Osx Lion, Montain Lion, Mavericks, Yosemite and El Capitan.


In the past i have installed Leopard and Snow Lopard on different hardwares.


Now i want to use newer bootloaders ( Enoch and Clover ) to get things workings ...


Then i will install Leopard and Tiger to have all OS X at same time in a multi boot system.


See Ya

Link to comment
Share on other sites


I installed Snow Leo on my pc. (GA-H67N-USB3-B3 and Intel Core i5-2500k )

I have used HackBoot V7 for Sandy Bridge and Retail Snow Leopard DVD 10.6.3 buyed some times ago from Apple.

Then i have updated the system with MacOSXUpdCombo10.6.8.pkg

Hint -> First i have deleted ACPI_SMC_PlatformPlugin.kext inside IOPlatformPluginFamily.kext to avoid  KP during upgrade !!


All Works Fine ( network RTL81xxx.Kext, Audio VoodooHDA.kext for 10.6 )


Now i want to get QE/CI patching FrameBuffers for my Intel HD3000  :->


AppleIntelSNBGraphicsFB is very different from the one from OSX Lion and over, so i have to dig around to find the magic numbers ...

Link to comment
Share on other sites


  • Create New...